Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Hyundai Elantra Maintenance and Repair

19192949697113

Comments

  • hey there all..

    I'm new to this forum, have a Hyundai Elantra 01, 4dr sedan.

    I'll be grateful if anyone could help me with this, the windshield washer doesnt work anymore, I had a look at it, its not the water being empty, or the pipes being clogged, so I think its the windshield-washer motor, cause I dont hear the motor sound anymore, any idea where the motor is located or how do I access it? short on money so i'll have to fix it myself.

    Thanx
  • jlflemmonsjlflemmons Posts: 2,240
    Drivers side of the radiator, on the very bottom. I believe it is red or orange. It is plastic.
  • jkobbjkobb Posts: 51
    Thanks Jeff , I wasn`t sure I was looking at the right thing. Mine was red with slot tha looks like a big phillips screw driver would fit into.I didn`t want to monkey with it if was the wrong thing. Jim
  • jkobbjkobb Posts: 51
    Someone correct if if I`m wrong , but isn`t that motor in the bottom of the washer fluid resevoir.
  • Thanx for the reply...

    ya the motor is at the bottom, and the worst part is, i cant pull it or slide off from the top,found a high pavement and pulled it out from below. the worst part is that the replacement i found has a different power socket so now to friggin go down and try to a re wire it.
  • jkobbjkobb Posts: 51
    The only one I`ve ever replaced was on a Mazda and I unbolted the resevoir from the the body of the car and pulled it up and out. Then getting at the motor was a piece of cake.
  • well on a Hyundai Elantra its a little bit more difficult, coz there is no way you can detach the resevoir, coz only the mouth part is seen from above and the bulk of it is hidden under a metal sheet, so the only way to get to it is from below or by removing the front side of the mud guard on the front passenger side. well anywayz i just fixed it today, had to find a nice high footpath and raise one side of the car so that i cud slide my hand in n pull it out, since the knock off washer motor for $15 came with the crimp-on connectors, thats all i wanted, coz the original connectors wudnt fit into the new motor .
    thanx for the help
  • I ran over a large piece of tractor trailer tire and it tore the plastic in the front passenger wheel well - in front of wheel. I pushed it back in place and so far it has held but is loose - the plastic tore away from the bolts holding it in place. Any advice on how to fix or how much will cost?
  • doohickiedoohickie Posts: 949
    I would search around local salvage yards for a new part. Make sure you get plenty of the little plastic fasteners. In the short term, make sure the old part doesn't come loose by tying it into place with nylon tie straps. (Maybe if you can secure it well with those, you can call it good enough and forget about it.)
  • jlflemmonsjlflemmons Posts: 2,240
    Was doing a late night oil change and realized I didn't have the Hyundai filter I thought was in the cabinet. Well, AC Delco makes the PF1127 that is a dead ringer, right down to the anti drainback and bypass valves.

    Ran down to the local Autozone and picked one up. Got home and when I went to install, found that there was no bypass valve in the filter. Checked it out further today and found out that the AC Delco was identical to the STP crap that they sell. Right down to the color of the filter, just the label was different.

    I had read that AC Delco was having a problem with counterfeit filters flooding the market, but this was the first time I had seen one up close. Just for grins I went to another parts house that carries various brands. Of the six brands I checked, only the STP and AC Delco did not have the bypass valve.

    I will be going by the dealer today to pick up a supply of Hyundai OEM filters. :mad:
  • Does anyone know where the crank position sensor on a 1996 Hyundai Elantra is?? Is this a hard thing to change? I was told this was more than likely the problem with my car, but I cant find where its located lol. I was going down the road and it died on me. It is trying to start, (it turns over but wont crank) I thought it might be the fuel pump b/c you couldnt hear it when you turned the key on so, I changed the fuel pump & screen which still didnt work then I changed the fuel pump relay. It started ran about 4 minutes then died again and wont crank. Any hints help or ideas would be greatly appreciated... I am at my wits end!! Thanks
    Samantha :)
  • jlflemmonsjlflemmons Posts: 2,240
    Couldn't find a picture, but it is located:

    The crankshaft position sensor which consists of a magnet and coil is installed by the flywheel. The voltage signal from this crankshaft position sensor is provided to the ECM for detecting engine RPM and the position of crankshaft. From Hyundai Service Guide.

    From what I could find, there is also a CAM shaft position sensor. It would make sense that the crankshaft sensor would be closer to the main pulley on the engine. Look for something screwed into the block or on a bracket near the pulley, with wires going to it.
  • thank you very much!
  • I have a 05 Elantra automatic 57500 km. I am not very happy with the dealer, they offer here a number of service packages; for example the service #1 (29.95 CDN)includes oil and filter change and also among other things "check fluid levels"; the first time I took the car for this service, a week later it run out of windshild washer fluid, I know I can refill that easily myself, but if I paid to have it checked at least they could have ask me if I wanted it replenished. So that makes me wonder if they actually checked everything else the same way. The second time for changing the winter tires and the oil I paid 142.79 and had to wait almost two hours, they didnt label the tires to know how to rotate then later. This is in Hyundai South London Ontario, I wonder if all the dealers are the same. Now the car is schedule to get service pack #4 (254.95 CDN), -they insist I should buy that. This includes a number of "inspections" and getting the air cleaner filter and the engine coolant replaced , and rotate the tires, it seems to me a little expensive. The car has run perfectly so far, except that yesterday it showed the "check engine" light on one hour after I filled the tank with gas, the light was on three starts after that and then went off, I opened and closed tightly again the fuel cap, but today the check engine light went on again. I have read here that it could be the fuel cap or the tank top-off. But now I wonder if I really should take the car for the full service #4 to the dealer. Any suggestions??
  • I HAVE A 2001 ELANTRA. WHILE DRIVING AT TIMES YOU PUSH ON THE GAS PEDAL AND NOTHING HAPPENS. BROUHT TO DEALER 3X HE HAS NO IDEA. HAS ANYONE ELSE HAD THAT PROBLEM AND WHAT WAS DONE FOR REPAIR .
  • backybacky Twin CitiesPosts: 18,718
    Compare what is in the dealer's "pack" with what is in your owner's manual for recommended service at around 57500 km. And ask your dealer how much just those services cost, and be clear that they are to perform just those services. They may have added some services that are not required by the manufacturer. However, a coolant flush seems like a good idea if you haven't had it done yet. Also the air filter should be replaced regularly (but you might consider replacing it yourself if you are handy and save some money).

    If you think your dealer's service charges are too high, you are free to have your car serviced by any mechanic--or even by yourself if you have the skill and the time. But if you do that, be sure to keep records of the services, in case there is a warranty claim related to parts that have been serviced (or not).
  • doohickiedoohickie Posts: 949
    Two things to watch if you get your car serived somewhere besides the dealer (or even at the dealer for that matter):

    1. Oil filters. Some aftermarket oil filters (at least in the past) have caused oil starvation due to a bad bypass valve spec. If the shop, for instance, uses a Honda filter instead of a Hyundai, the difference in specs can toast a Hyundai engine.

    2. Automatic Transmission fluid. Make sure anyone that touches the car ONLY uses SP-III as stated in the owners manual. Some shops say they have "universal" fluid. Universal fluid can replace Mercon and Dexron fluids used by other auto makers, but cannot replace SP-III.
  • jacobi1jacobi1 Posts: 32
    Hey all,
    I have an 02 Elantra GT, just pulled in the driveway from a long drive and tried to close the sunroof and it wouldn't budge? no clicking when holding the button and no movement at all? any ideas? anyone experience this? motor? eletrical? I have had some issues with electrical in the past so I'm thinking that may be the culprit...thanks!
  • doohickiedoohickie Posts: 949
    Have you checked your fuses in the panel to the left of the steering wheel (behind the pop-out bin)?
  • jacobi1jacobi1 Posts: 32
    not yet, before I look - do you know which fuse? guess I'll run out now and see if there's a map in the manual. thx.
  • jacobi1jacobi1 Posts: 32
    ok, map is on the back of the change holder (knew that, been a while). Nope, not the fuse - swapped out for a good one - still nothing. Any other ideas?
    thanks doohickie.
  • jacobi1jacobi1 Posts: 32
    well, was unable to figure out the problem today but got it closed. There's a manual way of closing it, remove a linch pin, pliers and turn (just need to pop off the cover that contains buttons and lights). Seems to be power going to it ok..maybe the motor is gone? off the wreckers.
  • doohickiedoohickie Posts: 949
    check the voltage at the motor before you spend the money
  • donniedonnie Posts: 24
    I noticed on the Forum that you recently replied to someone about installing a new radio in an '04 or '05 Elantra. I bought a used '03 GT some time ago. It had an Alpine replacement radio as the former owner said the original had very poor AM reception. As the antenna was broken when I purchased the used car I didn't know how the Alpine performed. Well, it's also pretty bad! Even when nearby stations are on, there's a lot of static along with whining when the HVAC motor is on---even whines when cruise control is on. Now this car spent several winters in upstate NY, and I wondered if the problem could be salty winter roads causing corrosion---or what? Could you give me any advice? Thanks in advance
  • Engine won't start, starter just spins.
  • I have a 2000 elantra that needs to have the starter replaced the dealership wants $380.00 to replace it. Is there a way to do it my self? I would like to know if anyone here can help me locate it and advise me in taking it out. The junk yard has one for $40.00 but I need to bring him the old one but I don't know where it is? I'm pretty good on the car I do most minor maintenance myself(breaks,oil,coolant)now I need the starter
  • doohickiedoohickie Posts: 949
    Sound like it needs a filter on the power supply line, or you have a bad ground. Also, if you can, check the continuity of the antenna wiring (resistance too).
  • doohickiedoohickie Posts: 949
    Try looking under the hood at the fuse box. Pull the fuse marked SNSR; it is for all the sensors that control the fuel system. If it is burned out, try replacing it.

    If it isn't burned out, the next most likely culprit, from what I've heard, is the crankshaft position sensor. It measurs the rotation of the engine, and if the computer doesn't think the engine is spinning, it won't turn on the fuel flow.
  • doohickiedoohickie Posts: 949
    Assuming you have the 2.0L Beta engine, the starter is underneath the intake manifold on the side of the engine toward the firewall. The best way to get to it is to remove the air intake. Disconnect the intake where it goes into the intake manifold and remove the whole thing (not all that hard) and you should be able to get to the starter.
Sign In or Register to comment.