Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Cadillac Escalade Maintenance and Repair

14567810»

Comments

  • Definetly get it checked out before you purchase a model. When it comes to the 2002 cadillac escalade seriously don't waist your time to many issues...possibly not at first when you buy it..but eventually you will be better off NOT buying a cadillac escalade!
  • I need help, we just got this 03 escalade (with suposely 109.000 miles on it), 2 and half hours away from home, got on the road.. about a hour and half in the road... check control center light came on , the low oil pressure came on shortly after,........ we got off the high way, trying to find a gas station.... the car had smoking coming out of the distribuitor and died, we turn on again and a lot of smoke came out of the distribuitor. We got to the gas station, my husband put 2 quarts of motor oil in it, we think that the previous owner just didnt change the oil or maintain the car at all... it appeared that no oil was in it, we made another hour on the high way, the warnings on the dash ware there still. Getting off of the high way, at the stop light... the smoke came on again off the distribuitor, the car died again, we turn on ... same thing happend all over again, well , we made it home. Now we are worried about what could be wrong with it, we dont want to go around spending money and have this to keep happening. I was thinking about having it fully tuned up (by our mechanic that comes to our house)... then taking it to a shop to be put on a computer.
    I would love to hear your advice on this. Thank you in advance.

    (sorry any miss spelling, I am from Brasil)
  • hi, i want to add that the dam [non-permissible content removed] guy... put a small battery in there, it needs a bigger one. thanks
  • I need help, we just got this 03 escalade (with suposely 109.000 miles on it), 2 and half hours away from home, got on the road.. about a hour and half in the road... check control center light came on , the low oil pressure came on shortly after,........ we got off the high way, trying to find a gas station.... the car had smoking coming out of the distribuitor and died, we turn on again and a lot of smoke came out of the distribuitor. We got to the gas station, my husband put 2 quarts of motor oil in it, we think that the previous owner just didnt change the oil or maintain the car at all... it appeared that no oil was in it, we made another hour on the high way, the warnings on the dash ware there still. Getting off of the high way, at the stop light... the smoke came on again off the distribuitor, the car died again, we turn on ... same thing happend all over again, well , we made it home. Now we are worried about what could be wrong with it, we dont want to go around spending money and have this to keep happening. I was thinking about having it fully tuned up (by our mechanic that comes to our house)... then taking it to a shop to be put on a computer.
    I would love to hear your advice on this. Thank you in advance.
  • isaac9isaac9 Posts: 2
    I know that this may have been a while, but I was wondering what happened in your chase, cause I'm having a similar issue where I'm hitting the gas, and the car does not move, and I tried all shifts. I also have a 2006 Escalade. Love that car, but I'm not feeling too good about it right now. Someone said it is the Tranny, someone else said it may be the Gear Shift Linkage. So not sure what to do. Can you please tell me how yours turned out?
  • gmcustsvcsarahgmcustsvcsarah Posts: 1,964
    Good morning isaac9,
    I'm sorry to read about the difficulties you're having with your Escalade. Are you planning on getting this looked into? We're happy to look into this further with you if you like.
    Best,
    Sarah
    GM Customer Service
  • isaac9isaac9 Posts: 2
    Yes, I did have it looked at by one Transmission shop, and they said it was the transmission, but I do not trust mechanics, so I do want a second opinion. How can you assist me without me having to sell my soul?...lol
  • gmcustsvcsarahgmcustsvcsarah Posts: 1,964
    isaac9,

    The following is our process:
    We would set up a Service Request through our department (would need your name/Edmunds username, phone and address, the last 8 of your VIN and current mileage, and the name of your preferred dealership). If the transmissions shop you visited was not one of our dealerships, we would have you set up a diagnostic appointment with your preferred dealer (would involve a diagnostic fee) for them to look into the vehicle and determine the source of the transmission concern you're having. From that point, we would look at what it would take to repair the vehicle and we would consider any available options. I can't promise up front what the end result of the case will be, but our priority is to resolve any concern that you're experiencing and have you leave satisfied with your vehicle.

    If this sounds like something you are interested in pursuing, please send the request information to socialmedia@gm.com and we will go from there.

    Sarah
    GM Customer Service
  • dms1815dms1815 Posts: 2
    I realize your message in nearly 3 years old but what did you ever find out about the service stability system issue? I too have the rub, rub feel and my service stability light randomly comes on. Any help would be greatly appreciated.
  • dms1815dms1815 Posts: 2
    I realize your post is a few years old. Hopefully you've gotten rid of your Escalade. I'm sure ready to get rid of mine! I'm having the same problems with the brakes locking up and the growling/grinding noise. What did you find out about those issues. Any help would be greatly appreciated.
  • kasmirkasmir Posts: 3
    The problem with my Escalade was the Transfer Case if I remember correctly. Hope this helps.
  • gmcustsvcsarahgmcustsvcsarah Posts: 1,964
    Good afternoon dms1815,

    It looks like you've already gotten some feedback from kasmir; if we can look into recall or warranty information for you, or if you would like for us to be involved in the process of you working with a dealership to get this looked into, please send the last 8 digits of your VIN as well as a brief summary of the situation to socialmedia@gm.com

    All the best,
    Sarah
    GM Customer Service
  • jstwoodjstwood Posts: 1
    What did you do to fix this problem? We have 1 low beam that keeps going out.

    Thanks.
  • kelelakelela Posts: 1
    :cry: My drivers side front brakes randomly lock up and make horrible noise right after stability system active light comes on on my dash? have had it checked dealer cannot find any issues, also the air works great but no heater, when I turn heating system off, we actually feel heat coming out?
    any one have any Idea?

    Thank you
  • Hi All,

    i have Escalade 07, and my problem started three weeks ago while i was driving on the highway the radio went off for a moment and then back on, and a message "Stabilitrak off" began flashing...
    however, i went to the dealer trying to fix the radio disconnecting problem with no avail. no one could help me to diagnose and fix this problem!

    then, while i was driving home (thre days ago), the doors locks began locking and unlocking, chiming, warning lights, and the vehicle became unstable/normal...
    at that night i went home and google any info regarding to my escalade problem till i went through some posts here and i figure out that it could be from the ground cable connected to the battery.
    finally, i fixed the ground cable myself and everything (till now) is fine and the car back to normal...thanks God and to you guys.

    now my problem in the message "Parking assistant Off", it's still comes on the board, and the Parking Assistant Button flashing...

    any idea how to fix it?

    pls help, guys

    thanks
  • brandis5brandis5 Posts: 1
    No, never figured it out...we have put at least 80,000 miles on the car.. p
  • megbowman3megbowman3 Posts: 1
    edited October 2013
    I have a 2002 Escalade, which has approximately 120,000 miles, recently the ABS started to engage on dry roads. I noticed it slightly at first then it became a problem and dangerous. I pulled the ABS fuse and have since had no problems. However, due to the seasons changing, I do not feel safe driving it without ABS, not to mention my dash board is lit up like a Christmas tree. Has anyone experienced a similar problem, and is there a cost effective fix, or should I just give up and start searching for a new car? I also had new brakes and rotors installed May 2012, and have only put 10,000 miles on since, could it be a problem with the new brakes (dealer installed/furnished)? Any help would be greatly appreciated.
  • When starting in park (initially turning key) I hear a 1 time clunk. Not sure if it's a pinging noise or ?? If it were a stick shift it almost sounds like a throw-out bearing noise. Purchased in Oct 2013 with 100K on her. Runs great ! After a 2,500 mile trip (used 85 octane) the noise started as described above.

    Has the 6.0. Drove South to sea level from Vail CO. Would the change in altitude have anything to do with it. Do I need to make any adjustments regarding the fuel system etc. Next fill up will be 91 octane to see if that helps. If you want to copy me also pls do. tmkkel@yahoo.com

    Many Thanks,

    Todd Keleske
  • ypypwypypw Posts: 2
    We have a 2000 escalade 4WD. We bought it used, has been running wonderful. Started stalling and stalling completely out. You could let it sit for a few minutes and it would crank, at other times it would not crank back. Thought it was the fuel pump so it was replaced yesterday. Ran fine for a little bit and now it's started the same thing. It will automatically crank now though when it stalls out. I can smell gas very strong. Any and all help would be appreciated.
14567810»
Sign In or Register to comment.