Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Cadillac Escalade Maintenance and Repair

191011121315»

Comments

  • kasmirkasmir Posts: 3
    The problem with my Escalade was the Transfer Case if I remember correctly. Hope this helps.
  • gmcustsvcsarahgmcustsvcsarah Posts: 1,964
    Good afternoon dms1815,

    It looks like you've already gotten some feedback from kasmir; if we can look into recall or warranty information for you, or if you would like for us to be involved in the process of you working with a dealership to get this looked into, please send the last 8 digits of your VIN as well as a brief summary of the situation to socialmedia@gm.com

    All the best,
    Sarah
    GM Customer Service
  • jstwoodjstwood Posts: 1
    What did you do to fix this problem? We have 1 low beam that keeps going out.

    Thanks.
  • kelelakelela Posts: 1
    :cry: My drivers side front brakes randomly lock up and make horrible noise right after stability system active light comes on on my dash? have had it checked dealer cannot find any issues, also the air works great but no heater, when I turn heating system off, we actually feel heat coming out?
    any one have any Idea?

    Thank you
  • Hi All,

    i have Escalade 07, and my problem started three weeks ago while i was driving on the highway the radio went off for a moment and then back on, and a message "Stabilitrak off" began flashing...
    however, i went to the dealer trying to fix the radio disconnecting problem with no avail. no one could help me to diagnose and fix this problem!

    then, while i was driving home (thre days ago), the doors locks began locking and unlocking, chiming, warning lights, and the vehicle became unstable/normal...
    at that night i went home and google any info regarding to my escalade problem till i went through some posts here and i figure out that it could be from the ground cable connected to the battery.
    finally, i fixed the ground cable myself and everything (till now) is fine and the car back to normal...thanks God and to you guys.

    now my problem in the message "Parking assistant Off", it's still comes on the board, and the Parking Assistant Button flashing...

    any idea how to fix it?

    pls help, guys

    thanks
  • brandis5brandis5 Posts: 1
    No, never figured it out...we have put at least 80,000 miles on the car.. p
  • megbowman3megbowman3 Posts: 1
    edited October 2013
    I have a 2002 Escalade, which has approximately 120,000 miles, recently the ABS started to engage on dry roads. I noticed it slightly at first then it became a problem and dangerous. I pulled the ABS fuse and have since had no problems. However, due to the seasons changing, I do not feel safe driving it without ABS, not to mention my dash board is lit up like a Christmas tree. Has anyone experienced a similar problem, and is there a cost effective fix, or should I just give up and start searching for a new car? I also had new brakes and rotors installed May 2012, and have only put 10,000 miles on since, could it be a problem with the new brakes (dealer installed/furnished)? Any help would be greatly appreciated.
  • When starting in park (initially turning key) I hear a 1 time clunk. Not sure if it's a pinging noise or ?? If it were a stick shift it almost sounds like a throw-out bearing noise. Purchased in Oct 2013 with 100K on her. Runs great ! After a 2,500 mile trip (used 85 octane) the noise started as described above.

    Has the 6.0. Drove South to sea level from Vail CO. Would the change in altitude have anything to do with it. Do I need to make any adjustments regarding the fuel system etc. Next fill up will be 91 octane to see if that helps. If you want to copy me also pls do. tmkkel@yahoo.com

    Many Thanks,

    Todd Keleske
Sign In or Register to comment.