Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Cadillac Catera Maintenance & Repair

1272830323347

Comments

  • FroyFroy Posts: 3
    I had the same problem with my 2000 Cadillac Catera Sport. Does you cadi have no horsepower when you are stopped and try to peel out of the intersection and have no juice? Also once you turn it off and turn it on it runs normal again? If you answer yes to these questions then in about 6 months you will need a new transmission. I though it was the stupid computer again but its not. Good luck!
  • FroyFroy Posts: 3
    I have the same problem with my 2000 Catera Sport. I really wanna drive this car off the cliff because of the stupid computer problems. My radio does not work and trunk release I gotta put in drive to open it! Wonderful german technology! May I ask you how much it cost you to put the relay board? Thanks a lot!
  • FroyFroy Posts: 3
    I just recently replace my radiator and a couple days ago the upper hose came off. I thought no big deal so I put a clamp back on and I was able to drive the car home however there was no heat. The next day I put the Dex Cool antifreeze and notice the milkshake in my antifreeze reservoir. There is no antifreeze in the oil and my transmission is brand spankin new. The headgaskets I recently replaced 6 months ago. Any advice anyone? My guess is the oil cooler? Has anyone done this job before? Please help????

    Please note my car has 355,000 kilometers and this car was a great car FOR ME until 300,000 kilometers with no major repairs. I still have the original timing belt or I am assuming it is chain because it hasnt broken yet. I guess I am one of the few lucky ones!
  • I'm not sure how much it was. I will check my records once I get home from vacation. At first they said it would be covered by the extended warrantee, so I paid nothing when I picked up the car...then it turned out it wasn't covered. I think it was around $200.
  • I love my 99 catera sport aside from the usual fixable problems I am veryyyy happy with my silver baby
  • merckxmerckx Posts: 565
    It's a real pleasure to hear of someone else who is enjoying their Catera. My wife was so distrustful of our 2001 that last June I bought her a 2008 Buick Lucerne. I've kept the Catera as a weekend car,as it is worth very little on the usee car market...I keep waiting for something else to happen to it,but it's been fine for a while now....Only up to 52,000 miles.
    It is a little irksome that the collant level sensor went bad...i just haven't bothered to get the panel warning light to shut off;I understand the only fix is to replace the overflow tank.
  • It is about a 10 minute fix. Get a new overflow tank, ( as the sensor is in the btm. of the tank. remove all hoses and un plug the wires from under the tank, replace the unit re connect the hoses and it is all set to go. Buy the new tank from ebay or from the Cad. Dlr. in Chicago and the price is lower. check ebay first..... best not to use a used one as the sensor may be bad again... Good luck. By the way I have had the everyday things go wrong with our Catera, but I have been able to do the repairs myself. Water tank, heater valve and the cps ( sensor). the shop would have charged me bout 1200.00 for all three repairs, but only cost was parts about or under 100.00 as I recall.. " GET ER DONE. LOVE OUR CATERA. LEE...........
  • It is about a 10 minute fix. Get a new overflow tank, ( as the sensor is in the btm. of the tank. remove all hoses and un-plug the wires from under the tank, replace the unit re connect the hoses and it is all set to go. Buy the new tank from ebay or from the Cad. Dlr. in Chicago and the price is lower. check ebay first..... best not to use a used one as the sensor may be bad again... Good luck. By the way I have had the everyday things go wrong with our Catera, but I have been able to do the repairs myself. Water tank, heater valve and the cps ( sensor). the shop would have charged me bout 1200.00 for all three repairs, but only cost was parts about or under 100.00 as I recall.. " GET ER DONE." LOVE OUR CATERA. LEE...........
  • fehufehu Posts: 7
    well so far I know the battery is good and will hold a charge until I try and try to start it and eventually it runs down. The car turns over but won't start. Put carb leaner in the intake and nothing and then into the spark cylinders and still no start. It's almost like the computer is telling it not to start for some reason.
    I have a lot of oil on the engine from a valve cover gasket leak not sure it that is an issue?
    Starter is working because it turns over and the ingnition obviously. End of my ropes and cadi dealers down here want your first born to fix them just can't afford it.
    Any ideas????
  • ssklsskl Posts: 45
    I suggest to first of all to see if there is spark to any one cyl.. You can do that easily by twisting the easiest to get at plug wire at that plug location and pulling wire off plug carefully with pliers. Then set that plug wire end at about 1/2 inch from a surface of metal (to ground) to cause an arc that an observer can see while starting is attempted, If it arcs after several cycles you will know that the cyls. are most likely getting spark and the problem might be a lack of fuel supply.
    Try this first and we'll go from there.
    By the way carb cleaner is not meant to be used as a fuel to start with, I don't like any starting fluid, gas is good enough. You can blow the top off your intake with any fuel shot into the intake. The fuel injectors must be the only supplier of fuel.
  • gngurugnguru Posts: 108
    Read my post #801. Since carb cleaner in intake did not fire it (probably not a fuel problem) I would try replacing the CKP (crankshaft position sensor). If you can wait a couple of days for the part, the cheapest place to get it is GMPartsDirect on line (about $50 + or - a few $$). About 45-60 minutes labor. If that doesn't fix it repost. Good luck.
  • Hello Everyone, I am glad to hear that some people still enjoy their Cateras, I do enjoy my 1999 even though since I bought it over a year ago I spent almost twice the price I paid for it to repair its various and SUDDEN problems, which some were repaired and some I've learned to live with :) Anyway, since this car made me broke I am trying to avoid going to the dealer anyway possible so I am back to ask if you can help me with two questions:
    1. The dashboard light fuse keep blowing, I replace it and about 15min later it goes (only when the light is on) nothing else seems to be affected by this, all the warning lights and signals work fine and are not affected. I tried to see if the AC/CD/Fans/heater being on/off makes any difference but it does not. the fuse is 10amp, I tried with 25amp and it also went. Not sure if this is related but I had the passenger side window replaced about 2 months ago (not at Cadillac dealer), about a week later the dashboard fuse started going. I know this is open for many possibilities but if someone had similar problem or any ideas please share.
    2. Where can I find replacement arms for the rear window sun shade? the hinges at the top were broken since I bought the car, I tried different types of glue with no luck. and I tried to get replacements at salvage yards and ebay but could not find them their either. not sure if they are called something else. Thanks for any help. :)
  • ummmm We have had Cateras since 2002, and are on our second one. We love our Catera, but must confess that I have never seen a "rear window shade on either one, I will have to check again...???????????? Lee BRB

    ( just checked and can not find it.........)
  • ArtXArtX Posts: 3
    I buy 3 yrs ago catera `97, I like this car for comfort ride, but....only for comfort ride, nothing more, and nothing special more. A lot problems with electric, lights inside sometimes work, sometimes no, nobody knows why. And big problem with rust on forward doors, left and right( I saw few other cateras with rust in this same places) This Car is comfortable mistake. After this winter I will try sell this car, and I wanna buy BMW 525 /530 from 1997-99 I know this is better choice like catera. ;) :shades:
  • az_hvyaz_hvy Posts: 30
    I have a 98 and no sunshades in mine ether Maybe previous owner had them installed As far as the dashboard fuse no clue sorry cant help
  • ssklsskl Posts: 45
    Please tell me exactly where the rust is in the door area so I can prevent it on my mint '96.
    My son watched some Cateras being built in the Opel plant in southern Germany when he went to college there. Funny, they used them for police cars since they were built so good for the Germans.
    I suspect after hearing all the electrical probs with them that the export ones included some intentional fopaughs (electrical mysteries) during assembly.
    Our 635 BMW was trouble free but wasn't as good on gas as the Mercedes Benz 300e, and insurance was much higher. I am an (unusual car) nut, mostly odd ones
    I only traded my Reatta for this Catera because it was so sharp looking, missing on one cyl. and apart now to fix and no regrets yet. Dave
  • Thanks alot guys, seems like I am going to have to go to the dealer after all; just for the dashboard lights fuse problem, for now I can live without the sunshade. By the way it was factory installed in mine, according to the manual the shades are an option, seems like a rare one that's why no replacement parts available.
    Thanks.
  • Did you ever get a response as to what caused the no heat condition and how to fix it? I too have no heat out of the passenger side. It makes the passenger uncomfortable on cold days.
    Thanks
  • it is the oil cooler for sure I just replaced mine and now it works fine. the trick is the oil cooler is between the head gaskets. not a hard fix but just a little time consuming. I got an oil cooler out of a junk yard for $80 dollars and they pulled it out for me. after you fix it you will have to flush the old coolant out a few times to make sure it is completly clean. also i replaced the dex cool with the blue stuff...
  • Never got a response to this problem. Please keep in touch, please post if you hear anything and I will do the same. I can't believe no one else has or had this problem.
  • Ok I bought the part its called a Module M/Function part number is 90494163...Can anyone tell me where this goes on the car? The Cadillac parts counter said it had no info on where this part was to go which seems weird...Any help would br great! Thanks!! :sick:
  • hello fellow cateras.just have an issue with my 97 catera.the leveling light is on and i checked the fuse and noticed that it was popped so i changed the fuse and popped soon as i put the fuse in.anyone have any ideas on what the problem is?
  • Like everyone else here i have had many a problem with my catera, :lemon: , but im in college and don't have the money to get most of them fixed, so they have all piled up to now. The biggest problem is that sometimes after turning the car on and off 4 or 5 times in a short time span it will not start (crank but not fire up), but after a jump its fine. After a few months of this the battery will go dead and i have to replace it. Then recently i went to try to start the car and it woulden't even try to turn over, no clicking, no noise, nothing. All the lights work and nothing looks dim but no crank, much like one of the earlyer posts on the forum, #858 by gnguru. I had this battery tested and its fine and the alternator was tested last time i got a battery, so 6 months ago, and it checked out. gnguru's problem was fixed with a starter, but i wanted some more feedback before i started buying parts and having them installed. Any advice??
  • I 'd have to go with the starter problem. that is the way they go " sometime' Try to pick one up from Ebay or from a bone yard. Lee
    By the way are you from Alabama"
    I am from Daphne.............
  • ssklsskl Posts: 45
    A good mystery is why I bought a Catera. Your problem has a good puzzle to solve which I like.
    Might be the starter but I'm wondering why the engine would start only when jumped when the starter would turn the engine. A clue from that might be that the starter armature is grounding out due to worn armature bearings and takes most of the lone battery current not allowing engine to fire up but the jump provides enough current to fire the engine.
    The other possibility is a poor connection at the starter, should hear a click even though starter is bad which indicates a bad solenoid or relay.
    Try leaving lights on and try to start to see if lights die when starter is engaged, if they do die then most likely the starter is bad, if they don't die then that means starter is not connected, the current flow is broken, then likely it's not the starter. .
  • dave53dave53 Posts: 2
    The trannie has sliped from drive to nutral at slow speed, 15-20 mph twice now.
    We have conserns since we found out about it's interference engine after we drove it home" as is"
    The wife loves the car, except the drivers side seat heater is inoperative.
    Any ideas about this symtom and how to deal with it.
    We have had the car 5 days, It has 88,000 miles
    Thank you
    Dave
  • fehufehu Posts: 7
    Are you sure it's slipping into nuetral or just slipping from one gear to the next?
    Catera's have a sealed transmission so no way to put fluid into them. But if you go to one of the lube shops and can get them to agree to it they can inject some fluid into the trani for a temporary fix. But you have a leak somewhere evidently so it's probably a gasket. Catera's are known for the gaskets wearing out quickly. Mine only has 47K miles and I have two bad gaskets to fix already.
    Just some thoughts on the situation as my last catera had a trani problem.
  • fehufehu Posts: 7
    The best thing to do is to check as much as you can before buying parts. It can get expensive. Is the battery dead again? A couple of things you can check are as follows. Check if the engine is getting spark. If the engine isn't getting any spark and will turn over but not start it's the Crank shaft sensor. Can get one at auto zone for around 72 bucks. pull off the spark plug assembly and check one of the chambers to see if it is getting spark.
    You can also check the fuel pump by spraying a small amount of carb cleaner (NOT starter fluid) into the intake. If the car starts when you do that then it's most likely the fuel pump. but if you are not getting it to start AND not getting spark it's most likely the crank sensor.
    This sensor can fool you by starting sometimes and then just going completely out. Hope this helps only tips I have right now. Good luck
    Hope these tips help you out.
  • i just bought a 2001 catera and i love the car but i have a couple of questions. has anyone had the light that illuminates that speedometer go out? mine did as soon as i got it home....... and my passenger side heater only blows cold air??? does the car have two thermostats? anyone have the heater problem?
  • drascodrasco Posts: 1
    Have the transmission serviced at a transmission shop. Make sure they install a new transmission oil filter, and have them take apart the old one to see if it's full of old friction material. You may need to have the trans rebuilt. If there's not a lot of junk in the transmission pan or the filter, then have the low band readjusted. It's the band in the rear part of the trans. There's a screw in plug on the right side of the trans pan where you put the fluid in. You check it with the car running in park. Oil should just be dribbling out. That's considered full. Good luck!
Sign In or Register to comment.