Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Cadillac Catera Maintenance & Repair

1626365676871

Comments

  • hturnerhturner Posts: 3
    i have a 2001 catera and it has had major brake problems. we have replaced the brake pads a couple of times but now when the brake is applied the pedal basically goes to the floor before any pressure is applied to the brake rotors. The front left tire locks up and the back left only tries to grip but the other two brakes do nothing at all. does anyone have any information about this problem?
  • country2country2 Posts: 26
    I have a short to ground on my 2000 catera and I can't find the problem. My fuses, #6, #8, #24, #25, #27, #29 are all short to ground and I have checkes so many wires for bare or touching metal that I am ready to use this thing for a firecracker on the fourth. Has anybody found a problem area like this on their car.
  • Hey my radio just shuts off every now and again. Wish I had a bettter answer for you, sounds like your wiring harness though.
  • verynicaverynica Posts: 2
    hello
    I am having problems starting, when the tempersure is hot my car would not start back after being park I took it to gm they said the starter I fix but the same problem please help ,
  • verynicaverynica Posts: 2
    hello
    I am having problems starting, when the tempersure is hot my car would not start back after being park I took it to gm they said the starter I fix but the same problem please help ,
  • cadiman2cadiman2 Posts: 2
    hi i am have the same problem did replacing the crank sensor idid it work if not have you fixed it if so how please email me wilqm2@aol.com its killing me ive had in 2 shops and the dont know cause it wont misbehave
  • cadiman2cadiman2 Posts: 2
    im having startin probs when warm nothing all dash lights on and the dinger but no click when u turn key light dim very little i have 12.66 volt on batt 13.87 volts runnin it starts every day just not when warm i just found a brown wire not connected and found a red wire not connected if diagram is right it the ignition possitive wire im affraid to hook up it is bare looks like was ripped out fyi its under colum/fuse panel red wire is sticking out of fire wall it has a stk and aftermarket alarm and aftermarket is installed but its not preatty(not my install) also the radio/dome/map/vanity mirrors only works when car is off please help me i love this car and dont want to part out is a 1998 catera 83000mi and it fully bagged up/down left/right and even 3 wheel lots and lots of money invested
  • hturnerhturner Posts: 3
    while driving the brakes will apply pressure slowly without my wanting and will completely stop the car to the point where the motor cant even power through it. so if i turn it off and wait a half hour the car will be fine, the brakes will have stopped squeezing and it seems like nothing happend at all and it has done this 6 times in the last five years. it has new brake pads new master cylinder new abs i dont know what else to do. does anyone know anything?!?!?
  • country2country2 Posts: 26
    edited August 2010
    Sounds to me like your ABS. I had to have mine calibrated after I replaced them. I think its a computer thing. Did they do that when they put your new abs on.
  • micldarmicldar Posts: 7
    Hi,

    I had the same problem, checked all, no one mechanic had idea of the problem, very strange (the mechanics).

    Finally, with a good logic, I guided the "research" and discoved the guilty one: the Neutral Safety Switch (NSS). Study what's the function of this switch!!!

    The solution was very easy: disconect the NSS and make a direct connection to the starter ($25.00 to my electro-mechanic). ATENTION! disconnecting this switch will permit you start your Cadi not only in Parking and Neutral - this may be dangerous if you have kids or forget shift to P or N !!!!

    If you want to buy new NSS, this is a good decision too. It may cost starting at $45.00. Good Luck.

    MD
  • bob3441bob3441 Posts: 1
    Running hotter than normal. Oil light comes on and off and now transmission light is coming on and off. Has not been driven alot all summer. This is a 97 Catera. Any help would be great. Water and Oil levels are fine. No leaks showing up under car either.
  • ssklsskl Posts: 45
    Are radiator fans coming on and are there any outside signs of running hot.
    If not, then possible electrical problem from setting. WD-40 removes moisture which might be causing circuits to malfunction. The computer connections ( 3 of them near front left near battery) have twist on caps which could be sending incomplete signals.
    Only a guess! If not really overheating, driving for awhile might eliminate the problem on its' own. Dave
  • jeff167jeff167 Posts: 2
    my son has a 1999 catera that runs perfect when he first starts it and runs fine for 15-20 miles.when he starts it back it starts fine but dies when he puts it in gear if he doesnt have the rpms at 1000.if it goes below 1000rpms it will die
  • jeff167jeff167 Posts: 2
    did your car run for a while then when you shut it off it would it start and then not run
  • hturnerhturner Posts: 3
    my mechanic said he didnt recalibrate them bc. he didnt think i had too. how much did it cost to get yours recalibrated?
  • country2country2 Posts: 26
    I don't remember but I put a new ABS unit on my Pontiac and it didn't work so I took it to Midas and they calibrated it and it worked fine. It took them forever to do it because they had to figure out how to do it. Just call them and ask,
  • lou89lou89 Posts: 27
    Would lie to know how to replace the heater control valve. Cannot find a 98 repair manual, other than for transmission. Thanks
  • I have a 2000 Cadillac Catera and it had been sitting for over a year. Changed the battery and the heater valve and oil change. Now the fan won't kick on to cool the engine and the key gets stuck in the ignition. The only way that I can get it to come out is to unhook the battery. Help!!!!!1
  • I have had several repairs and tok it to the dealer it left me stuck it will light up like its going to start then cut right off. So i took it to 3 mechanics which were stumped. Finally i took it to cadillac and told them i needed a new key with the chip. Got it back and it worked great for 3 months. The other day i went to start and its doing the same thing again. Any suggestions it has 112.000 miles do u think the key went bad again or something else is the problem please help.
  • lou89lou89 Posts: 27
    Have a '98, had same start problem for years..not bat volt, not a start solinoid click. Call AAA, raise hood . About 15 to 25 m in, summer, try start, has been firing up; call AAA , and cancel serv call. Dealer says bring inwhen it has the problem-thus far problem goes away each time. Had it hauled in couple years ago in NC, dealer said he not found anything, not even a battery sale. Did that in Dallas once, dealer sold me a battery, wrecker fee, and a $500 + charge. Still living with uncertainty.
Sign In or Register to comment.