Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





V8 Mountaineer / Explorer Spark knock

gpz1gpz1 Posts: 7
edited March 8 in Mercury
I have a 99 Mountaineer with 26,000 miles. I have developed a spark knock that happens at highway speeds (65-70) only, while accelerating up a grade (hill) on the highway. It only happens in this situation and the spark knock is so bad you have to let off the gas. Around town, it never knocks. It knocks on both 87 & 89 octane. I refuse to have to run 92 octane to correct this problem when 87 octane is approved and it used to run fine on 87 octane. I've tried every brand of gas and fuel system additives and the highway knock always comes back. I even put in a K&N air filter to help the truck breath better, but no help. I've had it to the dealer 3 times and they claim that it's normal. The manual does say that occasional spark knock is normal. But mine is not occasional, it's every time, I run on the highway.

Does anyone have any suggestions or like experiences ? My dealer says he can't help.

Comments

  • 2k1trd2k1trd Posts: 301
    I ran into this problem with a 4.6 grand marquis and i replaced a bad mass air sensor to correct this problem.
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,525
    Well, I'm sure it's correctable, or at least improvable, but in the meantime you had better use 92 octane....spark knock under load can hurt an engine if you let it go too long or let it get worse. Maybe you need to see another dealer or have them call in the tech from the Zone office.

    MODERATOR

  • vriosvrios Posts: 5
    tk1trd tell me more about the pinging problem. I am having a pinging problem with my 4.6 grand marquis. How was it diagnosed?
  • I dont know if we are talking the same thing here but I had a Pinging coming from my V8 Explorer sounded almost like when the valves go bad. This was right after I had filled up at a gas station I usually dont do buisness with so when the tank was low, I filled up at my normal station and no more pinging. Same symptoms as you described at highway speed and all, but it has dissapeared for now. good luck if you find anything else out let us know.
This discussion has been closed.