Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Nissan Altima Care and Maintenance

13

Comments

  • Hello all,

    I am new to this forum and just wanted to share my experiences with fellow altima drivers. I currently have a 95 with approx:133k miles on it. I was driving from NY to NJ and suddenly on a stop light my car began to sputter, like when it is not getting any fuel or your out of fuel running on fumes. I looked in my Haynes repair manual for the specific vehicle and retrieved the DTC(diagnostic trouble codes) for my car. I came up with code 11 (camshaft position sensor (CPS)) and code 34 Knock sensor. Unfortunatley I cannot replace the CPS because it is integrated with the ignition distribution unit (THE DISTRIBUTOR). so now I have to replace it and guess what I think it will work. Moral of this story it's wise to consult your ECM (ENGINE CONTROL MODULE) and research the trouble codes for best car maintenance resolution.
  • i have 1995 nissan altima. recently it just wont start. There is gas in the car and i getting spark. it seem like the gas is not goint to the cylinders. i have check the fuse for the injector and they are okay. what could be the problem why the car wont start?
  • gsemikegsemike Long Island, NYPosts: 1,743
    Did you check the fuel pump?
  • markr5markr5 Posts: 1
    Just bought a 2005 Altima yesterday with extended warranty. It is good nation wide and you can buy a rider for an additional $200. The rider stipulates if you don't use the warranty in 6 years or 100,000 miles you get your money back. You have to file within 2 months of the expiration of the warranty. Thought is a no brainer, just hope I don't need and remember to apply for the refund. :P
  • empiempi Posts: 6
    Hi nrechtman. I just saw your post. I am thinking of buying a 2005 Altima. Did you buy the 4 or 6 cylinder, automatic or manual? I have been following the forums and it does not look like a lot of people have posted an inordinate amount of problems so I am presuming it is a pretty good vehicle. Have you been able to check the kind of gas mileage you are gettting. I would like an automatic but I also want good gas mileage as I live in California and we pay very high prices for gas here. Uneaded regular is still in the high 2.80s and premium is $3.15 so it is becoming a factor for me even though I do not have a long commute it is mostly all city driving.

    I had purchased a 2004 VW Beetle Convertible GLS Turbo but I am so disappointed. It barely gets 15-16 miles per gallon. I had a Fuel Consumption Test done on it but the dealer says the computer it not showing "any faults" whatever that means so basically they say there is nothing they can do so I am selling it. As a result of this forum, it seems the VWs have a lot of problems so I am going to cut my losses

    Any information you can give will be appreciated. Can I ask what you paid and where you live because in california we pay more for everything. I think they charge us extra for all the great weather and sunshine(smile)

    That warranty you mention sounds pretty cool. If it is what thet say it is you can't go wrong especially if you are plannning to keep the car beyond the warranty period. Repairs can be very costly. I probably would buy an extended warranty. What is the warranty that comes with the car?

    empi
  • Your knock sensor generaly goes bad on a oil change. Its right under the oil filter and there is almost no way to stop the fluid from hitting that sensor. Common i guess. My 93 altima runs great 245000 miles on it. Dosent eat, burn or drip oil. Just changed the trans pan out due to a pothole but she works well.
  • Had the same problem. Its prob the distributor cab assembaly. On the 93 it has a sensor on it. When that goes bad the car will crank and act like it wants to start but no joy. That assembly isnt too expensive. If ya got spark then the coil pack is good. (another way to check a coil pack it to shake it near your ear. If ya hear the liquid in it its prob. good. There either good or bad, no middle)
  • Exausts are a dime a dozen. Its the caddy and or the muffler. Sounds like the car backfired and blew out a baffle in the muffler. Have you emission tested it since the bang noise? If so and it passed then its the muffler. If it didnt pass the caddy prob blew out on ya. Speekin from experence. 93 altima 245000 miles.
  • If your seat belts dont retract and or move with key anymore and its happening to both, check your accident sensor in the trunk. For some reason it effects my seat belts and not the fuel pump like in every other rig ive ever owned. Its on the left hand side of the trunk behind felt at about the area of the hinge for the deck lid. A little ball breaks out of a surrounding and prevents a circuit of sometype from completing. Check that. Still think'n about what else ive learned about the rig. Anyone know the fluid specs on the altima around 1993? Advance auto said it could take 10 yes 10 quarts to fill the trans. To me there is no way! Can someone help?
  • MY CAR HAS BEEN FINE I STARTED IT THIS MORNING TO WASH IT AND WHEN I WENT BACK TO START IT, IT WILL NOT START. IT IS TURNING AND IT SOUNDS REALLY STRONG BUT WHEN I GIVE IT A LITTLE GAS IT SEEMS LIKE IT WANT TO CATCH BUT WILL NOT. CAN SOMEONE PLEASE SHINE SOME LIGHT ON WHAT MY PROBLEM MIGHT BE
  • I have an 02 Alima and had this exact problem. My dealer told me the car was flooding because of turning the car on and off and back on again after washing it. After you start your car, let it run for a bit. Then after you wash your car, turn it on and let it run for a while or drive around the block, this gives the car a chance to burn off the excess fuel from starting it up. This works every time for me.
  • gsemikegsemike Long Island, NYPosts: 1,743
    In my 03, I've had a problem starting it a few times on cold mornings. First it turns fine and almost catches but doesn't start. It feels like I may have let up on the key a second too soon. After that, it will turn but doesn't sound smooth at all (like the timing is off). I need to keep trying it and it continues to turn like the timing is off and it has always started after 10 minutes or so.

    This problem sounds like it could be related to this problem above. Anyone hit upon this before?
  • Have you found out what was or is the problem? I have a 2003 altima with the same problems. Checked coolant level it's full but when the car stops the heater start blowing cool air.....What's wrong people!!!!!I need help badly.
  • I have an '02 2.5 altima, and mine had the same problem two winters in a row, but never started. I had to get towed and the guy replaced the starter both times, which was not the problem. This guy says its the variable valve timing. He says that when it gets cold, some really technical guy stuff (I didn't really read that part) happens with the oil and the compressor that throws the timing off. Apparently flooring the gas will get it started eventually, though. Just wish I had known that before. At any rate, its ok because it means you don't have to drop a grand to get it fixed.
  • haefrhaefr Posts: 600
    Without more information I can only guess that your heater core may be partially plugged or you have a defective thermostat that's not closing*. How recently have you had your coolong system serviced?

    *If you had to have a problem with a thermostat, a partially locked open one is better than a closed one. Better to have too much cooled coolant circulation than NO cooled coolant circulation.
  • I just recently went to go to an appt. , Got in my car and it woudlnt' start. I have a 93 Nissan Altima GXE. It wont turn over either...I don't hear any noises..just put a new fuel pump in it
  • ray_h1ray_h1 Posts: 1,134
    How old is your battery?
  • jivelojivelo Posts: 1
    MY 93 NISSAN ALTIMA IS EMITTING BLACK SMOKE FROM THE MUFFLER, THIS IS USUALLY PRECEDED BY THE CAR TURNING OFF. THE CAR TURNS ON RIGHT AWAY BUT SPUTTERS A BIT. OTHER SYMPTOMS INCLUDE EXCESSIVE FUEL CONSUMPTION, CAR TURNS OFF WHILE IN IDLE AT A STOP LIGHT, SPARKPLUGS ARE EXTREMELY CARBONATED. IVE REPLACED THE FUEL FILTER, OXYGEN CENSOR, GAS REGULATOR, AND SPARK PLUGS. HELP, NO DIFFERENCE.
  • suellensuellen Posts: 1
    My 1993 won't start. The battery is fine. We turn the key and get dead silence. If anyone else has had this problem please email me asap. How did you resolve it?
  • My 95 altima won't start I'v had work done to it and it's still not working.I've had problems starting it went it gets cold. First it turns fine and almost catches but doesn't start. It feels like I may have let up on the key a second too soon. Then it will turn on and make a loud pop noise. I have to keep trying it and it continues to turn like the timing is off and it has always started after 10-30 minutes or so. I had the fuel pump, the ignition coils, and the distributor changed and the car still won't crank right up.
Sign In or Register to comment.