Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Nissan Altima Maintenance and Repair

1235788

Comments

  • shemzshemz Posts: 34
    What could be the problem, i just fixed it 4 months ago at a nissan dealership for 250 dollars!!! it was the rear O2 senceor...but it couldnt just have broken down in 4 mo?? my gas cap is tight...i use med to high gas...i tried taken off hte neg battery for a whole day..and i have been driving rough roads lately i dunno if that could be the cause??? I still need to try the fuse thing...but how and which one??? other than that the car is in perfect shape...can i just ignore the light..because i dont hear or feel any problem with the car at all??.any advice would be appreciated....
  • nickm2nickm2 Posts: 11
    When I first start my car after its been sitting around for a while, I hear a sound that sounds like a chain being dragged across concrete whenever I step on the gas. It goes away after 5 minutes or so, and the sound's not loud, but its new, so I'm concerned. Anyone ever hear of this?
  • shemzshemz Posts: 34
    This morning on my way to my university, the car did something weird and crazy, the RPM started to go up and down like crazy, then the car wouldnt accelerate and was shaking, it was very weird, then after i pressed the gas pedal a little harder it went back to normal...?? I remember i read this same incident that happened to one of us here..any advice would be helpful.. by the way The check engine light turned off.....
  • wackawacka Posts: 16
    I went and test drove an Altima S and SL and the thing with the arm rest I noticed had a problem too.

    The sales guy was showing if off and he COULDN'T CLOSE IT... tragic... it wouldn't latch.
  • jmaxejmaxe Posts: 198
    My 97.5 Altima has 35k miles and the airbag light recently started flashing and won't go off. I suspect this could range from a simple sensor problem to something quite costly. Anyone have similar experience and what was the outcome?
  • jebsdaddyjebsdaddy Posts: 52
    I helped my parents choose the Altima with the sunroof option and it is currently giving problems. The dealer will change the motor out when they receive a new one.

    My question is: The Edmund's paper back describes this as a one touch close/open type sunroof but that is not true is it? Someone with a sunroof on their car please let me know. I believe you have to hold the button down until the position is reached. One touch to me sounds like the driver's window that will lower all the way down with one touch.

    The problem with their sunroof is when I hold the close button, the sunroof closes but does not stop at close but keeps going until it is tilted up. To close the sunroof, one has to time it exactly right when to let off the button or bump it, bump it, bump it just before it starts to tilt up. Thanks for the help. Robert
  • aftyafty Posts: 499
    You are correct, the Altima's sunroof is NOT a one-touch open/close type. You have to hold the button down until it closes.

    Your parents' sunroof definitely has a problem. Mine stops at the correct point when you hold the button down.
  • rugmankcrugmankc Posts: 133
    I have a 94 Altima that has a flashing air bag light. Are there any recalls or service bulletins on this or is this an isolated incident? Any do it yourself fixes to avoid dealer pricing? FYI: to date this car has been flawless, highly recommend for purchase.
  • Hello all. Past few months, randomly, the car (2000 Altima GXE/auto) doesn't start - doesn't even attempt to. After a little jiggling with the shifter (which may be unrelated), it starts w/o problem. Its a random problem and this weekend I had my dealer look at it after getting an oil change. No problems found and it always started. The next day (yesterday), it left me stranded and I had to have it towed to the dealer this AM because it would just not start. It got off the tow truck, and started w/o problem yet left me stranded yesterday. I'm thinking its a loose wire somewhere, or possibly a faulty starter. Any ideas here as to what could be wrong?

    Anyone have advice for fixing a problem like this, where the car doesn't have the problem at the dealer so they can troubleshoot it?

    I don't want to take the car back, having the dealer say its fine, drive it to work, and find out that my car doesn't start at 7pm in a parking garage downtown where I work.

    Any help would be awesome. Thanks all.

    Dinos
  • iowabigguyiowabigguy Posts: 552
    There is a starter interlock switch that might be causing you your problem. The switch is connected mechanically to the shift lever and is meant to prevent you from starting the car with the transmission in drive. Your jiggling the shift lever is probably related. These switches can go out of adjustment or fail. If your dealer can't diagnose the starting problem I would suggest you find a dealer who can or an independent auto shop and have the switch replaced. On older American cars it was mounted on the shift column and was easy/cheap to replace. I'm not familiar with the Altima with the auto trans, mine is a 5 speed manual. Rick
  • rugmankcrugmankc Posts: 133
    jmaxe

    read post 20, I have similar problem but have not tried post 20 recommdation. will advise if it works. my 94 altima has been flawless to this point. a very reliable vehicle.
  • rugmankcrugmankc Posts: 133
    jmaxe

    did procedure in post 20 and it worked first time. don't know how long it will last. if problem reoccurs and parts are needed I will post info. good luck on yours.
  • knapp3knapp3 Posts: 112
    My Altima is only 10 months old with 14,000 miles. I noticed by 9,000 it was using a quart of oil every 3,000 miles. Mostly city driving. I've heard some say that oil consumption at this rate is nothing to be concerned about, but this is the first car I've ever owned that started using oil this early. Is there anything I ought to ask the dealer specifically to check since it is still under warrenty?
  • jd3456jd3456 Posts: 1
    I recently fixed the exact problem both of you mentioned - tach needle jumping up and down while driving and at idle, no accelleration, and stalling. It turned out to be the distributor (not the cap, but the distributor itself). I had it in three times before the mechanic caught this on a test drive. The mechanic was at least clueing in when he was troubleshooting because the engine computer was registering ignition failure codes. After two failed replacement rebuild parts, they have one in that is working and the problem is gone. I hope this helps.
  • hunter39hunter39 Posts: 375
    Hi! Has anyone else had problems with their emergency brake rattling in their 2002 SL 2.5's? Mine makes a "click" everytime I step on the brake at a slow speed, like waiting to get on the freeway at those green/red lights where you creep up to the light. It also rattles! I went to the dealer, and they ordered me a new brake, but that was 3 weeks ago! How has everyone elses experience been at the dealerships regarding warranty work?
  • ryan226ryan226 Posts: 1
    See post #108 by nickm2. I have a 2000 Nissan Altima with the same problem. It's at the dealer now in fact, having a last minute inspection before the warranty is up. The tech guessed it could be a worn belt. I found two service bulletins that I thought could even possible apply, NTB99052 and NTB00-005. It's not bad, the car still drives great, but it's new and I'm concerned. anyone else heard of this?!
  • blu1blu1 Posts: 2
    I have a 2001 altima and i have taken it to the dealer twice because the driver's side front window rattles when it is partially down, it rattles whenever i hit a bump or rough pavement. They have tightened the regulator and i guess reset the rubber sealing and it still rattles--help please? anyone else have this problem? or a solution/suggestion? thanks for any assistance
  • khoner13khoner13 Posts: 2
    I have a 2002 SL with a sunroof, and you can reset the sunroof by opening the sunroof to the full vent position. It is explained in the manual.
  • vindervinder Posts: 1
    has anyone noticed the very pronounced dash reflection on the 2002 Altima? I rented a 2002 and found that to be very annoying--more so than in any other car I have driven. Is that something that can be corrected. One car magazine review mentioned that as a negative.Has anyone else experienced this?
  • ling1403ling1403 Posts: 3
    NO, definitely not.

    I have a 4 cyl. auto. 2.5s. Have any of you experienced some tapping noise from the engine hood? It is like a noise from circulation of chain or belt. It is not so noticible when the car is running, but in idling condition, it is very noticible. I took the car to a Nissan dealer, but what I heard was simply 'normal'.
    Any of you know how to erase it?
    Any comment will be appreciated so much.

    From Eugene, OR
  • ling1403ling1403 Posts: 3
    NO, definitely not.

    I have a 4 cyl. auto. 2.5s. Have any of you experienced some tapping noise from the engine hood? It is like a noise from circulation of chain or belt. It is not so noticible when the car is running, but in idling condition, it is very noticible. I took the car to a Nissan dealer, but what I heard was simply 'normal'.
    Any of you know how to erase it?
    Any comment will be appreciated so much.

    From Eugene, OR
  • mark38lmark38l Posts: 10
    I have a 99 Altima with 100,000 miles and just brakes replaced so far. Runs so good I dislike having major service items replaced. I do the usual oil and xmission changes etc. But not replaced plugs or timing belt. How safe is it to postpone or never replace the timing belt? I dislike mechanics pulling the engine apart to do that, seems like other problems get introduced. Anyone ever go 150,000 miles on an original timing belt?
  • gslevegsleve Posts: 183
    aren't required to see that much mileage without replacement it'd be interesting to see how the computer reacts when these maintenance items are performed. You can count on the engine racing at 2500 rpms due to the shock introduced to the ECM you'll have to give it time to get acclimated to the change because it's just so radical and not gradual.

    You're in for a real surprise, the computer can only compensate so much and for a so long.
  • shmangshmang Posts: 297
    The altima uses timing chain instead of belt, so there is no need to change it right now, you can go until you hear some symptom that suggest your chain need to be changed, but that would normally happens around 150k - 200K.

    But, for plugs, wires, distributor cap & rotor. You need to change them. even for performance and fuel economy purpose. You will be amazed to see how much better the car performs after replacing them. I have done all of that on my car when it had 70K and noticed a real performance and MPG gain.

    The distributor on 95-99 altima is not very reliable, if you don't change the cap&rotor, you will stress it and it will fail sooner or later - which will cost you about $300. I have heard a lot of people had distributor went north around 100K mark (most are around 120K though). So, it would be good to replace all of them NOW!
  • mickei26mickei26 Posts: 2
    i've been having problems with my altima's door locks for about 2 weeks now. first the driver's side. the key goes in but won't turn or anything. so i've been unlocking my car from the passenger side. (i don't have remote entry-but i do have power locks) yesterday the same thing happened to the passenger side door!!! i have two keys to my car and tried them both. nothing. since the trunk still opens i figured the keys weren't the problem. or maybe they are i don't know. i called a nissan dealer and they told me to try wd-40. i sure hope this works. :( any help is greatly appreciated. thanks.
  • shmangshmang Posts: 297
    If the key does not work, it has little to do with power lock. It is the linkage that opens the door when your turns the key. (From what you describ, the unlock function on the power lock works OK.) So, the best thing to do is: remove the door panel and see which part of the linkage is broken. Since the power lock is connected directly to the lock/unlock pin, it can still function even the key does not.

    It is farely easy to remove the door panel and inspect yourself before use any chemical - which may make it worse, then you need you pay $$$$ to get it fixed.
  • dash11dash11 Posts: 1
    I'm working on my 3rd Nissan. The thing that I like about the engine is the timing chain (versus a belt on other engines that might need replacing at 60k - 100k miles). My 1991 Stanza was running great with 184k miles on the original timing chain, until it was totaled by a rear collision last week.

    I expect the same use out of my 2001 Altima (21k miles).
  • blu1blu1 Posts: 2
    my 2001 altima driver's side door window rattles when it is partially down, i've taken it to the dealer twice-- they have adjusted the regulator and the rubber seal and that has not corrected the problem. it is so annoying, if anyone has any suggestions please HELP. Thank you
  • beefy620beefy620 Posts: 1
    96 altima gxe has under 75k done all routine checks and replacements there is a sort of clicking or scraping noise coming from what seems to be where the timing chain is located. the car runs perfectly to my knowledge. One opinion says its just a guide that can be easily removed. want to know if anyone has had similar problems and if it just is the guide or if I need to get the timing chain replaced.(which isn't cheap) Any suggestions???
  • johnk13johnk13 Posts: 1
    Has anyone had a problem with cracks in the
    front wind shield of 2002 altimas?
Sign In or Register to comment.