Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Nissan Altima Maintenance and Repair

14849515354132

Comments

  • timbitstimbits Posts: 1
    Hi,2001 atlima 2.5 serpentine belt (for a/c,power steer)suddenly shredded and I lost ++ green fluid(?steering or a/c fluid,I don,t know)Are these known to snap ,or am I looking at something more sinister Tim
  • how do i check my ECM/ECU codes?
  • helmutoehelmutoe Posts: 1
    I just had the motor of my 1996 Altima steam cleaned. When I took it home, a couple of hours later, the engine light on the control panel went on. The performance seems OK. Anybody have any idea as to the cause?
  • doyindoyin Posts: 22
    Fisrt,u'll have trouble reading your codes.97 is OBDII and 93 is not.Cant say for sure about trans problems tho.
  • desibhaidesibhai Posts: 3
    Hi,
    I own a altima 1995, the car would start but would stop after going some distance...I started opening the spark plug wires and checked to see if there were ignition....3 of them were ok , but the 4th one when i pulled the wire, ,there was lot of oil in it. I gues oil has gotton into the spark plug chamber......is this something i can fix...seems like u had the same probblem...can u advise how i fix this
    thanx
  • desibhaidesibhai Posts: 3
    Car would turn on ....but stop after some distance....when i pulled one of the spark plug wires, ,there was lot of oil in it...the other 3 wires were fine/.any idea what i shoud do ???. Car keeps stalling. last year they changed the distributor and sparplugs and the wires....

    thanx
  • ckg7310ckg7310 Posts: 1
    I just had the radiator replaced in my 2002 Altima which only has 45,000 miles on it. I originally took it to the dealership service dept and was just told I needed the radiator replaced. I then took it to my regular mechanic and was told that the epoxy used on the radiator had come loose and had clogged up the radiator and would have to have it replaced. Has anyone else experienced this problem?
  • rayfeurrayfeur Posts: 6
    My Nissan Altima 2002 stalls all the time, as soon as it hits 2500 RPM.
    Per the Hudson Nissan the problem is being caused by the DashBoard Circuits..
    (Unified Meter) according to the Service Manager, it controls the RPMS and
    transmission, it sound like BS to me. Can anyone with knowledge of this help
    me out.They want 600.00 plus labor to replace it... 'm leasing ,
    why should I have to pay.

    This is the last Nissan that I buy.

    Year/Make/Model: 2002 NISSAN ALTIMA SE
    Body Style: Sedan 4 DR
    Engine Type: 3.5L V6 DOHC MPFI 24V
  • chillschills Posts: 1
    My gas gage is not ready correctly. When full it reads a 1/8 tank past the "F" mark. The needle seems to stick on the 1/4 full mark also. The only way to get the needle to drop past the 1/4 full mark is to shut the car off and restart and that does not always work either. Last night the needle read a 1/4 tank, I drove 10 miles shut the car off and when I got back in to leave the gas light was on!

    I already took it in and the dealer found no problems. Go figure!
  • k8ttyk8tty Posts: 3
    I have a 98 altima. The airbag light is on. Its not flashing, the light is steady. Will this procedure work as well?
  • k8ttyk8tty Posts: 3
    I have a 98 nissan altima. The antenna is broken. Is it best that I go to a Nissan dealer and replace it? Can I just go to an auto parts store like Pep Boys or Autozone and just get a replacement antenna mast. A friend said that its best to use genuine Nissan parts for the car, but I know its going to so much more expensive. Would I have any problems using a power antenna that I didnt get from NIssan?
  • rugmankcrugmankc Posts: 133
    don't know, try it. there was a recall on the airbag system, at least for my 94. not sure what they did. you may need to do some research.
  • jennkajennka Posts: 3
    Oh my gosh!! This is the same story with my '97, any final solution?!!!
    Please Advise!
    -Jennifer
  • the noise is in the strut it needs to be replaced
  • it is a normal thing its the cooling fan inside the altenator
  • I have a 94 nissan altima and the left rear and front right speakers don't work. The other two work fine. When i tried conneting a new speaker one of the ones that did not work it also did not work.
  • fizgig36fizgig36 Posts: 4
    My car didn't start again on Tuesday and of course it always happens after 5pm so I can't take it anywhere and than it starts up fine the next day. My mechanic has no clue what the problem is. I will tell him to check out the fuel pump. Thanks for your help!
  • roadmaproadmap Posts: 1
    I live in Tucson Arizona and I have having the same issues exactly for me now that the hot air is here it is happening more and more for extended periods of time. I have yet to be able to find the solution.
  • ddhamiltddhamilt Posts: 2
    The muffler on my Altima 97 has broken off from the exhaust pipe...I bought this Altima '97 used last year and it runs great.

    MEINEKE SAYS....
    Need to replace muffler and exhaust pipe both, because the flanges on the muffler and on the exhaust pipe are rusted together. The connection broke just behind the flange on the exhaust pipe. So the muffler is intact, Meineke claims that because it is fused together with the exhaust pipe flange that both pieces need to be replaced. Hmmm...

    Cost of muffler $157
    cost of exhaust pipe $138
    plus gaskets and labor charge of about $50
    TOTAL about $340

    Doesn't $340 seem too much for replacement of a muffler and exchaust pipe? Shouldn't the parts be cheaper? Is there serious markup going on here? Would I be able to order the parts online and have a local mechanic do it? I am in Queens, New York (NYC).

    I appreciate any help. Thanks.
  • dballdball Posts: 15
    I have a 2005 3.5 SL with 1400 miles on it. Since it had 10 miles on it, it has driven and ridden like a piece of junk. I tried to take it back but the dealer refused and said I had to bring it in for service. I called the GM of Reed Nissan in Orlando, FL 3 times only to be ignored. Called service manager, salesman and were ignored by them. Called Nissan NA and told my rep I wanted a new car. She had me take it to another dealer who could only manage to road force balance the tires and then proclaim there was nothing else to do. I had a continental tire dealer put 4 new contis on, then some Michelins. No help whatsoever. You can put a glass of water on the dash and there is a steady ripple vibration the whole time, at 40 and over. I drive a lot of rental cars in my job and these cheap American cars ride much better than this $30000 dollar Altima. I am lemon law-ing the car this week. How sad, I think it's either one or more of the wheels that are not round or the axles. Nissan refuses to stand behind their product and the dealers are a joke. Buyer beware!!!!
Sign In or Register to comment.