Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Nissan Altima Maintenance and Repair

1676870727388

Comments

  • Yes, the fuel filter is in the gas tank with the fuel pump. I would check the fuel pump relay and then measure the fuel pressure first to see if it is in specs. If the fuel pressure is low or erradic check the fuel pressure regulator, and if ok you will have to remove the fuel pump and replace the pump and filter. There should be a removeable access cover inside the car under the rear seat or trunk.
    Good luck
    E.D. ISF
  • lp123lp123 Posts: 1
    I cracked the front of my bumper, and along with the bumper, the part of the car that covers the wheel and is screwed onto the bumper cracked, also. What is that car part called? Does anyone know where I can buy cheap replacements for these 2 parts, and around how much I might be looking at for auto body labor costs? I have a 2002 Nissan Altima 2.5 S. I'm just trying to find the cheapest way to have these replaced because I'm a broke college student haha. If anyone could help me, that would be so amazing! Thank you!
  • Usually for things like this, I would go to a "wrecking shop" a/k/a junkyard. However, considering that many recent models of cars are creations of molded plastic held together at times with clips, I would see if an auto parts clerk at a dealership can help with some good advice. I am lucky enough to have a guy who takes the time to go outside and look at whatever problem I may have. At times, he would suggest aftermarket. I don't look at him as a traitor, but a good employee helping to build goodwill for that dealership. That will factor into my next purchase. Oh, by the way, I am one of those people who does not hesitate to write letters of complaint. I have already sent of letter complimenting him to his general manager.
  • Have you checked the voltage regulator
  • wbwwbw Posts: 1
    A coke was spilled on the the shifter cover so it went all over. Any idea on how to take the cover off so it can be cleaned inside and out??
  • yggieyggie Posts: 1
    I just recently purchase a 2003 Nissan Altima, 4 cylinder, S. Today when I was going to lunch, I noticed the car engine started shaking. I drove about three blocks and the check engine light came on. I didn't want to stop for fear of being stranded. I drove about one mile and the light went off and engine stopped shaking? I took it to the Nissan dealer (as I still have a warranty on it) but they wouldn't see it until tomorrow to check it out on their computers. Does anyone know what is wrong with my car? Please help!
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,902
    Sounds like you lost a cylinder there for a minute---either faulty coil/igniter/spark plug/wire (not sure what your engine uses) or maybe a bad injector. I bet the code will show a "misfire" in a certain cylinder.

    MODERATOR

  • jd10013jd10013 Posts: 779
    isn't there a recall out for the cam and/or crank position sensor? and wouldn't that cause the same thing.
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,902
    not a crank sensor. That would cause the car to go dead I think and not restart, whereas the bad cam sensor will cause the engine to die but restart for a short drive, then die again, etc. Both of these should throw the CEL as well as error codes.

    I'm still gonna go with weak coils or some other problem relating to just one cylinder.

    MODERATOR

  • You did not say how many miles are on the vehicle, but I would guess high since it's a 2003, probably 80,000 or more.
    Lot's of things could cause that miss. Here is another possibility:
    This symtom could also be caused by engine coolant entering a cylinder, the same thing happened on my daughters 2002 Altima 2.5S, with 100,900 miles. Watch the coolant level in the resivior and radiator, check the radiator ONLY when the engine is COLD. If you mysteiously loose coolant without any apparant leak, it could be the problem. Also watch for steam out the exhaust pipe, AFTER the engine has warmed up. It is normal for most cars to emit a small amount of steam and water out the exhaust pipe when first started, and for the first few minutes while warming up. This is because gasoline turns into mostly water when it burns. It is in the state of steam in the exhaust stroke, then when it enters the COLD exhaust pipe and muffler, it condenses back into water that you can see. Once the exhaust pipe and muffler are hot, the water remains steam and you don't see it, unless it comes out into cold air. If you have coolant leaking into the cylinder, it will often come out the exhaust as visible steam because of the volume of the coolant and it also causes the cylinder to misfire. This may or may not show up in a code, depending upon how bad it is.
    These engines are KNOWN to warp heads, my daughters Altima 2.5S head was warped .005" and had to be milled at the machine shop. After rebuilding the head and putting it back on a week ago, it is doing fine so far.
    If you want to know more about the work I did on the engine, you can go look in the Nissan Altima Engine Failures forum. There are long discussions there about the problems with the Pre-cats, Catalyic Converters and engines. Use the SEARCH feature.
    Good Luck,
    E.D. in Sunny Florida
  • neo_neo_ Posts: 14
    I can pull mine straight out. give urs a try.
  • I'll take a stab at this one: I'm willing to bet its the cam or some times called the crank sensor. Nissan has a factory recall on this issue that started in August of 2006. You can call Nissan at 1-800-647-7261. They will re program the engine control modal (ECM) for free. Low speeds and stop and go driving can cause the cam sensor (located at the top of the engine -inline with the distributor) to overheat. When the sensor over heats it gives false signals to the ECM. The ECM will try to correct the engine timing which will cause the engine to vibrate, which in turn is picked up by the knock sensor (detects engine vibration) - which will shut the engine down before the vibration causes mechanical failure.

    Please write back and tell us what the dealer tells you.

    Ray Danley
  • How to remove front door panel for Altima 2000? I'd like to replace speaker.
  • All,
    Can you please help with this vexing issue? I bought a 2002 Nissan Altima 2.5 SL new from the dealer 6 years back.

    The remote for our Altima had stopped working. Initially the car used to respond sporadically, but without any sounds (usually associated with locking of the car). But after sometime, it stopped responding completely. I thought it's the battery in the remote and got it replaced. But the problem continues. Never had this problem in the last 6 years.

    I, now, suspect that it's an issue with the car sensor. have you guys heard/seen something similar?

    Thanks in advance,
  • I have a nissan altima. We first had some problems with the injectors. Than I was driving the car and it just died. Than it wouldnt start. I am wondering could it be the distrubitor. Or I also was told that it could be the timing chains. We want to get the car fixed but we are afraid that if it is the timing chains the valves could be bent. Does anyone have any ideas?
  • 2003 nissian altima 70+ miles :blush: ...recently gear box starting sticking ... having problems shifting from park to drive, reverse...sometimes i spend 2-3 mins trying to move it...help :cry:
  • 97alty97alty Posts: 4
    Did the car made a lot of noise before it died? You sure you fixed injectors right? Sounds like injectors or ignition problem to me.
    Timing chains usually last very long time, why would you think it's chains? How many miles you have on your car?

    Try posting your question on edmunds answers page too...
  • You ask many questions about what the problem could be, but the only way to find out is with proper diagnosis, not just guessing. How many miles on this engine?

    First, what was the problem with the fuel injectors and what was done about it? Fuel injectors ar relatively trouble free. Sometimes they can clog or burn out. If you have bad ones, you simply replace them with new ones and replace the fuel injector seals with new ones. You check the electrical signal to each fuel injector by connecting a "NOID LIGHT" to each fuel injector, they will flash each time the they recieve the signal to "fire" the fuel injector. If the noid lights flash they are recieving the signal. The only other problem that you can have is if the fuel injectors are out of time. They are fired by the computer signals and the computer sends the signals according to the signals it recieves fron the CRANKSHAFT SENSOR and the CAMSHAFT SENSOR. Those sensors should be checked to be sure they are working. If the fuel injectors are working properly, continue to the next item.

    Second, the distributor and ignition timing should be checked. If the timing chain was off, it would make the ignition timing off. Check the distributor for any leaking oil inside of it, as this has been known to create problems before. If the distributor is working fine, the ignition timing is set correctly, the spark plugs wires are good, connected correctly, and good spark at the spark plugs, continue to the next item.

    Third, remove the spark plugs, connect a battery charger to the battery and using a cylinder compression tester, test the compression of each clyinder while cranking the engine. You should disable the ignition and block the throttle open while doing this. Write down the compression on each clyinder, the miles on the engine and the date, and keep it for your records. You would need to check the specification for your vehicle to see what compression should be expected. I would expect compressions of more than 140, but check you specs first to be sure. First, look to see how even they are, they should vary by no more than 20%. If the compressions are low on one clyinder, and ok on the others, I would investigate to see what the problems is with that one cylinder. If all of the cylinders are low, it may be because the timing chain is out of time or possibly some of the valves could be bent or leaking. This would require looking into the engine, removing the valve cover and timing cover to check the actual timing of the camshafts relative to the crankshaft.
    Good Luck,
    E.D. in Sunny Florida
  • 2001 Nissan Altima. ~56,000 miles. Today, I turned off my car and opened the driver door, and the car alarm went off. I closed the door and waited it out, then turned the car on, off, removed the keys and tried again. The car alarm went off again. The security light was fine.

    I've been driving it for the past month or so without the keyless entry/lock, since the buttons were damaged. Using the key manually has been fine so far, so I don't believe that's the issue. Any help is greatly appreciated.
  • Hello, well I am not sure why they might want you to change all of your brake pads, unless they want to make extra money from you. Usually the front pads will go before the back ones. But, another reason you might need it really depends on if you are a person who is hard on your brakes, then they will need to be replaced sooner than someone who isn't. For instance, if you live in a city or is in traffic on a constant basis, then this may be the cause. Hope this helps.
  • Hello, I would go head and get a new remote or disconnect the alarm system. Reason being is most cars have a mode which disables the car when the alarm systems goes off, not saying that it will affect your car, but it might be a time when you try to start your car and it will not start, because of the alarm system. Hope this helps.
  • recently my 1995 altima has been giving me some trouble. The car will not recognize that it is in Park and so will only turn over in Neutral. i've tried jiggling the shifter to help the connection, but still will not work. what do i need to replace or do in order to fix this problem?

    also, the car has been randomly shutting off...on the interstate with my foot on the gas or at stop lights...there is no pattern to it...does a camshaft sensor sound right to anyone? Any feedback would be great!
  • yeah the alarm is querky, but it is disengaged...the problem is somewhere between the shifter and the starter...it wont recognize that it is in park
  • I have a 98 Nissan Altima. I bought it from an individual. I test drove it twice on two seperate occassions and it ran fine. The day I got it I drove about 50 or so miles in it and it done great. The next morning I drove it 20 miles to work. That is the last time it has ran right. When I left work, it cranked fine, but when I slow down or stop at a stop sign, it shakes and goes dead. As long as I drive about 45 mph or above it drives fine, but if I slow down or stop, it messes up. We have changed the plugs, wires, fuel filter, the altenator, the battery....we even took it to our mechanic. He put it on the diagnostic machine, supposedly, and said that it read no codes, so he suggested a new computer. We bought the computer and had him put it in. He told us that he drove it and it was fine. We went and picked it up, drove it half way home, and it was doing the same thing again. Please tell us what this could be??? I have the worst luck with cars...so I am desperate for an answer. :cry: :lemon:
  • I have a 98 Nissan Altima. I bought it from an individual. I test drove it twice on two seperate occassions and it ran fine. The day I got it I drove about 50 or so miles in it and it done great. The next morning I drove it 20 miles to work. That is the last time it has ran right. When I left work, it cranked fine, but when I slow down or stop at a stop sign, it shakes and goes dead. As long as I drive about 45 mph or above it drives fine, but if I slow down or stop, it messes up. We have changed the plugs, wires, fuel filter, the altenator, the battery....we even took it to our mechanic. He put it on the diagnostic machine, supposedly, and said that it read no codes, so he suggested a new computer. We bought the computer and had him put it in. He told us that he drove it and it was fine. We went and picked it up, drove it half way home, and it was doing the same thing again. Please tell us what this could be??? I have the worst luck with cars...so I am desperate for an answer. :cry: :lemon:
  • lrs52lrs52 Posts: 5
    HI EVERYBODY , I HAVE A 2OO1 ALTIMA WITH 54,000 MILES. I WAS HAVING SIMILAR PROBLEMS LIKE OTHERS REGARDING THIS. IN LATE OCTOBER MY LOCAL DEALER RECOMMENDED REPLACING THIS SENSOR. LESS THAN A MONTH LATER THE RECALL IS ANNOUNCED BUT DOES NOT INCLUDE 2001 MODELS. I AM CURIOUS HOW MANY OTHERS THIS HAS HAPPENED TO .I AM SURE THIS IS THE SAME MOTOR 2.5L AND THAT NISSAN NEW THEY WERE HAVING PROBLEMS FOR A WHILE. ANY HELP FROM OTHER OWNERS WITH THIS ISSUE WOULD BE APPRECIATED. I LIVE IN SANTA ROSA ,CALIF. THANKS. LRS.
  • It's the distributor! You need to replace the stock Nissan distributor with a Dorman distributor. I own a 1994 Altima (318,000 miles on it) - my daily driver, a 1998 Altima (78,000 - wife's), and a 1994 240SX (play drifter). The distributor on your car has a well known flaw - at low speeds it heats up and causes an oil seal to leak. Right now yours has a small leak. Oil is passing into an area, in the distributor, that contains a cam timing sensor. The sensor works by passing light through slotted holes in a spinning medal disk. If oil gets on the disk or light reader the sensor will send weird signals to the computer. The computer will try to compensate by adjusting timing or fuel flow, but it only makes the problem worse. This is why your mechanic wanted to replace your perfectly good computer. The engine will run correctly at high RPMs because the leaking oil gets spun off the disk read by the light sensor.

    This problem will only get worse. When the oil seal completely breaks you car will not run at all. I have heard of some people solving the problem by drilling a small drain hole at the base of the distributor casing. I opted to simply replace the Nissan distributor with a high quality model. I have had no problems since the replacement.
  • Please check to see exactly what engine you have, because I checked, and the 2001 Altima should have a 2.4 L engine. The problematic 2.5 L engine did not start until 2002. You may not be having exactly the same issues, but possibly similar issues, because all the computer based engine systems use sensors. Some are just more problematic than others. A faulty crankshaft position sensor could cause a number of problems, engine runs bad, engines dies, hard starting, or no starting.

    Exactly what "similar problems" are you having? If the dealer recommended to replace a sensor, it is probably a good thing to go ahead and do it, since they have the equipment there to diagnose it correctly. Unless it is very expensive or troublesome, then you could always take it somewhere else for a second opinion.
    Good Luck,
    E.D. in Sunny Florida
  • Thanks alot for your reply. We took a look at the distributor before I ever posted my question. Are you familiar with the plug that goes into the side of the distributor? Well, mine is all busted up. We tried putting black tape on it and it worked for awhile and then messed up again. We went to a place in Atlanta called Pull-A-Part and found another plug, but, just my luck, we put it on and it was dry rotted so it is now broken also. We have called around, but everwhere wants to sale us the whole wiring harness. So, do you think it is the plug, or still the whole distributor? If I buy a new distributor, will the plug come with it? Thanks for your help!!!! We are pretty desperate to get this think fixed. It is very dissappointing to buy a car and only get to drive it twice.
  • jd10013jd10013 Posts: 779
    I don't think you need to buy a new distributor, just a new cap should do. that, and a set of cables should have it running perfect. shouldn't cost that much. a good set of plug wires will probably go for $60, though you can go cheaper if you want. not sure what a distributor cap runs.
Sign In or Register to comment.