Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Ford Expedition Maintenance and Repair

1141517192094

Comments

  • All, I just purchased a new Expedition (E.B. 4x4) 11 days ago. It has been in two different dealerships totaling 7 days for vibration related issues. I just spent a hell of a lot of money on this vehicle...obviously my dissapointment level is high. It gets higher when both dealerships tell me that they have looked at everything and can not rid the vibration; "yours rides better than the three we have on the lot"...what the heck is that?
    Does anyone have any suggestions or has anyone found a solution, i.e. new tires, steering, etc.?
    Please e-mail me at pkahl@micheldist.com.

    Thanks,
    PK
  • wkohlerwkohler Posts: 74
    Whatever you do, stay away from 03 expeditions that have an "A" before the last 5 digits of the VIN. They were early built (2002) models that had numerous problems. Look for ones with a "B" or better yet, a "C" before the last 5 digits of the VIN..........Mine had a "C" which was built in May of this year, has just gone over 10,000 miles with nary a problem. The other expedition I had was an "A" model and was in the shop more than I had it on the road.
  • tkenny53tkenny53 Posts: 41
    thanks for the info. I'm looking at the sticker dates, what I'm seeing is build dates from 4/03 to 6/03, did saw one from march.
  • wkohlerwkohler Posts: 74
    Those dates should be good, as long as they're the build date. One positive way to tell is to open the drivers door and look at the sticker attached to the door post. good luck!
  • graytrgraytr Posts: 1
    WE have a 2002 XLT when we go to the drive in theatre we back up the vehicle and open the back door. The vehilce lights inside and outside perimeter and running board lights all turn on. I asked Ford if there was a way to disable the lights or turn them off they said NO thats just the way it is.
  • nvbankernvbanker Posts: 7,285
    I believe the dealer is correct. It's a courtesy feature and security issue. You'd have to pull the fust for those lights, and live without them all the time.
  • rtomrtom Posts: 2
    Am I the only one who has noticed, strangely enough, that almost every 03 Expedition's front wheels are very dirty? What's with that? There is obviously some design problem, because I don't have that on my older model, nor have I ever seen it on other older models, but almost every new one is like that. Anyone heard any response about this?
  • nvbankernvbanker Posts: 7,285
    Oh yes. It's the brake pads. There are a couple of fixes in the works, and I'm not posted on the details, because it doesn't bug me that much that I would fix it. There is a shield that scares me. I don't like to mess with the engineered ventilation of the brakes. The pads can be replaced with another type that doesn't make that much dust. But what I really like is the brakes on my Navigator are incredibly effective, and have saved me twice so far already. I'll put up with the black wheels.....
  • I have a 98 Eddie Bauer purchased used. It has about 63000 on it and I have this rattling coming from the rear. I am wondering if it needs new shocks or struts? I'm not sure what the truck has becuase there was no manual in it when purchased. I have ordered one, but in the meantime I don't want to do any damange to the truck. Other than that, it is running GREAT.
    thanks for any input...RJS
  • Move the dash light dimmer control all the way to the bottom. This will deactivate the lights when the door(s) are open. If it doesn't work then they are made to be turned off, and you would need to pull the fuse to turn the lights off.
  • nvbankernvbanker Posts: 7,285
    Do you have the optional air suspension on your truck? An Eddie Bauer most likely does. So, if that's what's rattling, (although mine never did), those are about $1000 a piece installed. But it could be anything. This isn't a normal problem, and it could just be your spare tire loose.
  • jrc346jrc346 Posts: 337
    Check to see if the spare tire is up in there tight. I had a rattle coming from the rear of my 99 Expy and sure enough, the spare wasn't quite secured very tight. Goodluck!
  • Soon after delivery I noticed a vibration between 45 - 50 mph. Took it in to local Ford Dealer on July 7th with 1033 miles on it.

    The checked front end alignment, tire balance, replaced differential, u-joints, drive shaft and engine. After 16 days in the shop I sent Ford a registered letter advising them they had 10 days to repair vehicle, if not after 30 days I was going to pursue the Florida Lemon Law. Ford did not respond. After 37 days and they quit trying to fix the problem Ford offered me a like vehicle and offered to forgive the mileage amounting to $54.27. I have ignored their offer as I already asked for refund under the Lemon Law. Hope this will help someone.
  • omega35omega35 Posts: 1
    I have a 2003 XLT (8,000 miles) and I'm having a similar problem, but the car shakes while its on the road (mainly the freeway). My wife will no longer drive the car and its been sitting in my driveway for the last week. At first I thought it was the tires but after putting on new top of the line tires (because the stock tires are every lacking) 75% of the problem went away. I finally took the car in today to the dealer and Ford knew about the problem. It seems they have had a lot of 2003 come back with the same problem. They are currently working on the car. What they have said is the rear ends in lot of these are bad and this is what is causing the shaking and vibrating problem. I will email back when I get the full service report.
  • nvbankernvbanker Posts: 7,285
    Oooh, that's not good news.....
  • ttvjottvjo Posts: 4
    i just got my 2003 expedition xlt 4.6 motor 3 weeks ago and sometimes it feels like i have bad gas in it. Sometimes it feels like it just won't pick up not all the times but sometimes. I took it back to the dealership and they could not find anything wrong because the engine light was not on and that the problem just wasn't there at the time they drove it, just fine. it has 7500 miles on it and it's a demo. what kind of gas do u guys use in your expediton because they told me 87 octane which is regular gasoline. I prefer to use plus but i really think it is a gas problem any one else have this problem. and what's up with the break dust on the front wheels i just wash the vehicle yesterday and my wheels are black and getting tired of cleaning them off all the times
  • nvbankernvbanker Posts: 7,285
    I didn't even know they still sold the 4.6L in the Expedition. In my opinion, that's not enough engine for that size truck. But if you're using Premium, you're probably exacerbating the problem. The car is designed for 87 octane. It will run best on that if it's running right, and if it's not running right, you'll get a check engine light. By putting premiun in, you're raising the combustion temperature some, and wasting money, and probably lowering your mileage.
  • yodeyyodey Posts: 3
    Has anyone else had there 2003 XLT in for service for vibration when turning ? I have 800 miles on my new expedetion and took it in to get this checked and service said it is the disc plates for the posi track rear rubbing together. So they squitted lube in it and said to drive it and it will go away. Well it has not gone away. Any soulutions out there because I am embrassed to have people ride in $40K that rides like a clunker.
  • Limited slip rears do occasionally bind up. The way to correct it is to put in a "limited slip additive". If they just topped off the resivoir with regualr fluid it probably won't change anything. To do it right they should have removed some of the fluid to allow the right mixture of additive and fluid. This of course depends on whether or not the original diagnosis was correct.
  • jrc346jrc346 Posts: 337
    This may sound corny, but it's just a thought. Is your A/C running during this time that you are encountering this situation? If the expy runs smooth, but just doesnt have the juice at times, it may be because the A/C is running. With 4.6L in these newer heavier vehicles, you are probably going to feel it when the a/c kicks in.
Sign In or Register to comment.