Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Ford Expedition Maintenance and Repair

1616264666794

Comments

  • Firestorm-

    Your right on. It was the coil on the #6 cylander and the cost is $370.
  • i have a 98 expedition and im havein battery problems. the car won't start all the time, i give it a jump and it will work for a little while but then the battery will go dead. I need help badly!
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,403
    If it's the original battery it's probably tired and needs replacement. 5-7 years is more than enough for a battery.

    Here's what you can do. Put the battery on a charger (SLOW charge), then take it in and have it LOAD TESTED (a stress test). If it fails, replace it and then have your alternator tested--although I suspect if the car keeps running with a battery jump, the alternator can't be the problem.

    The only other problem I can think of if it's not your battery is that you have a current drain.

    By the way---don't keep charging a dead battery with your alternator, or you'll soon have a dead alternator AND a dead battery.

    MODERATOR

  • I have tried a dozen times to follow the directions to turn off the seat belt warning on my '05 EB Expedition. The dealer won't help.

    Has anyone benn able to get it off?

    Thanks.
  • Well more rain, and more issues. However, this time 121.34 at the Ford says that water was in the circut box and has now been "fixed"... The two problems we had as the fan blower and air shocks. I will let you know...

    Wen
  • There is a technical service bulletin TSB-05-9-17 that covers this problem. You will need your restraint control module (RCM) changed and the software upgraded. Take it your dealer, this problem is covered.
  • i have a 99 expy and it used to blow hot air with a/c on. have you looked at the temp switch/dial (knob) in the dash? mine has cracked twice and then it spins on the pin, and therefore, won't move to or blow cold. had taken it to the dealer and they wanted to replace whole switch panel for the fan, temp, etc. did not like price and pulled knob myself, then turned the pin with a pair of needle-nose pliers. boom, cold air. crack in knob is very small so get it under a light. may or may not fix it but it's cheaper than replacing items until you find the problem. good luck.
  • my left turning signal is blinking fast whats the cause of this, a friend of
    minds said it's the turning signal bulb so i replace the 1 i thought was out but
    it still blinking fast . do anybody know what the problem is..
  • I own a 2005 (bought in April) and I have had it in for repair numerous times. The rear A/C makes a hissing sound and a "hooting" type sound. After sixth time the dealership said it was low on freon. After repair they said it was all fixed. Picked it up and it was still the same. It wasn't until then they discovered a TSB from Ford explaining they are having problems with some rear A/C units. They explained to evacuate system and recharge to 58oz of freon. If this didn't work there was no fix for the problem at this time and there engineers were working on it.
  • Is anyone else having a problem with their tire pressure sensor?

    Last year when it was a round 10 degrees or colder and snow and ice on the ground I could understand it happening. Last year the light would only stay on a few minutes. Now it is only in the 50's and it's coming on. The dealership reset it and it seems to be worse now. It stays on from 6-10 minutes. When they have kept it over night of course it hasn't been cold enough for it to come on. Should I take it in 1 more time when it is cold and see what they say or should I just call Ford and see what they have to say? Is it something that can be disconnected?

    Thanks for any input.
  • in my experience timing chains rarely (if ever) have to be replaced, maybe your advisor said the front guides (or cassettes they are referred to) need to be replaced. i know somebody else mentioned the chain is replaced at 100000kms as maintenance but that is a timing belt. does the noise only occur on start up or is it present while driving or at idle? i will keep pondering this one.
  • rbatesrbates Posts: 1
    I have had the same , i mean same identical problems with my 2003 expedition. including new ac mirror motors, rear end replaced, altenator, transmission rebuilt and they still will not do any thing for me.
  • I own a 2005 Expedition and the A/C is also making a hissing noise toward the rear of the car. I can turn the rear air unit off and the noise still occurs, but if I turn all the air off (in the whole car), the noise goes away.

    My Ford service dept. has told me the same thing...we've done what the TSB says and there's nothing else we can do.

    Anyone have any thoughts?

    Thanks!
  • I just picked up a 2006 exp. limited last week. I have 3 clothing bars in my garage but none of them fit over the wide fitting in the exp. I called the dealer and ford does not offer anything. If someone has a clothing bar that fits, will you post where you got it. I'm talking about the bar that goes across the back or second row seats that allows you to hang clothes on it.

    Thanks
  • The check battery red symbol is always on even after I have replaced a failed battery and alternator. It passed a battery and charging system load test. The battery charging gauge never fluctuates and always gives a good reading.

    Thank you in advance for your help, Cliff
  • I had the same problem but on the right side I replaced everything including relays and so I took it to Ford....they had to replace the entire blinker assy....in the steering colume...there was a short in it.

    Aprox...$300.00
  • Recently fixed the spring that allows the dashboard cupholder to be pushed closed/locked, then pushed again to open and pull out. I can't figure out, though, how to get the locking mechanism set. There is a small post on a pivot in the back of the mount that fits into a mechanism on the cupholder - has anyone ever put one of these back in that can help me? Thanks.
  • scdscd Posts: 15
    Leather seat update: Took my 05 XLT to the dealer regarding the seat problem. They replaced the front seat leathers. Looks like they are starting to crack again. I'll probably be back in the dealer in about another month for more replacements. Does anyone know if the King Ranch or Limited has a better leather seat surface than the EB or XLT's?
  • pmorg1pmorg1 Posts: 7
    I have a '99 Expedition EB with a 30 gallon tank. Whenever I try to fill the tank, usually when it requires 25+ gallons, the last 5 to 6 gallons has to be pumped very slowly or it will cut off the pump. This is frustrating. It has been this way since purchased new, 6 years ago. Obviously it seems it would be related to a venting problem, but I have been unable to find out any information on this type of problem.

    Does anyone else have this problem or know of a solution.

    Thanks in advance.
  • I have a 2004 XLT Expedition with 4 wheel drive. I have found that when it sits a day or two without being driven, It makes a loud clunking noise when it first starts up. I can not tell if it is the engine or transmission where the noise is coming from. Only 3,000 miles left on warranty, so I really need to locate this if it is a problem. I have been unable to recreate for dealership, they seem to not know what I am talking about. Any help would be greatly appreciated !!!!!!!!!
Sign In or Register to comment.