Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Ford Expedition Maintenance and Repair

1656668707194

Comments

  • kenatakenata Posts: 4
    I had the exact same problem with my 97 Eddie Bauer. I've got the 5.4 Triton engine. Each spark plug has its' own coil. I would say one of those coils is going bad. Might have to wait until it triggers the check engine light so the codes can be read to determine which coil it is.
  • kenatakenata Posts: 4
    My 97 Eddie Bauer also hums, sometimes, when I shut the engine off. It does not concern me much but I was thinking the idle air control valve was doing it. One of these days I'll get out there with my mechanics stethoscope and check it out to satisfy my curiosity but I would not worry about it.
  • We have a 2000 Expedition that has the dead - start problem. I load tested the battery and it checked O.K. Replaced it with a new one anyway. Problem represented a few days later. Bought an automatic 1.5 vdc trickle charger that plugged into the cigarette lighter. Eliminated the problem for several months. Now the problem is back with a vengence. We have to jump start it if it sits more than 8 hours off a charger. The interior lights shut off or blink when the problem occurs. There must be steady drain on the system but nothing is obvious :cry:
  • b20755b20755 Posts: 1
    MY DRIVER SIDE WINDOW IS GIVING ME PROBLEM ALSO. SOMETIME IT WILL DOWN WITH OUT STOPPING AND SOMETIME IT WILL JUST STOP. AND WHEN I TRY TO UP THE WINDOW IT WILL TAKE A VERY LONG TIME. I WAS TOLD BY THE DEALER THAT MY SWITCH IS GOING BAD
  • The leak might be under the hood with the hoses run to the heater core. If one camps is loose you will loose antifreeze and need new wires and plugs.
    PS
    Check the antifreeze overflow tank
  • azzleazzle Posts: 1
    I just bought an '02 Eddie Bauer and it has been in once to fix a water leak (rain) on the passenger side coming in from the handle on the windshield column.
    I took it back to where I bought it and they had it for four days and finally said they found the problem. They stated they cleared all four drains from the moonroof.

    Yesterday it started leaking on the drivers side???

    Has anyone experencied this???

    Thanks,
    Az
  • I can't get my wipers to turn off. Switch (knob?) seems to operate correctly (I can turn it to "off") but the wipers stay on intermittent. Since the problem cropped up after washing the vehicle I'm guessing a short in the electrical system somewhere?

    Thought problem disappeared on 2nd day, but as soon as I used the blinker the wipers started working again. Any suggestions?
  • My 99 expedition also has a broken front blend door. How did you replace it ? did you have to remove the dash.and if you did can you give me info
  • I had the same problem years ago. It is more than likely just the Thermostat that controls the temp it cracks and when you turn it you think you are turning the temp but you are not. I suggest you get a new control if manual if digital I am not sure. Good luck I had it in the shop many times finally a deal after going to numerous one's
  • OK, I will start off saying I have those continental tires that I keep hearing not so good things about. my problem is this, I have had my tires balanced twice in the last 3 months and i still have this ocassional vibration when operating at slow speeds while driving the expedition, balancing the tires helped some, but the tires according to the tech are spin balanced perfectly, he even recalibrated the tire balancing machine on this last balance job. But it still vibrates the dash at certain speeds. Most of the vibration is comming from the piece that fits over the passenger side airbag> this is getting very frustrating! Has anybody else out there experienced this excessive vibration with 2003 Ford Expeditons? and what can be done about it? any other areas to check on the vehicle besides tires? Thanks for any help!
  • Every single window switch has gone bad on my 2003 Expedition.
  • yibelyibel Posts: 2
    Bought a used 99 expedition, no owners manual and there is no label in the fuse box under the hood to see which fuses are for what. would like to disable the A4wd since it has a worn out transfer case and I only need 2wd right now.

    Thanks

    Bill :confuse:
  • yibelyibel Posts: 2
    My Prolem was the opposite - door (or something in unit) broke. Used assembly $125, $1,000 in labor.

    Bill
  • gheimurgheimur Posts: 88
    I have a 2004 EB EXPY? Aren't these the slowest power windows ? All my other cars including a 96 taurus are much quicker. Comments?
  • i have 2003 that leaks also
    please let know if you find out why it leaks
  • What was that noise, can anyone tell me how to stop it?
  • nbxnbx Posts: 28
    What is that old song about some good news today for a change? Thought I would share information about a strange noise that the subject has had for several months off and on pulling steep hills. Noise from the beginning was like something trying to engage up front in 4wd system, a harsh banging and clanging. Dealer techs passed it off as spark knock from bad gas from the Gulf after the hurricanes. I discovered by trial and error that there was no noise when setting stayed in AWD instead of 2wd. Armed with this feedback, the Ford tech did a vacuum test and found a leak on the way to the left front wheel that was preventing that hub assembly from staying in 2wd as designed. Luckily there is some sort of flange or safety devise that prevents permanent damage when vacuum is reduced. Tech replaced plastic line that had worn through with a rubber line. Seems to be 100% fixed.

    In hindsight all now easily see how the vacuum drop pushing it hard on long grades with a hole in the line was causing the problem.
  • If the clicking happens when you turn the a/c on, take it to the dealer, they know what it is and will replace it. I can't remember what the defective part was called, but they knew exactly what I was talking about. (03 Expie EB)
  • HAVE ANYONE OUT THERE EXPERIENCED ANY UNUSUL ENGINE VIBRATIONS,RATTLING P/SEAT, OR WEIRD NOISES COME FROM THERE REAR WHEN VEHICLE DOOR OPENS OR CLOSES? IHOPE NOT BUT IFSO PLEASE REPLY. WE HAVE TAKEN VEHICLE TO DEARLERSHIP NUMEROUS TIMES.
  • I have a 2004 expedition and swapped out both outside mirror with the one with turn signals. The procedure was quite easy and they just plugged into the harness My question is, I went to turn on the turn signal and they won't work on either side of the outside mirror. Is there a step I left off, or something I forgot to do?
Sign In or Register to comment.