Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Lincoln Aviator

1868788899092»

Comments

  • aviprobaviprob Posts: 1
    did you find a solution to your luggage problem? I am curious because I am having the same issues....
  • Has anyone exprienced this nightmare? For no apparent reason fuse # 29 DTRS (digital transmission range sensor) keeps blowing causing a no start situation. The fuse is very hard to get at up under the dash. I have replaced the neutral safety switch twice and removed the remote start which had some chafed wires do to rubbing against the carpet. Every time I think I've solved it it happens again (over 50 times) LIncoln has no clue, my best mechanics can't figure it. Any help would be appreciated.
  • I have experienced the defective coil pack problem which Lincoln is supposed to fix for free. I have been getting nothing but a hard time from Lincoln. Seems like all they want to do is upsell to a laundry list of other problems > I have opted to fix it myself (pretty easy) and most auto parts stores will tell you which one to change . Part is about $50.00
  • Just fixed mine. Look under the dash at the brake pedal arm. Push the brake pedal in with your hand to see all the parts that move. On the inside of the arm you will find a plastic box about 1 inch long and maybe 3/4 inch wide. It has an electrical connector in the back. If you disconnect the connector, the lights will go off. Next, there is a yellowish-green submarine shaped cap. On one end is a push in clip. Take the submarine box off. This will reveal a cotter pin. Take the cotter pin out. The plastic box relay unit can now slide off the approximately 1/4 inch diameter pin it sits on. Watch carefully: The secondary arm, that goes through the firewall, comes off with the box. When you put it back together, the arm goes in the center of the arms on the plastic box. (All of this will make more sense when you get the relay box off). With the box free, take off the plastic top. It is held in place with three clips. Just pull the top off over the three clips. Inside you will find a set of "points" (sort of like the old points on the distributor in an old 1970's car). When the little square at the end of the plastic relay box is pushed in (use a screwdriver or something), the points will touch, thereby completing the circuit. In my case, I took some fine sandpaper, folded it in half, ran it between the points on the relay and cleaned them up. Then I sprayed it with electrical circuit cleaner, hooked it up to the electrical connecter, and, presto!, the lights did not come on until I pressed in the little square at the end of the relay box. Hooked it all back up, and it worked perfectly. I'm sure that sooner or later I will have to buy a new one, but for now this works. Took about an hour to get it off, clean it, and put it back on. Much easier if you just buy a new relay. I couldn't. Everything was closed for the Thanksgiving holiday. The hardest part of the job was being contorted on my back on the floorboard, reaching up under the dash. Good luck to anyone else who tries it. It's not hard, and a shop will charge you at least an hour of work to fix this. Probably worth the work.
  • Happened to me too once. I have an 03, 100k on it. Its pretty easy to fix yourself. Also that piece has a lil spring that belongs there too.

    Besides all the headaches this truck has given me in the past 2 years I gotta say I love my aviator!!
  • Anyone know how many watts are the aviator stock speakers all around and how many watts does the amplifier pushing the sub have?
  • I have had the same issue. Deal cannot identify the cause. I have found that if I put it in neutral and rev it to about 5000 rpm for a few seconds, the engine then stops making the roaring sound and revs the way it should. It sounds like induction noise. Maybe there is a bypass in the intake that is not opening when it should. Either way, a quick rev seems to make it go away, otherwise it will continue for the first few minutes of driving.
  • nvbankernvbanker Posts: 7,285
    It's just your fan clutch, which is made to blow the fan hard on start up for a few minutes, then adjust to the actual engine temperature. I don't know why, but they all do it, any Ford with a fan clutch. Explorers, trucks, Aviators, Navigators, Expeditions. Don't worry about it, you can't fix it without damaging something, and there's nothing wrong.
  • My 2004 Aviator "had" adjustable pedals.The brake pedal is now closer to the seat and the gas pedal is fully extended.I've searched the internet for a temporary fix but i wanted to know if any of my fellow forum followers have had any experience with this problem.Thanks.
  • los2hotlos2hot Posts: 1
    05 Aviator run rough at idle, but smooth while driving. The #38 fuse blows immediately after changing 15A. Book says vent canister or egr module don't know what that is. Also check engine light codes read P0443, P0135 and P0141. I know the last two are for o2 sensors, but don't want to change them because I know something else is causing them to read bad. I checked the wire on them and everything looks good as far as I can see. I also checked for vacuum leaks did see any visible. Also there is a slight continuous hum under hood. Have any ideas?
  • akirbyakirby Posts: 7,622
    Take it to a mechanic. You're in over your head. If you start changing parts you'll just be throwing money away. Better make sure it's not the head - check compression in cylinder 8.
  • Hello,

    I know this is an old question, but I'm having the exact same issue today. I was wondering how you resolved your issue. I need that part and no one has it anywhere. So frustrating.

    Thanks, Vince
  • I'm taking my 2004 Aviator to dealer tomorrow morning re acceleration hesitation problems that cause the suv to shake violently and not accelerate when I attempt to go over 60 mph. Started happening right after a recent oil change. The mechanics who did the oil change said it's not their fault, ran diagnostics and nothing came up. I know almost nothing about cars and after reading some of the posts, I feel like I'm in big trouble. Already had the heads and coils replaced by the previous owner. Any suggestions I can tell mechanics tomorrow?
  • I suspect bad coil packs.There is one for each spark plug.There
    have been service bulletins on them.The warranty on them
    was extended through 100,000 miles.There have been some issues
    with the #6 & 7 cylinders.My engine was eventually replaced.
    Here's to hoping it's just the coil packs.Good luck!
  • akirbyakirby Posts: 7,622
    I thought the 4.6L still used a single coil pack rather then COPs. Either way it does sound like a coil problem but could also be a clogged fuel filter or fuel pump.
  • Thanks abtrman. Fingers crossed.
  • I believe the engine was redesigned to address the overheating
    in the 6 & 7 cylinders.Perhaps the coil configuration was changed
    as well? I agree that it could fuel related but this has happened
    to me with 6 coils.My has had the same problem with 4 coils
    on her 5.4l expedition.
  • Abtrman and akirby- you were right on- coils and clogged fuel injector- you guys are awesome! The cost to replace some coils (and some spark plugs) and flush the system came out to $1,100 which I can afford. Can't wait to get my baby back purrin like a kitten. Thanks; I was relieved to hear it from the mechanic today because u gave me a heads up. Thank you again for the fast responses and you were dead on target.
Sign In or Register to comment.