Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Acura RSX Maintenance and Repair

12829303234

Comments

  • I have a 06 type-s and the AM radio reception is horrible. I like to listen to AM sports stations while driving and it never comes in clear like it does in my mom's G35. I have asked the dealership about this problem too and they said that it has to do with interference with the radio signals... This is one of the few things about my car that I don't like. If anyone has been able to fix this problem please let us know...
  • li_sailorli_sailor Posts: 1,081
    Have they checked the oxy sensor?

    I have an '02 also and just switched mine, although I was getting the appropriate code.

    But I just saw a lexus rx300 that was giving similar misfiring codes and it turned out to be one of the O2 sensors.
  • tonidtonid Posts: 4
    thanks for replying i will ask my mechanic said it might be the coil packs. he oredered 4 of them. the problem is when you are driving and are going up a hill it seems the check enigine light comes on any ideas on that also. how do you like your car
  • vibsrvibsr Posts: 47
    I replaced the drivers side headlight on my 2004 RSX. IT IS NOT EASY BY ANY STRETCH OF THE IMAGINATION. The procedure was more involved than what the owner's manual suggested. I had to remove the battery (well...okay), then unfasten the washer bottle filler tube from the body. From this point forward, it gets hard because you can't see what you're doing AT ALL. First, disconnect the plug. Second, slide the rubber dust boot off the assembly. Third (here's the joke), unhook this hinged horizontally swinging rod and move it toward the left fender so that you can take the light bulb and carrier out of the headlight assembly. If you think that was easy, try putting it back together!! :mad: It took a while, but IF I COULD SEE WHAT I WAS DOING :mad: , things would have been much easier. LESSON LEARNED: Use one of those compact mirrors attached to a telescoping rod or buy the bulb and take it to Acura. Poor design! :(

    I believe that when this car was being assembled, the bulbs were mounted in the headlight assembly BEFORE the headlight assembly was attached to the car. I even wondered if I could remove the assembly from the car. As I looked around, I realized that I couldn't do that w/o removing the bumper first! NO WAY! :surprise:
  • 2006rsx2006rsx Posts: 32
    I agree, what a pain! But you are lucky... 50% of the time the tab holding that wire clip onto the junky "pot metal" casting will break off, especially if you try to force things. (because you can't see what you are doing). One has to wonder why Acura chooses to use these crappy old-style bulbs on the low beams. Funny that they used the modern style, easy to change bulbs on the hi beams, isn't it?
  • 2006rsx2006rsx Posts: 32
    Yeah I have the same problem with my '06 RSX. And it was bad with the stock radio, but even worse with an aftermarket Kenwood. The wire antenna, which I believe is in the rear window, is obviously totally inadequate. I can't see any reason why we could not install a regular antenna somewhere. I just might do that eventually.
  • dj1rsxdj1rsx Posts: 7
    Sorry i didnt get back about this problem, It's still there, they say it's normal, i dont believe it. When I get time i'm going to bring it to another dealership.
  • drawdefdrawdef Posts: 14
    I've been meaning to get on here and post about this now too. As if the spring problem was enough at under 1000 miles, I just hit 1 year old in March and now in June I'm only at 13k miles and I've started to experience this shift problem when its hot.

    As another poster pointed out however, its going to be next to impossible to reproduce for the dealership.

    I wonder how they justify this being 'normal'.
  • dj1rsxdj1rsx Posts: 7
    I dont know how we can reproduce the problem. I got it to do it for them once or twice, not as bad as it gets but i did reproduce the problem, and the keep putting it on the computer and telling me there's no problems with the car, that its normal. What a crock of [non-permissible content removed]!! I had a piece of [non-permissible content removed] plymouth tc3 once, and that had more balls when hot then my rsx. I'm going to bring it to another dealership when I have time.
  • crystlebcrystleb Posts: 1
    I have a 2002 RSX with only 35,000 miles on it and the air system seems to have stopped working. It doesn't matter if it's on heat or ac and it doesn't matter how high I try to turn it up nothing comes out. No air what-so-ever. Has anyone else had this problem and do you know how to fix it? Thanks for your help!
  • joem5joem5 Posts: 201
    Did you push in the A/C and cabin flow thru air button so only cabin air is used? Set the temp guage on 69 and put it on auto,or turn up fan. After a couple of minutes,if it dosent work go to a garage you trust,it may need a recharge or have a snall hose leak.
  • ljm2043ljm2043 Posts: 7
    Yes, it still happens but I cannot duplicate it either and neither can the dealer.
  • I just purchased an 03 RSX base with 19000 miles from a private party clean title. My owner problem is when I start the car it hesitates to start it happened 10 times in the last two months maybe 3 times a week I checked and did have gas. Also today i noticed that I can feel the transmission shifting since its an AUTO i dont remember feeling that before can that be from putting cheap gas
    THANKS I APPRECIATE ANY HELP
  • ezel30ezel30 Posts: 1
    I have a question.

    I have a 2002 Acura RSX and I can't get the darn thing out of park. I know how to do it manually, but I was wondering if anyone knew the permanent fix to this problem. And how much do you think it would cost if I took it to a dealership?
  • Thank you for your help... when I talked to the dealer they said a recall or general repair was issued to them. So the 'shimmied' the struts and the no longer make a noise.

    Thank you
  • rsx06rsx06 Posts: 1
    I have on 06 RSX and has 38,000 miles. I get regular oil changes every 3,000 miles and 6,000 mile tire rotation and fluid checks.
    The maintanence light goes on every once in awhile. When I get oil changes they usually reset it. It is on now, and I am wondering if considering the mileage I have, I need some other sort of maintanence. Please let me know anything I should do.
    Thank you!
  • I have a 2003 RSX base model. Yesterday after getting gas I noticed the flap that is typically there on all the other Honda cars I've owned is missing. Am I an idiot or has it fallen into the tank or was it never there.

    The dealership didn't have an RSX to show, but pointed out other Acura models don't have the small metal flap where you put the gas nozzle in. Looking to confirm or deny if the flap exists on the RSX.

    Thanks for the help.

    D
  • My 03 rsx does the same thing. It hesitates to start and i noticed if i dont have my foot compressed on the brake properly, i have to try 3 times to start the car. It Does start on the 3rd time....

    also, recently I stopped at a stop sign i noticed the car "jump" forward. after that, it wouldn't go faster than 45 mph. any ideas on what it could be? I've also had regular oil changes on the car and its well maintained. :(
  • when i stated my car my maintance lights came on what does this mean what should i do. i have a 2002 acura rsx..
  • I have had the same problem multiple times. Its hard to explain how to really fix it. But its basically the ignition isnt connecting when the key is engaged. Try playing with the ignition and the Trani at the same time. Turn the ignition key, turn the steering wheel too, sometimes the steering lock is an issue. Good luck
  • 6ea6ea Posts: 1
    I have owned the 2002 Acura RSX type S for about 1 month. The car does have 17" aftermarket rims and low pro tires. I have been hearing this clicking noise from the front right, by the tire. I know its not the wheels.. This clicking comes on when i press my brakes or accelerate sometimes I did replace the struts and nothing changed. Its getting really annoing.I have also noticed when switching to 2nd gear there is a lil roughness in the shift, Anyone have any suggestions on what it is.
  • Hello,

    I am trying to buy a 2004 rsx

    I just looked at one this afternoon.

    Car is in good shape and deal is pretty good too.

    I would love to buy it if I can resolve this problem.

    when I was test driving this car, I noticed high-pitched noise comming from
    the front of the car. I could only hear it between 0-10 miles and when I went faster
    the sound disappeared.

    Noise sounded like high-pitched electric/flapping sound. I was not loud but I could clearly hear it.

    I am a first time driver and knows nothing about car.

    Please enlight me people!
  • joem5joem5 Posts: 201
    It's normal,as I took my Tye S to dealer stepped on brake and he said the clicking noise was normal. :shades: .
  • jprocjproc Posts: 135
    Well we've had an 03 RSX for 5 years now and I've never heard any high pitched noises
  • vickatvickat Posts: 43
    I've had RSX'03 for 5 years now. A month or so ago, at mileage of 127K, high-pitched, buzz-like noise started in engine bay, driver's side.
    At irst, it was heard only when starting car cold; now it may be heard any time.
    It's hard to replicate, as it comes and goes.
    any suggection will be greatly appreciated!
  • redbeltredbelt Posts: 1
    No Low Beams on my 2004 Acura :confuse: Help,
    I turned on my head lights only to find no low beams, but I have high beams and all other lights. Any one else have this problem and does any one know what the problem might be? I have had to replace the drivers side low beam bulb twice before this happened.
  • joem5joem5 Posts: 201
    who is talking about a high pitch noise?
    All I said was, sitting still turn car on and step on brake and you get a clickking noise and it's normal. :shades:
  • lp2lp2 Posts: 1
    I''m currently looking to purchase an RSX 05 or 06 type s and I wanted to know what type of gas the car can drive on. I remember browsing over a review that said that the car takes unleaded premimum. However, I'm unable to locate any other solid info about this. I would like to hear from the owners what type it takes.

    Thanks
  • drawdefdrawdef Posts: 14
    I have an 06 and have only put 93 oct in it from day 1. 91 or better is what Acura says. This is due to the high compression engine. I'm sure it would run on lower octane, but I honestly wouldn't do it. Performance above all would suffer, you'd probably experience knocking and other such engine issues too. If you don't want to put the extra 20c a gallon for the good stuff in it, I wouldn't bother buying one.
  • 10a10a Posts: 6
    Hi, I hear that clicking noise when I step on the brake too...it's near the gear shift area, and I hear it when my car is in P, even when I just step on the brake when I haven't turned on my car. I went to the dealer to check it out before too. They told me it was normal, but now the sound is getting louder. Would this still be normal? I drive a 05 RSX, what about you? Maybe it's specific to the year?
Sign In or Register to comment.