Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge Neon SRT-4

1202122232426»

Comments

  • OK, I GOT A 2003 DODGE NEON SRT-4, AND I THINK MY TRANSMISION BROKE, BECAUSE I WAS RACING AND I MISSED 3rd SHIFT, AND AFTER THAT I COULDN'T GO TO ANOTHER GEAR, IT JUST STAYED ON NEUTRAL, AND I DONT KNOW IF ITS THE TRASMISION OR THE CLUTCH OR MAYBE SOME OTHER THING THAT I DONT KNOW, ALL YOUR OPINIONS WILL BE VERY HELPFULLLLLLLLLL!!! THANKS!!! :confuse:
  • okko1okko1 Posts: 327
    could be the shifter...you might check with orangesrt4 :shades:
  • jimsrt4jimsrt4 Posts: 1
    SRT4's are sick!!!!!! Purchased 05 SRT4 with few aftermarket parts, Car runs PERFECT!!!! Just had a ?....I noticed a sensor on the intercooler piping was broken, cannot figure out the name of the sensor.... Sensor is located just near the BOV. Any 1's input will help. THX.
  • Hey did you ever get your srt running again and how so? Im havin the exact same probs with mine and changed both sensors and checked wiring which look okay if you could please write back and tell me how you got your fixed cuz im just totally stumped
  • mc_7723mc_7723 Posts: 1
    just got the a new typhoon air intake and for some reason when i step on it. it starts to skip like make it starts boging i dont know wahts up everything is pluged in properly. do i need a new air sensor or maybe turn the boost up on the turbo. reply asap its really bothering me... :sick:
  • addposaddpos Posts: 1
    I have a 2005 srt 4 and am preparing to get it going faster. I am starting with the fuel side of it and am looking for a 255 fuel pump, 750 cc injectors and a fuel line return kit! any body know where I can find them or have any good deals? Also if anybody knows where I can get a factory front drivers seat. (cigarett burn, makes me sick!)
  • hero166hero166 Posts: 1
    did you figure out your problem with you srt?? cause i am just starting to have problems with my car as well, and i don't know were to start ( all ready changed the camshaft sensor )
  • Hey guys, My SRT-4 is a piece of S$@# to me. It's a 2003 body with a 2005 motor and tranny swap (LSD). I bought it a while back from some hispanic guy who had just took the easy way out of fixing everything pretty much. He just rigged the whole car such as he cracked the oil pan and took some silly puddy and cemented it on to hold the crack. (not literally silly puddy but i don't remember the name) He had also broke the TPS sensor to the car and just cemented the wires back into the slots on the broke sensor and just left it.. Personally, i'm surprised that it still moves. I bought it unaware of all these problems because it was for sale for 4,500.. i knew that there was some problems coming in hand but not like this. ANYWAYS one day, the car stopped going in to gear so easy. It eventually just gave out and it wouldn't go into gear without it being slammed so i put it in the garage and ordered me a new clutch. while i was pulling apart the clutch and tranny, i noticed that the master cyl and the slave were toast so it took me a while to buy my new parts. After i got them both installed, i started my baby back up and it was running fine but then i looked at the cluster gauge and the needles were on the wrong side of the prong that held it at 0MPH and same as the RPM gauge. Only weird thing was that my Temp, Boost, and the gas gauge was working fine. After that i let it warm up and gave it some gas, i'd say it went to about 2.5 RPMS and started cutting out and backfiring. I have no clue what this problem is, nor will it still go into gear. (The RPM and MPH gauge are still stuck saying that i'm at about 310 MPH and at 25 RPMS. I've put well over 2,000 dollars into new parts on this bucket and still WONT go. Just curious if anyone else had any of these problems and can offer me some help . Thanks a lot. Any advice is helpful, please throw it my way!
  • lokillolokillo Posts: 1
    edited February 2012
    Hi im new in here and ive got an 2003 stock srt4 and i was wondering what could be my first mods to do, any help please
  • tinnerntinnern Posts: 1
    My grandson’s check engine light on his 05 Dodge Neon came on and the car stumbles under acceleration. He’s also noticed it is sucking down gas. He can get up to speed if he accelerates slowly. Took it to Advanced Auto and they read the code: Crankshaft Position Sensor / Intermittent. He said either the sensor was breaking down or it could have an oil leak that is causing the sensor to not read properly. He also said we should take it to the dealer to have them diagnose the problem as they could tell for sure what the problem is. I’ve never worked on a Neon before, has anyone else had this problem? Where is the crankshaft position sensor located on a 05 Neon? Thanks.
Sign In or Register to comment.