Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy Vans: Problems & Solutions

11516182021

Comments

  • hubbiehubbie Posts: 2
    Driver's side power-window "chokes" everytime when closing. Glass tilts forward and needs to be pulled back at least twice to help closing. Goes down just fine. Anyone got the cure ?

    Hubbie :mad:
  • haulenhaulen Posts: 2
    My van turns and fires and is getting gas. It is in time but won't start. I think that it might be something electrical but not for sure. Could anyone help? Advice is really needed and appreciated. Thanks
  • Has any one else had problems with sudden acceleration and/or a "runaway" cruise control?
  • I have a 97 chevy venture, bought 3 yrs ago and had a new engine put in when it was bought. Recently it's been shutting off completely when I turn the steering wheel all the way left or right making it real difficult to get out of parking spots. Sometimes it shuts off after I start it and put it in gear. Once it shut off as I was driving, I put it in neutral to turn it over again (I was rolling down hill and there were cars I couldnt pull over) and it wouldnt turn on, until I finally got to pull over, stop it, then it turned over after several tries. :cry: Can someone please tell me where I should start looking!! :confuse: Thank You
  • That sounds like what my friends van was doing. ( Is yours red?) Anyway her problem was the head gasket and a lot of things that led up to that going. They weren't real good about maintainance. Was the engine new, or used? Also, my husband says to have a proper cooling system flush done if it hasn't been.
  • i recently acquired a 91 chevy astro from some family and on the way down here the speedometer stopped working on me i hit the trip reset and it went kaput i'm not too good with the electronic as opposed to the cable speedometers if anyone knows anything that i could do to check this out please let me know.... i do have an 88 astro LT for spare parts however it's got the cable instead of the electronic speedometer any suggestions would be great :confuse:
  • Our 1998 Venture has done something similar. At first the backup lights and hazard lights on the dash would come on when the brake lights,and some times the abs light came on. Only when the head lights were on. The yesterday the brake lights went out, except for the third brake light. :confuse: I found a pin on the plug to both tail light socket assemblies had melted. Did you find out what caused your problem?
  • mccoolmccool Posts: 1
    I have a 1997 Chevy Venture and the passenger power window will go down but will not go up, I have replaced the motor and the switch on the driver side and now I am at a loss of what to do? :cry: :cry: Please HELP ME!! Thanks for your time.
  • You may need to replace the switch, motor, and regulator in the passenger door also. If you have not replaced the regulator in the driver's door, I would do that because that window will eventually do the same thing. I am having a problem with my driver's side auto window right now. To put it back up, I have do raise it a little at a time, straighten it with my hand and put it up a little more. If you end up doing this, DO NOT hold the edge of the window too long (and don't let your hand slip) as it will really hurt your fingers. All these parts are dealer only but I have noticed that all these parts are on EBay.
  • I am trying to remove the passenger-side engine mount torque strut bracket from the ENGINE. I have removed two bolts but the bracket will not come off. I have searched extensively but in vain for other bolts. Is there another bolt and if so, where did they hide it? If not, is there a trick to removing the bracket?
  • I haven't has the issue with oil pressure light. But, I have been having issues with the airbag light on my 99 Venture van since it was brand new. At first the resolution according to the code was to replace the seatbelts. That would make the light go out for a while, but within a year it was back on. The last time they replaced a wiring harness, but it is back on again. Lasted about 6 months.
  • I noticed when I shut off my engine but leave the key in the run position I hear a humming coming from the DVD player. It makes the sound constantly even when there is no disc in it. It's not loud, sort of like a laptop pc. Is this normal? Also, what is the round circle next to the monitor? I first thought it was a speaker but now I don't think so.
  • I thought I would answer my own question since I was able to solve the problem. There are two additional bolts that have to be removed. They are the two long bolts that support the top of the ac compressor, then pass through the strut bracket and finally into the engine block.
  • I have a 2000 astro and had the same problem. I had the spider replace with all injectors on mines it fixed the problem, but after a year it started again.
  • My 1995 Astro AWD leans slightly to the left at the rear and is at least 3 cms different from the right side height. Is this possibly the leaf springs or shocks? Not sure if they are the fibre glass springs or not.
  • I have a 2000 Venture with same problems including the
    transmission shifting hard and in the same order.
    The transmission problem only happened once.
    Have you found out what the problem was?
    If so, what was the remedy? Thanks.
  • When my headlights are on and i put my left signal on it has a normal blink,but if i step on the break its starts to be a rapid blinking and my tail lights all blink,when i put the right one on both of the lights for the signal light but only the right one blinks.When i turn the headlights off everything is normal. How do i fix this without costing a arm and a leg.
  • hi, i had same problem with my 1998 venture. check the male/female connections located inside the back lighting panel. known as the pig tail. mine were not connecting good, causing them to burn out. had to replace pig tail and lighting panel around $160.00. ;)
  • hi,
    thinking this is a sencor problem, just don't know were it is located. I have a 1998 venture van. HELP!!!!

    thanks,annie14 :sick:
  • cobcob Posts: 210
    Have you checked the coolent level? If it is low it is probably leaking lower intake gaskets, the 3.4 is famous for this problem.
  • My 2001 venture is doing the same thing. My power windows, power locks and interior lights all went out at the same time. All of my fuses are fine. did you ever figure out what was wrong with yours?
  • my 1998 Venture started with the classic low coolant sign, then overheated. my husband and i tore into the manifold ourselves and replace all the intake and valve cover gaskets, drained, flushed and refilled radiator. Van ran fine for 4 days. Day 5 brings overheating in the morning... radiator drain plug had worked out...how we don't know. that night after running fine all day it Over heats again. replaced thermostat. that was 3 days ago. This morning it tried to overheat in 55 degree weather after going less than four miles. Thick white smoke rolling from under the hood but not the tailpipe. No water in the oil. Don't no where to go next. Please someone help???
    p.s. water pump appears to be working.
  • Need help on standard equipment for the 2003 Venture LS extended.
    I bought a used one on 12/29/06 and according to reviews I read on the 2003 Venture LS, its suppose to have a standard Power sliding door on the passenger side,height adjustable drivers seat and an overhead storage bin. Mind does not and was wondering if the review was in error or if someone slapped an LS badge on a base model?
  • I have a 2003 Chevy Venture and it does have an power sliding door on the passenger side only and my seat is power adjustable which stinks by the way because the seatbelt always gets snagged and moves my seat out of adjustment all the time. Last but not lease I do have the compartment above.
    I have a question for you... Does your starter sometimes stick when you start the van? Does your heater work right? Mine won't get warm until the van is in motion. Does your radio work alright? Mine will get louder when I drive fast up on the highway. I think my van has a major electrical problem somewhere in the front end. I ram starting to regret buying this van. I purchased mine in August of 2006.
  • I don't have any of those problems yet. Maybe the power sliding door is part of a power pkg seeing you have a power seat? The radio has an AUTO button that allows the volume to adjust with the speed of the vehicle. You can disable that function by pushing the auto button on the right side of your radio. I was reluctant to buy a Chevy/GM mini van based on Consumer reports recommendation, but most personal reviews were positive that I read. I was on a tight budget and only plan on keeping the van a couple years, it is in show room condition and only had 15,500 mi on it. For $10,500 I figured what the heck. As far as the heater goes, I really haven't used it yet. I live in Florida and the A/C works great! Much better than my Vibe I traded in.
  • cajzmerecajzmere Posts: 2
    Starter runs until motor starts, regardless fo how long you hold the key. This keeps you from holding the key on too long and wearing out your starter, or "tapping" the key and killing your solenoid. The heat DOES take along time to warm up if just idling. Normal.(I live in the snow belt)The radio sound is also a convenience feature built into all GM radios at this time. You can turn it off. I am now on my second Venture and would buy a 3rd. I have had some small problems and some big ones, but I think that just comes with trying to buy an "American" vehicle, ANY of them.
  • scott78scott78 Posts: 3
    I wonder if this Venture was a Canadian Vehicle brought into the US used for resale...
  • robofirerobofire Posts: 5
    I'm pretty sure that's not the case. According to CARFAX it was purchased and leased the whole time in Miami Florida.
  • Recently my 3 yr old decided to use the rear wiper as a hand hold to pull himself up on the bumper of my venture and it hasn't worked properly since. Sometimes it wipes about 160 degree on the body rather than the window and other times it will only wipe half of the window. Does anyone know if there is a position stop within the rear hatch that might have gotten broke or is the fix simpler than that? If anyone has had the same issue I would love to hear how you got it fixed.
  • It sounds like the sleeve inside the wiper arm is stripped. you should be able to remove it and possibly get a new sleeve for the arm???? anyone else know??
This discussion has been closed.