Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Toyota Corolla Maintenance and Repair

1137138140142143188

Comments

  • MrShift@EdmundsMrShift@Edmunds Posts: 43,681
    Could be a lot of things but the usual suspect is the EGR system (Exhaust Gas Recirculation).

    Also a car that is overheating will cause this, and also a car with lots of carbon buildup in the cylinders (too high a reading when you take a compression test).
  • bob157bob157 Posts: 1
    I know what the light is and means. I want to know how to turn it out. I have been to the dealer twice and he has showed me, but he did it so fast that I could not write it down and could not remember how he did it by the time I got home. I change my own oil and oil filter. Toyota also says I should use Toyota Oil Filters. They claim it has a valve that prevents oul from draining back down to oil pan when you stop the engine, which prevents dry oil start ups.
  • kiawahkiawah Posts: 3,666
    Bob, look in your owners manual to reset the oil change indication, it will tell you how to do it. The latest Camry has a process where you use the TripA odometer reset, with a turning ignition key on and off sequence. Your Corolla may be different, but it's always documented in the manual.
  • imidazol97imidazol97 Crossroads of America: I70 & I75Posts: 17,727
    My friend's new 06 Corolla had the front bumper bumped in parallel parking today while at the theatre. It sprung the part of the bumper that is the front of the right wheel well and broke a clip about 1.5 inch square at the top next to the car metal fender.

    Should she go to the Toyota body shop to see if they repair that clip and put the pieces back into the snapin location or should she just try a standard body shop? There is NO damage to the bumper's paint. It looks like they hit the front license plate area and just nudged it and the right side flexed.

    This message has been approved.

  • MrShift@EdmundsMrShift@Edmunds Posts: 43,681
    I think any good body shop can do this. The dealer probably sends it out anyway to a subcontractor.
  • binh1957binh1957 Posts: 3
    I want to buy toyota 4Runner limited 2007. If somebody bought already please let me know how much I will pay. Thanks for your help.
  • patpat Posts: 10,421
    You can find out what others are paying in this discussion: Toyota 4Runner: Prices Paid & Buying Experience. Also, you might be interested in some of the other discussions in the 4Runner group.

    Good luck!
  • tcbin07tcbin07 Posts: 7
    My 2001 Corolla (125K km) has developed a steering vibration at speeds over 65 mph that I've read so much about in this forum. My mechanic tells me the front end is all good, but he did suggest that the sway bar links could need replacing. All the tires were new last year, and they show no signs of unusual wear. I pulled the driver's side front wheel and rotated it to the rear, and checked out the sway bar links on both sides. They look good and were certainly tight to the bar, but they appear to be more of a ball and joint type rather that the bushing type I expected to find. Anyone out there with this problem find a way to resolve it without spending $$$$ replacing things that "might" be the cause of the problem?
  • MrShift@EdmundsMrShift@Edmunds Posts: 43,681
    I don't see any relationship between sway bars and a steering vibration. I'm puzzled your mechanic would suggest such a thing.

    If you get a vibration *at a certain speed* this is a rotational issue of some kind, which limits you to a) rotating wheels/tires; b) rotating axle shafts and c) rotating engine.

    I've listed probably causes in sequence of most likely first.

    MrShiftright
    Visiting Host
  • tcbin07tcbin07 Posts: 7
    Yeah, I was puzzled too. I didn't like his solution to this. Plus the sway bar links looked in good shape to me, which is why I asked for advice. I will rotate the tires front to back to see if that makes a difference. The tires on it right now were highly rated when we bought them, but a slight vibration was there with the winter tires we had on, just prior to switching to summers. The tires are definitely the easiest thing to check. Your second cause sounds expensive and I'm hoping I don't have to go there. Thanks for the help.

    Toyota Novice
  • MrShift@EdmundsMrShift@Edmunds Posts: 43,681
    Usually any vibration at a set and certain speed is tire related. Generally, axle vibrations will occur all through the speed range. As for harmonic vibrations coming from an engine, usually those are related to mounts, or to improper assembly after a clutch or transmission job.

    good luck with it,

    MrShiftright
    visiting host
  • kenymkenym Posts: 405
    When you purchased the tires did you have them balanced? :shades:
  • alex24alex24 Posts: 54
    I have the same problem with my 98 corolla, I tryed everything, they keep telling me its the cheap brand tires I have, that the corolla body is so sensitive it will feel every thing once the tires get worn some, they said I have to get a good brand set of tires that roll perfectly, the vibation is not real bad so I just am waiting till these cheap tires wear out before I go to the cost to buy good tires, I jack my front car off the ground , started the motor put it in low gear and study the tires rotation, they do seem to have a slight woble in them, but up to 1/8 woble is suppose to be aceptable and check my rims same way, and one strange thing, No matter what rim I put on the front left side ,it seems to woble more, where the right side does not,with switching the same rim, can't figure that out cause the axle and bearings all seems good, if any body has any answers I would like to hear them. I also have the same problem with my 97 Honda Accord.
  • tcbin07tcbin07 Posts: 7
    Absolutely. And the place we got them from is a reputable tire business. So I'm going to be very surprised if this ends up being just a tire problem.
  • kenymkenym Posts: 405
    It really sounds like you have a rim that is out of round. It won't take much to cause that vibration. :shades:
  • jlawrence01jlawrence01 Posts: 1,828
    There are a certain number of tires (or batteries) in a lot that are not "quite right". The tires look good, are properly mounted and balanced but vibrate at a higher rate of speed.

    I had that happen on a rental Chevy Malibu a couple of years ago. Brand new. The car ran great up to 45 mph. Over that, there was heavy vibration in the front tire.
  • tcbin07tcbin07 Posts: 7
    I hear ya. But don't they usually do a high speed balance on these things when they install them? I guess it's possible that some belt separation or distortion of some kind has occurred, but I'll bet there's less than 5000 km on the new tires. I'm going to make some inquiries as to the tires we bought, and find out if anyone in the family remembers dusting a curb.
  • jlawrence01jlawrence01 Posts: 1,828
    You can have a defective belt in a tire from the factory that may not be evident until you drive on the tires for a short difference.
  • I drive a 2003 Toyota Corolla and it has started making a rattling noise when I start the car. What is upsetting about it is that it sounds like a rod, but I don't think that's what it is. When I accelerate, the noise goes away. I keep the oil changed methodically and it isn't time for it to be changed yet. I just want some ideas before I take it to a mechanic and they try to stick it to me by telling me a bunch of junk that needs to be fixed to jack up the price.
  • kiawahkiawah Posts: 3,666
    What I do when I have an unknown noise like that, is to take off the serpentine belt and start the engine. That way you can determine whether it is one of the belt driven accessories, or internal to the engine.

    You could have a bearing going bad in an alternator, for instance. I'd suspect water pump, alternator, air conditioner compressor, or even the tensioner pulley.

    If you determine that the noise goes away, turn off the engine and spin the accessories by hand. Wiggle the pulleys of the accessories to see if you can determine which is bad.

    I've used this diagnostic approach on two of my vehicles in the last year. One was a water pump beginning to go bad. Another was a tensioner pulley.

    Good luck.
Sign In or Register to comment.