Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Toyota Corolla Maintenance and Repair

14344464849188

Comments

  • dynoludynolu Posts: 5
    At only 5,000 miles, rattling noises and vibrations appear to be coming from the driver side dashboard area. Slightly irritating, it's noticeable at low to moderate speeds while driving over less that perfect road surfaces. Just like another posted message, I'm very leery of having service techs remove the dash, they'll never get it back perfect. Hopefully the dealership will restore my confidence with Toyota products.
  • CapeCodCapeCod Posts: 117
    My car is a Vibe...
    but your Matrix board is more active !
    Has anyone else noticed volume does
    not stay constant when switching between
    Cd and radio ! Radio is much louder !
    Is this normal ???
    Anyone having weak radio signal with antenna ?
    Thanks.
  • jeproxjeprox Posts: 466
    what you are experiencing is normal. nothing wrong with your radio. usually, cd's are recorded at a much lower volume.

    try playing the cd on your home stereo and swith to radio. do this back and forth and you will get the same results.
  • nippononlynippononly SF Bay AreaPosts: 12,687
    my radio reception isn't that great, but OTOH the antenna is one of those new wiggly ones that you can unscrew for car washes and stuff. With an antenna that is only about 10 inches long, how much radio reception can one reasonably expect? I have been thinking of switching it out for one that gets better reception.

    2013 Civic SI, 2009 Outback Sport 5-spd (stick)

  • jeproxjeprox Posts: 466
    my radio reception is excellent. if you are having problems with reception and it happens only on certain occasion or certain channels, you may be better off leaving it alone than replacing the OEM antenna.

    because the antenna is on the roof, you risk the chance of having a leak if you remove it and not install it properly. you also have to remove the roof liner to get to your antenna. if you really want to replace your antenna, look at getting the original FUBA antenna. they are excellent antennas and OEM on cars such as VW, porsche and audi. many people buy them coz of their excellent reception/quality but they are pricey. FUBA antennas are the same shape/style as the corolla antennas and they may even fit perfectly on the corolla.
  • We also get good reception on stations that don't have the strongest signal, both on AM and FM. That's one of the things I tried out when we test-drove the Matrix, and reception is also good in the one we bought -- as good as the '94 Corolla wagon with the old-style antenna, and better than the Nissan we got rid of. Talk with your service people before putting money into another antenna. Something may not be quite right with yours.
  • mpynempyne Posts: 120
    allot of people

    Mine rattles when cold and going over really small bumps.

    if my gf wants my car i think ill give it to her and get myself a hyundai instead. thins is my second toyota and i dont like the way the inside rattles and squeeks makes it feel like a very cheap car.
  • My dad's 01 Avalon had an annoying rattle, and we found out that the sun visor on the passenger side was making the noise.
  • djhodjho Posts: 2
    I just had the timing belt on my '96 corolla replaced at a Toyota service center 3 wekks ago. About 1 week after the service was performed, I started hearing funny noice under the hood. Last night, the car broke down and I towed it back to the dealership. They just called me and told me the water pump froze and it caused other problems too. However, this has nothing to do with their service and they certainly didn't screw anything up.
    I found this hard to believe because when they did the service they actually looked at the water pump and said "water pump is dry, no seepage but bearing has some freeplay". Now they are telling me they didn't touch the water pump.
    Does anyone know if it is possible to replace a timing belt without touching the water pump? I have a hard time believing this is a coincient since the water pump has been working fine for so many years and start to break 1 week after the timing belt is replaced.

    Thanks.
  • sandman46sandman46 Posts: 1,798
    Very sorry to hear about your problem. I had my timing belt replaced on my '96 Corolla last week also but they put a new water pump in since they had the whole thing apart anyways. My mechanic said it was a good idea to replace the water pump even though it was fine since everything was exposed anyways. Too bad Toyota didn't just say to you to just do it. Go back and see if they will just replace it without all the labor being charged to you. Can't hurt to ask!
    Again, sorry for all the trouble you're having.

    The Sandman :-)
  • nippononlynippononly SF Bay AreaPosts: 12,687
    If I had heard this, I would have asked them a couple of times why they did not just replace the pump. On these cars, it is such a pain to replace the pump all by itself, whereas it is right there when they are doing the timing belt.

    Since it is a Toyota service center, and especially if you are a regular customer, I bet if you try real hard you could get you to replace the pump for just the price of the part.

    2013 Civic SI, 2009 Outback Sport 5-spd (stick)

  • guanguan Posts: 1
    I had to replace my 99 toyota corolla engine after 66K on the odo. The #4 cylinder of the engine was myteriously worn out (egg shaped). And it's just 6K over the 60K powertrain warranty. I have always maintained the car according to the manual, and actually I had the old changed every 3K-5K (even a little bit more often than the manual said). I couldn't believe this happened on a Corolla with such low mileage with well-oiled machine. I have tried to talk with Toyota to see if they can offer help on the repair cost, but got declined anyway even though I kept all the maintenance paperwork. I couldn't be more disappointed with such a lemon from Toyota. Just before the engine bust, I was thinking to get a Toyota Sequoia for my family. But now, I will say bye-bye to Toyota forever!
  • nippononlynippononly SF Bay AreaPosts: 12,687
    Maybe they would have given you a new engine to get you to buy a high profit item like the Sequoia! LOL

    That is unusual for a Toyota engine. Sounds like you got the lemon of the bunch...

    2013 Civic SI, 2009 Outback Sport 5-spd (stick)

  • mld2mld2 Posts: 1
    I have a 2003 CE with 8,500 miles. I get the intermittent sulfur/rotten egg smell. Very bad after going up a hill. I've read other messages on this and was wondering has anyone found out if there is a problem or are dealers just telling you it's the gas. My car is great otherwise with very good gas mileage, but that smell is annoying and I'm afraid will lead to something. Thanks for any info.
  • I have a 2003 Matrix . I had a automatic starter installed. Started having problems like the lights going on in the middle of the night and wearing down the battery. Had automatic starter disconnected. Car was dead today. Dealer said I left dome light on. I never touched it. Any one else having this problem?
  • sandman46sandman46 Posts: 1,798
    Two questions for y'all.
    (1) Had the timing belt, a pretensioner, and the water pump replaced last week and now the mpg's have dropped a bit, the fuel needle moves quicker than before.
    (2) The back of the car seems to bottom out over bumps with a single thud now. Had the front struts replaced under a TSB back in '98. Is it possible that I need new shocks in the rear?
    TIA for any help from you nice folks!

    The Sandman :-)
  • nippononlynippononly SF Bay AreaPosts: 12,687
    How does that work, who makes it? If it is hooked to the car's electrical system, and is not OEM, and now you are suddenly having dead battery issues, I would say it almost certainly has to be the culprit.

    2013 Civic SI, 2009 Outback Sport 5-spd (stick)

  • Thanks for the response nippon. I will certainly find out. However, dealership blames car starter for problems and car starter co. says no way. In the mean time I have to hope my car will start each day. Since the car starter is disconnected, I don't understand why I am still having the problem.
  • jrct9454jrct9454 Posts: 2,363
    ...that have to be made to install the remote starter. There is almost no doubt in my mind that this is the source of your problem. If you want Toyota to try to solve this problem, you have to restore the car to stock, no matter what the other guys say.
Sign In or Register to comment.