Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Buick Park Avenue Maintenance & Repair

1131416181923

Comments

  • imidazol97imidazol97 Crossroads of America: I70 & I75Posts: 17,714
    Are you able to disconnect the cd player completely as a first check? It was the change made and then after that you noted the problem. Logical move.

    Alternators have been known to allow a drain on battery. So have starters.

    Not sure just how the wiring logic is on your car but some have had problems with the rear strut load-leveling compressor running even if the car is off. You might pull the fuse for it temporarily. Do you notice the compressor cutting on while driving indicating the struts or lines may be leaking?

    Also the automatic blower speed control, the blower control module, can be on after the car is off--if your car has the digital temperature control. However, I would believe it would be on immediately even if the key is off. The modules fail in different ways.

    Beyond that you're down to checking for a drain and I believe that's 30 milliamperes or more. I can't guarantee that as the maximum normal drain because I'm recalling that value from memory for the H-bodies where people have checked.

    This message has been approved.

  • mem454mem454 Posts: 2
    find who traided keys with you !
  • mem454mem454 Posts: 2
    Hi! I'm Mike. Does anyone have any idea how a serpentine belt goes on a 1998 Buick PK. \ Ave. 3.8L. ? There is no sticker on the car to show how to put it on. Can someone PLEASE send or post me a pitcher or something that looks like how it's sapose to go on? I'm new at this forum stuff i don't know post a pitcher or not, I thank you so much! Mike..
  • bowfanbowfan Posts: 55
    Wow that link contained a lot of different diagrams! (but none of them match mine)

    Here's what mine looks like:
    diagram: http://rides.webshots.com/photo/2698621300105698750ZGDjuw
    picture: http://rides.webshots.com/photo/2999066120105698750gRPVZQ

    If you haven't removed your belt yet, make a diagram. If you have, I'm sure you've figured out what a pain it is to remove the lower motor mount to replace the belt. That design flaw was fixed in the 2000 model I think, it is a 5 minute swap on the later models.

    On the other hand, you may just be replacing a component like the alt or water pump.

    Hope this helps.
    :)
  • bought a radio from junk yard and theft deterrant is active. is there anyway to disable when you don't know existing code. the code is possibly same as set by factory but i don't know that either. any help appreciated.

    i have factory service manual for 95 PA. from all i read, buick radios from 95 to 2000 are compatible. in that case, assuming that 95 FSM instructions are applicable, i have the procedure for disabling theft deterrant system. however, the radio was purchased off the shelf from the junk yard so i don' t know the VIN the radio was taken from. as i understand it, dealer will not tell factory code if they don't have VIN.

    i would just return radio to JY for credit but it has features i was looking for (dvd player and cd casette player).
  • Here's a place that says they'll do it, but whether it's a scam or not, I have no idea.

    UNLOCK RADIO CODES
  • i am going to give the site a try. will post results later for future reference. thanks a bunch.
  • with reference to my previous post, the site is legitimate. they charge $7.00 for help in determining your radio theft deterrant code. they also provide instructions on how to go about entering the code.

    they were not able to help me because my radio had an additional malfunction but they are refunding my cost voluntarily.

    my thanks to Mr. Shiftright for steering me to the site. the site is radio-code.com.
  • The car is the 3.8 series 2, after cranking, the car idle changes rpm from around 800 to 1200 and back, then while in park or drive it has a shutter at 4000 rpms.The fuel hand rises to full and then back to correct. The parts I can say are good are fuel and air filter, plugs and plug wires. Of course the engine light is on, we have 148273 miles. I've read all the forums and eliminated any vacuum leaks or cracks in intake or gas in vacuum lines, haven't bothered to get codes checked out yet. I consider myself pretty proficient at auto repair but not not on computer type engines. Any help will be appreciated and I promise to post what fixes it. Please include an idea of where to find the part on the motor. Thanks
  • bowfanbowfan Posts: 55
    Can you check the fuel pressure throughout the RPM range?

    Are the battery connections good and clean and tight? If the connections are good, and the fuel gauge needle is erratic and bouncing around, that would seem like a possible sender unit going bad. This is found inside the tank, attached to the fuel pump.
  • I held the rpm at 3800 to see if it was just running out of enough fuel pressure and it ran ok, if u rev quickly to 4K it still breaks down at that rpm, do u know where egr valve is and any other thing is that i can take off and clean? Cables are fine, another clue is the wife said her gas mileage went down before the skip, also 1 of the plug wires shorted out to manifold, wife took it to shop and they wanted $ 480 something for a tune-up and mass air flow sensor, i just brought it home and replaced plug wire and it ran fine for 2 weeks, could be a damaged coil, is there a way to ohm it out?
  • imidazol97imidazol97 Crossroads of America: I70 & I75Posts: 17,714
    When you are revving in neutral the limiter cuts in much sooner to protect the motor. Is that what's happening?

    This message has been approved.

  • I haven't really checked to see if it's doing the sputter at 4k in drive but it does sputter at some rpm, in truth the fuel hand has been on the blink for about 6 months and also the oil pressure has read 128psi and i know that ain't right, figured the computer was erratic.
  • you guys were right about sputter at 4k being the limiter, still have rough idle and run though, anyone know where the MAF and EGR are located?
  • The problem turned out to be the spark plug wires, I cleaned the MAF, EGR, and took off the throttle position sensor and there was nothing there to clean, all these things were what Advance Autos code reader called out along with multible mis-fires. Thanks for the help especially the rev- limiter ones.
  • imidazol97imidazol97 Crossroads of America: I70 & I75Posts: 17,714
    Thanks for the reply about what you did find as your problem. Those of us who try to give remote help appreciate the feedback. It's not the first time the rev limiter has fooled someone so I hoped that was what you were noticing; it's cheaper than a real problem!!!

    Spark plug wires seem to be a very common factor in problems on the 3800's. Replacing them with Belden or other OEM quality wires helps. Also replacing the plugs with the AC Delco replacement saves trouble in the end. Occasionally someone has other plugs and switching back fixes the problem. There are some who run NGK plugs who are successful in the Bonneville groups.

    This message has been approved.

  • yunghillyunghill Posts: 3
    i have problems with my rare reatta i know i have a small crack in my exsaust manifold i put some sealer onit but all of a sudden it sounds like a truck and it sutters when i take off and it lose power on incline like the transmission and sparks aint on the same page????i need help please i heard it could be my something moduleor crank censer but i dunno
  • yunghillyunghill Posts: 3
    i have problems with my rare reatta i know i have a small crack in my exsaust manifold i put some sealer onit but all of a sudden it sounds like a truck and it sutters when i take off and it lose power on incline like the transmission and sparks aint on the same page????i need help please i heard it could be my something moduleor crank censer but i dunno
  • patnjoepatnjoe Posts: 4
    I have a 1996 Buick Park Avenue. I need to replace the driver's power window motor. How do I remove the window control switch panel in the driver's armrest without breaking off the black plastic tabs on the ends that secure it in place? Thanks for your help.
    Regards, Joe
Sign In or Register to comment.