Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Ford Escort ZX2

1656668707177

Comments

  • milguymilguy Posts: 4
    Hi, how did your blower motor go out? How did you replace it? Was it a PAIN IN THE @#$#@!@ ??? I was driving down the road the other day and the blower just stopped. Thought it may be a fuse. NOPE, all good. Any Ideas?
  • profordproford Posts: 3
    HI you need to change your coil pak which the four spark plug wires plug into.this will solve your problem. THANKS PROFORD
  • profordproford Posts: 3
    HELLO the pcv &hose is down below thermostat housing driver side front of block tight spot ,hose goes from it to back under throttle body and connects with spring clamp to plastic emmision box.change it all and you will be amazed at difference it makes.hose elbow deteriates and gets sucked in while running and can't breath. THANKS PROFORD
  • profordproford Posts: 3
    SIR change the coil pak.PROFORD
  • remowusremowus Posts: 40
    The motor just quit. There is no fuse for this . I guess its one of those inline jobs . If you buy the motor from the dealer, you will get the plug in connection to just plug it in,but it costs 180.00. If you buy it from AZ, it's about 80 bucks , but you will have to do some surgery on the connector.
    And you'll need a circuit tester and a crimper for the new connection you are about to put on.
    Have fun with it.
  • 2000zx22000zx2 Posts: 10
    I have a 2000 escort zx2 S/R and I tend to do a little racing here and there just for fun. Well when I first bought it turns out I needed new head of engine, head gasket, and timing belts. Then I had to replace the radiator. And it's always flashed my 'check engine' light when I hit about 105, 110 mph. Now its starting to flash at about 80 mph. And I dont rev over 5.5-6 rpms when racing. I was first told that it flashing might be a warning that I'm about to reach my govn. limit. But now that it's doing it sooner. I dont know whats wrong. Any one got some ideas???
  • i have a 99 ZX2 no big problems realy other than it tops out at 105 SLOW!!! my old 86 camry toped out at 120 which is really sad i need my ZX2 to top out at a higher speed any one know how to do that other than a speed chip mod to my ecu, also i have alot of slack in my pedals especially my gas and my clutch, it also likes to bunny hop when i burn out and i tried to power slide a turn at 40 and i came up on two wheels never done that before so what i need to know is how do i top out at any thing over 105, whats the deal with my pedals, and im pretty sure on the last one the answer is to just lower my car but thats expensive so if any one can help please i need it
  • 2000zx22000zx2 Posts: 10
    I dont have an answer for your top speed or slack in your pedals. But I have had the same problem with the bunny hoping, and I was told it has to do with not enought rpms and how fast u punch the gas, im not for sure but i was told to keep ur car reved up to 2 - 2.5 rpms then punch the gas. and about the power slide (drifting) I also do that a ton. But what I've found to work, if doing a u-turn, is pull the e-brake, [non-permissible content removed] down to 2nd gear release e-brake and punch it. And if your just talking powerslide around some small corners on the streets, then try slowing down or you might not be turning enough to get the effect.
  • yea the only reason why i prefer to call it power sliding is because the zx2 is front and all my past vehicles have been rear and there is some what of a difference between power slide and drift but any ways i appreciate your advice man ill try it out later on this week and let you know how it went... also i looked up a forum last night about my rev limiter and it said under neath the dual cup holder in the zx2 there are a bunch of wires taped or held to gether amongst these wires is a white wire with a black line and supposedly that is the wire to your governor or rev limiter and if you cut it it will disable it and you could go up as high as 120 the only problem is i dont know if this wil cause my car to malfunction, the forum said it worked but also said it was not responsible for damage so i dont know you know anything about it
  • remowusremowus Posts: 40
    I always wanted to put a v-6 in my 'oo ZX2 . But I've been told it won't fit. Now that will get you over 105.
    But I want to talk about drifting. My ZX2 used to go straight as an arrow. Now it drifts in the lane. Not a serious drift, but a drift none the less .

    The tires don't show any abnormal wear, so I was wondering if maybe the CV joints were wearing and changing the camber slightly.

    Anyone heard of this?
  • 2000zx22000zx2 Posts: 10
    Ya i have actually read a little bit about that. I think im going to try it and if it doesn't work right then use a metal binding of some sort to put the wires back together.

    Does anybody know what the box under a '00 zx2 driver seat is?
  • yea mine does it too and nothing wrong with your cv's coz mine has nothing wrong with it... but in the event i am wrong then hears a little cv tip coz iv had them go out before just on a different car... this is the sound you want to listen for if you hear a knocking sound when you turn then you probably have a busted cv or a messed up bearing of some sort but as far as drifting tearing your vehicle up goes duhhh any sort of racing tears a car up it just kinda goes with the territory
  • yea tell me if it works or not coz if it does im sooo doing it
  • 2000zx22000zx2 Posts: 10
    Ya so I cut my governor and it definately works. Because I was able to get my car up to 117 mph on the highway. It was amazing. But be sure that when you cut it, its the white wire w/ the black stripe. You may have to take out the center consol to get to it. But its worth it!!! Hope it works.
  • remowusremowus Posts: 40
    how many RPM's at that speed? Do you have a tach?
    Do they all have a tach? I do. :)
  • thanks man ill reply and tell ya how it goes
  • my 99 red lines at like 7 and when im going 105 im at 55 rpm
  • yea i just cut mine as well and im able to go 115 but thats just coz of traffic i could have gone faster
  • 2000zx22000zx2 Posts: 10
    ya when I hit 117, i was at like 5.5 - 6 rpms. but ya I have a '00 and its a manual so it does. But ya I love it now. And just to let you know your check engine light may come on and dont worry about it. I had mine checked today at its jst bcuz of cutting the wire. Next I need a radar detector cuz i slowed down bcuz of a cop. haha
  • dan855ndan855n Posts: 1
    I have the exact same zx2 2001 and the same squeak and bill from ford for the same tensioner and belt. I found when I removed the breather, the squeak left. I will cancel my appt monday for replacement of timing belt and save some money ... I hit the breather with a hammer and the filter was clogged at the input from the air filter.. Thanks all
    your message confirmed that it will not squeak anymore.
Sign In or Register to comment.