Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy Silverado: Problems & Solutions

16869707173

Comments

  • Sorry to butt in... I'm new to this.
    the thermometer on my 2001 Silverado says NC in the mirror readout. Any ideas....

    Thanls!
  • the mirror readout says "NC"
    any body know the fix?
  • I have a 2000 Sierra Z71 with 60,000 miles on it. Within the first year of ownership, I started hearing a noise from the rear of the truck that sounded like a loose traler hitch. I had to hit a pretty good bump to make the noise so it wasn't normally bothersome. Every time I took it in for service, A I mentioned this noise and they always said they couldn't get it to make any noise and everything looked ok. I recently moved to a different town and took the truck to a Chev dealer for service. They checked out the noise and said there was some special lubricant they could apply to the spring that might possibly help and the total fix would cost about $100. I had previously determined that the noise was just on the passenger side wheel area so a spring problem could be the cause of the noise. Springs aren't exactly complex and I don't understand why one spring was fine and the other makes this noise. I go fishing and hunting a lot more since moving to this new town and riding over some washboard gravel road really makes some noise. I guess nothing is being harmed but it sure sounds bad. Any thoughts as too the cause of this noise and the appropriate cure?
  • I agree there is no "rocket science" in springs,BUT you haven't mentioned anything about TIRES, try rotating while they are off look for a busted leaf in the spring assy. That and maybe you have bad SHOCK, something could be bouncing around in there!
  • I am having similar problems. Have you found out anything on what the problem is/was...???? I am still having the problems... and getting worse.
  • I have a 1996 silverado Z71 that runs great but the 4wd recently quit working the front driveshaft spins but the front tires dont. It is a push button 4wd system and when I push the button it just blinks and stays in 2WD. I have no idea what is going on. any ideas or ways to fix this would be great
  • sorry guys i don't mean to take over this post, but i have no idea how to create a new one.

    I recently just bought an 04 silverado 4x4 extended cab w/ the vortec 4.8. When I bought the truck it had 66,500 miles on it. The dealer that I had bought it from took it to a garage and got it inspected for me, as well as an oil change. The sticker that was put in my windshield says that the next service should be @ 70,500. Well i am at somewhere around 69,200 right now.

    This morning i got in my truck and everything looked fine, but when i got done work i got in my truck and started it and i noticed that the change engine oil came over the display. Now my engine light is on. Is this on because my truck is saying to change the engine oil or should i bring it to a garage and get the code checked? Any help would be greatly appreciated.

    Once again i apologize if i am taking over someones post.

    p.s. Could someone explain to me how to create a new post?
  • Check your owners manual. In it where it says when to check your oil it will tell you how to reset the change oil message. Your dealer should be able to reset this at no or little cost. It takes about 30 seconds to do.....Matman98
  • evergreenevergreen Posts: 208
    To post a new message, scroll to bottom of page and follow instructions. :)
  • pete46pete46 Posts: 2
    Hey guys,

    My 2002 Silverado 1500 had the alternator go on it last week. I changed it out and now my battery light is coming on intermitantly. The voltage measured with a multimeter coming off the alternator is a good 14.5 and its registering the same on the gauge in the cab. I changed out the belt while I had everything apart so I don't see the belt slipping. I flip on my AC to max and I see the power draw down on the gauge, never did that before. Any idea's???
  • jnealjneal Posts: 247
    I would venture a guess that you got a bad alternator..especially if you bought it at AutoZone.
  • pete46pete46 Posts: 2
    I was thinking the same thing. I bought it at CAP and I was just telling a buddy of mine last week how I never had any trouble with CAP parts. Murphy's law!
    I was thinking I might have hosed the battery driving it back home after the original alternator went south. I have a life time warranty on the new alternator so maybe I'll give that another shot before I replace the battery.
  • obyoneobyone Posts: 8,065
    The dealer should do some research before spreading any grease. I don't have the part number handy but there are rubber spacers that are placed between the springs to rid that slapping problem. It is well documented and nothing new for the '00 model.
  • ricschricsch Posts: 540
    Dealer found the heater core to be leaking, will be replacing it and hopefully this cures the smell-never noticed any coolant loss or leaks anywhere.

    Service adviser mentioned the h. core is located on the driver's side of the truck(?) thought they were closer to the passenger side-says it's a bit involved to remove & replace. Good thing for the warranty.
  • l204l204 Posts: 6
    Someone did not re-set the milage meter for the oil. Its in the owners manuel. You are good until the 3,000 miles are up. I can send you the instructions for the 2002 but I am not sure its the same. It only goes by the milage. It does not inspect the oil.
  • It started with my speedo telling me lies. Then it stopped altogether. Unfortunately the symptoms were common in my other instrumentation as well, i.e. voltage, temp, oil pressure. I've read alot of similar circumstances in forums. And though they were in fact quite helpful, I guess I am only trying to hold on to my money so I can keep the wheels turning. Is it a flat out prognosis? (cluster defect) :mad:
  • c_lo5c_lo5 Posts: 2
    still haven't had any luck finding the problem does anyone have any ideas
  • i have a '01 chevy silverado and the speedometer, tach, gas gauge, message center, trip odometer, prnd321 lights, and factory stero quit working all at the same time. can anyone help me to figure out what is wrong with my truck. please help!!!!!!!
  • I can feel a small knock or clunking noise in the steering wheel while turning left and even hit the slightest bump. Service personel have said it is not a safety issue and the part that needs replacing cannot be fixed, except for a lube kit. Has anyone else experienced this if so what can I do?
  • mek0123mek0123 Posts: 33
    My brother has a 2004 Silverado LT 3500 with the Duramax Diesel that he ordered new with every available option and when he test drove two other Chevy 3500 model trucks prior to ordering his, the mirror control button would allow him to electronically fold in the trailer tow mirrors. He just recently realized after two years of ownership that his truck will not do this. GM nor the dealer has been of any assistance at all, after three calls/visits to each. Any idea why his won't work in this manner? Thanks and we both would appreciate any assistance at all.
This discussion has been closed.