Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Pontiac Grand Prix: Problems & Solutions

1192022242528

Comments

  • talltall Posts: 1
    First, only got heat from passenger side vents while driver side control worked fine. Just prior to this, there was a sort of flapping noise.
    After about a month, the driver side temp. control also went out and now both sides produce nothing but hot air.
    When the fan is on I hear a whining screech from the vents. If I quickly turn the fan off then on a few times the screeching noise will sometimes go away, but not always.
    What is the problem and how can it be fixed?
  • ken7308ken7308 Posts: 6
    I had a 95 grand am that did the same thing. It turned out to be a bad crank sensor. If that isnt your problem I would test your fuel injectors, one of them may be faulty. Hope this helps
  • tdwrigtdwrig Posts: 3
    I have an 03 GTP that all of a sudden produces a very high pitched whine when I press on the accelerator. Almost sounds like a vaccum cleaner noise. I checked belts and everything looks OK. Any ideas?
  • tschocktschock Posts: 2
    All 4 of my windows have played the "sometimes i work, sometimes i dont" game until they all actually died within the last year. It was the window regulator. which is a pricey part. I have contacted GM and they have reimbursed me for 2 of the regulators. good luck with yours.
  • 99blkgtp99blkgtp Posts: 3
    I have a running problem. My car has miles 133000 on it and about 1 month ago it stopped running with out any warning.
    I took it to a shop and they had it for 3 days and said to come get it because they could not figure it out. They said a wiring harness might be the problem it is located by the air cleaner. They said that for the part it would cost 600 dollars. I was told that this might not even fix my running problem. The longest I can keep it running id 10 min then is starts to sputter and surge in Rpms and then dies and I can't re start it. Does anyone have help for me before I go spend 600 dollars in something I might not need. Thank you.
  • graccogracco Posts: 2
    I have a 1999 grand prix GT and last night I came home from work and I could not turn the ignition completely off to remove the key. I'm a single woman with NO knowledge of car repairs. I went on this site and after reading this thread. I found the small cover under the ignition and thanks to the inside of a pen. I was able to release the switch and my ignition shut off completely to where I could remove the key. But one more thing. What causes this to happen. Does something need to be replaced. I turned the car on and I had to use the pen again to release it again.
    Thanks
    ]Maria
  • amoody2amoody2 Posts: 1
    dont feel bad. my 96 wont even budge. transmission just went out last night.
  • graccogracco Posts: 2
    I have a 99 Pontiac Grand Prix GT and I have had the same problem. It goes out or half the numbers will display then when I tap the display it'll come back on. One time it wouldn't come back on so I really gave it a whack needless to say I tapped it too hard and I think now it's done. What do you think causes this problem. I've read so many of other's problems and I have experienced many of them. I wonder why these issues have not been recalled over the years. I bought my car brand new in 99 and I have 127K on it. I love my car but sometimes these isuues are a headache and very costly...
  • ken7308ken7308 Posts: 6
    My car has about the same amount of miles and does the same thing only i can start it back up. I was told by GM that my crank sensor was bad you may want to check it out.
  • 99blkgtp99blkgtp Posts: 3
    cool thank you anything will help have a starting point
  • 99blkgtp99blkgtp Posts: 3
    I have the same problem with my 99 there is pin there where you are putting the pen and the pin breaks off I just reach into the steering column to release mine
  • I have a 99 Grand Prix 3.8, that has a whine to it when accelerating and turning but not in idle or high rev while in park. Does anybody have any ideas as to what would cause this and what to do to fix it ?

    Thanks
  • I have the same exact problem. Passenger side blasts heat and the driver side is fine. I also hear a whining screech from the vents. I have not been able to find the cause of this. Hoping maybe you have been able to fix the situation you are having. If you have recieved any valuable advise on this problem, please let me know. I would like to have working A/C this summer.
  • blkhemiblkhemi Posts: 1,717
    Is your '99 a GTP model? If so you could be nearing the death of the supercharger. If not, then it could be the power steering pump going out. Better the steering pump than the s/c. I had the same symptoms on my '97, and the steering pump fixed all the noises.

    BTW, you mentioned that it whines when turning. Is it more like a roaring noise more than a whine when turning? If so, you may want to have your wheel bearings/hub assmemblies checked out. Be prepared when you get the price of the hub itself, not to mention labor.
  • Thanks, I thought that too but why, when its idling in park its quiet and when I turn the wheels in idle park its quiet also. Problem is only when in gear and driving. Gets louder as I accelerate, whether I'm turning or not. No roaring noise either when turning. Oh, BTW its not a GTP. I thought seprentine belt or even alternator. Just don't wan tot start swapping things out that don't need to be replaced.
  • Did you get your problem fixed?? I have an 02 GTP that died at a stop light last night without warning and then acted as if the motor was flooded when I tried to restart it. It happened a couple more times on the way home and each time it acted as if the motor was flooded. Any help is appreciated.
  • bmwguy2bmwguy2 Posts: 13
    dear sir,i have a 2001 pontiac grandprix gtp special edition coupe ,purchased new ,i also work for a bmw dealership here in new jersey ,first i would contacr pontiac at the 800 number as you did ,2nd that you want to speak with a rep from pntiac ,this you have to work out with service manager at dealership to schedule they should know his schedule,send a letter to general motors of the problem that you are having ,you can contact pontiac customer service on line ,i had a problem and they were xtremly helpfull,i had a problem where 3 of my rims were leaking air thru the valve stem area due to severe corrosion ,each rim was $600.00 i do have a xtended warranty with gm ,the rims were replaced at no cost to me but you have to set the ball in motion,the next time it happens ,bring the car to the pontiac dealership were you purchased it,speak with service manager,possibly a fault or faults was set in cars computer ,speak with him at speaking with rep ,let me know how you make out,it sounds like a bad fuel pump or f/p relay
  • Hi folks, first off my car is a two door grand prix gt. it has every feature you can imagine. anyways while i was cruising around. my information center where it tells me how many miles per gallon, my oil life, my economy, and a few other things. well today that was blinking with zero's. What does that mean? everyone of the icons are blinking zero. even tho i have a full tank it blinks zero. it worked just find until today. also i see that my traction control says trac off. that was never off before. i try and turn it on and it wont. my abs light comes on at the same time. i assume that it has to do with the same think. i do not know. something is going on with this car. it is running find its just the information center. i thougth it might be everything but my heads up display works just fine along with evertyhign else on the dash. Please help me with this problem. much appreciated
  • georgekogeorgeko Posts: 1
    Have the same problem especially the screeching. Also for the last few months blower worked only on speeds 3,4 & 5, yesterday stopped working on 3 & 4 and now only works on 5
  • bman64bman64 Posts: 14
    power steering pump is bad
  • i recently ran into a problem with my gt.... i saw that someone else had a similar problem but didnt see the answer... when i have my ac on and everything set to cold the driver side will blow hot and the passenger cold..... if i mess with the driver side contorol a little bit by moving it up and down and what not it seems to be fixed for about 30 seconds... then it blows hot again... is it just the switches itself?
  • bigskidoggbigskidogg Posts: 8
    i have a 2000 gtp and need to replace my the fuel filter,if anyone knows the procedure for this would you please post it if possible? also if it is a hard job? any help would be greatly appreciated. thank you
  • bigskidoggbigskidogg Posts: 8
    does anyone know how to check, add, or change the supercharger oil?
  • anndjanndj Posts: 3
    I had a 2002 Grand Prix GTP that did the same thing. I went to the dealer and they said it has a sensor in the steering column and the shifter that has to be syncronized. They fixed it and it was fine until it burned up in my parking area! Be careful.
  • ken7308ken7308 Posts: 6
    Any luck with the problem?
  • Hi, I need some help. My 1997 Pontiac Grand PRix SE is consuming an unusual high amount of gas. I mean it consumes like 10 - 12 miles per gallon. Does anyone have suggestions as to what I can do regarding this problem? I would really appreciate any help. Thank you.
  • lrs1986lrs1986 Posts: 1
    ok so here is the thing...i know nothing about cars and i need some help. I have a 99 Pontiac Grand Prix GT. Here is the problem...I drove my car and everything was fine and then i went into the mall for about an hour and came back out and when i went to start my car it was having trouble and then i pressed the gas and it started up but the rpm's kept going up and down constantly and then white smoke started coming out of the exhaust so i turned it off. I checked everything and found that the coolant was low...like there was nothing in it but my light never came on to tell me that. So that was like a week ago and my car wont start at all. i had to have someone tow it to my house because i would act like it was going to start but it wont turn over....can anyone help me please.... :(
  • psyclepsycle Posts: 1
    Have a '93 Grand Prix V6, the temp gauge is going up and down from cool to red in 30 seconds and back the other way. Anyone else experience this problem? Thermostat,gauge ??
  • pjmz28pjmz28 Posts: 1
    Hi all,
    I have a 99 Grand Prix SE. Recently I had a blower resistor card replaced because my hvac blower worked only from the #3 setting and up. A few weeks later I noticed that when starting my car my daytime running lights would take about 10 seconds to kick on. They used to come on right when I turned the ignition key. Most recently my climate control panel has been acting up on me. When I start my car and put the heat (or a/c) on my drl's cut off and everything losses power. No heat, no a/c. Not even rear window defogger. When I turn the hvac off my drl's come back on. My mechanic is at a total loss. What makes it worse is that it doesn't happen all the time which makes it even more difficult for my mechanic to find the problem. Any suggestions would be greatly appreciated!
  • my grand prix head lights wont shut off they stay on and even the full light signal in the dash stays there if i pull the lever back it dosent go away i wonder if the lever is bad or its a fuse or a relay please help me im tired of removing the negitive side of the battery everytime i go somewhere..
This discussion has been closed.