Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chrysler PT Cruiser Owners: Problems & Solutions

blackcloudblackcloud Posts: 2
edited March 20 in Chrysler
my wife recently bought a 2002"WOODY" PT. MY question is what kind of wax do you put on the "wood". My dealer has no idea what so ever. Does any body know ?
«13456713

Comments

  • I have a 2005 Cruiser Convertible. I absolutely loved this vehicle. As you can tell that is in the past tense. At 1000miles the engine starting dying at every stop sign and stop light. Then the problems started with the gas tank, would not go above 3/4 tank, then would not go past empty, then would back and forth between empty and 1/4 tank. This car has been in for repair 6 different times, the 7th time coming on Monday, the idel is messed up again and there was a CD stuck in the CD player. I have decided against Chrysler all together. Anyone else with PT convertible with any problems?
  • jbolltjbollt Posts: 734
    Hi all...I have a 2002 Limited Edition 5 spd in Steel Blue for about six weeks now. Great car! I am starting to notice a curious situation after filling the gas tank. Sometimes, within 20 miles of filling the tank, the gas gauge shows 3/4 tank, and other times, it takes 60 miles to get to 3/4. All with the same type of driving, and I usually get gas at the same station. This is not a comment about MPG, rather about getting a full tank when I get gas. It seems that it is hard to get a full tank. Has anyone else experienced this?
    The next time I refuel, I plan to keep clicking on the handle (topping off) several times to see how much more gas I can get in the tank. Has anyone else experienced this?
    Also, I recently parked overnight on a slight up hill, with the gas gauge indicating 1/4 tank when I shut it off. When I started up in the morning, the low fuel light came on instantly, and the gas gauge showed in the red zone, less than 1/8 tank. After driving on a level road for several miles, the gauge was back at 1/4 tank, but low fuel light stayed on. OK, the incline caused the gauge to read low, I figure...no problem. I shut off the car, parked on level ground, and later in the day, the gauge was still at 1/4, and low fuel light stayed on. Doesn't the light reset with the ignition if it is now above the trigger point?
    Thanks for any input.
  • waynerpwaynerp Posts: 35
    Is this the only discussion about problems with the PT? If so, the PT must be a really great car!
  • Reporter for a major business daily seeks drivers of the PT Cruiser ASAP, to share your experiences with the car and possibly mention your name in the weekly auto feature that I write. Please email me at lori_f@eudoramail.com
  • Just bought a PT Cruiser and love the car, great to drive and it really does get 29mpg on the hiway, I got the 5 speed. I live on 3 miles of gravel and wonder if I put the spoiler on the back if it would direct the wind to clean off the dust on the rear of the car. I had about the same type of dust problem with a Plymouth Vouager. The dust settles badly on the rear window.
  • I've been driving a 2002 PT for about a month now. It's a rental and I'm considering buying one. There is a curious situation that's been happening. Sometimes the auto locks open and close on their own. My husbands says it must be a ghost. I was sitting in my office and I kept hearing click, click. I went outside to see the locks locking and unlocking. I opened the driver's side door and shut it real well and it stopped doing it. Then yesterday it started doing it while I was driving. So at a stoplight, I opened and closed the door and it stopped doing it again. I parked & locked it, went into my appt. and when I came out it was unlocked. Weird. Now I'm wondering if it's such a good idea to buy one. I really need a car that locks as I sometimes keep my cell phone in the car. Hmmm.
  • I experienced the 'mysterious' locking and unlocking with my PT also. I took it to the dealer, who fixed it. Since then, there has been no trouble. Apparently, some water, probably due to car wash, got into the front door lock, which then caused such 'automatic' locking and unlocking. Incidentally, I like my PT a lot. Don't give up your pursuit for a PT.
    DWL
  • kaywkayw Posts: 2
    At 12,000 miles my brakes started squealing on my 2001 PT Cruiser. The dealer said is was a problem with the new brakes they were instalilng on cars and all the new brakes will do this. Something to do with a safety hazard with material on the older brakes. They indicated they could put the more expensive brakes on the car but they don't last as long and would probably need to be replaced at 20,000. Pretty embarrassing to be driving a new vehicle with squealing brakes. Anyone else with this problem?
  • I just got a 2003 Pt Cruiser Touring. Is it supposed to have a dual note horn? Mine sounds kind of sick with a single note.
  • crkeehncrkeehn Posts: 513
    The 2001 and 2002 models came with a dual note horn. Part of the decontenting for 2003 was a switch to a single note horn.
  • jbolltjbollt Posts: 734
    Hi all...I have a 2002 LE 5 speed 18,000 miles, and the brake pedal seems to feel "hard" after the car sits overnight...feels normal as soon as car is started. My first thought is this is a new thing (don't recall it feeling that way before), but now I am uncertain. I would guess that this is a leak of vacuum to power booster, but wonder if anyone else has this or what your thoughts are. Is it a concern?

    thanks
  • Does anyone know of a kit (or method) to lower the driver's seat height on a PT ??
    I am 6'3'' and would like to lowr the seat by about 2"
  • larryj75larryj75 Posts: 1
    I've only had my PT Cruiser for a few weeks and already I'm having this terrible problem where once in a while it just refuses to start. I'm driving the base 2003 SE model, not the turbo. It doesn't seem to be a battery problem, however, as the starter seems to be working; it just isn't getting any gas. Of course, it doesn't happen all the time, but often enough to make it a pain in the tookus.
  • PTs are usually quite reliable. Hopefully you have a good dealer that will quickly take care of the problem.

    While mine has not been totally trouble free, the dealer (Rancho in San Diego) has been outstanding and has made necessary repairs quickly with no hassle.
  • Hi everyone,

    We are thinking of buying an 02 Cruiser Touring auto for the missus.I think I can get it for $12750, maybe 12500 from a dealer. It has 18000 miles on the clock. Can someone give me comments on the cost of running, servicing intervals and servicing costs and reliability. I know some think the 2.4 is underpowered with an auto, but for our use it will be fine. Coming from the UK, I will always choose auto. I used to change gear 1100 times a day on average!! Thanks in anticipation.

    Ian Jennings
  • My neighbor has a 2001 with about 50,000 miles on it. Mostly local driving and she has had no mechanical problems. Oil changes, an air filter, wiper blades, a new set of tires a little while ago, and new brake pads are the services so far.

    Mine is a 2003 GT and has had one significant warranty repair besides a routine oil change. Most owners I have spoken with say their PTs are very reliable and have been virtually trouble free.
  • crkeehncrkeehn Posts: 513
    Most Pt's seem to have been fairly reliable, those problems that have occurred have been taken care of under warranty. Generally as far as maintenance is concerned, the PT follows a fairly standard schedule with oil changes every 7000 miles. You didn't mention what you are switching from, you may find fuel costs to be the big expense, the PT can be a thirsty beast. Part of that is due to the fact that the PT is a fairly heavy car, well over 3000 lbs. In addition it offers the frontal area of a barn. Look for the fuel economy for the auto to be in the high teens for local driving and in the low-mid 20's for mixed driving. My wife has a commute of 22 miles each way with her touring edition, a mix of local streets and limited access. she has been averaging about 23-24 mpg even with the cold winter we have had.

    People have complained about the PT being sluggish, I would class the automatic as adequate. My 5 speed is a bit peppier than my wifes automatic but I have no problems keeping up with traffic in her car and heavens know that enough PT owners have managed to get speeding tickets. There are very few owners that are unhappy with their PT's.
  • Thanks guys for the response, it is much appreciated.
    We will be exchanging from a Grand-AM 2.4, also with 150 b.h.p and automatic. We average about 24 mpg around town and about 31 mpg on a run. In true GM tradition, top gear is very high and you often have to chnage down to 3 when going up an incline,so the PT wont be too different. We will get a test drive and see.
    One thing that disturbs me. I have learnt that ABS is an option which i personally feel is absurd!! This is a trend i feel needs reversing. It is the same on GM in the USA and UK where i come from. Am I right in saying that if a PT has rear drum brakes it has no ABS. If it has rear discs than it has ABS? Does anyone know this?

    Thaiks and regards

    Ian
  • crkeehncrkeehn Posts: 513
    If the rear brakes are drum, the car will not have ABS. The ABS came as a package which included the rear disk brakes, ABS and Traction Control. I also believe that you could not get the rear disk without ABS so if it has rear disk it would have ABS. You will also see a switch to turn off Traction Control if it is ABS equipped.
  • jbolltjbollt Posts: 734
    I have a 2002 LE 5 Speed with 21,000 miles. It has always started quickly on first crank, however, in the last week or so, it has been "slow" to start when warm after sitting about 20-30 min since driving. Outside air temp in the 70s. It cranks normally, but will crank longer than usual, then start hesitantly, rough idle for a few seconds, then rpms will increase to normal idle speed. The last time it did this, an observer seemed to notice a smell that might have been gas at the rear of the car. This is something new, as the car has always started on first crank for 21,000 miles, hot, cold or warm. It still starts on first crank cold or hot, just after sitting 20-30 min after driving does this happen. The dealer says, "can not duplicate, no error codes, or TSBs" (Does this means that there is nothing wrong?!) Anybody experience this, or have any suggestions/advice, other than a different dealer, or get used to it?

    Thanks for any input
  • I wonder if the problem is winter fuel on a warmer than normal day for that kind of gasoline. Have had similar problems for years. Started after oil companies started using oxygenated fuel (or fuel with a higher vapor pressure) during the winter here in SoCal. Cars always started and ran fine when the engine was cold, but gave problems when, as you mentioned, the engine and under hood had heat soaked for about a half hour. Once the hot fuel went through and cool fuel from the tank was being fed to the engine operation returned to normal. Problem went away when non winterized fuel was sold, usually beginning near the end of March or early April, only to return around early November when winterized gasoline was again sold.

    My newer cars seem to tolerate the winter fuel better and so far I have not seen this problem with my PT GT even though the underhood temperatures get very high after being parked for even a few minutes.
  • jbolltjbollt Posts: 734
    Thank you for your thoughts. You raise an interesting possibility, as I started experiencing this condition on a trip to SoCA from AZ. However, I have made similar trips to SoCA over the last few months, and not experienced this slow starting with warm engine. In fact, on these trips, I usually get gas at the same station in Yuma (cheaper than CA prices!). I will be filling up today at my usual station in Tucson, so I will see if that is in fact the cause, but I doubt it.

    I'm wondering if there may be some sort of delay in the fuel pump getting gas to the injectors on warm start, or an electronic malfunction in the fuel mixture controls for warm starting? I'm not very up on today's electronic systems in cars...

    I was able to demonstrate this condition to the service writer at the dealer, and his comment was " boy, is that subtle!" HA! I know this car, for 20,000 miles it has started on first turn of the key everytime. Something is wrong. Maybe it's time to try a different dealer. I'll post again after refueling.

    I really like this car, and this slow staring is really bugging me. Any other thoughts anybody? Thanks!
  • PTs do not come with long life spark plugs, but they should last more than the 20,000 miles you mentioned. In addition, if the gasoline you have been using contains MMT, spark plug life is sometimes reduced. "Reformulated" gasoline does not contain MMT.
  • riirii Posts: 2
    I have an '03 PT Base model and recently acquired OEM driving lights to self-install. The instructions indicate that if there is no wiring in cavities 13 and 14 of the 20-way connector (beneath the steering column shroud, connecting to the light switch) then the vehicle is not pre-wired. While checking out the driving lights cavities on the lower fascia, I found a wiring harness and plugs at each opening however have been unable to determine where the wiring leads and how to tap into it. Unfortunately the installation instructions do not address this situation. Does anyone else know where the existing wiring harness originates, or how to tap into this harness? I really do not want an extra harness and plugs dangling down behind the front fascia. My dealership is clueless (at least over the phone) and want to charge an arm & leg to look at the wiring (everything is "for a fee"). Thanks.
  • Suggest you try one of the PT club forums for more information. PTOC, PTE, and PTCC have a lot DIYers.

    The service manual only shows a LB wire running from the fog lights to the switch (the front fog lights are operated by pulling out on the end of the light switch on models that come with front fog lights.

    There is a large wire bundle visible next to the right front high beam headlight and that may contain the wire to the fog lights. I can see a LB wire in the bundle on my PT.
  • ggriffith1ggriffith1 Posts: 1
    Hi my name is gary. my sister is thinking of buying a PT Cruiser base model . Has anyone had any problems driving in the winter? She is looking at buying a automatic .
  • crkeehncrkeehn Posts: 513
    The PT Cruiser is a very good snow driving car. My wife has the automatic and had no difficulty this past winter, with all the snow we had in the Mid-Atlantic region. I had no difficulty with my 5 speed, neither car has traction control. I understand that the cars with traction control did even better.
  • saxamesaxame Posts: 2
    I have 2003 pt cruiser for about 3 months and I have brought it into the dealer to fix oil leaks for the 2nd times already. Wondering if any other pt cruisers owners out there have the similar problem?
  • fndlyfmrflyrfndlyfmrflyr Posts: 668
    Where are your oil leaks (engine, transmission, steering)?

    None on mine so far.
  • saxamesaxame Posts: 2
    the leaks are from engine area. first time was the gasket and the 2nd time is from the top of the engine
«13456713
This discussion has been closed.