Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Suzuki Aerio Maintenance and Repair

189111314

Comments

  • dkarasindkarasin Posts: 10
    My latest problem: The cooling fan.

    The fan blade broke at the mounting. Of course it did not break clean, so the fan rubbed on the radiator and caused a leak. I heard the noise but could not find the source until it was too late. The car has 74k mile on it. I have never seen this before have others heard of this happening. It looks like the only place to get the fan blade is at the dealer for $56 plus $180 for the radiator online.
  • dkarasindkarasin Posts: 10
    Did you ever get this problem fixed? I seem to have the same thing going on with my 2003 Aerio SX AWD. My car does keep some of the historic codes in the list after the check engin light goes out. Mine always has P0717 in the list. Turbine speed problem.
  • dkarasindkarasin Posts: 10
    I got a second set of rims and winter tires from Tire Rack. They are 14" they are better in the snow and less costly. I still run the 15" in the summer.
  • dog8dog8 Posts: 4
    There is a recall right now on some 2002 - 2003 Suzuki Aerio car for windshield faults - look into it.
  • dog8dog8 Posts: 4
    Do not go to the dealer the light goes out on it's own. Meanwhile you will not know if you have a engine fault when it happens but oh well. My car has 100050km when it died.
    Watch out for the crankshaft sensor that fails without warning. Driving along the road starting to apply the gas and then no power. the oil light comes on. The car will not restart. IT took the mechanic 7 plus hours to figure out what the problem was. 10 plus hours to do the whole job at $85.00 an hour. $750.00 for the part. Watch out Trade it in on domestic car. I am.
  • dog8dog8 Posts: 4
    I am with you on that one I have a 2003 Aerio SX that is falling apart at 100000km. I am in Canada. Car dies crankshaft sensor fails 8 plus hours to find problem by the dealer shop. $2000.00 dollar bill. Suckzuki all right. If you own the car get a savings account opened.
  • It is crazy suzuki will not allow the dealer to make camber or caster adjustments in the rear for some stupid reason. I realy don't understand why every other company allows it.
  • logmgrlogmgr Posts: 39
    I too have an 06 Aerio SX. Mine is automatic and AWD.

    What you hear is the clutch on the A/C compressor kicking in.

    It is normal.
    No cause for alarm.

    Hope this eases your mind.
  • logmgrlogmgr Posts: 39
    YES those Yokohama tires are absolute crap. !!!!!!
  • I am the owner of a 2003 Aerio S.. I am aware it is nothing special and seems most people are hating them, while I love my car for the fact Susie Q was my first!! Not only do I want to keep my first car but it is hard for a single mom to go buy a new one!! So here is my problem: lately before my car has completely warmed up, she has a problem with switching gears. My rpm's are just about red line when the car shifts down. A couple days ago I let her warm up for a few put it in reverse and its like nothing!! For the most part all I did was roll, the gas pedal didnt mean shite!! I put the car in Drive to at least park her again and still gas pedal seems pointless... Now I know my trans. fluid is burnt and has been for a while but no I was lazy! anyways.. I pray to god I do not have to rebuild or replace my transmission! If anybody knows what is going on with my car PLEASE reply and fill me in!! (car info) 03 base model w/close to 126k miles, air filter replaced w/ K&N short ram intake, keep the oil changed & the only problem I have ever had is the clock light doesn't work but I dont care. As far as I can see the belts look fine, there is a ticking for a short period after I turn it on, and I could top it off with a little anti freeze. The thought of a fuel pump problem of some sort crossed my mind but I dont know. I hope that info helped at least a little bit PLEASE somebody help me here ! ! ! thanks~ Lady Cash
  • logmgrlogmgr Posts: 39
    Get the trans fluid changed NOW !!!!!
    Make sure they use the suction machine otherwise the fluid in the torque converter will not be changed.
    Should cost around 100 dollars.
    RIGHT NOW add fluid if it is low but DO get it changed now.
    If you continue to drive it like it is you WILL be replacing the tranny.
    How did you get the fluid burnt ? Did it overheat ? Or is the fluid just old ?
    I have been a fleet manager for many years and hate to be the bearer of bad news,but you really need to get that transmission flud changed now.
  • logmgrlogmgr Posts: 39
    I agree ...have the charging system checked.
  • It seems really unlikely that you will escape a rebuild of your tranny if you have let things go this far. New fluid may temporarily help the problem, but a tranny slipping that badly is internally varnished and is likely to have burnt more than just the fluid.
  • To davidd5, I'm very interested in your problem, in that my 2003 Suzuki Aerio SX, which has only a little over a 100,000 miles on it suddenly, is having the Check Engine Light come on. I am being told I need a new Catalytic Converter that isn't available on a rebuilt ( because that aren't being built ) The cost from the dealer is about a thousand dollars. How am I related to your issue? It has been really cold here lately in our little patch of California, weeks and weeks, AND we are in a low area. I know that in the morning when we leave it's already warmed to 38,42 or 45 degrees. I got the oil changed recently, and [okay I admit it...no major engine services since 30,000 miles - oops! ] the mechanic changed spark plugs, air filter, transmission drain and refill... at that time, he reset the "Check Engine Light" and ...here we are. We agreed to the code reset in my car since the mechanic wasn't sure what was causing the light the come on in light of the amount of time since my last major maintenance. The next day I used the car for a series of short "hops" around town and during the 5th drive the light came back on. NOW, I'm sensitized as to whether the car really has "an issue" ( Catalytic converter, or what else could make that "Check Engine Light" come on...?? I have noticed the herky jerky sensation several times, and was wondering if it was a bad load of gas?? I called and asked the mechanic, there ISN'T any fuel filter to change out. It and the fuel pump are together. Hmmm. Thousand dollar part, $180 part or ??? If anybody wants to give me their two cents, I'm open. Oh yeah, my light for the thermometer / clock has been going out, again starting with cold whether too...since back at 30,000 miles at least. I read on a Suzuki sight it's this wire that is loose, but I'm not feeling warm about trying to tear apart the dashboard. I have an after market carbon fiber dash kit installed and it looks a little 'pried at' right now; I don't want it to look worse.
  • Lady Cash,
    Long ago, I had a major service, in which my transmission fluid was to have been at least checked. Three weeks later, my car, an automatic was popping out of gear - and kept going it. I call the service guy and he tells me to check the transmission fluid. It is OFF THE STICK, it is SO low! I'm freaked, but report my finding by telephone message. No answer. I call the dealer main line and leave a message. No call back. I leave another frantic message on my Service Guy's voice mail. In three weeks, never a call back. As it turned out, I put in like 2 1/2 bottles of fluid to bring the level back up, AND...the car as been fine, that way, ever since. Maybe you have something basic like that wrong? Also, now that it's been so cold lately, like down in the 30's or 40's at night, at least, the car takes a LOT longer to warm up. AND, during that warming period my car revs a LOT higher during that time period. This is an automatic, mind you, but it sometimes seems like it NOT going to automatically shift up, ...and then, it finally does. I garage outside.
  • logmgrlogmgr Posts: 39
    There are LOTS of things that make the check engine light come on.
    Do you know that a bad O2 sensor...there are 2 of them...one at the inlet and one at the outlet of the converter....will give the same code as catalitic converter ?
    Here is a rule I use....disconnect the battery for 30 seconds...reconnect..if the light is out do not worry about it....if it immediately comes back on then you have a "hard" fault. I drove a Toyota Corolla for over 100,000 miles while the light was on and the computer was giving a code of catalitic converter.
    Now the light could be on for ANY reason....bad cam position sensor, bad fuel injecter, etc etc etc....BUT...if you have not changed plugs since 30K that may be the nature of the problem as an incomplete fuel burn will make the O2 sensor trip the check engine light on....and if that tranny fluid has been in there since 30 K change that as well.
    IF you need a catalitic converter trust me they are available aftermarket for WAY WAY less than the price quoted you...check the local muffler shops...look online...you will find one.
    Also JCWHITNEY.COM sells a cleaner that you put in the fuel that will "clean up" the converter....it is under $20....I have never used it but I can see where it would work.
    Hope this helps.
  • bindybindy Posts: 1
    Everybody who owns an Aerio knows that tires going bald every couple of months, brake problems and violent shaking come included in the cost of the car. I have read a lot of posts of people who would like to start a class action , I have contacted and researched lawyers who do this and he needs only 3 people with the same problem to contact him. His name is Chris Kantrel with Belt Law Firm , he can be contacted at 1-888-933-1514. Hope this helps!
  • bindy,

    This is bogus. My daughter and I both have Aerios, and neither of us have had any of the above problems. As far as I know, the tire wear problems are largely limited to the 4wd models, and not all of those by any means. There is a known solution that involves putting alignment tabs on the rear suspension so that full alignment can be done. Just because you find 10 or 20 people on a complaint forum does not mean that you have a class action suit just waiting to happen. In many states, you have access to a lemon law suit, so that will handle many of the problems. I promise you, no lawyer worth looking at is going to start a class action for $400-500 worth of tires times three unless all three of those people have suffered severe injuries or a death in the family due to blown tires. Even there, it is really going to be tough to sell, because it takes an idiot to run on bald tires.

    Now, there is a well known problem on the Aerio with standard transmissions popping out of gear, especially 5th gear. If you ask them nicely, they will fix it, because they know it exists, so it is hard to get anything going there. If you try to proceed with less than a few hundred persons, your lawyer is going to want to charge you, and the cost can be high. If you've got that kind of money, you probably wouldn't be buying a Suzuki to start with, so I suspect that you are blowing steam here.
  • Geeze - I just read your rant and wish that people such as yourself would limit yourself to topics that truly concern you. The problem IS with the AWD Aerios, and you don't own one, so why are you even here? So, YOUR reply is not only moot, it is also BOGUS.
    Your inference that only an idiot would drive on bald tires is interesting as you fail to mention that the rear tire tread CANNOT be seen unless one gets under the car due to the configuration of the rear fenders/bumper which totally block any view of the tread! (are you SURE you own an Aerio or are you connected to Suzuki somehow which makes more sense) The only way to see the tread is to either have the neck of a giraffe, or to lie on the ground! And, there is a serious problem with this model. Suzuki even has a "fix" for this, but whether one gets the fix is left up to the individual dealerships. Interesting to note: out of 15 dealers I called in the USA, only a few (all in the North - none in the South) were aware of a problem and out of those, none agreed on the solution! In our case, it took several months of calling Suzuki's national number. They will do nothing unless you are tenacious - in our case they finally reimbursed us for the tires, and only after constant weekly calling! However, even after that, we are still left with no "fix" as our car's VIN isn't listed on their "known problem" list. Our back tires went completey bald - evenly with no pattern - after 4 months. The car was taken for routine new car maintenance & Suzuki obviously didn't check the tread or surely they would have seen this developing? The reason is obvious: They didn't check the tread as the car was brand new, just months old, & with low miles! It's also hard to get the " fix" when the dealer insists there is no problem, making matters worse as Suzuki uses the dealer's input whether there is a problem with a car. Interesting. So, Suzuki knows of the problem, has a fix, and yet the dealer decides whether any car gets the "fix"?! I think not! In our case, we had to go to a different dealer than the one who sold us the car, as we moved two days after we bought it, from CT to Tallahassee first, then Miami - all within 4 months. It's likely that FL dealers hadn't seen an AWD before ours, and so therefore lacked the knowledge of any problems or the "fix". The Miami dealer tried to blame the baldness on lack of tire rotation by us! However, the car, under new warranty, was serviced at a dealer in Tallahassee where we were for a few months, before going down to Miami. So this made matters worse & we got caught in the middle. The regional Suzuki rep got involved but he also deferred to the dealer in Miami who kept insisting that the problem was lack of tire rotation! Of course, the Tallahassee dealer admitted no wrong. So much for that. This was a classic "blow-off". And that's when I began to call around & found that only dealers in the northern USA knew of, or were informed of, a rear tire balding problem & the "fix" for it. Obviously, if only rear tires on an AWD car are balding, you have a big problem. So, if someone has found an attorney willing to try to help us, how dare you, without owning this particular car, swipe at us. We are trying to prevent injury here. I also got a similar trash talk reply when I first aired my frustration about this problem last year. Always blaming it on the owners! You really need to zip it as you only cause further frustration to those of us who are living through this!
  • logmgrlogmgr Posts: 39
    Now,now,poo,poo.
    I OWN a 06 Aerio SX, and yes it is the AWD model.
    I have owned it 19 months, it has almost 11,000 miles on it.
    I recently checked my FRONT brakes and they were still around 75%.
    My tires... I rotated them at 4500 and again at 10,000 miles....they still have 7/32
    tread depth remaining; so a usable life of 5/32; which in my case amounts to another 25,000 miles...sooo a set of Yokohama tires which are CRAP will last 35,000 miles....poor but not unacceptable. BUY AMERICAN TIRES !
    As a side note I also have a 06 Cobalt...I put Bridgestone Fuzion tires on it, these tires have a treadware warranty of 40,000 miles...I took them off at 92,000 miles of use and still had 3/32 tread depth, hence I could easily have gotten 100,000 miles out of them. The point being that driving habits, proper inflation which I check weekly, and proper rotation which I do every 2nd oil change or 7,000 miles has a lot to do with tire life.
    On this same car I got over 170,000 miles out of the front brake pads. Like I said...driving habits.
    I want to point out that the wheel torque for the Aerio is NOT 100 ft. pounds like most cars....the specs are 62 ft. lbs in the owners manual...I torque mine at 65 ft. lbs.
    On checking tread depth....if one is so infirm that they cannot bend over or down to check the rear tires maybe they are also so physically restricted that they should not even be driving....not to mention that all they would have to do was ask when the vehicle was serviced to have the tread depth reported to them....that is if they even service the vehicle properly.
    About a class action.... I suspect the attorney mentioned here wants another 3 people involved before he commences litigation....hmmm....could it be that he wants a total of 4 people to share in the cost of the action which I guarantee you will be expensive ? I would also question what he claims the chances of actually
    being successful in the proposed action are.
  • lynnster2,

    So, it's a rant if it disagrees with you. I'm not sure where you have been hiding all your life, but I haven't yet met a dealer that volunteered to fix anything that wasn't on a mandatory recall. There need to be stronger lemon laws and independent arbitration panels, but the dealers have a couple of dozen lobbyists at the state level and many more at the federal level, so I don't expect to see legislation tomorrow, if ever. In the mean time, if you are persistent and keep good records, you can usually get things fixed, aggravating though it may be.

    Now, as to your lovely contentions that I work for Suzuki. Drop dead. I'm a computer consultant who has been in the field for 42 years, but I do know how to take care of my cars. For seven years of my life, I lived at over 9,000 ft. west of Denver, CO, so I know a little bit about bad weather and 4WD and AWD vehicles. I also was a member of the volunteer fire department, and you'd be amazed at how many idiots there were who thought that having power to 4 wheels entitled them to drive faster. Two and four wheel drives stop at the same speed. The 2003 Aerio SX that I have is visually almost indistinguishable from the AWD model, though there is a subtle difference in wheel base. Otherwise, they are almost identical. I can check the tires on one by just stooping down and using a penny, or as logmar suggests, get a dealer or tire place to check it for free, just by specifically asking. Your problem is that you are one of those lazy idiots who expects the car to take care of itself. And, you apparently raised a daughter who has the same attitude...surprise, or do I have the wrong complainer here.

    Also, this area of the forum is for anyone who has Aerio wagons. The minority of those are AWD, or were until recently, when they started offering only AWD models, at least in the Aerio. Unless you haven't noticed, most people who buy AWD or 4WD vehicles don't buy them for snow or ice or mud or whatever, they buy them because they want them, and they put a little more power to the ground. Of course they suck up a little more power, cause more wear and tear, use more gas, and generally are useless except in rather extreme conditions, but people still buy them. The San Antonio dealers have had plenty of the AWD models, so I can't imagine what you are talking about on your Florida dealers.

    And lastly, unless you are a lawyer with expertise in the particular area, you should leave it up to the lawyers to advertise their class action suits, if any. If there is actually such a suit in motion, there is no problem in advertising it, but acting as free advertising for what almost has to be an ambulance chaser doesn't make you look like anything other than the joke that you have already shown yourself to be. It is clear that you have a complaint, but it is also clear that you have been so negligent that no court in the land is likely to help you recover. You might want to follow your own advice about "zipping" it.
  • logmgrlogmgr Posts: 39
    Good post !
  • Thanks for the information. Okay, I'm kind of shocked at this, but I ended up trying what this mechanic had recommended trying ( without any guarantees of it working, but what did I have to lose? ): In a full tank of gas, add 1 QUART of Denatured Alcohol, drive the tank away until you finish it, see what happens. At the end of the tank, the light was still on, BUT about a third a way into the next tank, "poof" the light has gone out! If it comes back on, I will try the unplugging the battery cable thing. At this point, I don't know WHAT to think. Usually I fill up at the 76 station, or Chevron - I have a gas card and this helps track fuel cost, but these past two tanks I have gotten gas at the local Valero ( Exxon in other words ). I consider it the "cheapy" gas station. I'm hypothesizing the gas at 76 is too "rich' and the Aerio too sensitive, especially with all this cold weather we have been having. If the Catalytic Converter was supposed to last the life of the car and previous to this I ran a Nissan Sentra S-E-R 250,000 miles on ONE Catalytic Converter, I don't think I could be THAT abusive. I'm convering a LOT of highway miles. Anyhow, thanks again! Will keep you posted. :blush:
  • pychogirlfrien,

    Alcohol is usually used to pull water out of the tank, but it also raises the burn temperature, possibly pulling contaminants out of the converter or burning off excess hydrocarbons plugging the matrix, but I am unsure of that. In any case, when you pull the battery cable on most modern cars to include the Suzuki, it may or may not clear the codes in the engine computer, but it usually triggers a separate code caused by that removal. It also causes most cars to go back to a default tuning, which may be a bit sluggish for a certain number of miles. The engine light can stay on for a tank or two of gas, depending on circumstances. So, the old, "if the light comes back immediately, it is a hard fault" ain't necessarily so. Now, if you have a reader, that's another thing entirely. There used to be a simple trick to cause the lights to flash out a 2 or 3 digit code, but that doesn't seem to work any more.

    Also, since you are covering lots of highway miles, you are putting very little load on your converter, because it is damaged most at start up and under acceleration, when the exhaust is likely to be fuel rich. The EPA only requires that converters last 100,000 miles if I remember correctly, so they are not guaranteed for the life of the car. If you keep the engine running reasonable cleanly and do not consistently run it for under 5 miles on cold mornings, the converter should last the life of the car.
  • logmgrlogmgr Posts: 39
    The alcohol simply cleaned up the fuel system and the converter.
    It made for higher operating temps as the previous post says which in turn rid the converter of deposits.
    More than likely it was the "cheapie" gas that made the problem arise on an already older converter.
    I drive 175,000 miles a year and I only run Chevron in my Suzuki, and either BP or Shell in my Chevy. I had two Toyotas I ran for 400,000 miles almost exclusively on BP fuel.
    Keep in mind that now most of the fuel contains10 % ethenol, I consider this a bad thing. I add a fuel cleaner once a month.
    Good luck to you and keep us posted.
  • Just got a 2003 aerio w/ 56K miles, but no owner's manual...would someone help, please: need to know the grade/type/specs of the oil recommended for this engine (2.0).
    Had the car 3-4 days now, not many issues to report except that the owner before me put 2005/60/15 tires on it (really louse and noisy ones at that) and they drive me crazy, will be changing them ASAP
    thanks
    brianm6
  • Should have proofed the last post: forgot to ask about the tranny (5-sp) oil also
    Thanks
    brianm6
  • logmgrlogmgr Posts: 39
    My 06 Aerio uses either 5-30 or 10-30. (either is fine according to owners manual)
    SM grade oil.

    I have an AWD so I am not sure on the transmission, but the Suzuki website says
    for an 08 with a 2.0 engine to use SAE 75W90 for a manual transaxel.

    Here is the # for Suzuki 1-800-934-0934 (Customer assistance center)

    Hope this helps.
  • Thank you for the info, will get this done ASAP
  • We encourage debate, disagreement, etc but remember to avoid name calling, derogatory comments and the such. Those posts will be deleted.

    Thanks.
Sign In or Register to comment.