Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mazda6 Maintenance and Repair

19394969899141

Comments

  • mz6greyghostmz6greyghost Posts: 1,230
    Bought my '04 Steel Gray 6S manual sedan new...

    One year and 16K miles later...

    Still grinning from ear to ear...
  • slennonslennon Posts: 2
    Bought a new 6 in october of 2004. I noticed the horrible smell immediately, my husband said it was a under coating and would burn off. 10 months and 9500 miles later it still smells. I was told to change gas. That didn't work. Now my head lights work when they want to. This is the second time in the shop since June. If they can't make the problem re occur they won't do anything. I am getting mad. Anyone else out there with these issues?
  • slennonslennon Posts: 2
    I had a similar problem. It seemed as if it slipped out of gear if I let off the gas and then didn't completely stop. The dealer re programmed my transmission. It helped, but it still does it sometimes, not as violent though.
  • mz6greyghostmz6greyghost Posts: 1,230
    Bought a new 6 in october of 2004. I noticed the horrible smell immediately, my husband said it was a under coating and would burn off. 10 months and 9500 miles later it still smells...

    Sounds like a problem with the catalytic converter. I've never had this problem myself, but from what I've heard and seen from other 6 owners, you could have a bad cat.

    Now my head lights work when they want to. This is the second time in the shop since June. If they can't make the problem re occur they won't do anything. I am getting mad

    Make sure the dealer checks the electrical connections thoroughly, and there's no short circuit anywhere in the fuse panels or the switch.

    Always remember that you can bring the car to a different dealer to have it worked on. Unfortunately, some car dealers aren't the best in service/repair, and some dealers will often see things that other don't. Happens with all makes, not just Mazda...

    Good luck. Let us know how things turn out. :)
  • pats1pats1 Posts: 36
    Which AT do you have? Tech services is working on complaints about the 6 speed autos (I have one) with jerking and overloading in the 1500-2000 RPM range, all gears.
  • i have a 2004 and the seats are a beige/tan color supposingly with this scotchgard type sealant for spills, hah, if anything it is the worse sealant i have ever seen. spills do not just wipe off and i tried just the damp cloth which are the instructions, the stains just get bigger, and mazda doesnt sell a cleaning agent to take care of this. i now have beige front and back seats that look like 10 yrs old. it is just ridiculous. and YES I HAVE FUZZIES THAT ARE EVERYWHERE. i have to constantly trim the frays and i figure by 2007 i wont have any cloth left.
  • ericzoomericzoom Posts: 213
    I thought the 5spd ATX was bad. Now i see similar problems trickling down to the supposeibly indestructible 6 spds.
  • Recieved the key fobs from the dude on Ebay on friday and within 15 minutes ahd three fobs (2 new 1 old) programmed.
    Thanks for the idea.
  • I have one with 7 k on it and I noticed it doing that as well - but not to the point where it is to the foam, yet, over the long term, I am worried about the durability.
  • My Information LCD screen on my m6 got all glitchy over the last couple weeks. Like when i change my volume there is a blank in the middle of all the numbers. Also when it is showing how far i am into a song on a cd there zeros look like a backwards C. Did this happen to anyone else and will the dealer fix this under warranty?
  • Did this happen to anyone else and will the dealer fix this under warranty?

    Hasn't happened to me, but I've heard about it.

    Chances are it's a faulty LCD board. They should be under warranty, although the dealer may have to order one. It MIGHT be a loose connection between the radio and the LCD, but the symptoms shy me away from that conclusion...
  • I have taken my 04 Mazda6S to the Dealer for the same problem (5 times); Brake moaning at low speeding, when approaching stop lights or parking spaces. A TSB was issued for this problem, but it continued to come back after each fix. I was then told that's how it is. Well, I had my car serviced in July 05 (oil change), and I mentioned that my brake pedal squeaks when I press on it. They checked it, and fixed it. I noticed the difference, but within days it was back again. Well, yesterday I took it back again because the brake pedal just did not feel right. The Service Department called and said that my Front Brake Pads were below 20% and needed to be replaced ($219.00 plus tax). I raised H ! L L, I have never replaced my Front brake so soon pads on a vehicle. I requested Mazda's number from the Service Department, because I was not a happy camper. To make a long story short, I explained my situation to the Mazda Rep; she called the dealer and told them that they will pay for the Front Brake Pads to be replaced. :D

    SO........... If you hear your brakes moaning at low speed, take it to your dealer. Make sure you have a paper trail so that if this situation should arise, you will be covered. :)
  • aviboy97aviboy97 Posts: 3,159
    I have had a Mazda6 i for a few months now, I have 4,000 miles on it, and I have no problems what so ever to report. I have been reading some complaints about CEL's and a stinky smell. I had the smell for about a week, then it went away. I also work at Mazda dealership. If anyone has any quesitons, I have to sources to get you good answers. Our service dept. is one of the best around. :D
  • Mazda 6 2005 clinging noise occurs at 60 + mph. Can't locate issue and dealer can't locate noise because they do not go on highway when they test drive it. Noise does not occur at lower speeds and there doesn't seem to be any negative impact to the running of the car.
    Suggestions?
  • I own a 2003 Mazda6-i with 34000 miles on it. Last saturday the battery warning light came on. Took it to the dealer. They said it had a bad alternator. How does an alternator go bad at 34k miles? There was no indication that it was going bad. The car acted normally up until then, and even when the light came on. Has anyone else here developed a bad alternator with your cars? Is there some svc. bulletin I missed?
  • ct6sct6s Posts: 3
    I've had 3 repairs (all different) in my first 6k miles. First was a fuel sensor, can't remember the second off-hand, third was a bad throttle body. Anyone else having so many issues in such a short time? I'm thinking of going back to the dealer and demanding a free extended warranty. I can't stand being without a car all the time.
  • autonomousautonomous Posts: 1,769
    2003 Mazda6-i with 34000 miles ... had a bad alternator. How does an alternator go bad at 34k miles?

    So did the dealer replace the alternator?
  • ycoxycox Posts: 2
    got mazda 6 . have a tinny sound when pressing down on accellerator. took it into dealers they have heard noise but are unable to locate it. could this noise be the thrust baring as my husband has suggested. i only have another 500 miles left on warranty. don't want somthing costly going wrong...
  • mazda6smazda6s Posts: 1,901
    ycox - You should keep your service records. To be covered by warranty the problem must be shown to exist before the warranty expired.
  • autonomousautonomous Posts: 1,769
    "thrust baring" What's that?
    tinny sound Do you mean tiny sound or sounds like tin?
    :sick:
Sign In or Register to comment.