Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mazda6 Maintenance and Repair

1959698100101141

Comments

  • mz6greyghostmz6greyghost Posts: 1,230
    Sounds like you need to take it to the dealer. Have them check it out, it sounds like it needs a TCM reflash, which is basically updating the computer software.

    It's not an uncommon problem with the automatics.
  • Yea I already brought it to mazda for the updated flash....they said it was fine I pulled out of the dealership and it was doing the same thing i brought it in for..i havent had time to bring it back yet....maybe the trans mount?? I dunno its a pain im just tryin to find out what the problem is before i have to go back to the dealer and deal with them...
  • smooshsmoosh Posts: 2
    I am having the exact same problem! I was in traffic and almost rear ended someone. It doesn't happen if my foot is pushing on the brake, just when I am coasting....it will surge forward. I brought it in 2 weeks ago and they said there was a recall and they had cleared it up, something with the computer. Problem is that it is still doing it and now it is even worse! It also seems to get stuck between gears or something. When I am in traffic it will act like it is in neutral, when I try to go it will rev up extremely high and not go anywhere.
    I have an appointment for Wednesday.
    What is the lemon law?
  • mazda6smazda6s Posts: 1,901
    Just make sure you keep taking it in for the problem and get it documented (keep your service records). Here's some info on state lemon laws:
    http://www.autosafety.org/lemonlaws.php
  • I have a 2004 mazda6 and mine is doing the same thing. I took it to Mazda and of course it wasnt doing it when i took the tech for a ride to try to explain and show him what was going on. They told me that they cant look into what it is if they cant see what its doing. They told me to bring it in the next time it does it (which has been a lot) but its always on my way to work and from work, when of course the service dept. isnt open. Please let me know if you find a solution.
  • My mazda 6 is doing the same thing. . .is this ecm covered by my warranty? If not, how much does it cost?
  • mz6greyghostmz6greyghost Posts: 1,230
    All ECM/TCM reflashes are covered by warranty.
  • not really sure if this was answered already b/c it seems i have a similiar problem like other mazda 6S vehicles but mine is automatic...not manual....problem is:

    2005 Mazda 6S Automatic 6spd auto
    I was on the parkway today and its raining and i guess cold...about 45 degrees and traffic was very slow but moving and i have my gas pedal touches oh so lightly but going slower sometimes then have to hit gas pedal a lil and so forth....ive noticed a kick back when going into 3rd from 2nd...and i was going like 10mph....which to me is weird but whatever...and it kept going from 2nd to 3rd but going very slow mph but im in bumper to bumper traffic....then all of a sudden i try to go and my car stalled...no shaking, no beeping noises...i didnt even know it stalled it was so quiet...so put it into neutral real quick and started up at the drop of a dime but now some my TCS light and *losing traction* light was on(picture of car fish tailing sort of) was permantly on but...i had traction and couldnt shut them off....i pulled over...shut everything off, heat, radio, lights....and restarted the car....and it everything was back to normal....i noticed again, later in more traffic, it was going to do it again...so this time i thru into the manual shifting and just left it in 3rd gear and shifted myself until traffic was normal....does anyone have any idea of what happened? i really dont believe its my driving b/c i was in traffic...but i just bought the car in February and to my knowledge...this car should not be stalling and to me, it seems its a tranny problem but its automatic..i have no clutch...please, any response or feedback would help...thank you very much
  • funvtrfunvtr Posts: 3
    My mom returned her car to the dealer -- they paid the balance of her loan and gave her money towards her new car. Look under your state government website for the lemon law.
  • autonomousautonomous Posts: 1,769
    my TCS light and *losing traction* light was on(picture of car fish tailing sort of) was permantly on

    Judging by the TCS (traction control system) light I wonder if a sensor is acting up? Your mention of rain seems to be very important also as that may be causing wheel slip. What has your dealer said?

    Here's an explanation of TCS from Bosch:

    "In order to maintain directional stability and prevent the vehicle breaking away, the wheels should neither lock up during braking, nor should they spin when driving off.
    Bosch TCS prevents the wheels from spinning. It ensures good traction, stability and steerability when driving off or accelerating. Each wheel is continuously monitored by wheel-speed sensors. TCS evaluates the wheel-speed sensor signals and immediately recognises when a wheel is about to start slipping. In this case TCS is activated and regulates the drive torques of the driven wheels. This electronic wheel-slip control selectively brakes individual wheels and intervenes in the engine management."
  • in addition to this, your correct, maybe there is a short somewhere as well that set off the sensors....but the point of my thread is my car stalled....im not to worried about about the TCS b/c i knew i had traction and my handling of the car was fine....but the thing of the gears and the kickback....and then i stalled...i mean the car is only 7 months old...my car should not be stalling i dont care in what condition, ya know? ive been at work all day i havent called my dealer yet...im actually going to call before i leave work around 5pm EST....see what they say...ive been busy all day and really couldnt call

    ok just got off the phone with the dealer service dept. explained to him of what happened and his lovely answer was "we dont know we have to see it first".........dont you just love dealerships? so i made an appointment for next week for when im on vacation...and they have to "look at it"
  • smooshsmoosh Posts: 2
    Big shock, the dealer has had it for 2 days and they have no idea what is wrong with it. They can't replicate the problem and basically said it was driver error.

    So ridiculous.

    Please post again if any of you find a solution.

    Thanks!
  • Did you ever get an answer to the "crumpling" noise question? This is now happening on my M6 Wagon, and driving me nuts. Two different dealer service departments have said this is "normal!" Thanks for any info.
  • my cd player skips at the slightest bump.. does anyone else do this?
    also, i have a pebble colored exterior...it seems like the front fender and rear bumper color is a little off from the body of the car....is this because they are fiberglass and the body is metal? lastly, my beige interior has many water spots from raindrops that enter when i am getting in. the water dries to leave unsightly spots......any help would be appreciated!
  • it's an in dash one-disc changer....it really annoys me
  • For the CD player, I suggest you find a CD/DVD cleaner disk. Clean the player a couple of times, and it may help. If not, take it to the dealer. It is a warranty item.

    The different shades of paint are because of the material of the part underneath. Unfortunately, there's not much you can do about that...
  • I'm having A/C problems. The 3 vents near the drivers side are blowing cold air and the 2 near the passenger side are blowing warm air. I took my car to Mazda and they said that is normal. I've had the car since 2003 and this just stating happening a month ago. The car doesn't cool down with the 2 vents blowing warm air. I was amazed when the dealer said this was OK. What could be the problem?
  • Wow. My 2005 6i is just the opposite. The 2 left vents blow warmer air than the other 3. I am going to report it when i go in for my first oil change.

    I'm having A/C problems. The 3 vents near the drivers side are blowing cold air and the 2 near the passenger side are blowing warm air. I took my car to Mazda and they said that is normal. I've had the car since 2003 and this just stating happening a month ago. The car doesn't cool down with the 2 vents blowing warm air. I was amazed when the dealer said this was OK. What could be the problem?
  • I have a 2004 6 Manumatic. It has approximately 22k and I am bringing it in for the 3rd time to have the pads and rotors replaced!!!!! The rotors continue to warp. They tell me Mazda just is not putting good brakes on the car. Do I have any recourse????? I have learned to live with the annoying squeaks and rattles!!!!!
  • I have taken my car in three times now with only 9000 miles. The first time was for faulty brake pads, rotors, and calipers. The second time was because the rear window was not sealed properly and a glare was building up inside the window. I just took my car in now for a faulty transmission, and when I got it back the problem seems to be worse. I just hope that Mazda will finally get its stuff together and deal with these problems, since a lot of these seem to be an issue for many MZ6 owners.
Sign In or Register to comment.