Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevy TrailBlazer Transmission Problems

11820222324

Comments

  • dws2kdws2k Posts: 12
    How do we go about filing a class action suit against GM? My transmission is bad also. I don't have that kind of extra cash for a tranny rebuild.
  • burdawgburdawg Posts: 1,524
    Good luck. Most class action suits never get anywhere or take years to wind through the courts, only to see very little gain for any of the plaintiffs. How many miles do you have? What's the problem, broken gear cluster (star shell) like many people?
  • My 04 chevy tb has had the air compressor pump replaced thinking this was the problem but it didn't solve it. Sometimes it gets hung up on 2000 rpms in all gears and doesn't accelerate i can push the gas more and sometimes it will shift and go to a higher rpm. does anyone know what could be causing it?
  • KUQUEKUQUE Posts: 8
    sounds like you're having the same problem most of us have had. It's not the trans, it's the fan clutch. see posts 395, 399 and 400.
  • I am having my fan clutch replaced this tuesday will let you know if it works better :shades:
  • It is 2 day after the fan clutch was put in and the trucks runs great thank you for the help KUQUE the part i purchased from autozone cost me 216.50 but it came with limited life warranty and had a machanic put it in for 25.00 I hope that is all it needs so thanks again KUQUE :shades:
  • replace the fan clutch i did on mine and it works better now read my post on that same problem trail03 I also had that problem
  • My 03 Trailblazer has 201k on it with no problems. Tranny had first flush at 164k. Recently it started acting a little funny in overdrive. At cruising speed (50mph and up) it acts like it is searching for a gear. It doesn't actually drop down to third but at 60mph for example, it bounces between about 1600rpm and 1900 rpm about every 5 - 10 seconds. Ever heard of this? Any suggestions? I'll be going about 3k miles over Thanksgiving towing a trailer and want to prevent any problems. Thanks in advance!!
  • burdawgburdawg Posts: 1,524
    It could be the torque converter locking and unlocking. With that many miles the pump in the transmission is probably worn and the internal fluid pressure may be low. You may want to have it checked. When it was flushed was the filter changed?
  • I did have the filter changed at the time it was flushed. Can a tranny shop diagnose this with any confidence? I really don't think the tranny is slipping. It shifts firm in all gears. I don't want them to tell me it needs a rebuild if it really doesn't. What kind of repair bill can I expect?
  • KUQUEKUQUE Posts: 8
    happy to hear that your truck is running great now. wish I had me to guide me when I first encountered problem...lol. I replaced mine over 3 yrs ago, and it's still running great. t/c :shades: :shades:
  • KUQUEKUQUE Posts: 8
    you can take it to any mechanic with a diagnostic computer and it will give them a code. take that code and call dealership and ask what that code means. if it refers to fan clutch, you don't need trans rebuilt. most diagnostics cost about 30-50 bucks. good luck.
  • Well I had it hooked up to the computer and there were no codes, so I didn't figure it was the fan clutch, but I ordered one and put it in anyway. It really wasn't too bad to change. Unfortunately, but not surprisingly, it didn't change anything. I guess I'll have to take it to a tranny shop. I'm running out of time here before I take it on vacation. I like to put a few miles on a vehicle locally, before I take it on a trip to make sure everything is functioning properly. Do you think if the tranny needs repair, I can be confident that it will work properly and not leave me stranded? The shop I plan on taking it too seems pretty reputable.
  • dws2kdws2k Posts: 12
    I will take my truck to the trans shop and get the flush. I hope that works. They need to have a recall on these trans, if there are so many people having problems.
  • timb2timb2 Posts: 1
    I have an 02 Trailblazer with 160k miles. For the past year when I step on the gas from park or being stopped it goes well up til 25 to 30 mph, then it does not seem to shift into second gear until the rpms get up to about 3500 to 4000, The past month it has not wanted to shift at all into 2nd gear
    My mechanic said there are shifting solenoids that may be bad The tranny shop said 1800 dollars and I will rebuild it
    I just replaced the spark plugs and the problem has seemed to have gone away where it wont shift into 2nd gear at all and back to the first situation
    My question is what is going on with the transmission
    Two local dealers of G M Vehicles say the transmission is verry tough and they have not heard of this happening any Ideas???
  • replace the fan clutch my trailblazer was doing the same thing the fan clutch has a sensor in it and it some how tells the trans to shift gear aslo yoiu can read my post on that same problem on #394 and the answer is on 395
  • I have a 2004 TB Ext and just got a call from my friendly neighborhood mechanic who said my front differential is fried and will cost $2000 to replace. I have not owned an american car for many years and now I know why. I have a Toyota Sienna with the same amount of miles, it's a 1999, and have never had anything more than routine maintenance. Anyway, thanks for the posts on this topic, at least I know I'm not alone. Could someone who knows clarify the relationship between a fan clutch problem and this front differential problem? Is there a relationship? My mechanic told me several months ago that my check engine light being on was caused by the fan clutch and not to worry about it as it is expensive and doesn't really effect much except maybe the gas mileage slightly. WHat do you think??
  • burdawgburdawg Posts: 1,524
    I take it it's 4wd since your referring to the front differential. There's no relationship between the fan clutch and the front differential. What happened to the differential to make become "fried"? Was all the lubricant gone?
  • kapitkapit Posts: 1
    I was wondering if you resolved this issue and what did you have to do? I am having the same problem with my transmission on my 03 TB. I had the fluid and filter changed about 5k miles ago and the problem just showed up where it wants to fluctuate rpms from 2k to 1.8k and will not hold steay. Thanks
Sign In or Register to comment.