Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chrysler Pacifica Owners: Meet the Members

1234568»

Comments

  • qbrozenqbrozen Posts: 16,897
    well, struts and mounts shouldn't cost much, unless they are overcharging. Who stripped the oil drain plug? Of course, that's no fault of the car's. Someone stripped it.

    What's up with the cruise?

    Our cruise gave us a fit for a while, where hitting accel or decel would actually shut the system off altogether. But the dealer couldn't replicate (big surprise). It eventually just went away.

    '13 Stang GT; '86 Benz 300E; '98 Volvo S70; '12 Leaf; '08 Town&Country

  • qbrozenqbrozen Posts: 16,897
    hey mimma. sorry i forgot to come back and update ya. I did check the manual, and it does say as you stated. 6k miles.

    '13 Stang GT; '86 Benz 300E; '98 Volvo S70; '12 Leaf; '08 Town&Country

  • mimmamimma Posts: 5
    I think we have smoothed things over with the dealer.They are going to check the oil for us every 1K miles like you suggested. However, two days ago I started having something new happen. When I am going under 10-20 miles, after I step on the gas, I feel a clunk. Sometimes it happens with the brake, but mostly the gas. Vague description, I know, but that is the best word to describe it. Anyone know what that might be?
  • kkodalkkodal Posts: 34
    Hi MIMMA
    it sounds like the motor mounts to me.you might as well have the dealer check the mounts.
  • nbeannbean Posts: 1
    Try checking the nuts on the wheel axles. Our 06 was clunking because they had backed out.
1234568»
This discussion has been closed.