Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mercedes-Benz E-Class Maintenance and Repair

145791038

Comments

  • hkent1hkent1 Posts: 1
    I too am having the same electronic problems that have been mentioned (Gateway, etc.) Friday, my left stoplight malfunctioned and the entire assembly (LED) had to be replaced. My biggest complaint has been the rattles and noises, not just the SBC brake pump but sunroof, dashboard and seat noises. I have had my seat frame replaced twice. I have owned ten MBZ cars and have always been satisfied. This one was one of the first in So. CA. (Sept. 2002). I have 7,000 mi. and have contacted MBZ. in an attempt to get out of my lease or replace the car. If you were a early buyer of this model, you were told that the GPS system would be available in Jan. 2003 but has you all know it is not and cannot be added to cars that were not shipped from the factory with GPS as original equipment.
    What a tragedy for Mercedes to produce their best selling car with one with so many design and quality problems! Next time you really want to get upset, turn the AC on and on a hot day stand outside the car...it sounds like a helicopter under the hood. They went to a single fan this year vs. the two stage from previous models.
  • ran60ran60 Posts: 1
    Just bought a 2003 E500. After activating the Tele-aid, I started to get calls from MB response center that the alarm had activated, one of these calls came when then the car was parked in my garage. When I went out to the garage, sure enough the lights were flashing, but no audio from the horn.

    After 10 calls within the first 2 days of owning the car, I returned it to the dealer for service. The dealer was able to locate the problem, it's a module that the alarm system is connected to. The service advisor said the module is back ordered, and didn't know when it would arrive. There must be a big demand for these modules. 7 days later I'm still waiting.

    I'm longing for my 2001 C320 that I traded in. Never had any problems with it. It's sad to see that MB continues to have quality control problems with its vehicles.....
  • Aroundthebenz, re: your lifter problem. Because cams and lifter wear in together, don't you have to change the camshaft when you change lifters? (Or is that just on solid lifters?).

    In any case, rather than going for $1200 worth of new lifters, just get them reconditioned. There may be even people out there that stock rebuilt-exchange lifters for sale. The benefit here is you get a fixed price and instant shipment. While you track that down (maybe even calling the Automotive Engine Rebuilders Association in the Chicago area for some names), with your savings maybe you should check into some reground cams?

    Good luck.
  • I have a problem with 99' E-320. It gets very dirty with brake pad dust. Thinking of installing "KLeen Wheels" brake dust shield. Any advises is appreciated.
  • carnaughtcarnaught Posts: 1,580
    brake dust shields, metal or plastic shields that hold dust in away from the wheels? If so, you're "danged if ya do, danged if ya don't". These shields can decrease ventilation of the brake pads and cause heat build up which, among other things, interfere with the operation of the brakes. What do others know or think about them?
  • alcanalcan Posts: 2,550
    They worked well on my Riviera until the first heavy braking effort from high speed. Warped a rotor, and I can guarantee the lug nuts were torqued to spec.
  • Thanks for the advice, folks. My mechanic did change the oil to 10W30 (he doesn't believe in synthetics...who am I to argue?), and within a dozen miles, the lifter noise was gone. (I also heard from another long-time Benz tech that in his experience synthetic oil tends to cause noisy lifters because they bleed down faster.)

    *whew!*

    I have no idea what grade of oil was last put in the car, but we're back on the prescribed diet and all is well. (Except that my mechanic said that my wiring harness is disintegrating and will need to be replaced soon.)

    Thanks again,
    ATB
  • crosscwcrosscw Posts: 4
    anyone have a problem with the wiper dragging across the windshield when it gets the least bit dry? have had the arm replaced, windshield cleaned of grime and grit and it still drags; of course, on the driver'side so my visibility stinks. MB says the single swipe doesn't allow water onto the cleaned area as two blades would, so wiper is always going to be in contact with a dry area and drag slightly. hmmm..
    So, in other words, tough it out or any suggestions?

    oh, the Tele Aid problem-- there was a moderate recall on speaker volume which i had replaced and since then it works well.
  • Has anyone had a problem driving through puddles in a rainstorm and having the car pull hard. It seems as though the low profile tires make driving in the rain a little hairy. Has anyone changed tires yet. Are their any great rain tires for this car?
    Thanks
  • Recently had first B service at 21.7K miles. There were a bunch of little problems that detracted from enjoying the car perfectly.
    1. The readio volume control on the console would sometimes not work...the control on the steering wheel always worked. They replaced the radion. It appears to work okay now.

    2. A rear window would not always work with express up. They said that it could not be reproduced and did nothing.

    3. I complained about a drive train resonance that could be felt on smooth roads at around 65 MPH within the first 4 miles from cold start. They replaced a broken mount on a crossmember support. This fixed the problem and has reduced the background noise when driving significantly.

    4. Cruise control would down shift when going down a slope to hold the speed, but would not up shift when coming to a level. They made some adjustments but did not fix the problem.

    Other item: Break pads remaining on front 70% on the rear 80%. Seems that we may get close to 40K miles on the front pads.

    Bob
  • Regarding #2 in your problem. Try reset windows with your key. I had a same problem with my 2002 E320 and my dealer showed me how to fix. Aim your key to your driver side handle. When you press unlock, all the windows should scroll down and press lock to scroll up all the windows. After you did this, see if you will have the same problem. In my case, that fixed the problem and dealer told me that this problem occurs when your on board computer goes 'out of sync'. Hope this help!
  • hgphgp Posts: 11
    I had the EXACT problem you had. They replaced the steering and the noise went away...BUT the steering now feels noticeably lighter than it was before the replaced the rack and it seems like there is alot of play in it. I took it back and the said it was normal...I am at a loss since I know the steering is not supposed to be this light (tested other E's).
  • 2003 E320 Sport, 8000 miles - My issue is chronic out of alignment and shimmy with car pulling to the right after two balances and alignments. This last one they returned to me with 5 lbs less pressure in the left tire to correct - pretty shady stuff. My salesman says the Continental tires are "crap" and that I need MB to replace them. Have a call into Service Manager.

    Have also noticed (just once) the lopsided parking situation once that someone mentioned. Other than my issues, I feel pretty lucky compared to the rest of you.

    Shame on me for not doing my homework but with MB I thought I was safe - lesson learned.
  • microrepairmicrorepair Eastern MassachusettsPosts: 508
    The dealer *might* be right. Tires are not perfect and I've had some pretty bad ones over the years that have needed to be replaced. If the balancing requires more than 1.5 or 2 ounces of weights, chances are that the tire is causing most of your problem; it might be out of round. Take the car to a top notch independent suspension/tire shop and have them check the tire/wheel combination. Ask them to check the roundness of the tires as well as the wheels. I even had a bad wheel a few years back that had to be replaced after trying 4 different shops to get it balanced properly. And it was my MB dealer who caught the bad wheel. So they aren't all bad..!!

    FWIW, my 96 E320 holds it's alignment for years at a time and that's driving around New England's SMOOTH roads..!!
  • MB will usually replace wipers under warranty. The correct mix of MB soap is a must, and no topping off with the blue stuff or water. Rain-X can also make a big difference (available at all parts stores).
    Have heard that restricted steering hoses can cause groaning noises. the hoses on some models include valving that can be noisy.
    Brake dust problems can be solved by waxing your wheels when waxing your paint. when painted or chrome wheels become dry or contaminated they allow dust to stick. it takes about ten minutes to wax them, and NEVER spray Armor-all so that it gets on the wheels. I spray the brake dust off my wheels with water and no soap.
  • Pulling in the steering can be caused by Caster arm bushings failing in the front end.
    In the wet the car may pull to one side for no reason because the new electronic braking has no physical connection between your foot and the brakes. A computer makes assumptions and applies the brakes individually for each wheel and is sometimes wrong.( When the computer or pump fails you're in for a wild time!)
    The brake pump makes noises always ( a droning noise after every four brake applies and when opening a door). The fix almost works!
    The squeak noise can be caused by air in the lines. A brake bleed is a slight fix. The BOU (where the master cylinder used to be) may need to be replaced with an updated part.
    The audio problems are almost fixed now. The Head unit must be software flashed to a newer version, and the audio gateway must also flashed. Ask the dealership for printouts of the before and after software versions.
    If you go out of town for more than ten days on any MB you may come back to a dead battery due to the current draw of the alarm. If you park in a secure location it may be better not to lock your car as it seems to prvent dead batteries.
    If you get Tele-aid warnings you may just need a new instrument cluster, or a central gateway.
    Cars are getting to be just like microsoft software, sometimes they work great, and sometimes they #$@%^$$#%@#%
  • All these problems are understood once you realize that CHRYSLER has convinced DAM-MBZ to make the E class the new DE SOTO
  • I have had the exact problems with My E500. They couldn't reproduce the problem, so Mercedes didn't authorize any resolution. The strange break noise was initially fixed with a damper in the break line. After the fix, the noise was still present, but much quieter. Now the noise is completely gone. Since I first drove the car from the show room, I was getting an SOS Defective message on my display center. At first, Mercedes was aware of the problem, but did not have a fix. When I took the car in for service because of the crackling noise, they replaced my instrument cluster to deal with the SOS defective problem. I have not had another occurance of the cracking and sizzling noise since the first occurance.

    This is my 3rd Mercedes since I started buying them in 1999. I had a 1999 E320 that never required any problem fix. A 1999 ML320 that had a couple of problems over the 3.5 years of ownership. Now this 2003 E500. I'm not sure that I will buy another Mercedes. My first experience's were good. Mercedes knew how to fix their cars. Now.. Mercedes (I'm talking about the company, not my dealer service) is looking incompetent at diagnosing and fixing their own cars. What pity.. The Icon of most auto buffs is now at the bottom of the heap.. Dreaming of this car would be a nightmare!
  • paul_ppaul_p Posts: 271
    My experience with Continental tires, which I have had since 1995, has been very good. My first set (ContiTouring Contact) lasted well over 40k miles and was on the car when I traded. My current set (ContiSport Contact) have almost 11k on them with no abnormal signs of wear.

    I do have some balance issues from time to time, but a wheel balance and rotation every 5k miles seems to do the trick. Oh, I should mention they are on a C-Class and not an E-Class, so perhaps your mileage may vary. But I did want to let everyone know that they can be good tires.
  • sfvassfvas Posts: 10
    I have a E320, 2002, I am getting a little fan noise (whistle with fluctuations in speed). Anyone had this issue before? What was it? I took it to the dealer and he said that the vent was not open. Ah, wrong answer, that did not work.

    Before I take it back and they tell me that it's happening because there are clouds in the sky, I would like to find out if someone had the same issue.

    Thanks!
  • microrepairmicrorepair Eastern MassachusettsPosts: 508
    It hasn't happened on my E320 yet, but on at least two other cars I've owned there were similar situations that turned out to be leaves or pine needles that got into the air intake cowling and got trapped in the passageways and vents. In one case it caused ice particles to spit out of the vents when running the AC because it was clogging up the condenser unit. If you park under or near trees, you may want to check it out.
  • Diesel noise means you need new updated engine mounts. For Audio/Teleaid problems ask for a copy of the software versions of your audio, instrument cluster, and communications modules, and a bulletin stating the most up-to-date software versions! If they can't deliver these then find a new dealership for service!
  • Reading this message board really hits home! I was one of the people who bought a E500, paid full price,waited 4 months for delivery (early October)and now have had nothing but problems with the car. I have had the car in the shop 7 times and will be taking it in tomorrow for a total of 8. All the same electrical problems I have been reading about in these posts. Mercedes is telling me there is nothing they can do, ("that's what a warranty is for!!!"). I expected so much more. My next car will be a Lexus.
  • Is there anyone out there who owns a 2003 E320, and the car steers to the right, and also gets poor gas mileage? I would appreciate any info sent to me at sn654321@aol.com

    Thank you.
  • sfvassfvas Posts: 10
    I'm actually taking it back to dealer to get it checked out in a few days. I think the intake on the E320 vents have a filter, so the leaves should not be the problem. The service guy said it could be a fan regulator control unit or a million other things.
  • Please see web site www/Mercedesshop.com for information regarding premature crankshaft balancer failure and cost big money.
    Refer to SHOP FORUM heading and go to Tech Help-crankshaft balancer failure must read.
    Please report to NHTSA for complains.
  • radio on e320 sometimes starts to scan at random while listening to radio. Any ideas on problem and cure? Thanks
  • ncvolncvol Posts: 196
    I read a post on another site from an E320 owner who said that he drove through a deep puddle, and it shut down the engine. According to him, the dealer told him that there is some kind of air intake at the front of the vehicle (paraphrasing here, I'm not great with automotive lingo) that is known to suck water up into the engine even when you're not fording a stream or something like that.

    Has anyone ever heard of this?
  • jg69jg69 Posts: 2
    After 4 visits to the shop spanning at least a week overall, they seem to have fixed my keyless go system. They had to replace all the various antennas and sychronize the remotes. They also replaced the "gateway" whatever that is. They did have to replace my rear brake pads after a mere 17k miles. Has anyone else had problems with excessive rear brake wear?
  • Just got my e320 back from the dealership after 6 days in the shop. My complaints were:

    1. Loud vibration from the brake pump. First I was told this sound was normal. After my insistence that this noise (incessant every time I released the brake pedal)was obviously not even remotely within the range of normal even for a new type of brake system, I got results. A new pump, several new lines and some kind of dampening were installed and the brakes now sound fine. A minimal rumble is all I hear. I can be more specific on what was done if there is interest.

    2. My wife, whose hearing on the high frequencies is better than mine, complained of a high pitched whistle when the brakes were applied. On a test drive the shop foreman also heard the noise, said there was a service bulletin about that and applied the fix.

    So far 2 for 2

    3. After the first 500 miles, my engine began to sound like a cross between diesel and a sowing machine at idle and low revs. After listening to several other e320's at the dealership, we are convinced that our car is louder than the others we've heard. The dealership says the car sounds normal, but has agreed to bring the matter up with a MB rep next week.

    My experience with MB factory reps has been positive in the past. My 2000 e320 was running rough, and after several weeks of diagnosis, they replaced my engine and reimbursed me for the equivalent of month's lease payment. So we'll see.

    After this long winded intro, My question is this:

    Has anyone else experienced this loud ticking noise from the e320 engine, and what fix if any is out there.
145791038
Sign In or Register to comment.