Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mercedes-Benz E-Class Maintenance and Repair

1679111238

Comments

  • Hopefully somebody can help me shed some light on this problem. I have a 1993 E300 2.8, I have had the car at the dealer, had 2 Mercedes mechanics look at it outside of the dealer and no one knows what the problem is.

    The car runs extremely rich and cannot find the idle. To try to remedy this, we have tried a new mass air flow sensor, throttle body, new coils, new spark plugs, a brand new wiring harness for the computer. The cars runs fine when it is cold, but when it warms up the engine cannot find the idle, and when you push the accelerator the car seems like it is going to stall. Once the cars gets past 2000rpm it runs fine.

    Does anybody have any suggestions on what the problem(s) might be? Thank you.
  • I have the same problem with a '97 E320. Bought out of town and on the way home wound it up a bit. Very little tracking control. Brought back to dealer and they said all was okay. I am sure they did not test drive it. I took car up to 100 and then released gas - all over the place when the power came off. Shocks are good, alignment is good, tire pressure is good. Anyone else have any ideas?
  • Own a '97 E with 118K miles. The front spring perches have just collapsed due to excessive rust. There is also excessive rust to the frame rails which are also being replace. We are lucky the car did not collapse while underway or in an accident. MB is going to repair the car at their cost ($7,500 retailk - I'm told) - I guess that is preferable to the lawsuit that would come from the survivor of the inevitable total suspension collapse . I sincerely doubt my E is the only one afflicated with this problem - so BEWARE. So much for MBZ. It's my last one. That's a pitty, cuz the car was wonderful to drive. I would have expected more from a YUGO!
  • I also own a 1997 E320 and have experienced similar steering and stability problems. The car's drive line was easily put off course by lumps and bumps in the road. Changing lanes quickly caused the car to oscillate back and forth a bit. However, after replacing my Michelin Energy MXV4 Plus tires with a set of Michelin Pilot Alpin tires the problems disappeared. The Pilot Alpin tires probably have more rigid sidewalls. Tire pressure is set to the "heavy load" pressure. Sitting too far back from the steering wheel with arms completely stretched did not work well for me either. Sitting a little closer gives better control.
  • mzakmzak Posts: 1
    Pissed1, I too have noticed the "diesel sound" of my wife's new E320. However, the sound lessens considerably once the car has run about 20 minutes. My dealer says it sounds like a normal V-6 to them. Not buying it. This car should not be making this much engine noise. Does anyone else think their engine is noisey?
  • rashidirashidi Posts: 18
    we have a e500 and i find a similar anoyance with the "diesel sound" coming from the engine. the capable mechanic fixed all 8 of my service problems listed, however, said that the car runs "lean" and the noise and idle was normal.
  • I THINK I HAVE HAD MY PROBLEM SOLVED M.B. REPLACED MY MOTOR MOUNTS YESTERDAY. A SERVICE BULLITEN CAME OUT IN JULY STATING IF A CUSTOMER COMPLAINS ABOUT DIESELING AT 1000RPM TO 25OORPM REPLACE MOTOR MOUNTS. M.B. LIED TO ME SAYING IT WAS NORMAL B.S. HAVE ONLY DRIVEN MY E320 A COUPLE OF TIMES SINCE THE REPAIR BUT SO FAR NO DIESELING NOISE. THIS IS THE NEW PART #211-240-05-17. I HOPE THIS IS A PERMANENT FIX DONT TAKE NO FOR AN ANGER M.B. JUST WANTS YOU TO GO AWAY, IT TOOK ME 12MONTHS TO GET THEM TO ADMIT A PROBLEM. GOOD LUCK TO ALL.
  • ahmadmahmadm Posts: 15
    Dear MB Owners:
    I have been having problems with the windshield defogger. I live in Maryland and in low outside temperatures if I turn the climate control ON, all of the windows, windshield and rear included, get badly fogged up. The moisture sometimes is so heavy that I have to stop and hand wipe it. This only happens in low temperatures outside. Keeping the system ON removes very little moisture. I took the car to the dealer and they traced the problem to faulty wiring on the AC compressor. Guess what, it is hitting freezing temperatures again and the problem is back. Any insights into what may be the issue here? Thanks a bunch.
  • gumigumi Posts: 1
    Just bought 04 E320. The valet parking key does not work as the way it supposes to be. You suppose can use the valet key to lock the trunk and remote can't open it. But this does not work. The technichan at dealer said he tried on all other 04 models, and all act the same way. Is this true? I can't believe this.
  • ong2000ong2000 Posts: 19
    I just got the 04/E320 a couple days ago.
    We got 2 keys, but no valet parking key, the sales man said that Mercedes Benz doesn't make the valet parking key anymore. Is it true?? Did he lie ?

    But then later on, he said that he is going to order for us another extra key, the same keys as the other 2 keys. For free. But not the valet parking key.
  • merrelmerrel Posts: 45
    After 15 months I sold my new 2003 E320 black sedan. In its place I purchased a 2003 Jaguar 3.0 S type got a BIG check from the selling dealer for the difference too! What I did not initially get with my $52,000 Benz, and have now is: Special paint, a premium sound system, up-graded speakers, up-graded radio, a 6 CD player in the trunk, wood/leather steering wheel, electric dual lumbar adjustments, fold down rear seats a LOT more wood inside and many other crerature comforts. Say what you will but after owning TWO of them the Mercedes is overpriced iron and highly over-rated.
  • frjoefrjoe Posts: 2
    The paint on the hood has peeled off-about a three-inch square. The dealer tells me MBZ does not warranty their paint. I've also had a series of electrical problems. I've driven MB's for eighteen years now. I'm thinking seriously of going to BMW. My Starmark Certification expires next month. I just can't face the idea of running in with the machine every month or so.Dealer service is less than satisfactory.
  • I have had the car for a little over a year. Boy, it has been back to the dealership probably once a month with a variety of problems;

    1. Problems with radio going out. Now fixed.
    2. Head lamps on when they should not be. Now fixed.
    3. Sunroof, appears to loose its memory and does not recognise what position it is at (it moves a short distance when the button is depressed but does not open or close fully). Yet to be resolved. This problem has lingered for a while and has been back to the dealer for a number of times now. Shame, I thought MB where better built than this. Perhaps I should get a Toyota next time. My wife's 2000 Camry is just great and never been back once for any fault.

    If anyone has the same problem, let me know. Me too thinking of sending a lemon law letter to the dealership specially since they ignored an earlier well mannered note.
  • After reading all these problems im nervous about buying a new one.

    Does everyone have problems with their car???

    Do you think the problems have been worked out by now in the 04 cars?

    Any advice would be helpful as my lease is up in a few months.
  • Just bought a '04 e-320 sport. I've noticed a couple times when i put the car in reverse to get out of the garage the gear does not engage. Also noticed when decelerating (highway off ramp) when the car down shifts, it's rather noisy, a hard downshift. Has anyone experienced this?
  • irvnirvn Posts: 11
    Hey giselle1:

    I would think long and hard about the 2004 E-class. I had a 2000 E-class and gave up to a 2003 GX470 and a 2003 BMW 330i. I had a difficult time with my E-class with a host of electrical problems (COMAND, radio, sensors). I really liked the car, but I lost my confidence in the car with continued electrical issues. I think it is going to take two or three years for MB to change the philosophy to the MB of old where quality was important.
  • Our 2000 E-430 has 34,000 miles and has had numerous problems- the list is very long-
    dash board was replaced due to premature splitting of air bag cut out

    window regulators replaced on 3 windows

    dash board lights replaced

    plastic headlights and parking lights completely yellowed - replaced

    drink holder replaced

    vanity mirror lid replaced

    fuel level sensor replaced

    stop lamp switch replaced

    cowl seals on windshield replaced

    serpentine belt,tensioner and idle pulley REPLACED

    replace fog light bulb

    replace emblem on gear shift handle

    replace switches on steering wheel - finish turned very sticky

    Otherwise the car has been fine!!!

    Except for the OEM Conti tires - extremely noisy.
    Replaced with Turanza LS-Z major improvement in the ride - no loss of performance -

    Thats not a great tribute to what I expected to be a LUXURY automobile.

    We are presently discussing the premature wear of the leather seats and serious rust from small paint chips.

    Hope that this info assists you in making a purchase decision.
  • jchkjchk Posts: 5
    Guys,

    Could anyone kindly post a link or a copy of the letter that Mercedes sent out regarding the resolution of $3250 or buy-back for those who ordered the NAV?

    I would truly appreciated that as I am currently in Negotiation with Mercedes and they need a copy of the letter to prove the claim.

    Thanks in advance.

    mbnotforme "2003 E Class Comand/Nav Debacle" Jul 22, 2003 6:26pm
  • I have the same noisy engine in my 2003 E320. After multiple trips to the dealer and letters to MBUSA Customer Service in NJ, I've gotten nowhere. The dealership says the engine sound is normal, and MBUSA backs them up. They refused to send a factory rep to listen to the car. BTW the motor mount TSB only applies to the E500. I'm seriously considering getting rid of this car and going back to a Japanese car where customer service means something. Any success stories re: this problem would be appreciated
  • TIPSTER42 WHAT I STATED IN MY MESSAGE #259 IS THE SOLUTION FOR THIS PROBLEM, I WENT THROUGH THE SAME PROCESS. M.B. WAS NO HELP. THERE IS A BULLETIN, I SAW IT. IT STATES ONLY IF YOU COMPLAIN TO REPLACE THE MOUNTS. MY SERVICE DEPT. CALLED ME TO SEE IF IT WORKS. M.B. IS STILL TELLING THEM THERE IS NO PROBLEM. THEY DONT WANT TO MAKE IT A RECALL, SO THEY WILL REPLACE THE MOUNTS ON A CASE BY CASE BASIS. DONT TAKE NO FOR AN ANSWER. PLEASE POST YOUR SUCCESS. GOOD LUCK
  • jchkjchk Posts: 5
    Hi Guys,

    Could someone post the letter mentioned in the following link please if available?

    mbnotforme "2003 E Class Comand/Nav Debacle" Jul 22, 2003 6:26pm

    Thanks in advance
  • We wish we had read this message board before buying our car. We purchased our 2004 E320 less than a month ago and it's already been in for repairs once and has to go again tomorrow.

    Within a week after purchase, the ambient light next to the panoramic sunroof went out. We took the car in and it sat for a week at the dealer while waiting for a special light bulb to come in. Then we started hearing a sudden static noise that grew progressively louder coming from the speakers. It happens occasionally right after the car starts and can't be turned off. The radio will suddenly reboot and all is fine again. It's been difficult to identify the source of the problem since it happens randomly. Yesterday, I got in the car and before putting the key in, the display warned of a brake failure. When the key was put in, car wouldn't start and the display/clock went bonkers. We had to call roadside assistance and they replaced the battery. The car works now but the navigation system doesn't work. So the car is going back again to check what is going on. We're afraid the problem is much worse than a bad battery and we'll be stranded somewhere if the car doesn't start again.

    Anyone else have similar experiences or have any ideas about what's wrong with the car? The dealer and service reps have been really nice to us but we don't want to be making monthly trips to see them.
  • I drove MB for 23 years...my last two were total total trouble...had a 91 300SL owned it from new for 5 years..only had 20,000 total miles..was in shop on average of 30 days per year...traded for new 96 MB E320..had trouble from day one...cold start problems...drive shaft vibrated..was replaced..still never smooth..sold at 14,000 miles and bought new Lexus.now on my 3rd Lexus..almost an absolutely perfect car..would not buy anything else......Irv
  • I just purchased a 2004 E320 4matic sedan. I included the lighting package with the Bi-Xenon headlamps. The low beams only seem to illuminate about 50 feet of the road and than there is an abupt darkness. The high beams are wonderful. Has anyone experienced this problem with there low beam lighting. It is very distracting and unsafe
  • I too have the 04 E320 with the bi-Xenon lights. I believe that's just the way Xenon lights work. I have them on my 2 BMW's as well and they are very bright and full to a certain point and then just cut out. You can have your lights adjusted so the point a little higher, will give you more distance, but it makes it unsafe for other drivers since the lights are so bright and blinding.
  • khicekhice Posts: 13
    The phenomenon you observe is intentional by design. There is a popular misconception that xenon's illuminate farther ahead of the vehicle. Actually, they illuminate a wider area. As the light is whiter, the driver can see more clearly. Both features increase the safety of driving at night. Were the xenon's aimed higher, they would blind oncoming drivers. You may also notice that the right headlamp is aimed slightly higher than the left. This is so as the right headlamp does not shine as directly into the eyes of the oncoming driver and can therefore be aimed a little farther out.
  • My 2003 E320 sport had the same issues: static radio; dead battery, clock went wild, etc. At first, the deal replaced the battery but that didn't do the trick. The real culprit was the alternator. According to the dealer, the alternator was over-charging the battery. At least that's what the computer thought so it basically stopped charging I guess. Anyway, after the alternator was replaced, the car is trouble-free. Good luck.
  • allygallyg Posts: 18
    I had the same problem with my 2003 E320. I could only see about 15 feet in front of me at night the first night I drove the car out. It totally scared me. The dealer had since readjusted the lights and they are fine now.
  • allygallyg Posts: 18
    There is an annoying noise coming out every 30 -40 seconds under my 2003 E320. I can't seem to pinpoint the location but it seems to be coming from right above the rear wheels. It is driving me crazy. Anyone has similar experience? I try not to send it to the dealer yet until I find out more about the noise because the dealer usually ignors complaints about noise.
  • I'm may purchase a 1997 E320. Mileage 51,000, price $18,000. Never owned a MB, I'm hoping this is a reliable car. Looking for anyone to give info on likes/dislikes/problems, etc. Thanks so much for your input.
Sign In or Register to comment.