Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





2008 Toyota Highlander

1888991939497

Comments

  • wwestwwest Posts: 10,706
    Just be sure, CERTAIN sure, that like most modern day OEM/factory floor mats/carpets the new ones are firmly attached somehow such that they CANNOT slip/slide forward over time and thereby result in instances of unintended acceleration with HEAVY braking.
  • Has anyone had problems after oil changes with oil leaks? I've been back to the place twice that changed my oil and they insist they've fixed the leak. They said the car needed to be revved for a few minutes to create a vaccum. Anyway that didn't work.Am I stuck with only have my oil changes done by the dealer? :confuse:
  • findmefindme Posts: 36
    Does this come on the Limited? I know it has the smart key, but I'm not really sure I'd like it. I think I would like the engine start however.
  • I believe its an option, but not standard.
  • Another update on my own post:

    Things have been fine, no faulty alarms for a few months, until this week we had a few again. Today I opened the hood, and found a couple of those "pop rivets" (my term) loose again. Reseated them, closed the hood -- and no more alarms.

    Again, I can't be certain if the pop rivets are the problem. Could still be that somehow opening/closing the hood causes it to re-seat and stop the alarm sensor?

    I'm interested to know if anyone else has similar experience.

    Thanks

    (I monitor this forum, will get the message in my inbox if you reply)
  • I have 08 Highlander Limited and it came with Toyota installed remote start on the Smart Key key fob. Press LOCK button 2x within 2 seconds and press a third time and hold down button for about one second. Lights flash a couple of times and vehicle starts right up. Pretty much like the other remote starters and door unlockers made by Viper, etc.

    Got a nice Viper unit installed on my wife's 2004 Toyota Rav4 for her birthday. Has a range of about one mile and works good for door unlock - lock - remote start. Cost in my area in Michigan was $189.00 installed - out the door.
  • luck11luck11 Posts: 425
    I am looking at a 09 highlander, but have a question about illumination of the instrument cluster.

    I tend leave my headlights in the on position all the time given they shut down when the vehicle is turned off anyway. The only problem is that doing so dims the instrument cluster and during the daytime, it it is more difficult to see the readouts on the cluster, radio etc.

    My current Subaru has a button to increase the illumination of the cluster when the headlights are on, but I have to press it each time I start the vehicle. I know Mazda has a switch or button to keep the instrument cluster at "daytime brightness" mode all the time. Does the highlander come with a similar option, and does it maintain the "brightness" setting even after the vehicle is turned off?

    Thanks.
  • wwestwwest Posts: 10,706
    This has been a continuing point of frustration for me. My RX has the ability to over-ride the dimming of the instrument/dash lighting and indicators to FULL brightness, but then when actual darkness arrives I find I must return it to the automatic mode.

    And this "feature" has been this way, IDIOTIC way, throughout the industry, for as long as I can remember. I have to assume there is a patent fee they must pay, and refuse, in order to do it CORRECTLY.

    The only solution I have found is to tap into the daylight sensor and drive a relay that forces the system into the over-ride, FULL brightness mode, until "darkness" arrives.

    Idiots....
  • luck11,
    I have 2008 Highlander Limited Edition. I leave the lights on all the time. Never had a problem with visibility of the instruments like you asked about -- in fact, the clear contrast/readability of the instruments is one of the first things I noticed when driving it.
    I think you're in good shape.

    Also - not that you asked, but the Highlander also is intelligent enough to turn on and off the lights (headlights, dome lights, side mirror illumination for the keyhole, etc...) at the appropriate times. They did a good job with this stuff.

    My only complaint in this department is that the navigation system screen is very bright, and makes it a little difficult to see out the back window when backing up. But the rear-view camera mitigates this somewhat.
  • lewy2lewy2 Posts: 1
    My 08 Sport with 19 inch wheels seems to loose almost 2 psi per week. This is consistent on all 4 wheels, although I haven't checked the spare. Anybody else experiencing this, and if so what is the resolution. The dealer has "resealed" the tires and I'm going back Jan. 5 for a recheck. The only other suggestion the dealer has is filling them with Nitrogen.
  • Hello:
    Experiencing same thing with my 08 Limited. Sensor comes on and wheels need about 3-4 psig of air. Spare tire seems to be holding ok. Had the dealership check this out with no suggested resolutions either. Nitrogen will not do any good. I checked with reputable tire dealer in my area and they told me you must find source of leakage because Nitrogen will "leak" out as well. Then, stop at local gas station to fill with "air"? Why spend extra money for Nitrogen. HE believes the rims or TOYO tires are defective because air pressure drop occurs Winter and Summer. Not weather dependent. Good luck and let me know... Michigan Mike.
  • I have 08 Limited with 19 inch wheels. Did you try Belle Tire in your area? Mine came with TOYO tires and have been very happy with them; Winter and Summer driving in Michigan. It is my second snowy season with them on vehicle and so far, very satisfied with low noise on highways and wear. I rotate every 7,000 miles which is about every other oil change.
    Michigan Mike.
  • luck11luck11 Posts: 425
    Thanks to the replies regarding the interior instrument cluster lights.

    another question. I test drove a HL Sport today and given its winter, there is sand and salt on roads, and since the dealership is in a bit of a construction area, there seems to be some small pebbles as well.

    Thing is, I noticed a great deal of "clings and dings" as debris was flying off the tires and hitting the underside of the HL. Now, I did not notice this in previous test drives. The only thing I can think of is that this model did not have the mudguards and DID have the nerf side step bars. I wonder if it was the debris (small pebbles etc) hitting the alloy nerf bars or if this is common with all HLs. It concerned me because the noise was significant. When I drove out of the lot with my Subaru Outback, I drove the exact same road and did not hear a thing.

    Appreciate hearing from others.....is the HL normally this noisy with debris coming off the tires?
  • mdhuttonmdhutton Posts: 195
    I have never had the "cling and ding" experience in my 08 HL LTD, except when I drive over road salt, sand or other debris just like you did. I would almost expect it in such an instance and would say it's a situational issue, not a vehicular one.
  • luck11luck11 Posts: 425
    Hmmm.. Do you have the nerf side step bars installed?

    I agree its situational, but I must admit that the noise was loud that it immediately caught my attention. Just not used to hearing it sooooo loud. I can barely hear stuff being kicked up in my Outback, and what I do hear is very muffled. This sounded like the debris was hitting bare metal in the wheel well or the underbody, thus why a suggested that perhaps the nerf bars were the culprits. Living in Cda where we live with salt and sand for 4-5 months of the year, I'm worried that it would really start to annoy me.

    Does the underside of the HL come with an undercoating for rust and sound deadening?

    Think I might have to take another test drive.

    Thx.
  • Hi bjosephs,
    I am having the same problem(engine clicking noise) with my highlander and am in the process of trying to work it out with the factory rep. It started at about 4000 miles . I am curious as to what was done (if anything to cure this problem).It is getting worse as time goes on and will surely lead to some sort of failure. Any inpute would be appreciated.
    Regards
    Tom
  • wwestwwest Posts: 10,706
    Winter specialty tires can be very good at picking up and discarding, SLINGING, small road debris, gravel/stones..
  • maximafanmaximafan Posts: 592
    Luck, I would assume that the Highlander has daytime running lights the same as my Lexus RX350. So I just set the light switch to auto so that when it gets dark enough, it switches from the daytime running lights to the regular lights. I don't have to remember to turn on anything. I didn't realize that the instrument cluster dims during the day if you turn the headlights on since you have in the Highlander, again, like the RX, electroluminescent lighting. I love that automatic feature for the headlights!
  • maximafanmaximafan Posts: 592
    My '07 RX350 does the same thing on cold start. Heck, I think I even hear a little bit of clatter when the engine is warmed up and
    I'll be standing outside of the car as it's parked and idling. I believe this is a common trait on the 3.5 liter engine. A co-worker of mine has a 2005 RX330 and I've always felt that the 3.3 liter engine is sustantially quieter than the 3.5.
  • mdhuttonmdhutton Posts: 195
    I do not have the nerf side step bars.
  • explorerx4explorerx4 Central CTPosts: 9,730
    actually i am not here give anyone a hard time, but you could get automatic headlights on 1974 tbirds.
    i was going to respond to the tires losing air every week post, but it looks like one of those 1 and done posts. otherwise, i would have suggested having the valves replaced.
  • Not more than any other car.. but I always get the mudguards (dealer to throw them in to close deal). Is it possible the salt truck just went down the road before your test drive?
  • luck11luck11 Posts: 425
    I drove by on my way home to check and found that it did have the mudguards. Turns out they come std on Cdn models. Not sure if the salt truck went by, but regardless, I could barely hear anything in my Outback when I drove down the exact same road less than 30 minutes later. And, given there was little traffic (the street is like a big circle servicing an auto park), the stuff would still have been on the roads. That aside, it was loud enough that it immediately caught my attention as I was pulling away from the dealer on the start of the test drive. It was loud.

    Anyway, yesterday I was at another dealer on my way to pick up my son, and took a look at a Sport they had in the show room. I noticed the underside of the HL has a number of plastic panels...not covering the engine but further back....approximately where the driver sits. Tapping on them produced a bit of a rattle (were not on snug)and a hollow sound, and therefore, I could see how they could act as a "drum" when bombarded with dirt and debris. Not sure what purpose they serve but I suspect that a good spray of that black undercoating, which also acts as sound deadener might help solve the problem.

    All that aside, Toyota Cda just announced its promo for Jan....and again nothing for the 09 HL. It ticks me off when every other competitor up here is offering cash incentive and/or discounted financing (2.9% for 60 months) for their 2009s (I'm talking about Mazda CX-9, Hyundai Veracruz, Nissan Murano, Subaru Tribeca etc.)
    If only we had the rates being offered in the USA!!

    I wish Toyota would get off its high-horse and come back to earth.....economy is in the crapper, Toyota is forecast to announce its first ever loss in 70 years, and HLs are hardly flying off the lots given there is no incentive. Luckily, I'm not in an immediate rush to buy, so I can probably wait until Feb, but if there is no incentive then, I may just turn my eye to #2 on my short list.....Hyundai Veracruz.

    Cheers.
  • mdamesmdames Posts: 79
    I own a 2007 Lexus ES350. It does the same thing. Most of them do, from what I see on the Lexus forums. I've had the car for over 2 years with no issues. So it doesn't appear to be a problem, just an idiosyncrasy of the 3.5 Liter engine.
  • Ok, I guess I'll answer my own question. YES. It seems to be too scientific for the local Oil Change Chains to properly tighten the oil filter, hence the leak. The dealership however had no problems. I'm glad no one else has had this problem.
  • molinemoline Posts: 14
    I have taken the car to the dealership for the first 4 oil changes, and haven't had any problems with leaks. However, I decided to change the oil myself last weekend, and discovered that the dealer had _way_ over-torqued the filter housing, probably using the socket hole in the bottom screw to remove/replace it, since it took a tremendous amount of torque to remove the screw once I had the filter housing removed. I did have some trouble reinstalling the housing to the proper torque with a "standard" 65mm plastic wrench (it spun a little once it was snug), but that wasn't a big surprise since I believe that the housing is actually 64mm. Our local Valvoline oil change shop doesn't stock the filters, so they probably don't have the proper wrench to tighten the housing, which might explain leaks. That being said, I'm not sure that I trust the dealer any more either. On the plus side, it was a lot easier to change the oil myself than I had expected, and I know that it was done to spec.
  • findmefindme Posts: 36
    I'm thinking about ordering colored mudguards to match my silver sport. Has anybody had problems with the paint being chipped on the colored mudguards? I think I read about that somewhere. Thanks for your time!
  • steverstever Viva Las CrucesPosts: 40,844
    I moved your post over to the Prices Paid discussion:

    christy12, "Toyota Highlander: Prices Paid & Buying Experience" #3656, 13 Jan 2009 11:48 am

    Have fun shopping!

    Steve, Host

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • I can't comment on the HL mudguards as I have the unpainted (black) ones.. I think they look good against the metallic gray.

    However, I can say that after 110,000 miles on a Solara with silver mudguards, they were still almost mint.. in way better shape than the front bumper (from road sand/salt over 8 winters).
  • Now I have noticed something I :
    1) cannot totally validate
    2) cannot totally explain.

    I have a 2008 HL Limited. I run it with the headlight selector set to Auto, so when it is dark/light enough the heqdlights turn on/off.

    So what I think I have noticed is the dashlights seem to have an intermediate setting that lightens or darkens, depending on the sun rising or setting. It seems to happen only under certain conditions.

    Anyway I was wondering if anyone knew if the setting on the Highlander are able to change the intensity of the dash lights without affecting the headlights.

    Of course it may just be the gremlns doing this to mess with what is left of my mind....
Sign In or Register to comment.