Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chrysler Cirrus

124»

Comments

  • atfdmikeatfdmike Posts: 414
    First the basics, when was the last time you changed the fuel filter? How about Spark plug wires and plugs? Which engine are you talking about? If the fuel filter, etc; is OK, then I would look at the cam sensor as that sensor is most likely at fault given the problem you describe. Generally, the sensor plays a larger role at 2000+ RPM. You don't say which engine, so I am assuming yours has one. Have you gotten a check engine light,as that would store a code to check too. HTH One guys opinion.
  • Hello.. my car stopped stalling out until recently. It started it again. WOW we may need to check the crank sensor. what do you think? Other then that, the car seams to run great.
  • no check engine light
  • question, you stated you had to replace the fan control that blows the fan speed? Mine stopped working the other day and only works on high. How do you change that and how much roughly is the part?
  • Hi, i have been a Chrysler mechanic for 15 years. You need a blower resistor which is located on the passenger side under the dash or behind the glove box depending on the year. Lust look for a plug with about 6 wires going to it, and it is held down by two 8mm bolts. simple repair.
  • according to my son who changed his spark plugs,you do have to remove the valve cover assembly to get to all of the plugs
  • rsimcoxrsimcox Posts: 1
    1996 Chrysler Cirrus. Today after driving downhill on a very steep mtn road for 30 minutes when I got to the bottom (with what I'm sure were very hot brakes) suddenly the brake pedal went to the floor with only little friction... good thing no one was around me! For the next few minutes this happened off and on multiple times. If I pumped when I felt it going to far it would then work. After about 5 minutes all was well again. I had to drive 150 more miles to get home but it was mostly freeways or mild hilly highways.

    What happened? Did the abs kick in when it wasn't supposed to? What is the likely problem? Thanks much. Randy.
  • My car was recently a victim of complete stupidity and by that I mean someone failed horribly at stealing my car and they destroyed my ignition lock key cylinder I replaced it and car still refuses to start when I turn the key, accessories do not come on nothing..... its not the battery its something between the ignition cylinder and ignition switch...... anyone have any ideas? :cry:
  • I've just had the crank sensor and distributor replaced and my car is still doing what yours is doing (the car idles, it dies while slowing down and the oil pressure light will come on but go off after I pull over and restart the car). I took it back to Meineke yesterday and they said vacuum hoses were loose and that they fixed it. Car still did the same thing today. I'm taking it back to Meineke tomorrow. I wonder what they'll tell me this time.
  • keeps throwing a code says cam position sensor, replaced distributor three times, same problems help any one have any ideas
  • atfdmikeatfdmike Posts: 414
    What is the code number...likely you are getting a generic code and you need the actual powertrain code for the 2.5. Obviously it isn't the distributor, but without the code, diagnostics is tough!
  • New to this forum but have same problem with low oil pressure light, stalling, etc. How can you pull a code if the check engine light is not on? Did have check engine with generic exhaust code. Had it checked further and replaced cat converter. No light since and passed emissions inspection. STILL has other problem though. O2 Sensor doesn't seem to be problem since check engine is off now. Does anyone have the problem only when during or after wet weather? Thinking crank sensor but that is a lot of work on the cirrus. Want to be more sure before taking that route. Any other ideas... Thanks!
  • atfdmikeatfdmike Posts: 414
    edited April 2011
    You can still pull any codes that are in memory using a code reader. CEL does not have to be lit to do that.
    My experience with crank sensors is that the engine runs or it won't restart when hot. Not heard of missing as a symptom, not to say that is not possible, I just don't know. This engine is known to develop low oil pressure, best and cheapest fix is to replace the oil light pressure sensor (to be safe) and change the oil to a slightly heavier weight . Not much else you can do. Oil light symptom is more apparent in hot climates or hot running conditions.
    HTH One guys opinion.
  • How long have you had this car for you to replace the distributor twice and what transmission problems have you had? Have you gotten the transmission flushed and filter changed when recommended?
  • what transmission problems did you have. And what was up with the water pump. I have a 1995 Cirrus that I bought like 2 months ago. It needed a distributor and had a vaccum leak and sunday the a/c compressor went out on it but other than that it runs find. Did you get a transmission flush and filter change when suppose to?
  • I just bought a 1995 Chrysler Cirrus from this white woman and it wasn't running because it needed a distributor. The owner pryor to that was an old woman who drove it very little and was the first owner. The car had around 86,000 miles when the second owner got it and when I bought it from them it had over 111,000 miles but they had all the maintenance recipts. Besides the distributor and the vacum leak which I got fixed and this past sunday the a/c compressor went out I haven't had any problems. What is up with the transmission problems for this year cause I havent had any yet but does anybody know why it has transmission problems? Im getting my transmission flushed and a new filter next week. What Im basically asking is do you'll think I have a pretty good vehicle. Its super clean inside and out along with everything under the hood looking good. I just dont want this transmission going out on me. Any suggestions to make sure I limit the possiblity of transmission problems?
  • hello all, i am new here so please bear with me. I took my car to the chrsyler dealership to have the power steering pressure hose put on under a recall, after 13 years. my car is a 2000 chr. cirrus. anyway it has not worked the same since. there is motor oil leaking onto the spark plug covers which i chalk up to they took the little box off the top of the motor to get into the back of the motor to replace the hose. either they cracked something or have the gasket wrinkled under the part. also when it heats up there is a terrible squealling going on, so i dont know if that would be too much pressure on the steering pump or if it is the belt and pully, but it only does it when it heats up. please help. i am taking it back to the dealer for the oil leak and i know they are going to say well the car is old. could the new hose be too much pressure for the old steering pump and try to take me for a whack of money. neither one of these problems has ever ever happened before. thanks all for the help
124»
Sign In or Register to comment.