Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mazda RX-8 Problems and Solutions

1151618202146

Comments

  • I have a 2002 Millenia S with 45,000 miles on it and no problems whatsoever except for a recent glitch in the cd changer. (I have had problems with the tires due to potholes.)
    I recently received a letter from my Mazda dealer saying they were paying top dollar for my car. It turned out it was a come-on but it got me looking at the RX-8. Its the only Mazda model that I would consider purchasing. However after reading of the problems with it on this forum, especially the difficulty in restarting it before its warmed up, which I believe is a personal safety issue and totally unacceptable, I am going to pass until hopefully they fix everything.
  • graphicguygraphicguy SW OhioPosts: 7,142
    No need to wait for the RX8. Everything as it should be currently.

    The only caveat being, the RX8 is a very different car than the Millenia.
  • I know it is totally different. Before I bought the Millenia I had a Ford Contour 5 speed and put on 92,000 miles. Great handling but terrible reliability. That's one of the reasons I went with the Millenia. I do like shifting, although I have read you have to downshift in the RX-8 to get some power in the midrange. Also I live in the snow belt and rear wheel drive is not that practical and snow tires would be a must. Although the Millenia with its 17 inch tires are terrible in the snow and I purchased snow tires for it.

    Does anyone one what changes if any will be made to the 2005 model?
  • graphicguygraphicguy SW OhioPosts: 7,142
    Very minor differences for the '05. I think the keyfob is different and Mazda is dropping the yellow in favor of white. That's as much as I've heard.

    Snow tires are a must in winter climes if it's your daily driver. With snow tires, the RX8 gets around just fine from all reports. Of course, that's also more a function of how experienced the driver is. I can remember driving V8 powered RWD cars, no trac control with skinny tires many years ago in the winter without much of a problem.

    Acceleration is fine on the interstate in 5th or 6th (5th puts you lower in the power band). But, if you want to leave someone in the dust at 70 MPH on the interstate, drop it into 4th and the world around you will become a blur.
  • donaldsdonalds Posts: 28
    Here is where I am as of now, drove the car 170 miles one way to another dealer, saw the tech with it hooked to the comp. asked him if it had the "M" flash on it, he said I have no idea what you are talking about, asked to talk to mgr. he said it had the latest and greatest program on it, could not explain what it was.
    Called Mazda and told them I showed the tech and mgr. exactly what the car was doing mgr. said the shaking is the trans trying to catch up to the engine, told Mazda cs that and he laughed, C/S asked me to take it back to origional dealer and show the tech exactly what it was doing, did that, took it to 3K let off the gas, rpm dropped to about 800rpm car shook then went to 850 and tried to settle down, tech said that isin't the way it should run, left it Tues. and today, went in to get it and they said nothing showed on the diagnostics,well I think by now they should realize it will not show a code. I insisted the tech state on the service slip what the car was doing when I left it for service. he was hesitant about doing it but finally did to get rid of me.Mazda said the last time I called they may have to send in a factory rep, we shall see.
  • graphicguygraphicguy SW OhioPosts: 7,142
    These are exactly the type of techs you don't want to work on your car. You don't happen to be in CA are you?
  • donaldsdonalds Posts: 28
    No Texas, I talked to Mazda C/S again today and they don't seem to want to do anything, said if the car does not show a code not much they can do, so now it is off to file a lemon law complaint.
  • vtlcvtlc Posts: 25
    GGuy your right about the 8 on the power band. I was driving mine 3 days ago and a civic wanted to just have some fun at 40 mph. Dropped it from 4th to 2nd heard the beeeepp, shifted to 3 and the civic was about 2 cars behind. Well had to slow down though I was at 85 on a 45 street. What a rush.... no I ment What a risk. =)

    Donalds it seems like you and I are going to be business partners. There are so many things wrong with my car and Mazda keeps telling me the same thing they tell you. We cant do anything if there is no code. I tell them don't you guys see my car shake and just look at my shifter, now tell me thats normal. All they say is well we called Mazda and they said it's normal. Im just sick of Mazda and its CS and support if any. I got an appointment to get my car checked agian for the shaking and the lights dim as the AC comp kicks in, this time at a different dealer 30 mins away, I hope they can figure it out or its going to be just a few more days til I hit 40 days [non-permissible content removed] in the shop. And all I need is 30.
  • graphicguygraphicguy SW OhioPosts: 7,142
    Good luck with the new shop.

    Either way, I'd say you'd have support here considering what you've gone through.
  • donaldsdonalds Posts: 28
    I have finally figured out Mazda's game plan, they will not authorize a mechanic to start taking things off the car for inspection, they want it to run to failure, would you believe yesterday a person from Mazda C/S actually told me the factory service rep's were nothing but pencil pushers, and only concerned about cost!
    I notified Mazda per Texas law of the problem and lack of action on their part so now the complaint is on its way to the review board.
  • donaldsdonalds Posts: 28
    C&P response from C/S

    First of all you should not refer to this as a "concern" there is a definite problem with the car as witnessed by a Sames motor mechanic, when the customer service rep of Sames ask him how long it would take him to fix the car his answer was "I won't know until I get into it" all mazda would allow them to do is run diagnostics, everyone should understand by now the ECU will not show a code.
    It is beyond me why your organization has allowed this to continue for four months, I am not the only one that has an RX8 that has the same problem, maybe that is the data that should be collected and evaluated.
    And if Sames has been contacted then the service manager at Sames is lying to me when he says he never spoke the Mazda, only the tech. called the hotline for assistance, they told him to recheck the flash on the computer.

        From: Mazdavisitors <mazdavisitors@mazdausa.com>
    Date: Fri, 20 Aug 2004 12:16:44 -0700

    Dear *****
    Thank you for contacting Mazda North American Operations. I appreciate
    the opportunity to respond to you.

    You have noted that you have written to the Consumer Compliance
    Department to initiate a Lemon Law request. Please note that this
    office does not process any such requests, but your correspondence will
    be reviewed by the Consumer Compliance department. Once reviewed, a
    representative will be assigned to your case and they will contact you
    directly for any further handling.

    Be assured, I have confirmed through records in our corporate data that
    Daniel DID in fact send correspondence to your dealership, their
    technical services AND their District Representative regarding your
    vehicle concern.

    Again, thank you for contacting Mazda.

    Regards,

    William ***Specialist, Customer Assistance E-Business

    Original Message Follows:
    ------------------------

    Form Message

    Subject1: Ownership & Maintenance
    Subject2: Warranty Coverage
    Current Mazda Owner: true
    Model: RX-8
    Year: 2004
    VIN: Message Body: I have taken my rx8 in 4 times because of a very rough
    idle, nothing has been done because there are no fault codes showing,
    the condition has been witnessed and documented by two service centers,
    I have talked to your customer service about the condition and it is
    apperant Mazda does not intend to make the car correct, I have now begun
    a Texas lemon law complaint and have notified Mazda in writing of the
    condition of the car and lack of response. Your customer service person
    by the name of Daniel told me he could request a factory service rep to
    look at the car, another one told me today the service manager had to
    request it, therefore the action will be determined by the Texas lemon
    law board.
  • funbob4funbob4 Posts: 1
    I had the same problem with the shaking when the Rpms are below 3000. In addition, the check engine light came on 1 week after I purchased (7/04). I took it back to the dealership and they kept it for a week. After looking at the car, they said an intake valve was stuck open and would need to be replaced. Unfortunately, they had to remove the engine to replace the part.. Here is what is written on the receipt:

    R&R Engine ASSY to Replace Intake Manifold PLN Q.A. F0008XDX F0101ARX

    Since I've gotten the car back, the shaking has stopped. Hopefully this will provide you some insight to your problem.
  • vtlcvtlc Posts: 25
    I really like the RX8, but if I knew that buying a new car would bring so much frustration and anger I would have just settled for a used car. At least I could tell myself, this is why the they are selling this car. Keep up what you are doing, I'm making notes and will be following your steps soon.
  • graphicguygraphicguy SW OhioPosts: 7,142
    It's really shameful that poor dealer service depts are causing you guys such grief with such a fine car.

    I don't blame any of you a bit for taking your experiences to the next level.
  • jalal28jalal28 Posts: 5
    Recently had some H&R lowering springs installed on my RX-8 (less than a month old). Auto Leveling light malfunction light came on... any ideas why... or how to correct it. I have noticed that now that the car is lower what used to be a flat plane of light has become jagged and essentially un-level. Has anyone else experienced this problem after lowering the car?
  • pathstar1pathstar1 Posts: 1,015
    Sensors are on the front and rear pass. side suspension. When changing the springs they may have left one disconnected or perhaps damaged one. The lowering springs (that's what H&R springs do) may have thrown the sensors out of range. The sensors are little devices with rods connected to the suspension. Check them out and you should be able to troubleshoot the problem. They are also involved with DSC if you have that, so watch out for a DSC light as well.
  • I recently purchased the RX-8 and at less than 600 miles the transmission failed to where the car would only stay in 2nd gear. The traction control light came on and the engine light came on. I brought it to the Mazda dealer and they have had it for 6 days now. Every day I call to check on the car and every day they tell me their still doing diagnostic and can't figure out what the problem is. They said they talked with Mazda regional support and no one can figure out what to do. I've owned a Infiniti I30 for over 3 years now and I haven't had a single thing go wrong with that car. I considered the G35 before buying the RX-8 and it looks like I made the wrong decision. Has anyone else had a similar transmission issue?
  • bigmike5bigmike5 Posts: 960
    Is your car an automatic tranny? If so, the 2nd gear lockdown sounds like a problem with the in-put or out-put sending unit that controls the tranny. [Assuming that they have the same kind of set-up as most American cars.] If it is one of the little sending units [the ones for my 300M cost less than $20 each], they should be able to fix it easily, unless it is located inside the tranny housing on the RX-8. Just my guess, but you might mention tranny sending units to them and see if they have checked them out.

    Graphicguy- You were right on the horrible around town mileage on my new Vette. Darn, I am getting 24.5 mpg around town, compared to 30.4 mpg on the highway. I attribute the lower gas mileage to increased gas peddle travel from dusting upstarts at lights. lol
  • Yes its an automatic. They said everytime they try and fix it it just breaks again. So they think its an electrical short. But they haven't been able to find the short and its now been a week.
  • pokadotspokadots Posts: 10
    My engine light came on they say I need a new cadilitic converter. Not familiar with this but
    can the car drive safely for an extended period
    of time without the same.
  • graphicguygraphicguy SW OhioPosts: 7,142
    Engine light doesn't mean you need a cat.

    Drive it to your dealer (if the car is driving OK). If you've got plenty of oil, and it's running OK temperature-wise, driving it shouldn't be an issue. They can hook it up to see what the codes tell them. I doubt it is anything very serious, though.
  • qbrozenqbrozen Posts: 17,210
    well, when he said "they say i need a new cat", I assume "they" is the dealership. but maybe not.
    If it does need a new cat according to the dealership, that's very odd for a new car, is it not? Is it a manufacturing fault in the cat or is something else wrong with the car that caused the failure? That's the question I'd be worried about.

    '13 Stang GT; '86 Benz 300E; '98 Volvo S70; '12 Leaf; '14 Town&Country

  • Sorry not clear they means dealership.

    The dealership ordered new cat converter and it will be installed tomorrow. I was surprised that at 1500 miles that it would need this kind of service. Anyway the dealership said I can drive car. Also, they were very nice about it they have a loner car lined up etc.
  • graphicguygraphicguy SW OhioPosts: 7,142
    Ahhhh....now, I understand.

    Yes, very odd that the cat would be bad. Were there any warning signs, or did it just go out all of a sudden?
  • pathstar1pathstar1 Posts: 1,015
    is not that uncommon. The flooding etc. that occured pre "M" flash took out a few cats. Should be on warrenty. Depends on state or province, but I believe the cats. are covered on warrenty for quite a while.
  • will let you know how car runs. Hope this car was not victim of flood. I just lost a 6 month old M 45 with 2000 miles in a flood.
  • Took my Oct/2004 RX8 6spd...for 7500 mile sched maint....they did the M flash, bt never mentioned it to me....not really complaining just thought it a little odd that there was no ref to it on my paper work.

    I do have the sticker on the underside of my hood w/ the id# ending -M...this is hand written.

    So far I see no improvement in my 16 MPG ave I had before reflash....drove until light came on and then filled up....we'll see...I'm no lead foot and shift in the 5K-6K range with a once or twice a day romp into the 8K+....16 MPG is pretty rough on the wallet running premium gas, but love the cars handling....damn temp knob on AC is falling off....first year production bugs I figure....
  • You might want to try a couple of things. If cost becomes an issue--use regular gas--I've been using it for some time now, and I can't tell if there is any preformance difference.Two, try shifting under 5000rpm during normal driving.I believe somewhere around 5-5.5k larger injectors become activated so more gas gets used. That some people get 16 mpg and most others 19mpg is interesting. I have never gotten milage that poor even when I push it hard,and I mostly use the 1st four gears.
  • graphicguygraphicguy SW OhioPosts: 7,142
    While I don't practice this technique often, and I only do it while stuck in heavy traffic, you can also try skip shifting.

    That is, I would do a 1st to 3rd to 5th shift sequence. Most in-town cruisng is done in 5th gear anyway.

    Like I said, I don't do it often and only tried it a couple of tankfuls and only with in-town driving, but I hit 19 MPG by practicing the skip shift technique both times I did it.

    On the other hand, if I'm only accelerating moderately in the first 3 gears and getting into 5th quickly (which I find perfect for in town cruising), I can net 18 MPG.

    Highway driving always yields "low 20s" MPG if I stay in 6th (with occasional speed bursts downshifting to 5th or 4th when challenged). I've hit 25 MPG on a tankful in all highway driving in 6th driving 75 MPH with cruise control on.
  • Well....b4 9/2004 I was crusing along in the 3-4K rpm range for everyday stop and go...after M flash I tried chuging it around in 5th and 6th gears....as lng as i was not below 2K rpm I shufted to lowest gear I could...mpg is ave around 19 for month of Sept...am I chugging to low?...of course to have any fun ya gotta zip it up and shift away, but doing so sucks up some fuel...its a sports car so I aint too suprised...seems ya want 19+ mpg or better means driving it like your aunt Jo-Anne who's idea of fast is into the Sizzler at 4 and out at 5:15...
This discussion has been closed.