Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Toyota 4Runner Maintenance and Repair

1676870727383

Comments

  • tidestertidester Posts: 10,109
    if it is the alternator, are there any tutorials online that i can follow?

    If it is the alternator your only practical alternative is to replace it.

    tidester, host
    SUVs and Smart Shopper
  • jpp5862jpp5862 Wilmington, NCPosts: 377
    I have an 06 SR5 4X4 V6 and this same thing happened to me this morning. I started the vehicle and the Check Engine light stayed on, then about 5 seconds later the VSC TRAC, VSC OFF and the indicator that shows the traction system is active (a car with wavy lines behind) all came on, I restarted the vehicle but the lights stay on. I'm only at 16,700 miles so it's under warranty but wondering if you got yours resolved easily.
  • I have a 90 4runner V6 i was trying to give it a tune-up but the timing mark is advancing as i hold the timing light on it. It is moving slowly and constantly in a counter clockwise direction it will move out of site then slowly appear again from the other side and repeat. It is almost like the pulley is slipping on the crank but the bolt is tight and the engine is running fine. Has anyone got any ideas?
  • I'm having the same issue with my '99 4Runner. First thought is alternator, but not sure either. Brake light comes on when I first start the car and eventually blinks out. Let me know what you find. I plan to test my alternator this weekend.
  • Hello, I am new to this forum and recently purchased a 2000 4runner limited 4x4. The 4runner only has 81K miles on it and is in great shape. I have had it for about a month and noticed a squeaking sound this morning. It sounds like it could just be a simple belt because it goes away when I hit the gas. I didnt know if it would be the timing belt since I havent hit 90K yet.

    Any suggestions?

    Thanks again,

    Rob
  • Sorry for the late reply.............

    You'll need to make a jumper wire and connect it between E1 and TE1 or (T) in the check engine connector.
    This is located next to the fuse box in the engine compartment.
    After it's "jumped", you'll be able to check your timing.

    Hope this helped!
  • I guessing that your alternator is fine....check the parking brake lever/pedal. Move it around when you see the brake light on.
    If it goes out, you've found the problem...the parking brake switch.
  • Rob, take a bottle of soapy water and spray the belt when it's making noise. If the noise goes away, the belt is the culprit.
    If not, remove the belt and spin the different components; alt., idler pulley's, etc. and see which one is squeaking.
  • I did that before I started but thanks for the input.
  • First of all I have a 2000 4Runner 3.4lt engine v6.

    Secondly, everytime I go to refuel, the gas pump stops pumping short of 2-3 gallons. If I wanted to maximize my fuel tank capacity (for long trips), I would have to constantly squeeze the lever on the gas pump for at least 5 minutes (very annoying). I've used different gas stations and went as far as to checking the vent system of the gas hose and still nothing.

    Finally, I'm getting real poor gas mileage. I've checked spark plugs, had the oil and air filter changed and tire pressure checked. I'm currently in the process of putting fuel cleaner in the tank.

    By the way, a couple of months ago, on the way back for a trip. I was driving through the desert and stopped off at a gas station to get some drinks. After a few minutes have passed by, a couple of guys walked in and said that they saw a 4Runner spill alot of fluid. I didn't think anything of it, but later on while I was driving, I noticed that I was missing about a quarter tank of gas. I thought I would mention this fact because the poor fuel issue started right after this happened.

    Any ideas or suggestions as to what I can do to solve both problems?
  • Does anyone have them on their 4Runner? What do you think of them? How many miles? Would you get them again?
  • I've had Revo's for 12,000 miles. They just started getting loud, but are wearing well. Road noise is my #1 complaint with my 4Runner, and the Bridgestones just make it worse. My mileage has dropped 2-MPG versus the factory Dunlops. Traction is very good, but the stiff Revo sidewalls don't help the ride at all and I question what traction I'm gaining when it feels as though I'm bouncing down the road because the tires have no give in the sidewalls.

    Michelin just came out with a new all-terrain in our factory 17" size you might want to look at. Last but not least, my next of tires will be Michelin LTX MS. Everyone I know who has them love them as they're quiet, wear well, and give overall the best traction available. I'll have to change the tire size to P255/70/17 as the LTX MS isn't manufactured in our factory 17" size.
  • nedzelnedzel Posts: 787
    I replaced my Dunlops with Michelin Cross Terrains. Not cheap. They are not aggressive, so if you're going mudding get something else. But they work fine on the highway and on the beach. I use dedicated snow tires in the winter, so I can't comment on how the Cross Terrains work in the snow -- the Dunlops sucked hard in snow.
  • I was shocked to find that a shock began leaking ,16,000 freeway miles .Excellent warranty service at dealer in grants pass, oreg[was vacationing near there} Anyone else with similir failures? absolutely no wheel shake at any speed,as others have descibed. michelin crosses came on my 07 (had they not i would have put them on)and i drove them on a nissan pathfinder i owned, good in snow and never once a tire failure.
  • chuck1chuck1 Posts: 1,405
    With the thousands of 4Runners sold each year, and the thousands of parts used to create such a vehicle, a bad part is bound to happen every now and then.

    I wouldn't be "shocked" over the shock!
  • Your words are true,anything man-made will and can fail within moments upon its completion.
  • tidestertidester Posts: 10,109
    anything man-made will and can fail within moments upon its completion

    Apparently, your computer and the internet lasted long enough for you to post that message and you're obviously a very fast typist considering your keyboard survived long enough for you to type that sentence! :P

    tidester, host
    SUVs and Smart Shopper
  • rsmith8rsmith8 Posts: 47
    I have 50K miles on my '04 Sport Edition V8 2WD and was looking at maintenance items. Up until now I haven't done anything but change the oil/filter and have the tires rotated every 5000 miles to satisfy the 100,000 extended tire warranty requirement - except today I did have the serpentine belt replaced because of cracks, the throttle body cleaned and the differential fluid replaced at the urging of the dealer. (Dealer said transmission fluid change was NOT needed due to WS grade of fluid used. Also, he said it was not necessary to replace the coolant as this model has the ultra long life coolant.) Same battery, working fine even in the Texas heat. Same brake pads. Plenty of pad left per the most recent checks at the dealer.

    Believe it or not but I am still riding on the OEM Dunlops and per the last service, they still have 6/32" of tread, so I may just give up on ever getting a warranty replacement set and buy some new tires as handling is getting pretty sloppy. Getting 4 new Dunlops is by far the least expensive solution as the spare has never been on the ground. Has anybody had experience with Continentals? I never get offroad and rarely tow anything. Gas mileage is good (computer says 21.8 overall - and I know that is an inflated number, but ballpark). Road noise is minimal with the Dunlops. I'd hate to spend a ton of money and get significantly worse mileage and/or have a lot of road noise. Also, I cannot believe that the maintenance items NEVER mention replacing a fuel filter! Doesn't it have one? Surely, this is something that should get replaced sooner or later. Comments?
  • chuck1chuck1 Posts: 1,405
    You sure must drive easy to get that kind of miles out of the "Dunflops".

    You can check tirerack.com for reviews on the tires. Generally, the Continentals on passenger cars get extremely poor reviews. A good indication of mpg of tires is how much the tire weighs, while this isn't everything, a lighter tire "in most cases" has lighter rolling resistance.

    I spent the nearly two hundred dollars per tire to get the Michelin Cross Terrains, easily one of the best highway tires on the market for SUVs. Very quiet and very smooth.

    Good luck on whatever you decide!
  • I have almost 75 K on my Dunlops. Not sure what to get next?
    Either LTX and change size or the Cross Terrains. I drive 90% highway in my Sport Edition V8.
  • I have a 2004 Limited with 51,000. I just replaced the OEM tires (Bridgestone H/L) with Bridgestone A/T Revo. I really didn't need to replace them this soon, as I had plenty of tread left on the OEM, but I had my eye on the Revo for awhile now. Check them out on TireRack.com. They are a little pricey, I got them for $170/tire.
  • nedzelnedzel Posts: 787
    I replaced my Dunlops with Michelin Cross Terrains. Very expensive tire. I can't say that I've noticed any significant difference in the ride or handling. I think they are a bit quieter, though.

    I haven't driven the truck in the snow with the Michelin Cross Terrains -- I've now got dedicated snow tires. I did drive the truck in the snow with the Dunlops and was suitably unimpressed. Acceleration in the snow was good with the Dunlops, but turning and braking were downright scary. The snow tires are much better, as expected.

    Both the Dunlops and the Cross Terrains do just fine on the beach. Neither are aggressive tires for mudding. Revos are more aggressive, but you'll pay for that in gas mileage and noise.
  • chuck1chuck1 Posts: 1,405
    I am surprised you don't notice a bigger difference. The Michelins have a stiffer sidewall and are MUCH QUIETER than the Dunlops.

    They are also much smoother at higher speeds.

    Good luck!
  • rsmith8rsmith8 Posts: 47
    I ordered a new set of Dunlop Grandtrek AT20s, 265/65R17, blackwalls, from Sears yesterday which, I think, are essentially the same tires that came on the 4Runner. Sears agreed to pricematch Sam's Club price at 110% of the difference. Total for 4 tires with mount and lifetime balance and tax was $473. I'll be surprised if I am still driving the 4Runner when these tires need to be replaced again. I expect to buy another 4Runner when the next generation somes out - eventually. I have been very satisfied with this one.
  • chuck1chuck1 Posts: 1,405
    That's a very good price for the tire package!
  • nedzelnedzel Posts: 787
    The Dunlops weren't that noisy when new. They did get noisier as they got older, however.

    I just don't see a big difference in the handling or ride. With either tire, the 4Runner rides pretty good, for a truck. It brakes pretty good, for a truck. And it handles pretty good, for a truck. But I'll never mistake it for anything other than a body-on-frame truck with heavy, solid-rear axle.

    Perhaps if I drove the two tires back-to-back on a closed course I would notice a greater difference. As it is, I think the difference is somewhat subtle (except for the reduced noise).

    The Michelin is a good tire, but it sure is expensive...
  • chuck1chuck1 Posts: 1,405
    AS I mentioned above, I tow a 21 foot travel trailer. With the Dunlops I noticed a lot more side sidewall flex when towing that I do with the Michelins. (The SUV wouldn't want to go in a straight line even when no wind).

    I think this goes to a little harder rubber and a higher tread wear rating.

    On the '05s and up you have giant rotors that I believe are like 13". These are bigger than some 1/4 ton trucks out there.
  • jpp5862jpp5862 Wilmington, NCPosts: 377
    Just to update, the dealer told me this was due to the fuel cap not being on tight. I challenged them on that due to the fact that the Traction Control system lights were all on as well and they said that didn't matter, that having a loose fuel cap will turn them all on. Sounds fishy to me but for $50 they turned the lights off. :(
  • chuck1chuck1 Posts: 1,405
    I agree, I can see the check motor light coming on, but not the Traction Control as well.

    So - I am assuming the dealer hooked up the truck and pulled a computer code? If so - what code was it? Usually the paperwork will say what codes were stored in the computer.
  • rsmith8rsmith8 Posts: 47
    Tires I order at Sears arrived and were installed with several problems. First, the installer accidently broke one of the TPMS sensors. They ordered the part but it was going to take several hours, so I had them dismount the spare wheel and use that rim with sensor for the 4th new tire. I left the original, unused, spare tire to have it installed on the remaining wheel when the sensor arrived. I returned the next morning to have the spare remounted in its place under the back. The TPMS light stayed ON. They didn't know what to do to remedy and told me to take it to the dealer and they would reimburse the cost - assuming they had done something wrong. The dealer said the tire(s) would have be broken down so they could get the 'number' off the sensor so it could be 'reseeded' into the 4Runner's computer. They couldn't get to it today (Saturday), so I made an appointment for Monday AM. Hopefully, that will resolve the TPMS light and Sears will reimburse the cost. Otherwise, I will add a comment later.
Sign In or Register to comment.