Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Mazda B Series

11921232425

Comments

  • olson99olson99 Posts: 3
    I had to change the throwout berring in a 94 mazda 4x4 pickup, my dad and I pulled everything we needed and now there is one cable on the side of the transmission holding us up. It is the hydralic line that goes directly into the side of the tranny any suggestions on getting it out?
  • gentjohngentjohn Posts: 3
    I posted last week concerning the instruments acting up on my 1999 Mazda B4000 and have yet received a response. Let me try this. Does anyone know how the instrument is grounded. I think this is the problem, but can't be sure. If anyone know where and how the panel is grounded this would help in fixing the problem.
  • KCRamKCRam Mt. Arlington NJPosts: 3,516
    If you're not getting responses here, you may want to try posting in one of the discussions over at the Maintenance and Repair Board.

    kcram - Pickups Host
  • chad4chad4 Posts: 1
    I heard that you can stuff a small block under the hood of a b series. has any one done this and have any Idea of what I would need to adjust and change to get this to work?
  • I have a 96 Mazda B-4000 too.
    I have the same slippage problem, only during the cold months though . this has been happening to me for a couple of years, now that it is warm I have no problems. I have had my transmission serviced by a nationally know shop and they said they saw nothing wrong other than my fluid being dirty, it had never been changed! I also have a check engine light on, I just drive the darn thing like it is since that is the only problem I have had with the truck, please let me know if you get to the bottom of this mystery.
  • tc5tc5 Posts: 2
    I recently bought a '94 B-3000 cab plus with 85,000 miles. Since day two the truck won't start most of the time. The first time I thought the battery was completely dead until I turned it a few times and it fired up. I'm wondering if it has someting to do with the clutch needing to be fully engaged to start or if there's a loose connection? Anyone have an idea?

    :confuse: :confuse: :confuse:
  • screamerscreamer Posts: 2
    Gary.
    Have a 99 B3000 xtra cab with 4dr, 2 wd V6 w/5spd man transmission.
    Bought it one year old with 8K miles and now have 90K. Have had "NO" trouble....tuned up once....satisfied.
  • screamerscreamer Posts: 2
    I've lost one of my ignition keys for my B-3000 Mazda pickup...and have heard that dealers charge between $80 to $100 to make duplicates.
    Is there a way to program a cut key from a locksmith.
    It's a 2WD xtra cab 4 dr V6 5 spd manual.
  • steve31steve31 Posts: 3
    When I stop at an instersection or light, the RPMs pulse. The needle literally jumps.

    What do you think the problem is? ECM?
  • steve31steve31 Posts: 3
    Correction. the year is 2002. The whole truck jumps.
  • lesmorelesmore Posts: 2
    My son purchased a 1988 B2200 about 3 months ago. It has 200,000+ miles. Everything was fine until yesterday when he got home. After sitting for less than 10 minutes he decided he needed to go some place and when he started the truck it rev ved excessivley at start up. HE shut it off immediately and came and got me. We tried everything we know and everything the Haynes manual suggests but the problem continues. He can't drive it because were concerned the engine will blow.
    Any suggestions?

    BTW: Has anyone had trouble with the air filter housing filling up with oil? This cant be normal but nothing is mentioned in the Haynes manual and I've never heard of this problem before.
    Thanks
  • dbaukoldbaukol Posts: 2
    I'm having trouble after engine warms up. (runs good cold) I talked to the local parts house and he says there is a electrically operated chokestat to pull off the choke after warm up. Anybody run into this before? Also, when pulling up to a stop light, occasionally the idle is very fast until I go through neutral gear then idle slows to normal.

    If you can help it will be appreciated

    Dave
  • dbaukoldbaukol Posts: 2
    The engine runs after warmup like someone is turning the key off and on very jerky.
    I tried to edit the posting of the 1990 Mazda B2200 pickup (carb equiped) 4 cyl stick but could not so I'm posting another message.

    Thanks

    Dave
  • lesmorelesmore Posts: 2
    It turns out there was a secondary linkage back right corner of carb that had come loose. I reconnected it and all is well
  • jad1jad1 Posts: 1
    I own a 98 B4000 With a 4.0 5 speed. My problem is that since the oil has been changed it has developed a knock in the motor. the strange thing is that if you turn on the AC or put it under even very slight load the knock is not heard at all. The truck only has 70000 miles on it. Anyone have the same problem? What would the correction be? The dealer cannot seem to explain the cause of the knock.
  • dutchess1dutchess1 Posts: 2
    does anyone know how to change fuel filter (understand need special wrench) and how to change dashboard lamps.
  • tc5tc5 Posts: 2
    I recently bought a 1994 b3000 and am finding that as a taller guy (6'4") I am having a hard time with visibilty of traffic lights, etc. My field of vision from the front is better in my girlfriends Toyota Corolla. Any ideas on how to lower the seat? Thanks.
  • My 1998 B2500 pickup on a random basis between shifts of the transmission will not return to normal idle speed but sticks at approx. 2500 rpm. When I come to a complete stop it will return to normal but when I return to the road it will continue to do the same thing unless I fully turn the key off when I am stopped. Evidently this restets something. I have been told that a computer reflash might fix the problem. Anybody have any different ideas what the problem may be or had a similar experience?
  • birdbillbirdbill Posts: 1
    When engine is cold, under load, about 1,500 to 2,000 RPM's the engine cuts out. I was told by a Mazda mechanic that the fluid needed changing in the torque converter, but it does it when brake torquing also. Any suggestions? I sprayed the plug wires with water when running and found no problem.
  • I have a 1994 B4000 Mazda truck with 4.0 liter and code 332 is set after 10 to 15 miniuts of driving. I have reset the computer by taking the battery cable of and turning the ignition switch on and still the check engine light comes on. I pull the codes and 332 comes up. I replaced the EGR valve and still get the same code after re setting the computer. The symptoms are rus rough and surges at cruising speed. Can anyone help?
  • i had a similar problem a few weeks ago.....but my problem was that the truck would turn over like crazy, but wouldn't start. i ended up having 2 sensors (i believe they were a cam sensor and a crank sensor). after having the sensors replace it starts up with no problem. your sensors may be wearing out. hope this helps.
  • I have the same problem with the same model, only the high revving is not random, it's pretty much all the time now.

    I just replaced all the plugs and wires - maybe it's worse now.

    Previously, a service manager at the dealer said to clean the throttle body of carbon build up. That seemed to help 20k miles ago, but have not tried it again lately.
  • I have a 1994 Mazda B2250 SE-5 and it makes a coughing sound when i release the gas. What should i do?
  • Hi I own a 1989 Mazda B2200 and everything is fine on it except that when my dash lights dont work. And when i push on the brakes, the blinker lights on the front come on, but dont blink...(not that they are supposed to anyway.) i need help cause i cant drive at night with the lights out. any suggestions on this?
  • 2002 B3000 V6 4x4 when turning switch on dash board into 4 high or 4low I have no reaction. Will not go into 4 wheel drive, indicator lights will not illuminate either.
    When turning key to acc. position the 4low or 4high indicators will not illuminate as they should like all other indicators do,(air bag, seat belt , batt, gruise etc...)I have checked fuse panel near drivers door and the one under the hood next to firewall all seems o.k.. Does anyone have any ideas? Or has anyone seen this problem. Would appreciate any and all suggestions. My mechanical knowledge is average.
  • chef11chef11 Posts: 1
    I am not sure if any one has responsed to you but I had the same problem. The two thing that I did to solve it was I also replaced the EGR Pressure Sensor and with 94 there maybe alot of carbon build up in the top end I use some intake cleaner and sprayed it in though the intake and at the egr intake area after that the problem went away you also want to change your oil after you do this.
  • Did you ever find out how to do this? I am stationed overseas and there is no place that deals with the keys for my truck. I can buy a blank and have it cut but I do not know how to program it. PLEASE HELP
  • b4000b4000 Posts: 1
    does anyone know if you can lift a 2wd b4000. also if you know what size tires will fit on it. And what size rims
  • Is there any one who can tell me why my truck when it's cold starts to flood. Their will be black smoke coming out of the tail pipe. And then it will get slower and slower going down the highway until it just shuts off. I was told I need a new carb. bought one almost 500.00 and it still does the same, no better please help.
  • Dear Janselmi, I see that you are having a problem with your gas mileage, sorry, to hear that and I have a product that you might be interested in. If you are interested just e-mail and I will get back with you with more information. Lonnie D. Tanem
Sign In or Register to comment.