Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Lexus RX 330 Maintenance and Repair

1444547495061

Comments

  • sltpigsflysltpigsfly Posts: 16
    My car is also an RX330 with AWD. The service loaners in my area are RX330 with AWD as well. The dealer has had my car for a couple of weeks now and claims that they can't reproduce the clunking noise. There is a separate popping noise that they indicate is from heat expansion in the dash area. They weren't able to verify that noise either until the last time that I took it in for service. The service manager says that all RX330s do this, but I've had my car in at least 10 times for both of these sounds, and none of the service loaners have made either noise! I also have many friends who have the RX330 or the Toyota Highlander (the dash appears identical in the 2004 models) and none of them have this problem. I am very frustrated about this problem, but will suggest your fix to them. Otherwise, I'm ready to throw in the towel and get another car!
  • dandgdandg Posts: 86
    Hi all,
    have not posted since we bought our 04 AWDRX 330 but have checked in several times to keep up.It now has 45K on it
    Just recently had Radiator replaced (leaked-its a good idea to let them do it if suggested as the new ones is most certianly a different/improved type-we also recieved a $50.00 gas card from Lexus for trouble).They did brake booster and headlight etch then as well.
    Its at Lexus now as brakes have not felt right since the booster was replaced (low pedal) and quoted $425. for pads and resurface rotors in front (we are buying parts and having Toyota dealer do it-bought the "lexus" pads,shims from dealer(@typical overpriced $113) as suggested by the Toyota service manager-claims some of the Toyota pads are not exact fits and they will do for $176.00 saving $130 !
    Also quoted $900 + for tires,Michelin's.
    Any ideas for best price?? Sams, BJ's???
    Its a AWD and after 45k I figure tires and front pads is all I have had to buy for it (except oil changes of course-been doing Mobil 1 with Toyota filter at friends shop for free)
    Thanks in advance
  • steverstever YooperlandPosts: 40,171
    Also quoted $900 + for tires,Michelin's.
    Any ideas for best price?? Sams, BJ's???


    Check out Tires, tires, tires for suggestions too.

    Steve, Host

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • dandgdandg Posts: 86
    ended up going with Sams, they where cheapest even with special order,which you can do online, at 755 installed(if you use the Sams discover knock off another 15=740)
    Tirerack was $5 less per tire but by the time you add shipping and install (two of the reccomended installers where not to hot on doing it-kindalike bring a steak to restaurant I suspect)it would be 784.
    both Bj's and tire w/house where a good bit more and the dealer was 975!!!dont mind a bit more but damn 225 is to much.
  • leslexusleslexus Posts: 1
    I purchased a used 2005 RX 330 less than 2 months ago with only 18K on it - Certified from a Lexus Dealer.

    My parents have an 2004 so I am familar with driving it.

    The following has occured 3 times now:

    At speeds between 60-70mph the car all of a sudden gets very rough and stops accelerating.

    The whole car begins to shake violently and make loud clunking sounds.

    I have to full off the highway.

    The care feels like it is either running out of gas or I am stauling out.

    The first time the dealer said nothing wrong, but we'll change the brake pads and udate the software for the transmission.

    A week later it happened again. After being in the shop for a week with technicians driving it (putting 130m ont he car) they said nothing wrong, I must have had "bad gas"

    Now it is a week later I just got back from a weekend trip in which case it happened again. This time the sterring wheel shimmied for about 3 minutes before the entire car clunked and started shaking violently.

    It is truly very frightening. No warning lights are coming on and the dealer insists the car is fine! I am scared to drive it! I think it is the transmission, but the dealer thinks I'm just nuts - thankfulling it has happened with serveral people in the car to witness it, but I just want my car to run properly!

    HELP!
  • wwestwwest Posts: 10,706
    Sounds as if the VSC or traction control is activating when it should not. Next time it happens immediately pull, disconnect, the MAF/IAT connector while the engine is running and then reconnect it after the engine dies. The VSC/Traction system will now be disabled for a few drive cycles due to the resulting CEL.
  • JBaumgartJBaumgart Posts: 890
    Just had a rather unusual problem taken care of by our Lexus dealer, and was wondering how widespread this issue might be. At around 42,000 miles the hood (over the engine compartment) would not stay open when lifted. It took about 4 days for the parts to come in and the dealer fixed it in about an hour, under warranty. Otherwise, our '04 has been trouble free.
  • btill1btill1 Posts: 69
    My wifes 04 with about 40,000 miles had the same problem they needed to replace the"shock absorber" that holds the hood open. All done under warranty during routine maintenance.
  • JBaumgartJBaumgart Posts: 890
    Interesting - must be a poorly designed or defective part. Over the ~42,000 miles since buying the car new we haven't opened the hood very often, since the dealer has done all of the servicing. The car doesn't seem to use much oil, so I don't check the level more than once a month. You would think that given the rare usage the hood's "shock absorber" would easily last for the life of the vehicle.
  • s6926s6926 Posts: 1
    I'll begin this by stating I'm not a car expert but thought sharing my experience would be helpful to others:

    Brakepads/rotors: My Lexus RX330, approximately 25K miles, shook slightly whenever I braked on the highway. I took it in and the dealership stated that the rotors needed to be resurfaced and that this was not a defect in the car. This just didn't sound right so I did some research and thanks to "cotmc" I too phoned the national service number and the rep indicated that there was a service bulletin out for this issue and stated that the replacement of the rotors and brake pads would be covered under warranty.

    Radiator: There was a recall for the radiators about a year ago. My car heated up so I didn't find out until it was too late. First syptom was not the temperature gauge but rather less than cool air blowing out of my air conditioner.

    Hope this is helpful.
  • tadeusztadeusz Posts: 1
    My 2004 RX330 has had all the latest transmission software updates, but to no avail the gearbox still hesitates at low speeds and when it engages it does so with a pronounced ‘thud’. And now the transmission has developed a ‘whining’ noise at the start of gear engagement that lasts for a few seconds and the goes away. The ‘whining’ is most noticeable during ‘stop-and-go’ road conditions (traffic jams). The ‘whine’ also is appears when I take my foot of the accelerator.
    I have demonstrated this gearbox ‘whine’ to the Service Manager at the dealership, who had no answer and is going to check with Lexus Service to find out what could be causing it and what the corrective action is.

    Has anybody experienced similar symptoms?
  • daltmayerdaltmayer Posts: 1
    Thanks so much! I just wanted to let you know how helpful this info was. I have a 2004 RX330 with just over 30k miles. I noticed the steering vibration about a month ago and it's become increasingly worse. I decided to try a search to see if others experienced similar issues and found this posting. Long story short, I printed the TSB bulletin and called the Bellevue, WA Lexus dealership. They had me come in and I gave them the bulletin info. Two hours later, the brake parts and service was done free! No hassles or questions asked. Now, I'd like to think that I would have had the same outcome without this info, but I'm not so sure it would have happened. Thanks for sharing the info and keeping my wallet intact!
  • woody11woody11 Posts: 3
    My 2006 RX 330 has 10,000 miles and has been great except for a really squeaky rear-armrest when in the upright position. It's the leather rubbing against leather. I asked the dealer and they said it's common and there's nothing they can do. I need to keep the armrest up because my dog travels in the backseat. I had two other annoying noises they were able to fix right away: a dash rattle and the rattling of the cargo cover. Does anyone have a solution for the armrest situation? Thanks.
  • I haven't had the RX330 a week. The only problems I've had is mainly from the seats. My back hurts every time I get out of the vehicle. I'm only 26, and I'm not carrying anything in and out of the vehicle. I have noticed the common "rattlin' dash and seats". I just turn up the radio when I hear it. I am starting to wonder about the BMW X5. It seems to be much more sporty than the 330.
    :confuse:

    ARE THE SEATS UNCOMFORTABLE TO ANYONE ELSE?
  • alolewisalolewis Posts: 36
    Nope, I find my seats every comfortable, perhaps you need to play with the adjustments til you find a position that doesn't hurt?
    Sorry couldn't be more help.
  • avery1avery1 Posts: 372
    I'm 6'4" and have an RX 300. I am susceptible to back problems and I find I can drive all day and not have a problem.
  • I'll try... Thank You
  • This is my first really nice car. I think I'm just freaking out. While in Park the battery, oil, and check engine light are on. When I start the car it goes away, but are these lights "supposed" to stay on while the rx330 is in park? I was told by a lexus dealer that they weren't then told by another dealer that they were. I'm unsure.

    Please Advise

    Jazmine
  • avery1avery1 Posts: 372
    I forgot to mention that I keep the back of my seat almost straight up. Fortunately I don't have a sunroof so I can do that and not hit the roof.
  • alolewisalolewis Posts: 36
    If the engine is not running and you turn the key to the run position, I believe those lights will stay on. I am not at home now or I would check my 2004 RX330. It makes sense the lights are on as the battery is not charging, the oil pressure is less than the sensor is set at, etc.
  • lvn098lvn098 Posts: 26
    When the vehicle is placed in park, the ignition turned off, and the key is removed from the ignition, does the driver seat suppose to pull back? I thought it was working for me at one point, but now it just stay where it is. What did I do wrong and how to set it back? Thanks,
  • beubeu Posts: 4
    Adjust the lumbar support to give more support. Even if it doesn't feel comfortable.
  • petej2petej2 Posts: 13
    has anyone heard of cracked winshields due to hot weather and A/C use? I have a large crack by the seam on the A pillar. Started on a 100+ day when i turned A/C on
  • Had a very annoying persistent rattle, thought it was from the rear hatch. Opened hatch, opened the 2 storage compartmensts under rear floor, repositioned the Lexus first aid kit, closed everything back again, and the rattle dissappeared!!! Now our car is great to drive.
  • chea89, the saleswoman just happened to put
    my first aid kit on the wheel well in the
    storage area since it has a velcro strip to
    stick on anything. No squeaks or rattles to
    report on my RX350 which I've had for two
    weeks and three days!
  • wwestwwest Posts: 10,706
    there is a fairly serious design flaw in the Toyota/lexus automatic climate control system that results in chilled airflow, possibly VERY cold airflow, being routed to the windshield during times of primary cooling use. You must therefore be SURE not to use the full or partial windshield defrost/defog/demist mode at anytime the windshield might be HOT from long exposure to bright sunlight.
  • md52md52 Posts: 20
    Steve/Tidester

    Do you (or anyone) know of a link that shows a pic of the damage caused to an RX330 as a result of headlight theft? I seem to remember that someone a while ago had posted a link to an article about the headlight thefts that had a pic but I cant seem to locate it. I think the damage to the front bumper and hood is pretty severe.

    Thanks for your help....
  • tidestertidester Posts: 10,110
    I don't recall seeing one for the RX300 but I did come across this of an Audi from Google.

    tidester, host
  • steverstever YooperlandPosts: 40,171
    All I can find is a photo of some Audi damage:

    Carpundit

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • I, too, encountered a cracked windshield on my 2005 RX330.
    Neither my wife, nor I, knew of any road damage and there was no sign of any rock impact. The crack began directly above the defroster vent on the passenger side, and grew quickly in the heat. I live in Texas where we have experienced numerous 100+ degree days this year.
Sign In or Register to comment.