Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Lincoln Aviator Maintenance and Repair

1424344454648»

Comments

  • 04avi04avi Posts: 9
    Ok here is my problem 04 aviator engine runs at constant operating temp and has plenty of fluid. I have flushed the heater cores and replaced the thermostat. Heat only blows hot when engine is at rpm when at idle in driveway at stoplights etc air blows cold. Blend door seems to be operating fine I have read there is a valve in line on one of the radiator hoses but cant seem to find it anywhere. Also bought a heater control valve from auto parts store but havent installed because i cant seem to find where it is supposed to be located. Any suggestions
  • kartracer8kartracer8 Posts: 2
    edited February 2013
    Mine did the same thing, remove the engine cowl cover across the front by the radiator is metal tube with plug in it. A 1/4" drive is needed to remove the plug, mine took some heat from plumbers torch to break it free. Careful not to get to hot, there is an O ring on the plug

    My tube was empty, I filled the tube and squeezed the hoses on both sides until the bubbles stopped and tube was full. Lube up O ring and put back together

    Solved my low idle cold air problem, always hot no matter the RPM

    Hope this helps your problem
  • dwcraigdwcraig Posts: 1
    Hey guys I just made an account to post this. My grandfather just passed and I'm planning to buy his aviator for 10,000. I don't know the year of it but it has 23,000 miles on it.

    Just wondering what things I should look out for on this vehicle that may be a sign of an issue.

    Thanks
  • bostoncigarbostoncigar Posts: 23
    You will have to do a engine rebuild prior to 50K miles. This engine has a problem. Spend the grand and buy an extended warranty.
  • akirbyakirby Posts: 7,665
    If the compression in cylinder 8 is good you may be ok. Otherwise you'll need a new head (not a complete rebuild). If you can get a powertrain warranty it would be recommended if you want to keep it.
  • aviator04aviator04 Posts: 1
    When starting my aviator it runs just fine after starting it and shutting it off a few times I will go to start it again and nothing. Everything and I mean everything works but it won't even try to turn over. I've checked fuses fluids and everything else I can think of I was just wondering if anyone else has had this issue or if anyone could possibly shed some light on this for me.
  • tsleddtsledd Posts: 1
    Did you ever get an answer to this? I have the same problem and nobody knows where / how / etc

    Thanks Ted
Sign In or Register to comment.