Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Lincoln Town Car Maintenance & Repair

1202123252637

Comments

  • hi, I have a 1998 Town Car that I recently came out to and found a dead battery. After recieving a jump and driving for 30 mins everything seems fine, except the message center seems to now be stuck on "average fuel comsumption" in the dash display, where there used to be a selection other attributes, my favorite being distance to empty..Any advice on helping me restore this would be very appreciated.
    thanks
    Matt
  • euphoniumeuphonium Great Northwest, West of the Cascades.Posts: 3,344
    Our '94 dash display has a "Reset" button. If you have one, press it. If no Reset button, remove the Negative battery cable from the battery for about five minutes and the computer may automatically reset everything for y ou. It will even wipe out the radio station settings, but they can be re installed easily.
  • euphonium, thank you for your reply. my 98 does in fact have that reset button, it didnt do anything..as did the other button..it seems "stuck". I will pop off the terminal and see what gives upon reconnection. stereo settings = minor..thanks for your advice
  • Hi, let me start out by saying I know absolutely NOTHING about cars..I just bought a 90 Lincoln towncar with a rebuilt engine has 150k miles on it. About a month ago it started hitching and jerking when I would hit the gas peddal but it wouldnt do it all the time. It was once in a while. Now when I hit the gas, the car feels like its dragging anchors behind it, and it hitches really bad. the entire interior shakes,it makes a kind of popping sound when the gas is depressed, but if its not then the car is fine. It loses speed after I let off the gas, but doesnt make the noise or anything like that. Sometimes I start my car and its fine, it runs great no dragging etc, other times it runs like its dying. I've tried fuel/carburator cleaner/ fuel injector cleaner but no luck. I've checked the tranny fluid, doesnt look or smell burned, and it doesnt have a problem switching gears, but I do notice that when I try and speed up the car has no get go to it unless I floor it sometimes. My uncle suggested maybe the throttle position sensor? I dont have any warning lights come on or anything like that. Can anyone help me?
  • euphoniumeuphonium Great Northwest, West of the Cascades.Posts: 3,344
    Have you replaced (changed) all of the filters that are on the car? I believe there is an inline gas filter located on the side between the front and rear wheels, but I forget which side. There may be another gas filter just before the fuel line goes to the throttle body. A very dirty air filter should be replaced. Check out the throttle body spacer under the throttle body and above the intake manifold. If that's shot, it could contribute to your symtoms. Spark plugs and wires may need to be replaced.
    You have a 302 engine that powered Town Cars from 1980 to 1990 so there should be many experienced mechanics out there to diagnose the problem. Good Luck.
  • jayg2jayg2 Posts: 10
    Was wondering if anyone could help me out. Replaced my gas tank in a 1988 Lincoln Town Car. Used a sending unit from a 87 Town Car. Sending unit works but I have no power going to it. There is a black and yellow wire. Both seem to be grounded. Does any one know where the yellow or black wire go to? All fuses are good. Don't know where the power comes for the sending unit. Thanks,
  • friltcfriltc Posts: 1
    please help me.I have the same problem.my 1995 ltc won't
    shift when the power is on key falls out of the ign.
    how did you fix your car?
    thanks
  • euphoniumeuphonium Great Northwest, West of the Cascades.Posts: 3,344
    it is time to have a new key made by the dealer.
  • ajs26ajs26 Posts: 8
    I've googled and searched for a while and cannot find anything.

    I'm just needing to know what types of transmission fluids are compatible in a 1994 Lincoln Town Car.

    Thanks.
  • euphoniumeuphonium Great Northwest, West of the Cascades.Posts: 3,344
    Mercon V, a semi synthetique, rather costly, but worth it if you keeping your TC for a long time. Drain the torque converter and change the tranny filter while your at it.

    Drain the fluid in the rear axle and replace it with a Synthetique as well.
  • I have a 98 Signature Edition with 115K on it. Recently the following problem appeared - sometimes when you start it up the idle is so low it dies immediately unless you keep the engine racing a bit, other times it starts fine, stays running but has a surging idle - up then down then up then down. Any ideas anyone? I don't want to take it to the dealer and face a huge bill unless I'm prepared for it in advance.
    Second problem is that the Charging System light pops on for a day or so then off for several days then back on and then off. The battery is charged, never had a problem starting. just confused as to what would cause this, a bad sensor perhaps?
    I appreciate any help anyone might be able to offer. thanks.
    Craig
  • Try checking and replaceing the idle position sensor. They are not expensive to replace if you do it yourself. I bought a lincoln from a used car dealer and got it at a big discount because of simular idle issues. Cost me about $30.00 to fix the problem myself on the way home from the dealer..

    Most likley you have a broken and/or worn out brush in the alternator. Take it to a GOOD rebuild shop yourself. You'll get a much better alternator at a good rebuilder that just buying a rebuilt alternator at an auto parts store.
  • :confuse fuel comes back on you when filling,back pressure from filler tube,car warms up then wont start for 30 minutes
  • solved the fuel flying out the fill tube. The car wont start after its warmed up. It takes about 30 min then it starts right up. The mpg is about 26 and runs great the temp gage runs at a hair over half. Which #@$%()!&@^% sensor is it. Thank you very much
  • solved the fuel flying out the fill tube. The car wont start after its warmed up. It takes about 30 min then it starts right up. The mpg is about 26 and runs great the temp gage runs at a hair over half. Which #@$%()!&@^% sensor is it. Thank you very much 435,000 actual miles on car 3rd motor
  • Thanks so much...what you said makes sense to me...does the local parts shop carry a sensor like this or is it a dealer item?
    #2 - I've got a good rebuild shop in town so I will try that for the charging light problem.
    Thanks for the input!
    Craig
  • Any good parts house will have the sensor. It bolts onto the side of the air intake on top of the engine. Two screws and one plug. Easy to change.
  • I have a 1993 lincoln town car when i start the car in park and press on the break the gear shift will not let me put the car in drive,but if i turn the key in the auxillary postion i can put the car in nuetral and start the car then shift to drive.any help would be appreciated.
  • We are trying to buy a 1990 Town Car. The car has been sitting up for about 2 years. We tried to get it started today and we could not. You can put gas in the top of the motor to prime it and it will start, but will not continue to run. Please give me any advise you might have as to what needs to be checked or replaced to get the car running. Motor sounds good and runs good when you prime it, but it acts like it is not getting any fuel to the motor and goes dead. Any information would be so much appreciated.

    Cindy
  • euphoniumeuphonium Great Northwest, West of the Cascades.Posts: 3,344
    Perhaps the two year old gasoline in the tank has gummed up the electric fuel pump that is embedded in the fuel tank. Replacing the fuel pump in the gas tank is not cheap.
  • Fuel delivery problem, electric fuel pump,turn on the iginiton switch and listen for a whirling noise from the fuel tank. Try disconnecting the fuel line a the carberator and see if you are getting fuel. Also old fuel or even a dirty fuel filter. Ask the owner why was it parked for 2 years. A haynes or cliltion repair manual will tell you how to bypass the fuel pump relay to test the pump also.
  • Hi my name is Al,,,,, If your car will only run or start when primming it, make sure someone did not shut the shut off gas switch in the trunk to the off position, if this in not the problem then try to turn key forward one click but not starting with no radio on and quiet around you and listen to hear if you can hear the pump in tank sending fuel up from tank, also you may want to change the fuel filter that is located at rear side of car it should only be about 30-70 bucks to replace if u do it yourself....also take off breather on carb hold open chock with screwdriver turn key forward and have someone hold down gas peddel to see or smell gas going into carb, if fuel injected hold down gaspedel to flood it out this will tell you that gas in reaching injection, if gas gets that far then it might need to have plugs remove cleaned or replaced. If this car has been sitting for 2yrs then you might want to siphin gas out of tank or put 10 bucks of gas with some stableizer in the container with new gas and try that as well,....good luck let me know if this helped thanks.... Al
  • If you touch the brake does the brakes lights come on? If so, either a brake light is out or more probably the brake switch on the brake pedal is not working. My 2K did the same thing. My money is on the brake switch is not working to disengage the gear shift. DO NOT FORCE THE GEAR SHIFT :blush: , it will cost more money to fix it.
  • I had this same problem on my 2000 TC. The wire had burned off of the brake light switch. An easy fix. I just cut off the connector, and put regular spade lug crimp connectors on the wire and put the wires back on the lugs of the switch.
    You can shift out of Park if you pull on the gear shift while starting as the lock will release while in the starting mode.
  • :sick: Hi all, I have a '90 LTC. The brake lights are not working. I have taillights and signal lights just no brake lights. Checked the fuses, and bulbs everything is fine. Checked some forums and think it may be the brake light switch but I don't know where it is or how to fix it. :confuse:
  • Brake light switch is under the dash on the brake pedal. Most likley the wires are broken or burnt off.
  • I have a 1990 Town Car and the overdrive is completely gone. When it tries to shift into overdrive its like you shifted into neutral by mistake. I am getting ready to take it into a trans shop and wanted some input. Rebuild? Easy fix? Any ideas?
  • I have a 98 Lincoln TC and a couple of weeks ago an obnoxious rattle started under the hood. It seemed worse when the heater was on or the defrost. After about a week the Have Engine Serviced Soon light came on so I took it in. I took it in to a guy who works on air conditioning units and he says he thinks the compressor is going out so the whole unit will need to be replaced ($500). I think this guy is trustworthy but I just want to make sure other people think this is the route to go. He told me the belt runs the power steering and air as well as the water pump so when the belt gives, I will lose all that. Do belts go bad on their own and can you just replace a belt or does it sound like the whole unit needs replaced? Thanks so much for you help.
  • i replaced the switch but the fuse keeps blowing and i cant se any bare wires or find a short?
Sign In or Register to comment.