Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Lincoln Town Car Maintenance & Repair

1252628303155

Comments

  • nwraaanwraaa Posts: 159
    This model may not have a seperate flasher unit under the dashboard. I know that on the 96 model when I had this same problem I had to have the turn signal unit on the steering wheel replaced. You might me able to get one at
    E-Bay. They are not difficult to replace.
  • nwraaanwraaa Posts: 159
    In adddition to the other comments, have the blend door on the car checked. If the blend door is locked in the cold air positon you will not get heat. These doors have a sense of their own. When it is winter they stick in the cold position. When it is summer they stick in the heat position.
  • edsoledsol Posts: 2
    Only hot air blows from my A/C, regardless of setting, no cool or cold air.

    Even pushing the Vent button, I only get a rush of hot air.

    Please help!
  • I would take it to a shop you trust, and let them diagnose both problems.
  • edsoledsol Posts: 2
    Have cold air again...! Grinning...! :)

    Out of desperation, of fear, facing an expensive repair bill, I did the following:

    Opened all doors to vent the hot air, put one finger on the VENT button simultaneously pressing the AUTOMATIC button. Started de A/C, a few second later pushed the OFF button. Did this several times.

    The last time, the A/C did not start but a lot of blue numbers showed rapidly in the display, changing from 25 to 125 and then only some dots blinked.

    Then I heard a loud noise under the car floor and a sublime rush of cold air came through the vents...

    I hope this will help some one with the problem in the future.May save them some bucks from an unneeded repair.
  • The Lincoln Gods have shown you favor. Or maybe it was an exorcism.
  • Hi. Did you ever figure out what the problem was with "Check Trac" light. My 2000 is having the same problem. The transmision feels like its skiping everytime the light turns on" Please let me know. my e-mail is ldowling@szacorp.com
  • Hi. Did you ever figure out what the problem was with "Check Trac" light. My 2000 is having the same problem. The transmision feels like its skiping everytime the light turns on" Please let me know. my e-mail is ldowling@szacorp.com
  • Maybe...The problem kept getting worse until the transmission destroyed itself. Cost $1,700 to get it rebuilt but the original problems were still there! I got computer fault codes all over the place, with the most common being a cylinder 4 misfire. I changed the ignition switch because turning the key off and back on would often clear the problems. Didn't help. I changed all the spark plugs. They looked good except that number 4 (right rear) was rusty on the outside. This didn't change anything. I then changed the number 4 coil and the problem seems to be gone! I'll know for sure when I get a few more days and miles on the car. The problem was so intermittent and strange that I don't trust that it's really fixed yet. The spark plugs are under the coils on the top of the engine in a very deep hole. It's possible the heater hose might leak water into number 4, but I found no such leak. Now I think the misfire was happening because of the rust on the spark plug and coil boot, although I found no moisture in the hole or anywhere on the top of the engine, but there had to have been moisture there sometime in the past to cause all the rust I found. All other spark plugs looked great. Was this causing the main computer to try and compensate for the misfire by making the car surge and the trac light come on etc.? And was this surging not just the engine misfiring but the transmission shifting in response to the rpm changes causing my transmission to destroy itself? How in the heck did the temperature gauge always go off when the trac light came on? The trac is not in the transmission but the rear end I think. I still get a code saying the emission catalyst is below standards but I don't know exactly what that means yet. Otherwise the car is back running like new. I recommend you get this car fixed ASAP and do not do like I did and keep driving it until the transmission is destroyed. Please let me know if your number 4 coil and plug is the problem. This is so very strange..... :confuse: :)
  • :) the number u r looking for is a 5 digit number that is most likely on ur computer module.......have u look there
  • MY 99 TOWN CAR REAR LIGHTS DONT TURN ON BUT BRAKE LIGHTS DO WORK WHEN BRAKES ARE PUSHED .......SAME DEAL WITH THE FRONT HEAD LIGHTS ....DAY TIME LIGHTS WONT COME ON BUT THE MAIN HEAD LAMPS DO .........HAS ANYONE EVER HAD THIS PROBLEM AND IF SO WHERE SHOULD I START TROUBLE SHOOTING...... :mad: :mad: :mad:
  • Started last October to shut off when pumping gas. Took to dealership and replaced canister over $300.00 have returned and returned the last that they did was $151.00 to have manifolds replaced and it pumped one time and now you stand and stand waiting for it to fill. Click Click off it goes anyone know how to solve this problem???
  • What exactly is the problem? You are not clear about it.
  • euphoniumeuphonium Great Northwest, West of the Cascades.Posts: 3,320
    Suggest you fill the tank much more slowly than usual. You may have to fuel it just above the "trickle" level or adjust the nozzel away from the filler tube.
  • I can not keep the gas pumping in the tank. It shuts off you have to start pumping over and over does not matter how slow you pump it has a mind of its own. Cant stand out for 20 to 30 minutes to fill the tank.
  • nwraaanwraaa Posts: 159
    Hold the small plate open in the nozzle restrictor of the tank fill tube with a screw driver and look inside to see if there is an object blocking the flow.
  • biglbigl Posts: 2
    Hello, I have a 1995 lincoln town car, when the car is put into drive it revved up before taking off into other gears. I change the trans fluid and filter. Did tune up, plugs, wire and oil. I have a couple of questions , does the 1995 town car has a plug where you can change the torque converter oil, if so I know this need to be done,and is there any type of adjustment for the transmission to make it shift better. Or does anybody have any advice on what could be done to make 95 town car shift better. Or is their any switches or sensor that help the shifting of these car. Thank for all advice.
  • When I turn the switch nothing comes on It just happend like a fuse blew. Does any one know does the switch have a fuse.
    Also you know when you push the switch the enterior lights wont come on.
    But all the other lights work.
    The brake lights and hazards work. any help please
  • nwraaanwraaa Posts: 159
    The torque converter has a drain plug. The transmission has solenoids. It has a torque converter clutch solenoid and two shift solenoids. If these are not functioning properly, the transmission will not shift as it should. The solenoids are at the ends of the electrical wires in the transmission and are visible when you remove the transmission pan. If you endeavor to clean or replace these, be very careful.
  • nwraaanwraaa Posts: 159
    There is a fuse for the headlight circuit. Pull the fuse panel box cover, find the blown fuse and replace it.
Sign In or Register to comment.