Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Nissan Frontier 2005+

198100102103104

Comments

  • Well, picked up my truck today at about 10:15 this morning. I know you folks are going to laugh, and most likely call me an idiot, but damn I love this truck! I was so happy to get my butt back in my truck. Still hate freaking Nissan, but I cannot help it, I like my Nismo. I know I know....... I'm wondering about myself as well.

    That said, dealer feels bad for me even if corporate doesn't give a crap. Only charged me $95 even though they had many hours in it. I was very appreciative of their attitude. So, rolled out at about 10:15, ran by the house to load all of my work crap back into it (30 minutes after unloading all of that crap from the Dodge rental) and hit the road to continue my work day. Loved having my Nismo back under my butt. Now...... 88 miles and about five hours later, cruising down the interstate at about 70mph....... you guessed it............ freaking "Diff Lock" light and the "VDC off" light came back on!!!!! Within a few more miles all the remaining freaking lights came on!!!!! SSDD. Just &%$# me why don't ya.

    Yea, called the dealer. The service writer asked me to drive it tomorrow and call him later in the day to give him an update. If it's still doing it drive it through the weekend. SSDD, then back to the shop next week. His reasoning, "after what we did the system may still be resetting itself." I hate to talk junk about the dealer as I've been happy with them, but that reasoning sounds bogus to me. Since the "Diff Lock Position Switch" (per the repair order) is what had the initial fault code, I'd say just replace the %$#& thing.

    So, I've been sitting here the last half hour or so reviewing my Frontier electronic service manual. (I bought it after the wheel seal episode.) I've now printed off about 30 pages of "M226 with locking differential" troubleshooting/repair information to read at my leisure. I can already see one big problem though.... most of this junk requires the "Consult-II" diagnostic computer, aka dealerships high dollar toy. I'm hoping to simply order and replace the Diff Lock Position Switch myself rather than fight the aggravation of visiting the dealership yet again.

    One humorous bit, as I was turning in the Dodge P.O.S. this morning the guy totaling my bill asked me what Nissan I had. I replied "Frontier." He asked, "which one?" I said "Nismo." He said "Cool! I've been sort of thinking about buying a Frontier. How do you like it?" I deadpanned, "It's a total P.O.S." Then briefly recapped my service history/mileage etc. He looked at me and said, "you know, I've had quite a few guys come through here and tell me that about the Frontier. Maybe I need to think Toyota." I advised him to do so. You know, if Nissan corporate gave a crap I would not trash my truck to people. I would simply figure that I got the one in a million bad one. But since corporate doesn't care.... I don't care. If I can cost them even one sale I am happy.

    05nismo6.... I hear ya about the letter. Last go round I did get some response. I hammered them so badly with a couple of emails that some gubberhead tried for five days to run me down. We played phone tag continually. He finally caught me one day, so I proceeded to run though the whole experience. Total and complete waist of my time. They simply wanted to let me vent to a person. I wanted reimbursement for the wheel seal. "Ain't happening." So, we hung up with two end results. On his end, he marked my file "case closed." On my end I simply told myself "Those $#%*&@^ really do not care!"

    And the nightmare continues.....
  • lhuanglhuang Posts: 2
    Hi guys,

    I have my 2005 Frontier SE four wheel for almost three and half years. A few days ago, I found the engine service light was on and I had Nissan dealer at Richardson, Texas checked. The report says the fuel level sensor is bad (code P0463)and needs to be changed. The dealer charged me $101 for inspection and otherl cost is around $600 if the sensor get fixed. I cannot believe the truck has this problem with only 42,000 miles and I drive it mildly...

    Any thoughts and suggestion?

    Appreciate your responses!
  • I have the same problem. Only to make mine even better, because the sensor is bad the gas gauge has no idea when the tank is full or empty. I've decided not to fix mine right now, but I was quoted $479 to do so, because like any other day it's not the only thing wrong with the truck. It also needs a new radiator, the cheapest I could get anybody to was $638. That's right 82K miles, never been in an accident, and I'm adding to the laundry list of things on this truck that I've never fixed on another vehicle I've ever owned.

    Rear Differential sensor
    New Computer
    Window motors
    Rear axle seal
    u joint and drive shaft
    vent control valve
    Radiator
    Fuel level sensor

    Yeah Nissan
  • asaasa Posts: 359
    My fuel gauge sending unit went bad too in my '06, but thankfully I am still in warranty. When you get it fixed, be certain that your dealer is aware of TSB NTB07-006. It reads that if the fuel pump, fuel tank, or fuel gauge sending unit requires service for any reason, install the fuel pump protector from the Parts Information of this bulletin before final reassembly. I don't know what the pump protector does, but perhaps it helps aleviate future failures.

    Aside from this, my '06 SE has been good thus far, but I have only 18,500 Miles on it.
  • All,

    i'm in the market for a compact/midsize PU. been a dedicated Toyota owner for about 15 years, various models, including a 2WD 4 banger taco. noticed sites like edmunds and CR have said nice things about the Fronty so i put it on my list of possibilities.

    so, got my eye on an 06 SE, AWD, AT, 18k miles. a similar used taco would go for 4-5 more grand. i'm big on not having to repair a car every few weeks, it's the whole reason i went to imports anyway. to anyone's knowledge, is it just the NIMO's having issues, or are Fronty owners experiencing them across the board? aren't we just talking about suspension differences anyway, with the other mechanicals being the same?

    i know there's a couple of head to head comparison threads already, but my question is more specific to the reliability of the Frontier itself....

    TIA!
  • I'll be honest I have an '05 NISMO and while I love the look and style of the truck. I have at home 13 workorders for a truck that is 3 years old. This doesn't include brakes and other maintenance, it's been for parts that I've either never heard of or never had to replace on other trucks I've owned which included a Dakota with 100K, a Toyota Pickup with over 150K and a Tacoma with 90K. It is the most expensive vehicle to maintain that I have ever owned, brakes, air filters, and the high octane requirement. Granted I drive a lot, but mostly highway. Based on some of the posts I've read I don't think the issues are with just the NISMO's although that's where they seem to be prominant.

    Just my 2cents.
  • asaasa Posts: 359
    My Frontier is an '06 SE 4x2 CC 6-Speed and has only 18,000 Miles on the clock, but I've been well pleased thus far. Time will tell. It's sometimes hard to appraise most any vehicle on the Internet because far more people post queries about problems than kudos. The problems do matter and should be recognized, but I'd also research the Tacoma forums to see what owners are experiencing over there.

    I'd also sit in both, as they have distinctly different sitting positions. Many automotive publications have noted this too. If you're not comfortable behind the wheel, you won't like the truck no matter how well it runs.

    The '05s on both brands were their first year of the new design. I'd look only at '06+ models to hedge your bet. Good luck with your choice! :)
  • eman916eman916 Posts: 2
    Just putting in my 2 cents worth on this subject and my ownership experience with my Nissan '05 Frontier LE Crew Cab. This is without exception the most expensive vehicle, in terms of cost of ownership, that I have ever owned. I have just over 78K on it, and performance wise I couldn't ask for more from a midsize truck. But that is all the good things I can really say. Took it in to get the front brake pads replaced in December '08, tech discovered that I had a leak on the right rear axel seal, which had leaked oil on the parking brake shoe and saturated that and the rear brake pads. Thought I was going in for a quick and inexpensive front brake pad replacement and walked out with a bill over $1000.00. April '09, I take it in because my "Service Engine" light is on and the fuel gauge sometimes works and somtimes doesn't. After inspection error code PO-463 shows up indicating bad fuel sensor unit, and during inspection they also find that my left side rear axel seal is now leaking. So here I am again, going in for one thing only to have additional problems discovered, and walked out with a bill over $1300.00 this time. I also had asked them to check out a problem I am having with the interior fan selector switch, in which I set it to direct the air flow to the defrost, or defrost and floor, the system keeps switching the out flow alternating to all the different settings instead of just the out flow I set it for. Dealer wanted $130.00 just to diagnose the problem, so I cancelled that work order. Now after the $1300.00 + bill I just paid, plus the $1000.00 in Dec.( that is close to $2400.00 over the last six months), the wife and I decided it is time to get rid of this money pit and look for someting new, before more problems start to appear. One thing for certain - it isn't going to be a Nissan product.
  • shufflesshuffles Posts: 50
    I have had my '06 4cyl auto for three years. Here at 35K miles, I have had no problems at all. I get 21 to 22 mpg in mixed driving. (Haven't been on a trip since it was new.) fwiw
  • 05nismo605nismo6 Posts: 10
    My fuel level sensor is bad too. I've also had my rear axle seals done already. (I threatened to call a lawyer, mine were busted at 67K miles) It sounds to me like Nissan has issues with the Frontier that they are refusing to acknowledge.
  • asaasa Posts: 359
    This is the first I've read about axle seals. It's just insane what servicing costs these days everywhere. My wife's '04 Subaru (bought new) has been the worst car we've ever owned (eternal engine troubles, flimsy interior fabrics torn and stained), so I guess any brand can have it bad. Our favorite vehicle is our '92 Mitsu with 231,000 Miles. It's been a great car and I enjoy tinkering with it very much.

    As far as New Gen Frontiers, a large forum shows a bunch of owners have had the fuel sending unit problem. Something like 10 to 12% reported wearing out of the VQ-40 secondary timing chain guides (chains on the camshafts) and some early clutch failures as reported here. I had the fuel sending unit problem, but none of the others yet. Mine is a 6-Speed.
  • shufflesshuffles Posts: 50
    It looks like my fuel level sensor is on its way out. From full, the indicator drops like a rock for the first quarter tank. It moves very slowly for the next two quarters - then drops like a rock for the last quarter. Did any out there have similar experiences before the sensor went out? Or what were your experiences? Could this be an ethanol problem? Considering the expense of replacing the sensor, I am tempted to just let it go and buy gas every 400 miles. That has been a pretty accurate gage for me.
  • 05nismo605nismo6 Posts: 10
    Mine stopped going to full when I filled it up. But the first thing that happened was the Check Engine light starting coming on shortly after I filled it up, then it would go out at about a half tank and then come back when it was close to empty. Nothing like what you are describing though.
  • asaasa Posts: 359
    Yep, my CEL too illuminated when my fuel sending unit failed. I ran the tank down to near bone dry when it happened. My gauge had been working fine beforehand.
  • I just bought a 2000 Nissan Frontier Crew Cab and am looking for a Camper Shell. I probably will not be able to find a used camper shell make for my truck. Probably not right away. What camper shells other than one made for my truck can be used. Thanks Jim
  • Correction it's a regular cab not a crew cab.
  • just ran the tank down to fumes (first time in 40k). service engine lght came on as soon as i put some gas in. code PO463 comes up on tester. sounds like a hokie joke by nissan. if anyone has an easy fix, i'd love to hear 'bout it. thanks!
  • i just disconnected the battery for a couple of minutes to let the computer reset. the check engine light went off. no problems. a whole lot cheaper than letting dealer install new pump and sending unit! hope this helps!
  • mystromystro Posts: 64
    Thanks Mr.rodgers...excellent tip although I wouldn't advise that on some euro cars..bad things car happen to the computer.
  • Any suggestions on tires - please? I have been looking and the General Grabber HTS seems to be a good combination of safety, comfort and price. The Tire Rack ratings indicate them as vastly superior to the original equipment General Grabber AW. Snow and ice are not relavent factors here in Florida.
Sign In or Register to comment.