Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Malibu: Problems & Solutions

18889919394175

Comments

  • malibu0212malibu0212 Posts: 16
    I've done some research - and just changed the fuel filter which is dirty (but not clogged).

    The focus now rests on the fuel pump. Looks like my wife somehow damaged the fuel pump during that trip to Houston by keep restarting the car after stalling. The pump overheated when it only pumps little fuel. The damage (possibly the friction of rotating vanes getting high) is minor and fuel pump still works most of the time. When there is a full tank of gas the pump will stay cool since the fuel can pass the heat to the metal tank. When fuel level is down the fuel pump which was immersed in fuel will get hot. When it is too hot it will shut down and cut off fuel supply to the engine.

    Possibly my malibu's fuel gauge is not accurate when fuel level is low or the fuel pump already has a bit overheating problem the first time it happend.
  • mrsgaleymrsgaley Posts: 2
    We own a 99 base Malibu we bought new. We have replaced brake pads and rotors several times because of shimmy when brakes applied as described by many of you in this forum. Also our ABS light came on so had to replace one sensor. Was OK for awhile and then started coming on again - had to replace other sensor. One wheel bearing was replaced at this time also. Now, we have just had to replace the other wheel bearing because of noise indicating wear. Also have had problem with intake manifold leaking, water pump, alternator. We now have about 125,000 miles, and I think over the last year, we have spent over $3000 on repairs. Anyone else out there with the ABS sensor and wheel bearing problems? Our local mechanic says he has replaced wheel bearings on some malibus every 2 years. We are very disappointed with the lack of quality in this vehicle. We like to buy American, but with a record like this, we may be forced to look at foreign vehicles before we go broke fixing this American one.
  • 04ss04ss Posts: 5
    I bought a 2004 Malibu Super Sport. Went this weekend to buy brake pads and according to the parts dealers in my area, the car doesn't even exist. I've researched on the internet to no avail. They don't even list it on the Chevy web site! Anyone ever heard of this car and know where I can get more information?
  • paopao Posts: 1,867
    as far as Im aware there was not a production run in the SS badging for the Malibu in 04....that is scheduled of the 06 model year....not questioning that you dont know what you bought...however.....what makes you believe the malibu is an SS?...Did you purchase it from a dealer?...dont mean to ask what seems to be obvious questions here..If you bought an 04....how many miles do you have on the car in order to already need new brake pads???
  • 04ss04ss Posts: 5
    Did buy it from a dealer. And it says SS on the title and on the side and rear of the car. Where the other cars have an LT or LS, mine has SS. It doesn't quite have 13,000 miles on it yet, but it has a lot of down mountain wear which justifies the bakes. Not really worried about that part, just the whole "No SS" models.
  • paopao Posts: 1,867
    did you buy it new from a GM dealer? Did the dealer add anything to the car, wheels, spoiler, etc...and then simply call it a "dealer SS version???"....if so...I think you have a fraud case...since there were no SS production models in 04....you either have the LT or LS....I have an 04 Maxx LT....either..way I think you may have a case since it was titled by the dealer as an SS..when there are no GM production SS models for 04..VA doesnt specify model versions....my title just states Malibu Maxx......if concerned....I would confront the dealer again on the title and registration...unless they are an upfront dealer..which Im beginning to doubt at this point...they probably will not give you the time of day since you have had the car a year now......
  • 04ss04ss Posts: 5
    Sad thing is, I did buy it brand new (6 miles on test drive) from a reputable dealer in the Greater Cincinnati area. They didn't specify anything about a "dealer SS version". KY does specify on the title model type. Thanks for the advice. I guess I'll be going back to the dealership on this one!
  • kurtamaxxguykurtamaxxguy Posts: 677
    Pictures of that model, rumored to show up late fall this year, are in new issue of C&D and most likely somewhere on Edmunds.
    '04 Maxx had only LS and LT versions (I drive LS).
  • paopao Posts: 1,867
    were there any add ons by the dealer?..custom wheels...spoiler....etc
  • csandstecsandste Posts: 1,866
    I'd like to see this thing. Any way to post pictures?

    Are the brakes different between the LT and LS? If not, standard brakes should work fine.
  • kurtamaxxguykurtamaxxguy Posts: 677
    No difference in brakes on the '04 Maxx that I know of....4 wheel discs on all models. Wheels differ - LS has cast rims, LT has cast/machined face rims.
  • I don't think that the fuel getting hot is your problem. the fuel senders in most GM vehicle from 96 to current have had problems with wear and corrosion. GM states one of the causes is high sulfur levels in the fuel. your vehicle has a tech service bulletin related to this concern to replace the gauge sensor which is available alone or as part of the fuel pump module. If your vehicle has high mileage I suggest replacing the complete module.also related to this gauge concern the pcm may set a fault code related to evap control functions which uses the fuel gauge to run its self test.
  • paopao Posts: 1,867
    let us know the outcome of your inquiry with the dealer!!!???
  • joe3891joe3891 Posts: 759
    The specs list 10.866 dia front and 11.653 dia front, I assume the larger the Maxx. The rear are the same 10.630.
    :)
  • joe3891joe3891 Posts: 759
    Open the glove box, code for 11 inch JL9 and for 10 inch J66 or J67. :)
  • malibu0212malibu0212 Posts: 16
    Where is the bulletin? TIA

    My mechanic told me the fuel gauge issue the first time the car had the stalling problem. But the fuel gauge looks ok. I filled 6 gal when it showed half empty, and the gauge do move to show 1/4 tank or less. I'll be concerned if it always shows half tank full, but it is not the case.

    I also called local dealer and the serviceman said he never heard such a strange problem. Anyway, I've ordered a used fuel pump ($49+$10 shipping) and will do it at a total cost of $250 for fuel filter/pump replacement.
  • laurablaurab Posts: 1
    I've seen this topic addressed previously. I have a 2000 malibu. About 2 months ago, I started it, it cranked but would not start. I actually had someone jump it and it worked. Yesterday, the same thing happened. However, this time, it started up just fine about an hour later, and worked throughout the rest of the day. I have it in to the mechanics today (not dealership) and he doesn't see any problems, but did reference a problem that I've seen on this board (ie, something about the keys not being recognized?). Also, I've read on the board this board that it could also have something to do with the keys not being properly programed and/or the theft system. Now I don't have any theft system on my car, but interestingly, lately the theft system light has been going on and off.
    (for maintenance, I did also have the fuel system cleaned today, new gas filter, and new battery. However, the mechanic did not think that any of those things likely had anything to do with the starting problem).

    If you've dealt with this no start problem, please let me know what you did to resolve it, or what the dealer did. I'll take it to the GM dealer if that's necessary to re-program, etc.
  • bwolterbwolter Posts: 51
    This happened to my 98 GMC Sierra. At first, the dealer said they found no problem. So, went home, put up with it. The fifth time I took it back and said keep it until it's fixed. That afternoon they found the problem. The sensor in the steering column that senses the key was bad. They replaced it, and never had a problem again.
  • klj2041klj2041 Posts: 10
    I had been considering the Mazda3, but after discovering so many problems decided to take another look at the 2004 malibu LS. Can anyone tell me: are there any common problems with this car (besides the EPS/replacing the steering column thing)?? I only have about 15k to spend, and I want to get the most car for my money. :) Thank you!!!
  • csandstecsandste Posts: 1,866
    I got an '05 Maxx (which I think gives you a lot more car) for only $16K. GM cars seem to have a significant first year problem. It seems the '05's are more dependable, although improvements have been constant during the build year.
Sign In or Register to comment.