Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Toyota Tacoma 2005+

1367368370372373

Comments

  • kwingkwing Posts: 5
    At 90,000 miles my 2006 Toyota Tacoma (Extended Cab, 4WD, 6 cy, auto, TRD) came up with the following problems:

    1 & 2) air bag light went on - a coil under the air bag broke and oil pressure sensor wire/harness needed to be replaced because the wire broke ($680 to fix - already done).
    3) compass/temp stopped working ($289 to fix - it's not getting fixed).
    4) oil leak - timing chain cover needs to be resealed ($1400 to fix - going in today)

    Those are the bad things, but they are the first problems and my front brakes lasted 85,000 miles and my rear ones have not needed to be replaced. I went through brakes every 30,000 to 40,000 on my last truck, which was a Ford Ranger.
  • bigandybigandy Posts: 70
    Regarding the compass/temp problem, you can fix it yourself if you know how to solder. There's only one screw holding the whole unit in place. Push it toward the front of the truck and then pull down to get it out. There are two cable groups that unplug and and then get the circuit board out. Resolder the two resistors marked "510" and you're back in business. If the compass needs to be reset there is TSB available that shows to do it. Google the TSB.
  • I have a 2006 4 door Sport V-6. I have had it since new, and it currently has 45,000 miles on it. I just started noticing (or it just started happening) a noise that sounds like a spark plug knock. It occurs when you accelerate between 40 and 50 mph. It is similar to the sound I used to hear with the old GM V8s. It is a knocking and pinging sound. Since day 1, I have used unleaded regular. If any one could give me any insight or perspective on what to do, I would appreciate it. Thanks!
  • I have a 2006 4 door Sport V-6. I have had it since new, and it currently has 45,000 miles on it. I just started noticing (or it just started happening) a noise that sounds like a spark plug knock. It occurs when you accelerate between 40 and 50 mph. It is similar to the sound I used to hear with the old GM V8s. It is a knocking and pinging sound. Since day 1, I have used unleaded regular. If any one could give me any insight or perspective on what to do, I would appreciate it. Thanks!
  • Is this true that :
    1/ Tacoma 2004 and earlier used timing belt ???
    2/ Tacoma 2005 and later used timing chain ??
    3/ Tacoma has switch to 2.7 engine due to bigger chassis , in what year ??
  • We have a 2005 toyota and about a year into it the parking brake started locking up. It typically happened at the lake when pulling our boat in or out. As it got worse the only way to release it was to jack up the truck and remove the tire off the side stuck and bang on the drum - released quite easily with a few taps. We took it into Toyota on warranty and they said nothing was wrong.

    It just locked up on Sunday - and when trying to move with a boat on the back (not always convenient to take a tire off) - the back differential went. Now they have an e brake and rear differential to fix - thank god for extended warranties.
  • does any body. know whats the weigth rating on the stock spring coils for v6 4x4 06 taco and what can i replace them with, i wold like to run the bilstein 5100 with a softher spring. in advance thank you.
  • I am buying my first truck and I would really like it to be a Tacoma, does anyone have suggestions on what style and year to buy? I am looking to spend $15,000- $18,000.

    Thank You
  • Apparently there is a major recall of multiple Toyota models regarding floor mats on the driver's side that can interfere with the accelerator and cause a crash. It includes the 2005-2010 Tacoma and 2007-2010 Toyota Tundra. Now ya know!
  • I have the bright red paint on my '05 Prerunner pickup. The base of the hood scoop and the two door handles have all faded to almost a pink color. (I have to park it outside.) Dose anyone else have this problem and is there any recourse now? I bought it new in May of 2005 and it only has 29K miles on it. The dealer's body shop wants $300.00+ to paint those three items.
  • Did you ever resolve the leak issue in your truck? I also own an '05 Tacoma and experience the same leak problem. I can see no evidence of it leaking from the firewall or dashboard as the carpet appears to be dry in the upper areas. The underneath of the dashboard is also dry. I am suspicious that this is coming in on the side somewhere. We are experiencing a very heavy rain--close to 6 inches over the past 12 hours. The passenger side is dry as a bone. The truck was sitting in a parking lot all day. I discovered the problem when I went out to drive the truck home.
  • I PURCHASED MY TRUCK THINKING IT HAD A BED LINER INSTALLED IN IT.
    WHEN THE WINTER SNOWS CAME I SHOVELED SNOW INTO THE BED FOR
    ADDED TRACTION AS I HAVE DONE INTERMITTENLY FOR YEARS WITH MY
    OTHER PICKUPS. TO MY SUPRIZE WHEN I WENT OUT THE NEXT MORNING
    MY TRUCK APPEARED TO HAVE A DUMP BED INSTALLED ON IT. THE BED
    WAS RAISED ABOUT TWO INCHES IN THE FRONT FROM WHERE IT WAS ORIGINALLY POSITIONED. I HURRIEDLY SHOVELED SNOW FROM THE BACK OF THE BED TO THE FRONT AND THE BED DROPPED BACK DOWN
    EVENTUALLY. I LOOKED AT THE BED AND DISCOVERED IT WAS MADE
    OF PLASTIC EXCEPT FOR THE BODY PANELS.- BAD DESIGN- F.Y.I
    JUST CURIOUS IF ANYBODY HAS HAD A SIMILAR EXPERIENCE.
  • MY TRUCK HAS A 2.7 FOUR CYLINDER IN IT. AFTER I BOUGHT IT I CHANGED OIL IN IT AND TOOK OFF DOWN THE ROAD TO DISCOVER THAT IT LOST ITS
    PEP SO TO SPEAK SO I CAME HOME AND CHECKED THE OIL LEVEL AGAIN.
    THE OIL READING WAS EXACTLY ON THE FULL MARK WITH THE TRUCK PERFECTLY LEVEL ON LEVEL GROUND AND I HAD INSTALLED THE CORRECT TYPE OF OIL AND FILTER. I THEN PROCEEDED TO DRAIN OUT
    SOME OIL UNTIL THE STICK SHOWED HALFWAY BETWEEN THE ADD AND FULL MARKS AND I REGAINED MY PEP AGAIN. I AM NOW ONLY PUTTING
    FIVE QUARTS WITH FILTER IN MY MOTOR AT CHANGES BUT NOT USING THE FULL MARK ANYMORE . F.Y.I
    JUST CURIOUS IF ANYBODY HAS HAD A SIMILAR EXPERIENCE.
  • Taco owners,

    My 2005 A/C (4x4) is due for the 90,000 service. I just called dealer. Over $1,000! Does anyone have good advice on how to handle this? I'm ok with changing my own oil, but timing belt, spark plugs the the transmission/coolant systems scare me some.

    Thanks
  • My '05 Tacoma 4X4 has 58k miles and recently started making a growl or loud humming noise from somewhere in the driveline. It begins at around 30mph and gets louder as you drive faster. The dealer changed the rear diff., but the that didn't correct the problem. This truck has always been noisy (excessive wind & road noise) so it's very hard to determine where the growl is coming from. Also, now the dealer says they have no idea what the cause is and don't want the truck back to try to fix it. Has anyone had a similar problem? The dealer doesn't think it's a wheel bearing.
  • Steve:
    There is TSB on this condition. Go to the NHTSA web site and type in your trucks info then look under the TSB section or ask your Toyota dealer about the Technical service bulletin
  • Thanks, but I could only find the tsb referring to the differential. My dealership already replace that & it didn't help at all. Was there a different tsb out there?
  • scottc3scottc3 Posts: 109
    Hey Guys,

    I'm getting conflicting information if my 2005 Tacoma needs a timing chain / belt replacement. I've been to several shops and one guy, who seemed to know what he was doing lifted the hood and checked the motor code, 1GR-FE. He told me between 2004 and 2005 there was a motor change, going from belts to chain on the 'timing chain', along with other changes. He mentioned the new engine, 1GR-FE, has a chain, and does not need to be replaced until about 150K miles. I'm wanting to confirm this information in anyone KNOWS. I'd like someone out there that really knows these Tacoma's and has facts about this.

    Also, I don't have my service book, can someone outline what should be done at the 90K service? I'm thinking plugs, radiator flush, transmission flush, ...??

    Thanks

    Scott
  • Certainly sounds like a bearing. Have you had someone ride in the back while you drive? There's a bearing between the two parts of the drive shaft that might be the culprit (forget what it's called). Also, I'd either escalate, go to a different dealer, or go to a competent, non-Toyota mechanic to see if they can figure it out. You're about to exceed your 60k driveline warranty, so I'd act quickly.
  • I have a 2000 tacoma just turned 90000.I took it in for service had clutch kit put in, tranny service, rear main seal replaced (since we were there)I changed the oil,cleaned air filter(cold air intake)and radiator flush.Mine also has a timing chain and I too was told not to worry about it til 150,000 or if it was making noises before it needed replaced.
Sign In or Register to comment.