Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chrysler 300: Problems & Solutions

17810121331

Comments

  • drbditdrbdit Posts: 7
    I got my 300C in September and have been generally happy, but the dashboard has developed an annoying squeak that I notice when driving in the neighborhood (about 20 to 25 miles an hour). The noise started in the passenger side and now is across the whole dash. Also, my CD player started skipping so the dealer replaced it 3 days ago. The new one skips too, even with brand new CD's. Anyone else have these problems?
  • bjsohiobjsohio Posts: 69
    You really have to be careful. It's easy to fishtail around corners with all that power, especially on ice. The esp works well (and often) unless, of course, you're stuck on a hill and it won't give you any power at all (been there).
  • jo158jo158 Posts: 8
    This is my first posting to web site and I am relieved (somewhat) that others are having the same problems that I am. It is good to know that it is not my "imagination" as the 5-star dealer I bought it from would have me believe. I had thought the car felt as if it were pulling to the right, but thought it was my not being used to this vehicle? My car was back in the shop 1 week after purchasing(July 2004)for a very rough idle, light on the dash staying on and I felt it was not the quiet ride that they were promoting. In fact I feel as though I am in an airplane. I was told it had to be broken in, they could not reproduce problem, I had to get used to the vehicle as it was very different than my FWD 2000 Volvo S80 Turbo(how I wish I had this car back even with all the problems that had begun to occur) It has been back to the dealer 2 times since then for "minor" glitches of which the dealer again cannot duplicate. The idle is still rough after 6 months and 8,000 miles. The last time I had it in was because the car was stalling as I pulled into my parking spot at work. Again, could not duplicate problem at dealer. Just recently the breaks started to make noise - it is hard to describe. I definitely here it each morning backing out of my driveway, Has anyone resolved the rough idle problem? I am so very disappointed in this vehicle, the dealer and Chrysler. I contacted them within days after picking up my car and did not get anywhere with them. Has anyone experienced any of these other problems? Any suggestions would be appreciated
  • jo158jo158 Posts: 8
    I live in the Northeast and snow is a big factor for me so buying a RWD car was a concern. I have 4 snow tires on it- Blizzaks(spelling) and it is awesome in the snow. (My husband was amazed with my response as this is the first positive statement that I could make about my car other than it looks good. (2005 300 limited Satin Jade) We have had 3 storms since the purchase and it is really quite impressive.
  • jgalt1jgalt1 Posts: 9
    I was curious about your problem:

     

    "metallic popping or click every morning from inside the middle console or dash"

     

    because I have the exact same problem and I haven't seen an answer yet. Did you every get an answer ?

     

    Does anyone have an answer for this problem ?
  • Update to my message#299. I installed four P235/60R18 Pirelli Scorpion Ice and Snow. So far I'm truly impressed. Although slushy snow remains tricky, traction and control on loose and hard-packed snow is greatly improved. Stopping on icy roads is excellent. Added bonus, handling on dry pavement is better than with original 225/60 tires and nearly as quiet!

    P.S. My rims have started to pit also with only 4500 miles. It seems that there is too little (if any) clearcoat on the machined edge of the rim.

    Also, anybody have a problem with dash display switching on its' own from metric(Canada)to U.S.display after it has been programmed?
  • Took delivery of my 300C in August 2004 and have put 7.5K miles on it since. I've noticed several idiosyncrasies in my vehicle and am curious whether other C owners have had similar experiences:

     

    1. When using Autostick, no indication of the current gear shows at the bottom of the Transmission Range Indicator on the instrument cluster. I'm expecting to see 1,2,3,4 or 5 appear as the gears are cycled.

     

    2. Upon start, no sound emanates from the speakers even though the volume indicator shows that there should be. This only happens when the mode is other than Satellite. Changing the mode to Satellite will cause the sound to come on and it will stay on if the mode is changed from this point.

     

    3. At higher speeds and certain road conditions, the ride becomes overly bouncy. It feels as if some oscillation point is reached and this can only be corrected by the road smoothing out or reducing speed.

     

    4. A slight crease has appeared in the hood. This can only be noticed from a certain angle. It is located on the passenger side edge approximately 8 inches down from the windshield. It would be virtually impossible for a door-ding or other parking lot carelessness to have caused the crease in this area.

     

    I'd like to get feedback on the issues detailed above and any suggestions on how to resolve.

     

    Other than these minor vexations, the C has been a pleasure to drive. On at least a half dozen occasions, absolute strangers have stopped to chat about the car as I'm exiting/entering it. All comments have been extremely favorable.

     

    Impeccable styling, smooth handling, impressive power and reasonable pricing definitely contributed to the 2005 C being named MT's Car of the Year.
  • My 300 C is about 3 months old. This weekend was the third snowsorm I drove in, in the great Northeast.

     

    The car sucks in the snow. Factory tires. Snow tires are difficult to get, though I wonder how much difference it would make. At every traffic light, I can not get going, while other cars crwl around me. The dealer seems to say I am the only one with this problem.

     

    Has anyone else tried snowtires on the 300 C ?
  • i have a 300 touring and have had some problems similar to you. i owned a jeep wagoneer 4x4 before i purchased the 300 so i don't know if it's because i'm just not used to driving a car or because it's a rear wheel drive vehicle. i'm guessing it's the latter. i love the car, but this is becoming a concern. i live in michigan so the winter's here are pretty bad. i'm hoping that snow tires will help. i have noticed that the car does okay over ice, but has a lot of problem with a few inches of loose snow. anyone else have a story or solution to tell?
  • lennylenny Posts: 29
    I got my 300c back in Early June and I must say I need to "knock on wood" as I've had none of the several problems posted to this site. (pulling, electrical, noises, knocks, stalling etc.) The only "problems" was with the seat not moving back at exit every time, but a trip to the dealer solved that and the car had a "pimple" on the right front fender that I found one day while washing the car. It was real hard to see and again a trip to the dealer and the "dent Doctor" and can't tell it was ever there. As far as the snow. I believe the tires are fair for snow travel. I saw a survey on line and the tires on the 300c were given a 6.2 out of possible 10 for traction in snow. I must admit that it took me a while, but if I give it slow gas it starts out just fine from a stop. Too much gas and it's spinning right away. My wife and I drove a 2002 Bravada before this vehicle and she is still a little nervous driving the 300 in the snow. Believe it or not my business is looking to relocate me to Phoenix AZ. so this should solve my snow driving needs.
  • a couple of tips from someone who drove rwd for years in the northeast winters: use narrower tires when purchasing your winter snows. by focusing the weight of the car over a smaller tire patch you will have much better success at cutting though the snow. the wider the tire the worse the handling will be in the snow.

     

    also, there's only so much you can do with the 300c and it's poor handling in the snow. the block of the engine is cast in iron and that puts alot of weight over the wrong end of the car. you should be able to mitigate, somewhat, the poor balance of the 300c with the narrower tires and another added bonus: the car till turn in and handle much better in the turns with the narrower tires. jackg 90seville 96k
  • Have a new 300 base model. After driving and the car is put in park doors do not unlock. Manual states models with 'on board' computer system have a way to set preferences so doors will unlock when car is put in park.Base model does not have this system. Called three dealers, all are unsure if they put car on their computer system if there is a setting under customer preferences whereby they can change the factory setting. Also called Chrysler, and they could not answer my question. Am used to driving a Chevrolet Impala whereby when car is put into park doors automatically unlock. Also, too bad one cannot order auto on/off headlights on the case model. Sometimes Chrysler just doesn't get it.
  • jeepjeep Posts: 86
    I must disagree with your comment about poor balance. The car is almost balanced 50/50. Why do you think they put the battery in the trunk?
  • bjsohiobjsohio Posts: 69
    But won't they look like one of those Jeeps from WWII?

     

    I was thinking about getting a set of chains. Whatever happened to those tires with metal studs?
  • that is about the only place for the battery theres no room under the hood for it.
  • The 300 is okay on flat surfaces in the snow, but on a snowy hill, you are in a bad state! The traction control system cuts gas to the engine as the wheels spin, leaving you at a standstill mid-climb. There are no snow tires available on the market for the 300 limited, 17". If it snows where you live, and you have hilly terrain...Buyer, beware.
  • Where did you get the snow tires. I'm being told that there are none available for the limted. I'm also in the Northeast.
  • carcom2carcom2 Posts: 212
    Have a little over 4K on 300C and still really enjoy driving it. The first time I drove it in the snow, I must say I was a bit disappointed. Seems like it couldn't handle turning around the corner without spinning out a bit. But that's cause I was used to driving a FWD low HP Dodge Grand Caravan in the snow and loved driving fast in the 300C. I'm wondering about those not liking the handling in the snow. Have you tried accelerating slower in the snow & especially around the turns on side streets? Driving the 300C differently when there is snow seems to make a huge difference. I'm no longer disappointed with it. I accelerate less abruptly going straight & around the turns unless I feel like playing around while the car spins out a bit when accelerating too fast. Also find downshifting coming to stop signs helps a lot too. It's never caused the car to skid.

     

    Driving during a bad snowstorm, the car drove great and I felt good after easily driving past the Volvo that was going too slow. Also, to be fair, we've had a lot more snow and slick icy roads lately and for those not liking the handling in the snow, have you taken out another sedan over the same road at about that same time of the same day? Maybe you're other car would have disappointed you too. Up here, the road conditions with the snow seem to be worse than other yrs. Do a fair comparison, ease off the gas on the 300 and you might start getting used to driving this great car even in the snow. The driver's skills has a lot to do with how well you can drive in the snow. And remember, driving a RWD car in the snow has to be driven differently than a FWD car in the snow.

     

    Good luck. Be safe.
  • jeqqjeqq Posts: 216
    I've been following the posts and find an overwellming amount of posters complaining about the car's handling in the snow. I remembered seeing a Chrysler video clip posted by beach15 showing the 300C slalom up and down a snow bound course. How's that possible with all the negative feedback here?

    Here's the link to the video. Is Chrysler guilty of false advertising?

     

    http://www.dcxmediaservices.com/videoptrs/wms/dctv/Mar04/Houghton- _Ride_Drive_300k.wvx
  • carcom2

     

    You're right on the $$ with your post.

     

    People today are not use to RWD & why they are having problems.

    I drove my 300C Christmas Holidays up & down mountain roads...

    through NJ, PA & New York State 7 1/2 hours & car is a dream in the snow!

    Want to feel more secure, throw on 4 snows the car will be unreal!
  • jo158jo158 Posts: 8
    I bought the snow tires through the dealer in early December. Had to wait for them to come in. Central Chrysler Jeep 56 Providence Highway(Rt1) Norwood, MA.

    The tires are: Bridgestone Blizzak WS-50 Studless

    225/55R17 970

    Have had no problems driving in snow until yesterday. Had a very difficult time getting up a hill by work. As in Posting #367, I came almost to a standstill mid hill. The car did not skid, slide etc. It felt like the engine just cut out. I had the gas peddle to the floor. I eventually made it up creeping very slowly. In all fairness, we had 6 more inches of snow that day on top of the 2 feet that was already there, it was very early in the morning and I know the roads had not been re treated at that point.

    Good luck.
  • jo158jo158 Posts: 8
    I have snow tires for my 300 Limited. See posting # 372
  • in the video it was more driving over a little snow and or ice. my problems arise when i'm driving over 4 or 5 inches of loose snow. i'm looking into snow tires though and hopefully, that'll help. thanks for all the information sharing on this forum. it's all been very helpful.
  • For all of you complaining about how the "C" goes in the snow, it is obnoxious how poorly it goes in winter weather. This greatly improves with snow tires, or excellent all season radials. The 18" Continentals that came on mine couldn't go through warm butter! I purchased Nokian Hakapolitta SUV 235 60 18 tires and they are awesome. I was seriously thinking of putting the Hemi in the garage and getting a beater for the winter! I don't think it has anything to do with weight distribution, as it is almost a perfect 50/50. The tread on the otherwise outstanding Continentals is not conducive to winter driving.
  • bjw227bjw227 Posts: 1
    i have had my 300c since 9/04 and have about 5000 miles on it...let me start by saying that for 90 days, i loved this car...it was exactly what i expected and wanted from an automobile..i still love the styling and design, but for a mechanical and engineering standpoint, i hate this sled!!!!!!on about day 91,the car developed a major league pull to the right if i released the steering wheel from my hands...after 2 weeks of chrysler telling me that we have "crowned roads" in buffalo, it was time to get them to look at the car...they have had it in for servicing 3 times for the problem and each of the first 2 times, the car was worse when i got it back...it was sloppy under the hood, very loose steering and a very overly sensitive response to any steering...the third time i got it back, about 2 weeks ago, the dealership told me that it was not an alignment problem but a problem in design because of the 18in tires, the suspension system and it creates a "calibration" problem...they are awaiting a bulletin from detroit on how to remedy this issue...they claim it is only with the 300c model...they will call me upon receipt of the repair bulletin...additionally, i had the dealer install on Remote Keyless Entry (RKE)system for the holidays..everytime i use the RKE as warning appears on the dash that states RKE battery...the dealership told me that it was nothing and probably the battery in the remote was low, but assured me it was nothing to concern myself with...last week, as i had to climb into the trunk to get my jumper cables through the back seat i might add, (the battery had died) it drove it and left it w/ the dealership once again...the dealer stated that the RKE system creates a power draw and interfers with the circuitry of the electical system...they also do not know how to fix this and are awaiting another "bulletin" from detroit, which should be received in 2-4 weeks...i believe the dealership has been responsive but unable to service their own product as of this posting...they tell me the pulling unfortunately a problem w/ all the C models...has anyone had the same issues that i have faced??? what else do i have to look forward to w/ this car...this is possibly my last chrysler product
  • leorleor Posts: 1
    Boy you hit it on the head. I also had my car for about 4 months and the pulling to the right started, it also vibrates at 58 MPH. They tried to line it up, rotated the tires, but it still vibrates. The air bag light comes on, the abs light comes on, the head lights work when they feel like it, the battery had to be replaced, sometimes when I start it, it will only idle, you can push the gas pedal but nothing happens, sometimes the heated seats won't turn on. I'm thinking I need to try for the lemon law. I must say it is a nice looking car.
  • mr1340mr1340 Posts: 10
    i've had my 300c since june and have driven it over 12,000 miles. i to have gone through the pull to the right and tire wear (edge feathering) problems. after 4 alignments with numerous consults from factory engineers, and new tires, it seems to be much improved as of last alignment in december though still abit sensitive to road crown. otherwise a great car, the dealer has been great and chrysler has spent a fortune on loaners to accomodate me.
  • mr1340mr1340 Posts: 10
    i was actually impressed with the 300c performance in the snow and have had fun pushing it to the esp limits. certainly its no awd substitute, but if you let the computer work it will get you around. born and raised in buffalo.
  • I have had my 300 Limited since June,04. It does not handle very well in the snow and have noticed rim pitting also.What was the outcome of your encounter with your dealer on the rim pitting? I am thinking of calling Chrysler. Packard 1
  • Found the vehicle performs very poorly even with a light covering of snow. Often when starting off even on a moderate hill, the car will not move. Pressing the accelerator gives no noticable engine response. Car just will not move, no power.

    Switching off the ESP allows the engine to respond and even though the rear wheels spin, you can claw your way along enough to get moving.Has anyone had this same experience?
This discussion has been closed.