Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Equinox Maintenance and Repair

1343537394056

Comments

  • It doesn't seem to work that way in the Equinox. None of the electrical things come on when I remote start it until I put the key in and turn to the run position. I know in older cars with remote start heater will come on if it is left on previously. These new cars, everything is controlled by some computer. I haven't asked the dealer yet, but maybe it can be re-programmed. Any other ideas?
  • grosloupgrosloup Posts: 239
    I never noticed on my Equinox if it works like you say because I'm the type of guy who always forget to leave my heater controls on when I exit the vehicule for my next cold restart.
    I'll check this out and reply to you. I know that the older models could do it but like you said now everything is controlled by computers.
  • I bought my Equinox in April of 2007. After about 4 months it started stinking like a musty basement. It kept getting worse, so bad that I would smell like mold when I got out of the car. I have had it to the dealer and they replaced some evaporator part on the AC but it still stinks!!!! Now they want to replace the carpet and clean the upholstery. They put some type of deodorizer in the system that I thought was going to kill me. It coated my windshield with a white film, and choked me to death. This cannot be healthy. I noticed that there were alot of post from 3 years ago about this. I am wondering if anyone else is experiencing this problem now. It seems that they should have taken care of this problem over the past three years.
    The dealer told me that they have to work on the same problem 3 times before I can do anything about this. This means that I have to deal with inhaling more mold and more chemicals. Help Me!!
  • grosloupgrosloup Posts: 239
    Is that smell you're talking about coming from your vents or is it everywhere in the vehicule?
    If it's coming from the vents, there was an issue about bad antifreeze but that was in the early 2005 models and I've heard they fixed that problem. The antifreeze instead of being an orange/pink color turned brown with residue in it caused by bad radiator hoses.
    Did you check your "spare tire well"? Some Equinox had water in there and that's where their bad smell came from. Stagnant water.
  • grosloupgrosloup Posts: 239
    It's me again. Just went out to make a little test. I got in my Equinox, put my vent control to defrost and the fan to MAX closed and locked the doors. Then I used my remote start to start the truck, unlocked my doors, got in and the defrost fan was blasting air without having to put the key in the ignition. I'm sorry but I guess your Equinox needs a little trip to the G.M. dealer.
  • Hey, I'm sorry. The heater does come on if left on previously when I remote start the car. The rear window defroster won't come however, but that probably is correct operation, because when you turn the car off, you have to restart the rear window defroster again. This my daughter's Equinox, and she told me the heater didn't come on with remote start. The car wasn't at my place to check out, so I believed her! Bad idea!! After I checked it out myself, it worked as you said. Thanks so much for your help, now I don't have to go harass my nice Chevy dealer! As "Fonzi" could not say, "I was wrong" - or "I was wronnng"
  • grosloupgrosloup Posts: 239
    You're right! For the rear window defroster you have to put it on manually every time. Well, everything seems to be normal with the Nox.
    Heyyyyyy! (thumb up) I'm a "Fonzy" fan myself.
  • I have not checked the spare tire well yet. Never thought of it. The smell is through the entire car though, and as a matter of fact I have noticed it when I have opened the back hatch. This makes sense. I will check it out today. Do you know what they are doing to remedy the problem? I am ready to trade the smelly thing in today. Maybe I have a problem with the AC also, or maybe the dealer just doesn't know what it is.
  • grosloupgrosloup Posts: 239
    For the first time since May 2005 (except for maintenance) I had to go to the dealer for a repair today. I noticed some oil on the pavement underneath my 05 Nox. They told me that the seal of my transmission was leaking. What transmission? It's a FWD. And how do you check the oil level? there's no dipstick for that so called "transmission". Engine oil yes, but transmission? No dipstick. And I've been told it was a sealed transmission? How can it be sealed if they changed the seal and added some oil? I'm confused here.....
  • noxroxnoxrox Posts: 22
    Rotating parts that extend through the transmission case have to have a seal around them to keep oil inside the transmission and not onto the ground. Like the name implies, they seal the oil into the transmission.

    All vehicles have a transmission of some kind, either automatic, which may be of a normal torque converter and gear type of a constant velocity transmission that is of more recent design, and is usually found on smaller vehicles. The other type is a manual transmission, where you have to shift the gears yourself, or as of very recently a computer and control mechanism do the shifting.

    Anyway a FWD vehicles has a transmission that is connected to the front wheel instead of the rear wheels.

    Regarding a sealed transmission, it is not uncommon for auto transmissions to no longer have a dipstick to check oil levels. Transmissions do not "use" up their oil by burning a little every time you run them, like an internal combustion engine does. Hence, unless you develop a leak (like you did) the oil level is not going to go any place. So why bother to check it. I have owned many cars with auto transmissions and have never ever had to add oil to them.

    By "sealing" the transmission the danger of overfill is reduced/eliminated.
  • grosloupgrosloup Posts: 239
    My Equinox is a 2005 LT FWD. My original tire size is 235/65/16. I'm looking forward to buy winter tires this year but I'm having a hard time finding that size. Any suggestions for good dependable snow / ice tires? Is the size of winter tires the same as the original 4 seasons?
  • grosloupgrosloup Posts: 239
    Thank you for replying and for your nice explanation. My Equinox was ready the same day. Three hours work and they replaced the O ring of the automatic input sensor on the transmission (transaxle). That's were the leaking was coming from.
    I guess only God and you know what that O ring is all about.
    Well, at least, it's fixed and didn't have to dig in my pockets cause it's still on warranty.
  • grosloupgrosloup Posts: 239
    What brand and size of winter tires does your Nox have?
    My original 4 seasons are 235/65/16 and I can't seem to be able to find that size in winter tires (even on tirerack). Is it the same size in winter tires or different than the 4 seasons ones?
  • My Nox is a 2007 AWD 3LT. Comes w/chrome wheels & 235-60/17 Bridgestone all season Dueler HT I think. So far nobodoy else supposedly makes a tire this size, but Michelin might have one, or coming soon. I dont know about 235-65-16, but you could probably go to 225-65/16. Check Michelin.com or Bridgestone/Firestone.com or Discounttire.com. Bridgestone Blizzaks are really good & Michelin Arctic Ice good too. I've used both on some other cars I have. These are all studless tires. I wouldn't use studs on anything anymore. Studless are just as good or better than studs and much quieter. I think the Gov. should ban studs in every state. Studs do too much road damage, and now we have studless alternatives.
  • The only place I could find winter tires in size 235-65/16 is Bridgestone-Firestone. They make this size in Blizzak WS50 & WS60. You could probably use a 225-70/16 too if you want. A little narrower might have better traction on snow too. Hope this helps.
  • grosloupgrosloup Posts: 239
    You're absolutely right. One of my friends just called me and told me about his problem finding winter tires for his Nox (same size as mine) I mentioned your reply and he called his dealer and that's what his dealer told him... Blizzak from Bridgestone is the only (235/65/16) he could find for now and it's recommended as a very dependable tire. Imagine people with 18's. So it's Blizzak with no fear with me because your word is the same as the G.M. dealer. Thanks!
  • Just to let everyone with a stinky car know that I did check the spare tire well and it was full of stinky, moldy, smelly water. It's been full since August. The dealer never even checked it..yes they know what's going on. It has been in the shop for a week so that they can try to find the leak, replace the smelly carpet and clean the entire interior. I guess that I will find out if this works. It's depressing, it should still smell like a new car and I know that it will never be the same. I'm sick about it.
  • user777user777 Posts: 3,341
    did you scan this forum? if i'm not mistaken, one poster indicated the water was getting in through one of the rear light lenses.
  • grosloupgrosloup Posts: 239
    I'm glad you took my advice and checked your spare tire well for that smell.
    This is what I found on a post dated (jan 18 2007) # 1021.........
    (I took my vehicle in to have the water leak in the spare tire well fixed. They removed the bumper and welded something and seemed to fix it but after getting 3 0r 4 inch rain last week the water is back (about 2 inches deep) Is there anyone that has gotten results in fixing this problem that could reply to me and let me know what you did to fix the problem and what dealer fixed it). You can always make a "search" in the search box at the top right of the page by typing the cue words ex : water, well, spare tire.... and that's going to take you to all the posts with those words in. Sorry, I couldn't reply right away, I was gone to the cottage for Christmas.
  • This seems to be a serious problem that has eluded dealers everywhere!!! My car has been in the shop since last Wednesday, here is what they have done so far,
    replaced the evaporator coil on the AC, replaced the carpet, cleaned the interior 3 times with a bissell rug steam cleaner, replaced all of the sound foam, deodorized, ionized, deodorized again, and sealed a seam up in the wheel well that was near a vent for pressure in the vehicle. I really do not know what else. They called me from the dealership on Thursday, 12/27 and told me that the car still stunk. If the black mold will not kill us the chemicals used to try to mask the smell will. I'm really upset and looking into the lemon law at this point. I think this is a health risk more than anything at this point.
  • grosloupgrosloup Posts: 239
    Yep! I guess the "lemon law" is your next best thing. All the posts and people that came up with that problem (water in the spare tire well) said that it was fixed and in a couple of months the problem came back. Some had even sand or gravel on there spare tire coming in from somewhere with the water. They just don't seem to be able find or fix that problem.
  • grosloupgrosloup Posts: 239
    Last night I noticed that my steering wheel made a weird sound "squeaking sound" when I was stop and turning my steering wheel left or right. The sound seems to be coming from the steering column. It's not the regular tire on pavement sound, it's realy from the steering movement. Any ideas what it could be?
  • Hi,

    I let my brother borrow my Equinox a couple of days ago. Well the idiot broke the wiper switch and now my wipers won't work. Do any of you think that it might be the fuses or do you really think it is the switch?

    Any help would be appreciated.
  • I have a 2006 Equinox and I have noticed it doing this also. It is not every time but almost. Nothing surprises me with this car. It is the worst car I have ever owned. When I call to make an appointment for it all I say to them is this is the owner of the Equinox from Hell. They know right away who it is. It has been nothing but problems since I have owned it. They for the most part all seem to be electrical, and you know how hard that is to prove. It has been towed a total of 4 times for this. It is always when I am out of town. I hate to even think about going out of town now. Then I can be driving down the road and all of a sudden my window will go down just enought that I can hear the air coming in. They claim they can't get it to do this. It happens all the time to me. I will never buy one of these again. Also the gas mileage is horrible. Not even close to what they say it should get.

    I could keep on writing about this vehicle, but I will stop for now. Can't wait to get rid of it. Just can't afford to right now, so I am stuck with it.
  • tidestertidester Posts: 10,109
    Do any of you think that it might be the fuses or do you really think it is the switch?

    I'm not sure why you suspect a fuse when you already said the switch was broken. In any case, you can test the fuse hypothesis by swapping in a new one.

    tidester, host
    SUVs and Smart Shopper
  • grosloupgrosloup Posts: 239
    My 05 LT Nox has been a "Cream Puff" since the day I bought it (new) 32 months ago. The only problem is that every year I have to get my front discs "shaved" it's now my third time because they seem to warp pretty fast and caused a bad vibration when I applied the brakes. But recently, Hell is breaking loose. A squeaking steering wheel, squeaking brake pedal when pushed lightly, drifting snow comes in by the driver's door and tailgate, transaxle oil leak and a humming sound coming from the back. The sound is not coming from the tires because I still have the originals on and that humming sound came suddenly and I hear it every day. Your right, gas mileage is not exactly as they said and I'm not a fast driver I"m always trying to get the most out of it. Got three more months and the warranty is over and I'm not financially able to trade it right now. Kind of scary.
    I'm starting to believe that Hell must be full of Equinox.
  • Hi,

    Both of the main headlamps stopped working on my 2005 Equinox LT. I checked the fuses and even switched out the relay, but it didn't solve the problem. The high beams and fog lights still work fine. Is it possible that both lamps burned out simultaneously? Any other thoughts on the cause and how to fix it?

    - thanks muchly.
  • sgr5516sgr5516 Posts: 156
    I also have a 2005 Equinox LT and the right headlight bulb died last week. I got a new one from local auto store and it was a real pain to install. After you remove the 3 screws that hold the light assembly in place, you have to remove the plastic fasteners that attach the grill to the upper radiator support and pull the grill forward. You can then slide the light unit forward and manuever it away from the fender to access the light sockets. There is no way to access the sockets to replace the bulb without removing the whole unit.

    It is possible that both bulbs died on your Nox. Only one bulb is used for both low and high beam. Turn on your headlights manually, then see if the high beam works. If the highs work, then I would say the bulbs are bad. It is rare for both the low and high beam part of the bulb to fail at the same time. If your lows and highs are both out, It could still be the bulbs or you have another problem.
  • grosloupgrosloup Posts: 239
    About a week ago I noticed a humming sound that seems to be coming from the rear wheels of my Nox. Almost the same sound as tires rolling on the pavement but it can't be the tires it's been 3 yrs that I have the truck with the same tires and it just started a week ago. When I decelerate the sound seems to slow down as the wheel turns slower and increases as I accelerate. When I press on the brake the sound is still there, I've tried the truck in neutral and rev the motor while rolling = the same decreasing sound. So I figure that it's not the muffler, the brakes or the transaxle causing that sound. My friends tell me that a wheel bearing could be the problem but I only have 20,000 miles on my truck. Any suggestions?
  • Hello I have a 06 NOX and I have noticed a thumping sound and wonder if it is the same thing you had with you yours. It only does it at slow speeds as well. I will have the dealeship look inti this problem.
Sign In or Register to comment.