Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Equinox Maintenance and Repair

1414244464756

Comments

  • laserbluelaserblue Posts: 313
    I know more about the Equinox than you think because some of my family members work at Cami Enterprise that's where the Nox is assembled by the way.
    The place is called Ingerstoll, a city 155 km. (95 milles) west of Toronto. You are right, the engine is built in China by Shanghai G.M. and it's a LNJ V-6. The transmission is foreign to it's manufactured in Japan, it's a Aisin AF33 and all the plastic components (interior) are from Taiwan. So... I'll say it's assembled in Canada.
    Everything arrives in Vancouver B.C. by ship and then put on trains all the way to Ingerstoll, Ontario.
    The 2008 "Equinox Sport" engine is manufactured in the U.S.
    Many nice changes (body and performance) for 2009 but the biggest changes (interior) are to come in 2010 models.
    I visited Cami Enterprise in 2006 and they are well build with love and care.
    Anything else you'd like to know?
  • packer3packer3 Posts: 277
    Yea, does T Horton's still make great doughnuts.
  • bdymentbdyment Posts: 548
    Sure does and the coffee at Tim's is great too.
  • I noticed that a leading consumer magazine in its annual auto issue said that according to its poll (survey) results that the Equinox is one of the cars the survey responders would be least likely to repurchase.

    I also noticed that Edmunds says nice things about the Equinox but never lists it as a competitor to look at when reviewing other crossovers (Rav4, CRV, Santa Fe etc.) But here people seem to be mostly happy with their Equinox (especially post 2005 models.) Based on my experience this is a good vehicle at a good price but it certainly does not get a lot of positive exposure.
  • rvothrvoth Posts: 147
    It's mazing at what certain magizines say are poor to great vehicles.

    Consumer report had my 1990 beretta GT rated as average to below average , i still haveand drive it with 318 000 km and no major problems, engine ,tranny, suspension, with it and that's why we have purchased two more GM's in the past four years. Great value with low cost for maintenance and low operation cost. I don't see many 19 year old toyota's, honda's or hyundia's driving around in my city.I do see some Beretta's of the same age as mine though!!!

    Every manufacture has it's pros and cons but if you do regular maintenance the Equinox will last longer time than the competiters. Just my experience's with GM cars.
  • laserbluelaserblue Posts: 313
    Almost the same thing here.
    My sister has a 1998 "Chevrolet Lumina" with well over 260,000 km and no big problems with her car either and she still loves it as much as the day she bought it.
    You must see all the Chevrolet Lumina on the road that are own by taxi companies around here and they surely do lots of millage.
    I've own G.M. products since 1977 and I still bought one in 2005 "Equinox" and my next will probably be a G.M. again.
  • I also see a ton of Impalas and Trailblazers around with high miles on them. It is a shame that GM does not do a better job of advertising just how many cars they sell and how happy most people are with them. I think that part of the problem is that GM sells so many cars that there are always going to be more with problems just because of sheer numbers. Also the people with problem cars (of any brand) are more likely to make noise. So when you look in consumer magazines that rely on people to self report problems, or on internet comments about cars most people that do not have problems do not bother to report on their cars. Rather like the nightly news it distorts reality towards the negative.
  • Yep the big GM cars like the Park Avenue and Bonneville are known for running forever as well. I still see lots of Luminas around. Also a fair amount of Grand Ams and Grand Prixs with well over 100,000 miles on them.
  • rvothrvoth Posts: 147
    Just came back from the auto show and GM did a good job with their vehicles. They had a 2010 Camero SS with the LS3 v-8 nice looking not enough head room a poor blind spots visibility.
    I was disappointed, no new 2010 Equinox and there and the excuse was that no one would buy the older model with the new 2010 model being displayed. I guess there is alot of 2009 models that aren't selling that well in my area of the country....... it would only cause more problems for the dealerships. Heck GM didn't even a V series model in any of their Cadallic's in western Canada to show ...wow..
    Yes there are alot of Impala's and Grand Am's a few Park Ave's on the road around here.
  • rvothrvoth Posts: 147
    Just read that the Five speed Asian Automatic uses GM DEXRON IV Transmission fuild not the new DEXRON VI tranny fluid.
    If the two are mix you WILL have transmission failure says service info . Interesting the Asian five uses an older version of tranny fluid IV, FYI.
    To check the level you have to unbolt the dipstick from the front of the tranny and then check the level. Seems GM doesn't want anybody that isn't mechanically inclined or who can't turn a wrench to service and check the fluid levels of their cars. ....interesting.
  • Has anyone had any issues with only the low beam headlights not working? I have high beams and every other bulb is lit on the car. All the fuses are intact and the headlamp relay is clicking when the light condition is detected. I am hoping this is not a headlamp module on the steering column that failed similar to when the highbeam switches on the floors of the old trucks would fail.
  • I need your help. I have an Equinox that I have had a problem with. It would do alot of clicking when I tried to start and then slowly start. Dealer could not duplicate problem so they cleaned battery terminals.

    I was going down road and key fell out while i was driving and the car kept running like the old fashion kind. It just went out of warranty so i had to pay half for new ignition.

    I am hearing a whistling noise it started from the rear I thought but it seems to be from the front. It kicks on from a cold start after driving for about 8 minutes when you hit around 25 mph. When you put the brakes on it still stays on. When you slow down it seems to stop but slowly.

    This has happend to me twice. I started car and steering dosen't work. If you shut car off and restart it is is okay. This happend twice.

    I got a flat the other day and I oppend the hatch and where the tire was had an inch of water.

    The drivers door hindge needs to be replaced.

    I already replaced the hatch pistons one of them had stopped working.

    I have around 68000 miles and most of this occured after warranty except for the clicking noise when trying to start. Could you please tell me what I should do and what the problems could be so I can get them fixed, I called the dealer today and they said there is no reacalls or bullentins.

    Please Help
  • The only input I have is for your key issue. If you have a gob of keys on your ring it adds way too much stress on your ingnition switch and problems like you are having occur. My suggestion is that you take your ingnition key and put it on a separate ring and have only that ring in the ingition. Use a detatchable clip (like a carabeaner) to reattatch your keys when you are not driving the car.
  • Bad multifunction headlamps switch! $50 at the dealer and a piece of cake to replace.
  • packer3packer3 Posts: 277
    Get rid of it before your repair bills go past a down payment for a new one.
  • rvothrvoth Posts: 147
    The steering on this vehicle it either comes with Hydraulic or Electric steering assist.
    If it's the electric system there is a service bulletin 06-02-32-002C about if has difficulty operating it goes into system thermal error and sets a code to the DTC either C0476 ,C0176 . If this has happened it goes into a fail safe mode so the system doesn't over correct and damage the steering with too much force from the electric motor.

    Have it checked for safe operation of the vehicle.
  • rvothrvoth Posts: 147
    Technical Service Bulletin (TSB) for water leakage in 2005-2009 Torrent ,Equinox's. Dated Oct 8 2008 TSB 08-08-57-001A covers all types of water leaks in the vehicle and your water in the spare tire compartment.

    Have the chevy dealer check this TSB ,water is coming in from one of the seams . Probable needs to have new sealant applied to the seam area of compartment.
  • rvothrvoth Posts: 147
    News that GM will drop four car lines and remain with just Chevy, Cadillac , Buick and GMC to start 2011 model year .

    Also Obama asked Mr Wagner CEO of GM to resign before he reads the Auto sector bail out plans on Monday 30 2009, Mr Wagner did resign from his post as CEO of GM, i guess 13 million a year was too much money to be making when your company is in DEDIT.

    I guess showing up in November in front of congress having flown your private jet there and then asking the Government for bail out money wasn't that smart . What's it cost , at least 50 to 60000 dollars to fly round trip, oh ya there is airport landing fees on top..Not to smart maybe that why he got the boot, not spending money wisely is how the President looks at it.

    Sounds like the Chevy brand will continue to reach the 100 year mark so the value will rise.
  • Thanks for everyone helping out. I am going to call them again as soon as they open, One last question as far as the noise coming from the front. It sounds like whirrr or noise from the radio (it's not ) the weird thing is it takes about 8 minutes to start making the noise. The car needs to warm up. I had the brakes replaced in the winter. I read some other posts. Do you think that is the struts. It is not when I turn. Car hits about 25 mph and kicks on untill car slows down. Shut car off while driving and it still did it.
  • one more question. THis problem happend shortly after the steering locked up. Could the noise be coming from the steering?
  • rvothrvoth Posts: 147
    It could be electrical noise , sounds like the motor is fighting against the steering ,over working creating a load on the motor.. Seems to be in fail safe mode hopefully.

    Have you had a message on the driver information display about the steering.. service power steering.
  • no I did not, I am going to go to dealer again today to have them listen to the noise.
  • rvothrvoth Posts: 147
    There is TSB 07-08-46-002b about audio whine on the speakers from the OnStar ,for 2007 2008 car and trucks.
    They put a filter in voltage system to correct it. This audio whine increases and decreases with the speed of the vehicle.
  • Well I took it to the dealer again for the whinning noise. They heard it. They said it is probablly the rear differential housing. $2000.00 And not sure if it will fix the noise. Has anyone had that replaced for the whinning noise and did it work? I spoke with my local mechainic and he suggested changing the fluid first.
  • rvothrvoth Posts: 147
    The diff case holds 500 ml, 16.9 ounces differential axle lubrication GM 89021677 us -6778 cda. Just two plugs , looks like a hex key used for the plug takes about 40 minutes to complete.
    Is your an AWD Equinox.
  • rvothrvoth Posts: 147
    You can check the level by taking out the top plug in the differently. The fluid level should be at the bottom edge of the threads. Just stick your finger in and feel for the fluid in the diff. You can a synethic diff oil or use GM's.

    Check for any leaks from the input shaft into the diff and also on the seals on each side of the diff housing where the drive shafts from out from.
  • packer3packer3 Posts: 277
    This was in a message I posted a few weeks back on my 05 Nox, see rear issues I had, I wouldn't be a bit surprised if there wasn't a hidden warranty some where with the rear of this SUV. I would say the same change the fluid first with a synthetic conditioning rear oil from Lucas first.

    Rear growling like noise - They had to replace rear differential - 17,115 mls
    ABS light came on - They had to replace the right rear speed sensor - 24,236 mls
    ABS light came on - They had to replace left front speed sensor - 32,115
    ABS light came on - They had to replace the left front speed sensor wire harness - 32,815

    The whinring noise - They had to replace the right rear bearing.- 32,079 mls
  • rvothrvoth Posts: 147
    There is transfer case on the front of transmission it too has a drain plug and and fill plug to check the level. I believe it uses different lubricant than the rear diff but should be checked as well for leakage and fluid level .

    There are two types of transfer cases Getrag 760 and NVG 900 both have same amount of synthetic oil in them GM specs. The Getrag has the both plugs on the driver's side of the case. NVG looks to have a bottom drain plug and the fill plug is on the passenger side of case

    Man i love the AWD system but it has alot more maintenance issues than the FWD model version.
  • I am trying to install cross rails on rack,where do you pry to pop back covers off,I dont want damage anything on a new car ,i tried to get covers off
    but no luck, instructions are very vague,thank you for any help
Sign In or Register to comment.