Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Equinox Maintenance and Repair

15051525456

Comments

  • Had the same problem with mine, in the shop right now, have had a lean code for over a year that the dealership could not figure out. Finally got so bad that they could get a different code on it, turns out that there are 2 gas tanks in our equinox and the fuel pump and transfer pump was going out. Oh and extended warranties will not cover it since it is covered by the powertrain/powerwrap 100,000 mile warranty.
  • Bucking/jerking are not likely from bad gas (almost never the issue); more likely you have an issue with the plug wires and plugs going bad. I have the Torrent (essentially the Pontiac Equinox) and it is such a common problem that GM issued a service notification; but only extended it to certain VIN's. I've gotten nothing but the run around from GM; I believe they just refuse to admit the extent of the issue. If you want the details check out the Torrent Forum, the issue is discussed extensively there under Lurching on Easy Acceleration.

    If you want a shot at GM doing it and eating the cost go to a dealer; it's no guarantee, but based on my experience if you don't you have no shot.

    As for the GM reps that troll these forums......useless; IMO just here to act as if GM cares.
  • I have a 2007 Equinox. The current milage is 94,000 miles. At or around 30,000 the warning light came on stating "Service Traction Control" and also, "Service Stabilitrac"? The car would "buck and Jump" when trying to pull out from a dead stop. The car had about half the power as usual. After 3 trips to the dealer they replaced the transmission. A few short months later the car did the exact same thing?? Took it back to the dealer and they replaced the valve body inside the tranny. The car was fine for about 3 months then the same problem occured again. Back to the dealership again!!! They then replaced the computer that controlls the transmission. Again the car was fine for about 2 days??? By this time I am FURIOUS!!!!! I took the car back and argued with the service manager and they fixed the car again??? He said that the tech that worked on the car "Forgot to program the new computer"???? After about a year in the shop and total of all the bills around $5000.00 dollars the car seemed "fixed"??? Luckily it was still under warranty!
    Now a couple years and 50,000 miles the problem has come back!!!!! What is the problem with this POS? The car is out of warranty and I don"t have $5k to fix the problem again! What can I do to fix it myself??? I was a mechanic for 15 years and feel like I can fix about anything but, I can't find any information on the "Stabilitrac/Traction Control system/ All of the service manuals that I have looked at say that the Stabilitrac and Traction Controll system is a propriatary (spelling?) dealer only system and wont disclose any information on it or how to diagnoss problems with it..... Please help!!! I am at my wits end. I can't even trade it off because of the tranny problems. If I do I will take a major loss because of mechanical issues.
    Please, Please, Please Help!!!!
  • pamt523pamt523 Posts: 5
    I have posted this about my key being stuck in the ignition - of course this doesn't happen all the time - I can turn the engine off, but the key won't turn past the accessory mode. Then I have to wait - sometimes a few seconds up to a minute (feels longer when it's 95 degrees out and be driven insane by the door open bell) and I have to wait for it to decide to release. I hear a little noise in the steering column - then I know I can continue to turn the key to off. Does anyone possible know the answer to this? I have had my car to the dealer twice and trying to work up the stamina to take it in for trip number three. The dealer doesn't have a clue, does anyone out there know? Is there a manual release that I can reach thru the hole in the steering column? Thanks for listening.
  • Hello everyone I have an issue with my Equinox. It currently has 71,000 miles on it. My gas cap was broken and I purchased a new one and had the check engine light cleared. It's came back on and I've had the purge solied replaced. The error codes are showing its a large and small environmental leak. I've tried to research this but I'm not having any luck. I've called my dealer and they have no idea how to fix this. I've mentioned the EGR and that part is $285 and who knows how much labor to fix. My local garage isn't sure either because he's not worked much on the Equinoxs. We're trying to find out what the valve is that is on top of the canister that's close to the fuel tank. I can't really afford $285 plus ungodly labor right now. Any suggestions? I still owe 3 years on the thing and can't trade it in right now.
  • jnd1022 - did you ever resolve the issue?

    I have a 2006 Equinox LT, front wheel drive with 72,000 miles, and noticed it vibrates quite a bit at 70 mph, but even more at 80 mph plus.

    I added 4 new tires, thinking the vibrating was caused by older tires. The new tires did not help very much.

    I am wondering if it is a tie rod or an axle. Anyone have an idea?
  • Hey, my 05 is leaking like you stated--my question is. should I check the pipe on the drivers side or the passenger side? My problem sounds very familiar to yours, any feedback is greatly appreciated.
  • gmcustsvcgmcustsvc Posts: 4,134
    jslebod,
    I apologize for your frustrations. Have you spoke with your dealer regarding your concerns? Please feel free to email me directly.
    Christina
    GM Customer Service
  • mdawnsmdawns Posts: 1
    We are the 2nd owners of our '06 Equinox AWD. Purchased it in Aug 2011 with 61K miles and have put not quite 4k on it. On December 23, 2011 we noticed it driving funny, it felt like it wasn't wanting to shift into overdrive. So we took it to our local transmission repair shop, they had the car until after Christmas (5 days total) and said it was most likely a Chevy computer issue that they can not diagnose; so we took it to a local Chevy service shop. The put it on the computer and said it was the purge solenoid and fixed that and sent the car home. That might have needed fixed but it did not solve the shifting problem. We finally got it back to them and told them they didn't fix it in the first place and we needed them to look at the problem we are noticing. They drove it for about 50 miles and had the computer attached; noticed it went through all of the gears but the computer told them the casing around the rear drive shaft was broken. We got a quote of $1,500 to repair.

    We have had this car for 4 months, and are stuck having to put a huge amount of money into getting it fixed when it's a part that would have originally been covered under the original drivetrain warranty. Is it possible for Chevy to offer any assistance? We still have 35k miles before we hit 100K - the drive shaft should not have gone bad already!

    Anyone else experience similar problems?
  • I have a 2006 Equinox also, and it is in the garage now having the same problem and it only has 80 thousand miles, I actually took it to get a oil change and the staff said that my carrier baring was going bad and made me an appointment to get it fixed, they did not fix it, I drove it in the garage with no noises or problems and ended up having it towed home, I contacted the owner of the garage and he had it towed to another garage, well now they are saying that the carrier baring, 2 U joints and the driveshaft is bad. I don't know what to think. The current mechanic said that the driveshaft shouldn't have been removed because there not made to take apart, I don't whether the first garage tore it up taking it out or if it was messed up to begin with. I hadn't had any problems w/it untill that day. I am curious if any others out there are having similiar problems.
  • Hey Radboiler,

    I wish I was replying to say I have a solution for you but sadly only another problem. Our 2005 Equinox is doing the very same thing and I was wondering (and hoping) if you had discovered a solution.

    My father n law is a mechanic and has tried several things but the bucking and jerking continues. It's not all the time and is so inconsistent that it's difficult to trace down. The only thing we have not replaced is the computer on the trans but I've noticed that I can put the car in park or neutral and it is still idling sporadically and sometimes the engine even shuts off which is very bad when we are sitting at a red light..

    Anyway if you ever find a solution and can reply back and let me know I would greatly appreciate it ...
  • clebo1clebo1 Posts: 78
    Enough is not enough until these hunbks of hunks are fixed.i am still tracking you past assocaition with GM.You seem to be the only one who is defending this vehicle obviously you must be employed by them.!!!! :lemon:
  • dunzydunzy Posts: 1
    hi kris, my name is jim and i am posting for the first time and hopefully helping you and others. i have a neighbor who called me over to help with a 2005 chevy equinox. he called me because i had a similar problem with a 2004 chevy blazer in which my hatch/ gate would not open and i had to break the inside panel to access the latch then went to junkyard for a new panel. he however had better luck than me with his hatch. when i got there he took the open palm of his hand and tapped on the lower end of the hatch while hitting the remote unlock button numerous times. call it chance or dumb luck but the hatch did open. he had a replacement latch mechanism in his possesion and we replaced it immediately. kris as far as the manual release for the lactch if you go to a parts store and ask to see a latch you might see a ring style piece connected to the mechanism, at least this is where the 2005 one was. however i dont think it is accessible without bending back the inside panel which could result in breaking it. last resort options only. as far as fuses i am not sure. sometimes you can call automotive parts stores and they will help you diagnose problems. hope this helps. jim
  • fig79fig79 Posts: 1
    I just traded in my 2003 expedition of which never left me stranded or had any major issues just getting up there in mileage and fuel expenses. I found a 2006 Equinox at a dealer down the street ,test drove it and liked it enough to purchase it. I did some general research on the reviews before I bought it and seen pretty much the same stuff over and over again with ignition,brake and overheating issues but never the less took the chance. I have owned it for 6 days and last night at my kids baseball practice it left me stranded. NO START!!! Either ignition or security lock out at 60k miles. I disconected the battery for 60 seconds and it started. Once I got home it wouldnt start again, but this morning it did. It is on the tow truck on the way back to the dealer. I also noticed the day I bought the car it had a wet spot on hte drivers floor right at the bottom of the A pillar and a week later its still there???????
  • I had the same problem on my 2007 Equinox about six months ago. Authorized chevy repair center said it needed a new "shift kit". Cost was about $350 total, but no more problems.
  • gmcustsvcsarahgmcustsvcsarah Posts: 1,964
    Good morning toolmanmarv,

    I'm glad to hear that the repair done by your service center has resolved the ignition problem you had been experiencing!

    Many more happy miles,
    Sarah
    GM Customer Service
  • I bought my 2006 Equinox LS (FRNT wheel drive) two years ago from a Chevy dealer. It had 38,000 km on it. I thought it was an excellent deal...was I wrong!

    Complete disappointment! I've had to replace the blower motor ($1,000 repair at the dealer I bought it at) and now I'm not only having to replace the air blend temperature door ($1,707 at another dealer) but also the thermostat AND the drive shaft tower assembly! For a car that had that low km on it I'm surprised at all the repairs needed!!! In two years I'll have spent over $4,000 on repairs and new tires (as they, for some reason, were completely worn too).

    I'm curious of how a drive shaft tower assembly can be coroded within 6 years and with so little milage. I'm curious of why GM won't do a recall on the air blend temperature door (as it seems to be an extremely common problem) and I'm curious how a GM dealership could sell a car with so many issues!! Optimum vehical?! I think NOT!

    I've always bought GM vehicals and am completely disappointed not only with the Dealership but with this car specifically. I've driven other years of the Equinox (hence why I bought one) and really like how she handles and the comfort. I'd like to keep her but honestly if anything else goes wrong I'll be living in a box so it won't matter!
  • dcrabbdcrabb Posts: 3
    I have been dealing with nothing but issues with my Equinox! GM acts like there is nothing they can do because they can't connect all the issues as one problem. I want a replacement vehicle! I bought my car in 2010 brand new...it has been in the shop several times. I had to send the dealership an article to get the to actually figure out the problem. The first time I took it in they said it was a sensor so they reset it. Few days go by and the car is having problems again. I take it in a second time and they stated that it was a timing chain and my oil was really black. I just had a oil change the week before so I found that odd. They said change your oil more often...I was very confused because I just had it done so I knew there was more to it. A few months go by and my check engine light starts to come on and my car is again back to doing the same thing it's done in the past. The engine revs up when I'm stopped, MIT shakes, when I turn it off the car stays running several seconds, etc. so here we go again I take the vehicle back in. This time they say your car is no longer under warranty and it's an O2 sensor. I said I have had it and I want the codes my car is pulling. They gave me P0172 and P0300. Red flag!! That's codes for fuel pump and engine misfire. After some research I found several articles online about the equinox having issues where the fuel leaks into the oil...hints why my oil is black after just having it changed. I fault with them to take a look further and when they did they called me and said they had good news that fuel is leaking into my oil and that is covered under warranty! Ok that's great that it was under warranty but seriously...I had to send an article for them to solve the problem. I have been fighting with GM because I no longer want my Equinox! It's been nothing but trouble and on top of it my heated seats just stopped working! I recommend anyone looking to get a 2010 Chevy Equinox to rethink their decision! This vehicle is the worst vehicle I have ever owned!! And GM won't do anything to help you out!
  • I have 2010 equinox; 50+k; and started having problem of power of car. Can not go no matter how much gas you give. Also start and runs with lot of noise. DEALER changed cam selonoide still the same problem. infect it stopped middle of the road and shaking like crazy. I bring home and checked there was no oil and oil indicator shows oil level is ok. also oil life also shows 35%. I did went to oil change at 3k before and dealer associate says u don't need it because it is still 70% life. You want to do it about 5% or show.

    This car has multiple problems. Air bag, gas millage, noisy start and run, water condense in engine, oil consumption and indicator is not correct and so on. Now i am taking this car to dealer see what happens.
  • We hope your appointment with your dealership goes well, equinox10. If you would like for us to follow up on anything with your visit, please email us at socialmedia@gm.com (include your name and Edmunds username, phone and address, the last 8 of your VIN and current mileage, and the name of your involved dealership).
    Sarah, GM Customer Service
  • I have been having issues with my 2006 Chevrolet Equinox as of the last 10 months or so (Only finding out 2 weeks ago, there was a Technical Service Bulletin for the exact issue I've been having, extending the warranty for the part (not by enough for me apparently), 7+ months AFTER having the issue start on me.

    Basically the classic blend door issue, where I now have no heat in my car. So when my wife takes my son to school, and then goes to work in her vehicle, the window now doesn't de-fog properly, as well as it being as cold in the car as it is outside (Sometimes even colder, because the only way to keep the window from constantly fogging up is to keep the cold air blasting on the windshield.., even then it doesn't work well). I have taken it to a local dealership, as well as have a case open with GM, but I was informed this morning that they will not help me, and I cannot afford to pay the $1,500 repair bill they are charging for it all.

    So it's either I get help fixing it, or I will be trading in my car and never looking at GM as an option again. And to think, I was originally thinking of trading this car in later on for my wife for a brand new Equinox or Traverse.. I think I'm going to second-guess that one now. If this didn't cost so much (Labor time anyhow), I bet they would have recalled it, as it's a wide-spread issue, as well as being a safety hazard.
  • rsills82,

    If you wanted to forward us either the last 8 digits of your VIN or your case number (71-**********), we could check into this further to see if there are any alternative options.

    Sarah, GM Customer Service
  • I don't have the last 8 of the VIN handy right this second, but I have heard back from senior representatives (Including a regional GM person), as well as Sunset Chevrolet here in Sumner, Washington that they won't do anything to it, even know it is a defect, not a wear and tear part.
  • My wife's 06 equinox just lost the heat a couple of weeks ago. after checking the internet i called the gm customer service line and found there is an extended warranty for this for certain vin numbers. as long as the hvac system works( vent/floor/def) selector but no heat comes from the vents and under 10 years 120k. her car qualifies.

    I can hear the door actuator move with each click of the temp selector, meaning the actuator has traveled beyond its intended range and broke the plastic drive lug off the door causing it to stick in the last position selected.

    Its at the dealer with 119,818 miles on the clock. hopefully they will fix it and not try to claim its not covered
  • gmcustsvcgmcustsvc Posts: 4,134
    leon82,
    We hope that all goes well with your wife's Equinox. As you are already working with our Customer Assistance Center it is best that I allow you to continue working with your current agent to avoid any confusion, but if you had any immediate questions I'm available!

    Sarah, GM Customer Service
  • Yeah that's the weird part.. I was diagnosed at a local 5 star, they said that's what the problem is with ours. Our heat doesn't work, but it makes no noise at all when I switch between warm/cold, it's as if it just doesn't work.. so that makes me want to check out and see if it might be something with the gauge being stuck closed or something maybe.. hmm. It stopped working almost a year ago (When we were below the mileage part), but GM took too long to post the service bulletin extension for the whole thing, and when i recently worked with several reps from GM, I was told that I was SOL. The final dude on the phone was falling asleep halfway through the conversation, not even paying attention to what I had to say. The only one who went out of their way at all, or seemed to care one bit was the first guy that I worked with (Vince).

    I will never buy a chevrolet product again, this should be a mandatory recall, as at night time when it's cold outside, or anytime it rains, we can't drive our car. My wife has to take our Autistic son to school in the mornings, and we have to figure out other arrangements now because of this, and because of his care, we can't afford to spend $1,500+ that they quoted me to fix the problem.
  • My wife has a 2005 AWD Equinox, I just noticed a vibration at just above 70 mph, stops below that. Jacked it up and found the driver side rear CV joint has play in the differential housing (the joint is OK). Are there replaceable bearings in the housing? Thanks
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,283
    you might be barking up the wrong tree here. First off, get a proper tire balance. I don't think your vibration is axle related, as that would cause vibration at a much lower speed, and it would not "go away' now and then. The play you feel might be another problem, or could be just normal wear and tear.

    MODERATOR --Need help with anything? Click on my name!

  • Shiftright, thanks but its not tires. The 1 inch of play in the differential housing and the CV joint, shake in the floor (rear of vehicle) and not in the steering wheel points me to the read end. My question is here because I have not found a GOOD parts breakdown of the differential. Is the CV joint/diff connection supported by replaceable bearings, sleeve or just an aluminum housing that's shot.
    Thanks
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 45,283
    edited November 2012
    Hmmm...I searched ALLDATA but I can't find a good blow-up of the rear diff either. It's interesting that they don't list "vibration" as a typical symptom.

    Before we dig into that, have you checked the support bushing for the differential housing?

    how about the driveshaft, for a u-joint problem?

    MODERATOR --Need help with anything? Click on my name!

Sign In or Register to comment.