Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Ford Mustang (2005 & newer) Problems and Solutions

16869707274

Comments

  • gzgtpgzgtp Posts: 83
    While driving over the weekend I got a cycle of error messages. I can't remember them all, but remember Oil pressure low, check braking system, emergency brake on, etc.
    The gauges did not function nor did the turn signals. I shut the engine and restarted and all was fine until the next day when it happened again and restarting wouldn't clear the error messages. The next day the messages did not appear, but the check engine light remained on. I took the 550 mile trip back home last night (1st long trip) and reflashed the computer back to original backup (was at a 93 performance tune) and the engine light has not appeared since.
    Any clues to what might have happened? Any info would be greatly appreciated.
    Thanks.
  • I have a 2006 Mustang, first sports car..so far everything seems fine..after reading some of the msgs in this site, yall have me worried. Anyway back to my question, I have a white stang and the paint seems to have little specs of yellow and black in the paint, at first I thought that it was sap off of trees. Have washed it several 100 times..still there..and then I looked at my sisters car and she has a 2005 stang, white also, same problem. Can anyone help or give advice. Thanks :blush:
  • mschmalmschmal Posts: 1,757
    If you have a paint defect, it is imparitive that you immediately go to your dealer. Paint defects may only be covered for 12 months/12,000 miles.

    Don't be afraid to assert a warrenty claim. If your dealer fails to help you, go to another one. You at least want to get a response from Ford, not just the dealer.

    Make the dealer take digital photos of the car and submit the claim to Ford.

    If the problem is in the paint though, it may be something you have to live with, even if Ford offers to paint the car for you. A full body paint will negatively affect your cars value :(

    One other option is to consider getting Le Mon strips. I saw a white GT500 yesterday with the Blue stripes and it looks awesome!

    The Vista Blue stripes are as metallic as the Vista blue paint and the stripes REALLY kick!

    Mark
  • My car has 13,000 miles on it..But the specs are all over the car, but mostly in the rear...and the same with my sisters car..Thanks for your advice
  • Yesterday I received a pretty good scare when the passenger door opened as I was making a turn. No warning prior, no buzzer or alert to let me know the door was ajar until it opened. Noticed two things that may have contributed: 1.) exterior door handle is sticking ( both sides) and 2.)If you just push the door closed it apparently engages just enough to keep the sensor from tripping but not enough to keep it closed if there is any force against it. Car is a 2005 convertible with 8K miles. No other real problems that have been persistent or a pesterance. Anyone else had this problem?
  • Mine came with the clear bra on all front surfaces. Dealer is not sure how it got on the car since they claim they did not install it nor did any of the other Mustangs on the lot have one so they didn’t charge me the $500 or so . This has been great! I have taken some serious hits in the front and not a scratch.
  • You have every right to be worried. The Mustang is junk. I've had nothing but problems with mine and am in the process of a Lemon Law battle with Ford. We go to court on 12/20/06 and hopefully shortly there after I'll be rid of this junk.
  • cccompsoncccompson Posts: 2,388
    Not likely it's a paint problem given that the vehicles are two different model years. Water will cleanse tree sap so it can't be that. If you haven't already tried doing so, apply some wax and see if it cleans up. Failing that, use some light polishing compound.
  • My '06 Mustang ran great untill just over 5,000 miles. Same "symptoms" as yours. Ford actually kept my car for a month, replacing sensors,several other parts, installed recorder box, replaced pcm and finally the throttle body. At that point it stopped dying on them and they deemed the car fixed. Dont know that a lawyer at this point would do you any good. They pretty much have to deem your car a lemon, and then it's up to Ford whether they deem it a lemon and will replace it for you. Unfortunately, best they will probably do for you is offer a 5 year extended warranty. Good luck, we traded out of ours by the way. :)
  • lmmlmm Posts: 70
    Get some claybar and see if it removes it. It does wonders!
  • My 2006 Mustang is making these terrible noises. When ever I turn (either way) it makes this TERRIBLE squealing noise. We took it to the dealership, they claim nothing is wrong with it. My husband is going to take it in again soon. Also, I just feel like it swerves all over the road. I don't feel like a car that is less than a year old should be doing this!!!!!!!! Anyone else experienced these problems?

    Thanks
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,404
    Sounds like a very loose power steering belt.

    MODERATOR

  • I just took my 06 GT to the dealer service center last week, with the exact same problem. It turns out that Ford is aware of the problem. I was told there is a "tech bulletin" in regards to the problem and how to fix it. It even states this on the work order I was given after the work had been done. I was told the "clutches" in the rear axle needed to be adjusted and a synthetic lubricant was used. A spacer was also added. since I got it back , which was the next day, it sounded just fine. and its still ok. The service advisor rode with me so he could hear the noice. Right away he heard it and called it a "howel" coming from the rear end. I think next time you should make a service advisor go with you so he can hear it for himself. Also let them know there is a tech bulletin in regards to the problem. Ive had my share of problems with my car also, so I can really relate. I have a post on here about it. My car is only a month old. At one point they had it for almost three weeks for another problem !!! But thats another thing. Well good luck and I hope you get it taken care of soon. take care.
  • I had almost the same problem with my 06 GT. I wrote a post about it. My car was only a week or so old when it started to idle rough. And at a stop light it almost died twice. My engine light went on too. I took it to the dealer and I was told the PCM ( power control module) was bad. It took three weeks to fix it. They had it the whole time. They gave me a loner car and a rental car, but still that doenst make up for the fact that a new car shouldnt have that problem. Id say at least bring it up to the dealer. It couldnt hurt. But watch out, it took three weeks just to get the part and they had the car the whole time. I went and saw it while I was picking up the loner car. It was sitting in the back with the hood ajar, covered in like an inch of dirt. Im tellin you, it pissed me off. I hope you find out what the problem is soon. I really can relate. Take care. Oh and if they do need to keep it for a while, make sure you get them to give you a loner or a rental. I know for a fact they can do both. Take care.
  • Your tellin me its maddening. I almost gave the car back also...but the lemon laws in my state, california, says it has to be in the shop four times for the same thing. And it has to be a mechanical problem. It only has to be in twice for problems that would result in death or great bodily injury. Now I drive it like its gold. I baby it when I drive because im afraid of something else going wrong. Go figure. Its too bad because it is a good looking car and ive gotten nothing but compliments on it almost everywhere i go in it. And when its running good...that sucker runs. I guess right now I kinda have a love-hate relationship with it. Well good luck with you new car and I hope you are happy with it. What did you end up getting? Take care.
  • I had to take my 1 week old 2006 stang in to my service department for a loud rattle/vibration coming from the passenger side dash and after driving it with the serv. rep. and a tech they said oh yeah its a TSB so they took my pass. side a pillar cover off and supposedly put some foam piece in there. It fixed the problem.I havent heard it since. Only problem I had was the tech got grimy fingerprints all over my parchment leather trim and seats BOY WAS I HOT!!!!!!
  • You think thats bad I had to drive a loner taurus for a week after i bought my 06 cuz first they had to repaint the entire front bumper cuz the paint peeled off, then they took it to get rustproofed (midwest) i got it back and refused to take it because the undercoating crap was all over my performance white paint so after detailing and buffing it out i go to pick it up and i tell them the back bumper is still not right so the kid from the body shop buffs it all out and just as hes finishing up he gets the buffer caught under the pass. side taillight and breaks the lens and burns a huge spot of the paint off all the way to the plastic. So i finally get it back the next day I take it home and i pop the hood to put on some parts i ordered and the bolts that hold the front bumper on are not tight and both my head light mounts are broken because some idiot torqued them down too tight. YEAH i gotta find a new dealership. :cry:
  • As reluctant as I was, I traded into another '06 Mustang. We consistantly told them we love this car, but we felt like with that many issues already, there were bound to be more. So, I upgraded to the pony package with the Stampede Edition, Vista Blue with Silver Stripe. So far so good, we're keeping our fingers crossed !!!
  • tayl0rdtayl0rd Posts: 1,938
    Congratulations! I'm glad you decided to Mustang another shot. Lemons do occur from time to time. You just happened to be one of the unfortunate few to get one. I'm sure your next experience will be much better!

    What's the Stampede Edition?
  • Well, I read in this site about the gauges messing up, I've had my stang for about a month now and everything was fine until I noticed that my trunk light wasen't working, so I plugged it back in, and headed to town..within 10 miles the gauges started blinking and telling me low fuel messages and low oil, the needle gauges started moving up and down , did this off and on till I unplugged my trunk light, now everything is fine once again...What do you think that was about???? 2006 Mustang
This discussion has been closed.