Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Acura RL Maintenance and Repair

12425262830

Comments

  • ppeter58ppeter58 Posts: 4
    I have a 2005 RL and have reset the oil life indicator without waiting for 0% to show. My Acura dealer and another service place, in addition to myself, have done so also. The procedure described in my owner's manual worked fine.
  • I had the same problem on my 06 RL. You can ask XM to refresh your service and the problem should go away. Just make sure you follow their instructions about keeping the XM radio on a particular channel for a requested period of time otherwise the refresh will not work. It worked for me on the third attempt. Hope this helps.
  • lorenzo2lorenzo2 Posts: 16
    2006 rl just had the same problem car speeding up.
    Left car running got out opened garage door put the car in drive and likely my brake was on and my foot was on the brake pedal car started speeding up. Any one elese had this problem/solution. Hope this was a one time problem.
  • The AFS warning light on my '05 RL goes on intermittently, but I notice that not only do my headlights continue to work (the manual says they should) but that they continue to swing as I round corners. Anybody have a similar problem?
  • I was getting random AFS warnings in my '05, never many, maybe one every couple of months. Dealer replaced steering position sensor and I've never had another one. That's the ONLY warranty repair I've had done on my RL.
  • Hi, DO you have the Tec Package? If so was the cruise in ACC mode, I.E. was the radar system on? I filed a complaint with the NTSB and have not heard a word from Acura or the NTSB. I've been told that I will hear nothing from the NTSB, that there is no tracking mechanism to find out where in the process it is, may take up to one year and I will find out if and when they issue a recall. Acura told me that they didn't know if or when they would fix the problem. I could post the exact detail that I sent to the NTSB.

    As far as I'm concerned the NTSB is worthless.

    Jim
  • Thanks Scott. I'll try that on my dealer.
  • This is an awsome forum, I am in the market for a newer car & I really like the RL. This forum definetly has more Info than any Acura dealer actually knows.

    I am looking for a used RL under 15k miles. I wonder if any of you have any advice, if I should get an '05 or '06.

    Any feedback, would be greatly appriciated.
  • I own a 2005 RL -- and just purchased from Dice Electronics an I-Pod connector along with the digital FM component to attach to the existing radio.
    I will need to take apart the dash to get to the radio.
    Do any of you know where I could get instructions to do the disassembly?
    It would sure help to have this as oppose to doing it by trail and error.
    Thanks in advance for any help on this.
    Warren
  • klisterklister Posts: 8
    I would definitely go with the 06. The 05 was the first year and there were a number of electrical, sensor, and brake pad issues that were fixed with the 06. There were TSB's for most 05 issues so you can find one that will be fine, however, I never could get all the bugs fixed on mine and worked out a deal with an Acura dealer to trade for an 06.
  • My '01 started to get noisy and creaky when slowing and turning sharply into and out of my sloped driveway or when traveling at slow speeds over speed bumps. I suspect the car also made noise at higher speeds under certain conditions, though road noise probably drowned out the creaking/groaning. I brought the car to my independent mechanic (a trusted source who is always my first pass diagnostician) who looked at it and diagnosed a bad wheel bearing. At the time the car was still covered under the Acura Certified Used warranty, so off I went to the Acura dealer who replaced the wheel bearings on both sides up front free of charge to me.
  • Not sure if anyone with an '05 RL could have put over 40K miles yet. Really wondering how the AWD mechanism will hold up after warranty. Also probably too early to tell how the electronic gizmos will hold up over the years (for those who want to buy and keep a car at least 5-7 yrs). Anyone with major mechanical problems (not including lemons)?
  • None...from 2005 RL with 44,000 mi since late Sept 2005. Just got back last two weeks from Washington DC round trip to Blue Ridge, GA via a weeklong Charlotte NC, Charleston SC, Savannah GA, Atlanta GA and back. And this past two days, round trip to Kykuit Rockefeller Estate in Tarrytown NY via Brooklyn. Average hi-way mileage 26 with four people plus baggages and 27 with three without baggage respectively.
  • I have 43,000 miles on my 2005 RL and I was wondering whether to get an extended warranty because of all the gizmos and gadgets. I haven't had any issues as of yet. Have you heard any compelling information for or against an extended warranty?
  • r79207r79207 Posts: 9
    has anyone installed an after market remote starter on their acural rl? I was considering it and wanted to know if it works well?
    acura dealer referred me to a place that will do it for $299. I assume i need to give up one of the keys.
    also does acura offer a valet key? i only received 2 keys when i bought the car and they were both with a remote.
    tony
  • I've got a 97 RL w/ 180K miles on it. I am the original owner and have never had any real problems. Since my cost of ownership is minimal, I will probably drive it into the ground. The car looks like it only has 60K on it.

    Has anybody had problems with the power window motors/lifts breaking? I've replaced 3 window motors in the last 3 years.

    Thanks.
  • Hello,

    I was driving home on the Highway in my RL and I had what I think was a power surge? No idea why, that had never happened before. But the car seemed to go faster then slow back down to normal. When that happened the lights in the instrument pannel went out, as well as my power windows. Everything else works, idiot lights, interior lights, the radio, the power mirrors. For what ever reason the Instrument pannel is completely dead, and the windows won't open (the sun roof works though)

    I already checked the entire fuse block twice over, and pulled all the relay's and tested them. Any other thoughts?
  • I have 2000 Acura RL with a 12' sub and Alpine tv and everything has worked fine for 2 yrs. I was driving home 2 days ago and my tv completely goes out, wont even turn on. Then my check engine light/ warning light and traction control light came on. Now my alarm doesnt work, locks work when car is on and doors are closed, the clock and mileage reset every start up. My headlights being left on makes a beep, that doesnt work, my steering wheel goes up and down auto. when u start and turn off the car, that doesnt work. I checked the battery-it's fine, checked fuses-those are fine. I have no clue what the hell it could be. The car has never ever had any problems.
  • Yeah, that's a common problem on the RL. As far as I know, it's the only widely reported common parts failure. I don't recall the specifics, but apparently a design issue with plastics components instead of metal on the lifting mechanism. Do a search and you can find some history. I guess that you can do it yourself if you're skilled, but I never tried it.

    I've got a 96 RL w/ 175k mi. and I've replaced 3 lifts so far. All have gone out once except front passenger window. I even bought the replacement kit off of Ebay several years ago for it in anticipation of needing to replace it. So far it's still working.
  • I have a 2000 Acura RL n I had that problem so I went and bought a $2000 Alpine TV n stereo set up and LOVE it accept some electrical issues with my cars ecu I think
  • skbelskyskbelsky Posts: 3
    I have a 2005 Acura RL. I have always had an accumulation of soot around both exhaust pipes. Recently, the paint on the bumper started to peep around one of the pipes. My dealership insists this was the result of flex (compromising the bumper). I insist that it was from the soot, excess heat, or some ancillary problem related to the exhaust pipes (it is just too coincidental that the paint chose to peel in this exact spot). Has anyone else had peeling caused from this exhaust problem with an 05 Acura?
  • skbelskyskbelsky Posts: 3
    I have a 2005 Acura RL. I have always had an accumulation of soot around both exhaust pipes. Recently, the paint on the bumper started to peel around one of the pipes. My dealership insists this was the result of flex (compromising the bumper). I insist that it was from the soot, excess heat, or some ancillary problem related to the exhaust pipes (it is just too coincidental that the paint chose to peel in this exact spot). Has anyone else had peeling caused from this exhaust problem with an 05 Acura?
  • cstilescstiles Posts: 465
    I do not have any paint peeling, but the tailpipe extensions were redesigned in 2006 and our dealer replaced them with the new ones on our 2005 RL at no charge approximately 2 years ago. The new extensions go out a little bit further, and do not cause the same soot buildup that we originally experienced on our white RL. If I were you, I would go back to your dealer and ask them about the new extensions and at least see if they will swap them out for you, as they did for us. Once they admit that the extensions were replaced in subsequent model years, they may consider addressing your paint issue? Good luck.
  • wmengelwmengel Posts: 1
    I just got a 2008 Acura RL. I really like this car...but, I have noticed a random pulsating vibration coming from the gas pedal. It usually occurs between 1,000 and 2,000 rpm. The vibration doesn't last long (maybe five or six "cycles" [vibration for a second, then no vibration for a second, then another vibration, etc.]) I have searched the Internet for the answer and have noticed references to drivelines but it seems that these all reference TL's or MDX's...not RL's. This vibration is irritating to say the least.

    I went back to the dealership and they took it for a test drive but did not notice any problem...probably because the problem is random (maybe happens every two days or so).

    Does anyone have any ideas on this? Thanks.
  • ed111ed111 Posts: 22
    I have read in the Acurazine forums that some owners have noticed the engine "pinging" at low RPM's.
  • ackndaaackndaa Posts: 2
    This problem is intermittent. Starting from a cold start, the car drives ok. Changing into gears are a bit rough. After a short drive, and the trans dip stick is checked, the fluid is dark brown, smells burnt, and has small bubbles. The problem, after a while is that when the car is placed in any of the four gears of forward drive or reverse, the car doesn't move. This is the first time I've experienced trans issues, and the car has 200k miles. Any info would be greatly appreciated. Thanks in advance.
  • ackndaaackndaa Posts: 2
    While checking the oil after filling up, I noticed the P/S fluid bubbling/boiling inside of the res. What does this mean??? Is there something wrong with my pump, rack and pinion, and/or lines??? There's no indication when driving. There's no leaks either. All belts are new, connected correctly and taught. This too is the first time I've experienced p/s issues. My car has 200k miles. Any info would be greatly appreciated. As with my previous entry, thanks in advance.
  • bfrancobfranco Posts: 1
    Has anyone else had problems with the HFL while making calls? 2007RL purchased new. Almost immediately began experiencing problems with the Hands Free Link in making calls (doesn't get the numbers right - repeats back numbers that weren't spoken), drops calls, voice quiality both speaking and receiving is poor. Dealer replaced HFL unit twice, even supplied a new (supposedly compatible phone) but the problem still exists. Hands free phone operation is soon to be mandatory in our state and this will be more of an issue for us than before. Any ideas or similar experiences out there? :(
  • ascott1ascott1 Posts: 2
    Had my new '08 RL for about 4 months and car would not start today. Called the my salesman at the dealership and he suggested that I get a Sears battery. He insisted that the battery is a maintenance item and not covered under the warranty. After AAA started my car, all of the warning lights for the brakes, ABS, SH-AWD were flashing. So, I drove straight to the dealership service dept. I turned off the car in the service bay before they took it and started it back up and all of the warning lights were off then. The dealership said that there must have been a bad cell in the battery and that they would replace the battery. Funny though, when they returned my keys with no paperwork and the stereo was still working. I had to punch in the security code after AAA started it. I asked the serviceman why my stereo was still working if they had replaced the battery and he said that the service people have a way of replacing the battery without causing the security code having to be set up again. I also would think that the dealership would not be able to install a new battery without a record in their system.
    Has anyone had trouble with a very short battery life? Unfortunately, I didn't read the reviews on Edmunds about dealerships before I purchased the car, or I would have shopped elsewhere.
Sign In or Register to comment.