Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Pontiac Sunfire

1356717

Comments

  • moparbadmoparbad Posts: 3,842
    4 times to fix the same problem is a service competence problem, not a lemon vehicle problem IMO. Wish you the best in either getting the problem repaired or a buyback.
  • Anyone heard anything about the new Pursuit that is supposed to replace the Sunfire this fall?
  • moparbadmoparbad Posts: 3,842
    The Pursuit is offered in Canada only. No plans to offer it in the US.
  • Thank you for clearing that up. My local paper reported the Pursuit would replace the Sunfire. I thought they were wrong, though. :)
  • carrolltoncarrollton Posts: 2
    I have a 2000 Sunfire SE. 74K miles. When I turn the wheel at a very slow speed or starting position, I can feel a bumping in the steering wheel I think is coming from the right front. I have factory tires so nothing there is rubbing. I've checked the boots and struts which seem ok. I dont feel it once the car gets going. Could it be in the steering column? Anyone have this problem before? Other than that this car runs great.
  • carrolltoncarrollton Posts: 2
    Correction - I meant the problem is coming from the Left front of the car.
  • cindy10cindy10 Posts: 3
    One of my lights came on yesterday and I don't know what it means. (1995 Sunfire) It's a square with an arrow pointing down to what looks like either liquid or the ground. I checked all my fluids and all are ok. Anyone know? :confuse:
  • lrmmflrmmf Posts: 2
    I have a 1999 sunfire & I purchased it in 2002. Ever since I got it, I've hated it! The first thing to go was the radio. Sometimes it would just not start- that was cool. They said it was the key or something. I had the muffler hanger break, the crank case seal was leaking oil into the spark plugs which made driving fun- it was only running on 3 cylinders, the oxygen sensor was messed up, I've needed a new catalyctic converter, my trunk leaks into my back seat, and my favorite- THE CHECK ENGINE LIGHT IS ALMOST ALWAYS ON!
    :lemon:
  • beliverbeliver Posts: 155
    lrmmf: How many miles on this GM wonder car ? Let's see, Radio kaput ? It can happen. Just did on my brother's Lexus !! Won't start ? It COULD be the Key. Muffler hanger broke, NO big deal get out the old coathanger like they would do down at Bubba's "fix & go" shop. Can't see how a crankcase "seal" Gasket ? can allow oil to get to the plugs. Could you really mean the head gasket ? If OX sensor messed up you will for sure keep getting a "check engine" light. If under 70K the cat convt should have been covered under emissions warranty. Leaks happen, my 2004 Mustang had one on day one !! When or if did you have a tune -up on the beastie ? Sounds like a lot of neglected PM from the prior owner to me. Gotta stay on top of this stuff.

    Believer
  • gkneebonegkneebone Posts: 3
    My traction control light comes on and the car shifts gears violently. lf l stop the car and restart it, the light goes out and it's ok again for a while.
    Any ideas, it has 85,000 kms.

    gkneebone
  • Well I finally got my car back after another 9 days of being serviced at the dealership. It turns out, that every time they removed the tank to run the smoke test, they never thought to look at the O ring seals on the fuel feed lines. This time they finally looked at them and realized that one of the O rings had broke and slipped out of place, which is what was causing the minute leak causing a loss in pressure which set the check engine light off. So, they replaced the tank completely as well as the fuel feed lines and ran the test again. Thankfully no leaks. So I'm crossing my fingers and hoping that the check engine light does not come on again because I really don't want to have the car replaced. I tinted the windows back in January (which cost me about $250) and GM is only responsible for replacement of the vehicle, so I really don't want to have to spend another $250 to get the windows tinted again. Other than this repeated problem, I am satisfied with the overall performance and handling of the vehicle.
    :)
  • ClairesClaires Chicago areaPosts: 974
    Welcome to the Forums, gkneebone! You might also want to post your question in the Got a quick, technical question? Forum.

    ClaireS, Host
    Coupes & Convertibles | Vans & Minivans

    MODERATOR
    Need help getting around? claires@edmunds.com - or send a private message by clicking on my name.

  • cindy10cindy10 Posts: 3
    I have the same problem (my car has 255 000 km !!) My traction control light stays on all the time now. Shifts gears really hard too.
  • Hi Guys,

    Just wanted to know, the cooling fan has not been turning on when the engine gets really hot. I changed the rad fluid and just recently changed the sensor in back of the thermostat thinking that was the problem because when I unplug the wire harness on the sensor the fan goes on an as soon as I plug it back in it shuts of and never comes back on.
    I do not have air conditioning and it is an automatic if that can help.
    Thanks
  • ClairesClaires Chicago areaPosts: 974
    Welcome to the Forums, rbelleville! You might also want to post your question in the Cooling Systems: Problems & Solutions Forum, to see what the experts there have any advice for you.

    ClaireS, Host
    Coupes & Convertibles | Vans & Minivans

    MODERATOR
    Need help getting around? claires@edmunds.com - or send a private message by clicking on my name.

  • I purchased a used sunfire 2002 few months ago with only 33k km! After one month the light ABS started to go on with SERVICE! However, the brakes are working fine. I didn't take it to service yet, and now after 2 months i noticed that it is started to give some sound when braking. Pedal somtimes doesn't feel right!
    Can you give me some hint on this.

    thanks :)
  • chickschicks Posts: 1
    I have a 2000 Pontiac Sunfire 4-door. The problem I am having is that when I push down on the passenger side fender there is a knocking sound. I thought first maybe it was the strut mounts which I changed with no effect. I had the rear end checked by my dealership and the only thing they came up with was a bad muffler hanger. That was replaced and it still makes the noise. Also, now it seems that when I apply my brakes I hear a clunking sound coming from the same area, the clunking almost sounds like something rubbing.
    I re-adjusted the back brake drums but it still continues to aggravate me.
    The knocking sound is also there although slight when I am driving, especially when I go over a bump.
    I have been told the problem MAY be in the axle bushings, but have not tried anything with that as of yet.
    Any ideas would be appreciated...
  • redtide98redtide98 Posts: 3
    1999 Pontiac Sunfire It has like 120K on it since around 100K spark plugs started to just wollow out the thread and start bouncing around in the hole, causing misfiring etc. I have re-threaded two already and now its doing it again. Any ideas as to what is causing this?
  • elifelif Posts: 1
    that would be the coolant light.

    in my 1995 sunfire, that light comes on even if it is full, possible faulty sensor or blockage somewhere, after a few minutes of 65mph+ driving it goes away. even after a full flush and refill serviced by a local dealer it still came back on.
    so i ignored it. took it to another place and it hasn't come on since.

    good luck
  • redtide98redtide98 Posts: 3
    You should have your CV joints checked before you find yourself on the side of the road most cars around that or higher mileage have CV joint problems. Usually you can have them replaced for around $100 each or less.
Sign In or Register to comment.